-
Notifications
You must be signed in to change notification settings - Fork 137
/
05_7_heap_path.cpp
70 lines (57 loc) · 1.56 KB
/
05_7_heap_path.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
/*
* 05_7_heap_path.cpp
*
* Created on: 2018年5月16日
* Author: SummerGift
*/
/*
05-树7 堆中的路径(25 分)
将一系列给定数字插入一个初始为空的小顶堆H[]。随后对任意给定的下标i,打印从H[i]到根结点的路径。
输入格式:
每组测试第1行包含2个正整数N和M(≤1000),分别是插入元素的个数、以及需要打印的路径条数。
下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。
最后一行给出M个下标。
输出格式:
对输入中给出的每个下标i,在一行中输出从H[i]到根结点的路径上的数据。数字间以1个空格分隔,行末不得有多余空格。
输入样例:
5 3
46 23 26 24 10
5 4 3
输出样例:
24 23 10
46 23 10
26 10
*/
#include <stdio.h>
#define MAX_NUM_HEAP 1001
#define MIN_VALUE -10001
int heap[MAX_NUM_HEAP], size;
void create_heap(int *heap, int *heap_size) {
*heap_size = 0;
heap[0] = MIN_VALUE;
}
void heap_insert(int x) {
int i;
for (i = ++size; heap[i / 2] > x; i /= 2)
heap[i] = heap[i / 2];
heap[i] = x;
}
int main() {
int n, m, x, i, output_index;
scanf("%d %d", &n, &m);
create_heap(heap, &size);
for (i = 0; i < n; i++) {
scanf("%d", &x);
heap_insert(x);
}
for (i = 0; i < m; i++) {
scanf("%d", &output_index);
printf("%d", heap[output_index]);
while (output_index > 1) {
output_index /= 2;
printf(" %d", heap[output_index]);
}
printf("\n");
}
return 0;
}