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TraceCompass-4.1.0
Date: 2018/08/29

Section Content To do Pass Fail Total Comments Automated Lock held by... Manual Test Version

1 Integration 0 25 0 25 0

2 Junit Tests 0 18 0 18 18

3 TMF - Project View 0 149 0 149 With comments 102

4 TMF - EventsEditor 0 22 0 22 With comments 11

5 TMF - BookmarksView 0 17 0 17 With comments 2

6 TMF - Filters View 0 12 0 12 With comments 12

7 TMF - Colors View 0 6 0 6 With comments 6

8 TMF - Histogram View 0 49 0 49 With comments 5

9 TMF - Sequence Diagram 0 35 2 37 With comments 2

10 TMF - Statistics View 0 18 0 18 With comments 6

11 TMF - Time Chart View 0 26 0 26 With comments 1

12 TMF - Custom Parsers 0 28 0 28 With comments 12

13 TMF - State System Explorer 0 14 0 14 6

14 TMF - Flame Chart View 0 24 0 24 With comments 14

15 TMF - Remote Fetching 0 53 0 53 51

16 LTTng 2.0 - Control Flow View 0 52 0 52 With comments 15

17 LTTng 2.0 - Resources View 0 40 0 40 With comments 6

18 LTTng 2.0 - Control View 6 125 0 131 With comments 118

19 GDB Tracing 0 25 0 25 With comments 5

20 Tracing RCP 0 32 0 32 With comments 0

21 LTTng 2.0 - Memory Analysis 0 22 0 22 With comments 6

22 LTTng 2.0 - CPU Analysis 0 27 0 27 With comments 5

23 Trace Synchronization 0 13 0 13 With comments 0

24 XML analysis 0 42 0 42 With comments 0

25 Network Trace analysis 0 11 0 11 With comments 3

26 Critical path 0 45 0 45 With comments 2

27 LTTng 2.0 - I/O Analysis 0 20 1 21 With comments 5
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28 LTTng 2.0 - VM Analysis 0 39 0 39 With comments 0

29 LAMI 0 17 1 18 0

30 Flame Graph 0 19 0 19 With comments 11

31 Counters View 0 3 0 3 0

Total: 6 1025 4 1016 424

Open Fixed Total

Bug Reports  0 0
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# Section Pass Fail To Do Comment

Integration 25 0 0 0 31
Target: 

Step Test Case Action Verification Comment

1 Verify C/C++ EPP Package RC1

1.1 Download EPP Package Download, extract and start EPP package EPP Package starts Manual N/A
Verified in Aug. 22-2018 at 13:11PM. Help > Software Update > 
Update doesn't exist in Help

1.2
Version of Tracing Features

Go to Help -> About Eclipse -> Installion Details

Verify that all tracing features and plug-ins are 
present and have the correct version (TMF, 
LTTng, CTF, GDBTrace, PCAP) Manual N/A Verified in Aug. 22-2018 at 13:15PM. Not all tests were done this time for this milestone

1.3 TMF presence Open Tracing perspective Tracing perspective opens Manual N/A Verified in Aug. 22-2018 at 13:21PM

1.4 LTTng presence Open LTTng Kernel perspective LTTng Kernel perspective Manual N/A Verified in Aug. 22-2018 at 13:25PM

1.5 GDB Tracepoint Analysis presence Open GDB Trace perspective GDB Tracepoint analysis perspective Manual N/A Verified in Aug. 22-2018 at 13:28PM

1.6 Oxygen Update Site
Go to Help -> Install New Software...  -> Update site 
"Oxygen - http://download.eclipse.org/staging/oxygen/"

Verify that all LTTng Kernel, LTTng UST and GDB Trace are available
Manual N/A Verified in Aug. 22-2018 at 13:31PM

2 Verify C/C++ EPP Package RC2

2.1 Download EPP Package
Download, extract and start EPP package. Check the mailing list for the package:
https://dev.eclipse.org/mailman/listinfo/epp-dev EPP Package starts Manual Pass

Verified in Aug. 22-2018 at 10:39AM. Help > Software Update > 
Update doesn't exist in Help

2.2
Version of Tracing Features

Go to Help -> About Eclipse -> Installation Details

Verify that all tracing features and plug-ins are 
present and have the correct version (TMF, 
LTTng, CTF, GDBTrace, PCAP) Manual Pass Verified in Aug. 22-2018 at 10:39AM. Not all tests were done this time for this milestone

2.3 TMF presence Open Tracing perspective Tracing perspective opens Manual Pass Verified in Aug. 22-2018 at 10:39AM.

2.4 LTTng presence Open LTTng Kernel perspective LTTng Kernel perspective Manual Pass Verified in Aug. 22-2018 at 10:40AM.

2.5 GDB Tracepoint Analysis presence Open GDB Trace perspective GDB Tracepoint analysis perspective Manual Pass Verified in Aug. 22-2018 at 10:40AM.

2.6 Oxygen Update Site

Go to Help -> Install New Software...  -> Use the 
testing update site "Oxygen - http://download.eclipse.
org/staging/oxygen/"

Verify that all LTTng Kernel, LTTng UST and GDB Trace are available
Manual Pass Verified in Aug. 22-2018 at 10:43AM.

3 Verify C/C++ EPP Package RC3
3.1 Download EPP Package Download, extract and start EPP package EPP Package starts Manual Pass Verified in Aug. 22-2018 at 11:00AM.

3.2
Version of Tracing Features

Go to Help -> About Eclipse -> Installation Details

Verify that all tracing features and plug-ins are 
present and have the correct version (TMF, 
LTTng, CTF, GDBTrace) Manual Pass Verified in Aug. 22-2018 at 11:07AM.

3.3 TMF presence Open Tracing perspective Tracing perspective opens Manual Pass Verified in Aug. 22-2018 at 11:10AM.

3.4 LTTng presence Open LTTng Kernel perspective LTTng Kernel perspective Manual Pass Verified in Aug. 22-2018 at 11:17AM.

3.5 GDB Tracepoint Analysis presence Open GDB Trace perspective GDB Tracepoint analysis perspective Manual Pass Verified in Aug. 22-2018 at 11:21AM.

3.6 Oxygen Update Site

Go to Help -> Install New Software...  -> Use the 
testing update site "Oxygen - http://download.eclipse.
org/staging/oxygen/"

Verify that all LTTng Kernel, LTTng UST and GDB Trace are available
Manual Pass Verified in Aug. 22-2018 at 11:25AM.

4 Verify C/C++ EPP Package RC4
4.1 Download EPP Package Download, extract and start EPP package EPP Package starts Manual Pass Verified in Aug. 22-2018 at 14:07PM

4.2
Version of Tracing Features

Go to Help -> About Eclipse -> Installation Details

Verify that all tracing features and plug-ins are 
present and have the correct version (TMF, 
LTTng Control, LTTng Kernel, LTTng UST, CTF, 
GDBTrace) Manual Pass Verified in Aug. 22-2018 at 14:17PM

4.3 TMF presence Open Tracing perspective Tracing perspective opens Manual Pass Verified in Aug. 22-2018 at 14:21PM

4.4 LTTng presence Open LTTng Kernel perspective LTTng Kernel perspective Manual Pass Verified in Aug. 22-2018 at 14:25PM

4.5 GDB Tracepoint Analysis presence Open GDB Trace perspective GDB Tracepoint analysis perspective Manual Pass Verified in Aug. 22-2018 at 14:27PM
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4.6 Oxygen Update Site

Go to Help -> Install New Software...  -> Use the 
testing update site "Oxygen - http://download.eclipse.
org/staging/oxygen/"

Verify that all LTTng Kernel, LTTng UST and GDB Trace are available
Manual Pass Verified in Aug. 22-2018 at 14:37PM

5 Verify Update Site

5.1 Oxygen Update Site

Download Eclipse for Committers and install LTTng 
Kernel, LTTng UST, GDBTrace and PCAP Network 
Analysis from main simrel testing Update site
"Oxygen - http://download.eclipse.org/staging/oxygen/" Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 14:41PM

5.2 Trace Compass Update Site

Download Eclipse for Committers and install LTTng 
Kernel, LTTng Control, LTTng UST, GDBTrace and 
PCAP Network Analysis from the Linux Tools Update 
site
http://download.eclipse.
org/tracecompass/oxygen/milestones Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 14:45PM

5.3
Upgrade using Oxygen Update Site

Download Eclipse for Committers from Oxygen.0 and 
install LTTng, LTTng Kernel, GDBTrace and PCAP 
Network Analysis from main simrel Update site.
http://download.eclipse.org/releases/neon
Try to update the installation using the testing simrel 
update site.
Oxygen - http://download.eclipse.org/staging/oxygen/ Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 14:49PM

5.4

Upgrade using Trace Compass Update 
Site

Download Eclipse for Committers from Oxygen.0 and 
install LTTng, LTTng Kernel, LTTng UST, GDBTrace 
and PCAP Network Analysis  from the Trace Compass 
release Update site. 
http://download.eclipse.org/tracecompass/releases/2.
3.0/repository
Try to update the installation using the Trace 
Compass update site http://download.eclipse.
org/tracecompass/oxygen/milestones Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 14:52PM

5.5
Upragde from previous EPP

Download Eclipse previous C/C++ EPP package. Try 
to upgrade using both update sites:
(TODO find correct job: https://hudson.eclipse.
org/packaging/job/luna.epp-tycho-
build/128/artifact/org.eclipse.epp.
packages/archive/repository/)
"Mars - http://download.eclipse.
org/releases/maintenance"

The information about the update sites to use is 
usually posted on epp-dev Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 14:55PM

6 Verify Update Site Release outside release train

6.1 Trace Compass update site

Download Eclipse standard and install LTTng Kernel, LTTng Control, LTTng
 UST, GDBTrace and PCAP Network Analysis from main 
Update site: http://download.eclipse.org/tracecompass/stable/repository/Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 15:06PM

6.2
Upgrade using Trace Compass 
update site

Download Eclipse standard from Luna SR0 and install 
LTTng, LTTng Kernel, LTTng UST, GDBTrace and 
PCAP Network Analysis  from the Luna SR0 Linux 
Tools Update site. 
http://download.eclipse.org/linuxtools/update-3.1
Try to update the installation using the Trace 
Compass update site.
http://download.eclipse.
org/tracecompass/stable/repository/ Verify that installation was successful Manual Pass Verified in Aug. 22-2018 at 15:16PM
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Section Pass Fail To Do Comment

Junit Tests 18 0 0 0
Target: Ubuntu 12.04 64 bit and on Hudson

Step Test Case Action Verification Comment

1 Junit Test Cases
1.1 CTF Core Tests Plug-in Run manually or with Jenkins All test cases passed Pass
1.2 CTF Parser Tests Plug-in Run manually or with Jenkins All test cases passed Pass
1.3 State System Core Tests Plug-in Run manually or with Jenkins All test cases passed Pass
1.4 TMF Core Tests Plug-in Run manually or with Jenkins All test cases passed Pass
1.5 TMF UI Tests Plug-in Run manually or with Jenkins All test cases passed Pass
1.6 TMF UI SWTBot Tests Plug-in Run manually or with Jenkins All test cases passed Pass

1.7
CTF Support for TMF SWTBot 
Tests Plug-in Run manually or with Jenkins All test cases passed Pass

1.8
TMF Xml Analysis Core Tests Plug-
in Run manually or with Jenkins All test cases passed Pass

1.9 TMF Xml Analysis UI Tests Plug-in Run manually or with Jenkins All test cases passed Pass

1.10 LTTng Control Core Tests Plug-in Run manually or with Jenkins All test cases passed Pass
1.11 LTTng Control UI Tests Plug-in Run manually or with Jenkins All test cases passed Pass

1.12
LTTng Kernel Analysis Core Tests 
Plug-in Run manually or with Jenkins All test cases passed Pass

1.13
LTTng Kernel Analysis UI Tests 
Plug-in Run manually or with Jenkins All test cases passed Pass

1.14
LTTng Kernel UI SWTBot Tests 
Plug-in Run manually or with Jenkins All test cases passed Pass

1.15
LTTng Userspace Tracer Analysis 
Core Test Plug-in Run manually or with Jenkins All test cases passed Pass

1.16
LTTng Userspace Tracer Analysis UI 
Test Plug-in Run manually or with Jenkins All test cases passed Pass

1.17
GDB Tracepoint Analysis Core Tests 
Plug-in Run manually or with Jenkins All test cases passed Pass

1.18
GDB Tracepoint Analysis UI Tests 
Plug-in Run manually or with Jenkins All test cases passed Pass
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Section Pass Fail Type To Do Comment

TMF - Project View 149 0 102 0 56
Target: Ubuntu 16.04 64 bit

Step Test Case Action Verification Comment

1 Preparation
1.1 Step 1 Open LTTng Kernel  perspective LTTng  perspective opens with correct views Manual Pass Verified in Aug. 22-2018 at 09:37AM. * DEFINE CORRECT VIEWS!!!!@!!!

1.2 Step 2
Open Navigator View (used for independent 
verification) Navigator View opens SWTBot Pass

2 Project Creation
2.1 New Project Wizard Open New Tracing Project Wizard Tracing Project Wizard opens SWTBot Pass

2.2 Create project Specify a project name and finish
Tracing project appears in Project 
Explorer/Navigator SWTBot Pass

2.3 Project structure Open the new Tracing project Project contains Experiments and Traces folders SWTBot Pass

3 Traces Folder

Preparation

1) Download traces.zip (if necessary) and 
unzip into a local directory ${local}
2) Import Custom Text and XML parsers 
(ExampleCustomXmlParser.xml,  
ExampleCustomTxtParser.xml) from 
directory traces/customParsers into your 
workspace from the Manage Custom Parsers 
dialog.

SWTBot Pass
3.1 Traces Folder menu Select the Traces folder and open its context menu Correct menu opens (Import, Refresh) SWTBot Pass
3.2 Trace Import Wizard Select Import Trace Import Wizard appears SWTBot Pass

3.3
Import single custom text trace (link to 
workspace)

1) Browse to directory ${local}/traces/import/
2) Select trace ExampleCustomTxt.log
3) Keep <Auto Detection>, Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning" and select "Create Links to 
workspace" and 
4) press Finish

Imported trace appear in Traces Folder and the 
Trace Type Tmf Generic is set. Make sure trace 
can be opened SWTBot Pass

3.4
Import Single custom XML trace (link 
to workspace)

redo 3.1-3.3 but this time select ExampleCustomXml.
xml

Imported trace appear in Traces Folder and the 
Trace Type "Custom XML log" is set. Make sure 
that trace can be opened SWTBot Pass

3.5
Import LTTng Kernel CTF trace (link 
to workspace)

redo 3.1-3.3 but this time select directory kernel-
overlap-testing/

Imported trace appear in Traces Folder and the 
Trace Type "LTTng Kernel" is set. Make sure 
that trace can be opened SWTBot Pass

3.6 Rename + copy import

redo 3.3, 3.4, 3.5. However, Unselect "Create Links 
to workspace"

When dialog box appear select Rename

Traces are imported with new name that has a 
suffix (2) at the end. Make sure that imported 
traces are copied to the project. SWTBot Pass

3.7 Overwrite + copy import

redo 3.3, 3.4, 3.5. However, Unselect "Create Links 
to workspace"

When dialog box appear select Overwrite

Existing traces are deleted and new traces are 
imported. Make sure that imported traces are 
copied to the project and can be opened SWTBot Pass

3.8 Skip 

redo 3.3, 3.4, 3.5. However, Unselect "Create Links 
to workspace"

When dialog box appear select Skip Make sure that no new trace is imported SWTBot Pass

3.9 Default overwrite

redo 3.3, 3.4, 3.5. However, Unselect "Create Links 
to workspace" and select "Overwrite existing without 
warning"

Make sure that no dialog box appears (for 
renaming, overwriting, skipping) and existing 
traces are overwritten). Make sure trace can be 
opened SWTBot Pass



4.1.0-TraceCompassTestCases ProjectView

7

3.10 Import unrecognized

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import 
3) Select trace unrecognized.log
4) Keep <Auto Detection>, Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning" and select "Create Links to 
workspace" and 
5) press Finish

unrecognized.log is imported with trace type 
unknown. The default text file icon is displayed. 
The trace, when opened, is displayed in the text 
editor. SWTBot Pass

3.11 Import unrecognized (ignore)

redo 3.10, however unselect "Import unrecognized 
traces"

unrecognized.log is not imported SWTBot Pass

Preparation 
Delete all traces in project - Right mouse 
click on Traces folder and select "Clear" SWTBot Pass

3.12
Import CTF trace by selection 
metadata file only

Redo 3.5, However only select metadata file instead 
of directory trace

Imported trace appear in Traces Folder and the 
Trace Type "LTTng Kernel" is set. Make sure 
that trace can be opened SWTBot Pass

Preparation Delete all traces in project

3.13
Recursive import with auto-detection 
(Rename All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import 
3) select directory import
4) Keep <Auto Detection>, Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning", select "Create Links to workspace" 
and unselect "Preserve Folder Structure"
5) press Finish
6) When dialog appears select "Rename All"

All Traces are imported with respective trace 
type set. Traces with name clashes are imported 
with suffix (2).  1 trace (unrecognized.log) is 
imported with trace type unknown. Make sure 
that traces can be opened which have a trace type 
set. The unknown trace type should open with 
the text editor. SWTBot Pass

Preparation Delete all traces in project

3.14
Recursive import with auto-detection 
(Overwrite  All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/ 
3) select directory import
4) Keep <Auto Detection>, Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning", select "Create Links to workspace" 
and unselect "Preserve Folder Structure"
5) press Finish
6) When dialog appears select Overwrite All"

All Traces are imported with respective trace 
type set. Traces with name clashes are 
overwritten . 1 trace (unrecognized.log) is 
imported with trace type unknown. Make sure 
that traces can be opened which have a trace type 
set. The unknown trace type should open with 
the text editor. SWTBot Pass

Preparation Delete all traces in project

3.15
Recursive import with auto-detection 
(Skip  All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4) Keep <Auto Detection>, Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning" and select "Create Links to 
workspace" and uncheck "preserve folder structure" 
5) press Finish
6) When dialog appears select Skip All"

All Traces are imported with respective trace 
type set. Traces with name clashes are not 
imported. 1 trace (unrecognized.log) is imported 
with trace type unknown. The unknown trace 
type should open with the text editor. SWTBot Pass

Preparation Delete all traces in project

3.16
Recursive import with auto-detection 
(test rename, overwrite and skip)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4) Keep <Auto Detection>, Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning", select "Create Links to workspace" 
and unselect "Preserve Folder Structure"
5) press Finish
6) When dialog appears select "Rename" 
7) When dialog appears select "Overwrite"
8) When dialog appears select "Skip" 

All Traces are imported with respective trace 
type set. Traces with name clashes are either 
renamed, overwritten or skipped as per dialog 
action. Make sure that traces can be opened 
which have trace type set. The unknown trace 
type should open with the text editor. SWTBot Pass

Preparation Delete all traces in project
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3.17
Recursive import with specific trace 
type 1 (Skip  All)

1) Open Import wizard
2) Browse to directory ${local}/traces/import/ 
3) select directory import
4)  Select trace type "Generic CTF Trace", Select 
"Import unrecognized traces", unselect  "Overwrite 
existing without warning", select "Create Links to 
workspace" and unselect "Preserve Folder Structure"
and 
5) press Finish
6) When dialog appears select Skip All"

After selecting trace type, verify that button 
"Import unrecognized traces" is disabled.

4 CTF traces are imported with trace type 
"Generic CTF Trace" . Make sure that these 
traces can be opened SWTBot Pass

Preparation Delete all traces in project

3.18
Recursive import with specific trace 
type 2 (Skip  All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4)  Select trace type "LTTng Kernel Trace", Select 
"Import unrecognized traces", unselect  "Overwrite 
existing without warning", select "Create Links to 
workspace" and unselect "Preserve Folder Structure"
5) press Finish
6) When dialog appears select Skip All"

After selecting trace type, verify that button 
"Import unrecognized traces" is disabled.

One LTTng Kernel trace is imported with trace 
type "LTTng Kernel Trace". Make sure that this 
trace can be opened. SWTBot Pass

Preparation Delete all traces in project

3.19
Recursive import with specific trace 
type 3 (Skip  All)

1) Open Import wizard
2) Browse to directory ${local}/traces/import/
3) select directory import
4)  Select trace type "LTTng UST Trace", Select 
"Import unrecognized traces", unselect  "Overwrite 
existing without warning", select "Create Links to 
workspace" and unselect "Preserve Folder Structure"
5) press Finish
6) When dialog appears select Skip All"

After selecting trace type, verify that button 
"Import unrecognized traces" is disabled.

3  LTTng UST traces are imported with trace 
type "LTTng UST Trace". Make sure that these 
traces can be opened. SWTBot Pass

Preparation Delete all traces in project

3.20
Recursive import with specific trace 
type 4 (Skip  All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4) Select trace type "Tmf Generic", Select "Import 
unrecognized traces", unselect  "Overwrite existing 
without warning", select "Create Links to workspace" 
and unselect "Preserve Folder Structure"
5) press Finish
6) When dialog appears select Skip All"

All text files in directories are imported as trace 
and trace type "Tmf Generic" is set. Note that 
trace type validation only checks for file exists 
and that file is not a directory. Make sure that 
these traces can be opened. However traces with 
wrong trace type won't show any events in the 
table. SWTBot Pass

Preparation Delete all traces in project

3.21
Import wizard from workbench menu 
with project selected

1) Select project "Test" in Project Explorer view
2) Open import wizard from menu File > Import... > 
Tracing > Trace Import
3) Browse to directory ${local}/traces/import/
4) Select trace ExampleCustomTxt.log
5) Keep <Auto Detection>, select "Create Links to 
workspace" and 
6) press Finish

Verify that trace is imported to "Test" project 
and can be opened. SWTBot Pass

3.22
Import wizard from workbench menu 
with no project selected

1) Clear selection in Project Explorer view
2) Open import wizard from menu File > Import... > 
Tracing > Trace Import
3) Browse to directory ${local}/traces/import/
4) Select trace ExampleCustomTxt.log
5) Keep <Auto Detection>, select "Create Links to 
workspace" and 
6) press Finish

Verify that trace is imported to default "Tracing" 
project and can be opened. SWTBot Pass

Preparation Delete all traces in project

3.23 Drag and Drop from other Tracing
D&D a few LTTng traces from another Tracing 
project's Traces folder

Selected traces are added to the Traces folder 
with proper icon. Trace can be opened. Manual Pass Verified in Aug. 22-2018 at 09:44AM.

3.24 Drag and Drop from non-Tracing D&D a few files from a non-Tracing project

Selected traces are added to the Traces folder 
with default icon.  Files can be opened with the 
default editor. Manual Pass Verified in Aug. 22-2018 at 09:49AM.
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3.25 Drag and Drop from external D&D a few files from an external file manager

Selected traces are added to the Traces folder 
with default icon. For actual traces  Trace type is 
detected automatically. Trace can be opened,  
For non traces the files are added with default 
icon and they can be opened with the default 
editor. Manual Pass Verified in Aug. 22-2018 at 09:49AM.

3.26
Drag and Drop of trace with existing 
name

1) D&D a trace with name of an existing trace into 
traces folder
2) Confirm the renaming of traces

Verify that trace is added into the traces folder 
with the trace name of the orignal trace plus a 
suffix 2 Manual Pass Verified in Aug. 22-2018 at 09:49AM.

3.27
Drag and Drop of trace with existing 
name (2nd time)

Redo test 3.26 with the same trace and same 
destination folder

Verify that trace is added into the traces folder 
with the trace name of the orignal trace plus a 
suffix 3 Manual Pass Verified in Aug. 22-2018 at 09:49AM.

3.28 Import destination Open Import wizard
Verify that "Into Folder" text box cannot be 
updated Manual Pass Verified in Aug. 22-2018 at 09:52AM.

Preparation Delete all traces in project

3.29
Recursive import with preserved 
folder structure

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4) Select trace type "Tmf Generic", unselect  
"Overwrite existing without warning", select "Create 
Links to workspace" and select "Preserve Folder 
Structure"
5) press Finish

All Traces are imported with respective trace 
type set. The folder "clashes" is imported with its 
traces inside. Make sure that traces can be 
opened which have a trace type set. SWTBot Pass

3.30
Recursive import with preserved 
folder structure (Skip All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4) Select trace type "Tmf Generic", unselect  
"Overwrite existing without warning", select "Create 
Links to workspace" and select "Preserve Folder 
Structure"
5) press Finish
6) When dialog appears select "Skip All"

The wizard should finish quickly as no trace will 
be imported. Make sure that traces can be opened 
which have a trace type set. SWTBot Pass

3.31
Recursive import with preserved 
folder structure (Rename All)

1) Open Import wizard (see 3.1-3.2)
2) Browse to directory ${local}/traces/import/
3) select directory import
4) Select trace type "Tmf Generic", unselect  
"Overwrite existing without warning", select "Create 
Links to workspace" and select "Preserve Folder 
Structure"
5) press Finish
6) When dialog appears select "Rename All"

All Traces are imported with respective trace 
type set with suffix (2). The folder "clashes" is 
imported with its traces inside. Make sure that 
traces can be opened which have a trace type set. SWTBot Pass

Preparation Delete all traces in project

3.32

Delete with mixed selection of traces 
and folders

1) Create two trace folders under the "Traces" folder
2) Import 2 traces under each folder
3) Open all 4 traces
4) Select one trace in the first folder and the second 
folder in the Project Explorer view
5) Right-click, Delete. Click Yes.

A dialog should ask the user to confirm deletion 
of the selected elements. Clicking OK should 
remove all that was selected. The editor of the 3 
deleted traces should be closed automatically 
with one remaining editor opened. SWTBot Pass

3.33
Delete multiple folders

1) Create 2 trace folders under the "Traces" folder
2) Import a trace under each folder
3) Open both traces
4) Select both folders in the Project Explorer view
5) Right-click, Delete. Click Yes

A dialog should ask the user to confirm deletion 
of the selected elements. Clicking OK should 
remove all that was selected. The editor of both 
traces should be closed automatically. SWTBot Pass

3.34
Clear single Traces folder

1) Import 2 traces from different folders preserving 
folder structure
2 Open both traces.
3 Select the Traces folder
4) Right-click, Clear. Click Yes.

A dialog should ask the user to confirm clearing 
of the folder. Clicking Yes should remove 
everything under the selected folder and close 
the traces SWTBot Pass

3.35
Clear multiple Traces folder

1) Import 2 traces to different projects
2 Open both traces.
3 Select both Traces folders
4) Right-click, Clear. Click Yes.

A dialog should ask the user to confirm clearing 
of the folders. Clicking Yes should remove 
everything under the selected folders and close 
the traces SWTBot Pass

Preparation Delete all traces in project
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3.36

Import from zip archive, preserve 
folder structure

1) Open Import wizard (see 3.1-3.2)
2) Select archive file: traces.zip
3) select directory the root directory
4) Select trace type "Automatic", unselect "Overwrite 
existing without warning" and select "Preserve Folder 
Structure"
5) press Finish

All the files get imported under their respective 
folders. The CTF traces can be opened (kernel-
overlap-testing, simple_server...) SWTBot Pass

Preparation Delete all traces in project

3.37

Import from zip archive, no preserve 
folder structure

1) Open Import wizard (see 3.1-3.2)
2) Select archive file: traces.zip
3) select directory the root directory
4) Select trace type "Automatic", unselect "Overwrite 
existing without warning" and unselect "Preserve 
Folder Structure"
5) press Finish
6) Select Rename All when dialog comes up.

All traces are imported with trace type set. The 
traces from folder "clashes" are renamed with 
suffix (2). Make sure that the traces can be 
opened SWTBot Pass

Preparation Delete all traces in project

3.38 Import from zip archive specific traces

1) Open Import wizard (see 3.1-3.2)
2) Select archive file: traces.zip
3) select file "z-clashes/ExampleCustomTxt.txt" and 
folder "kernel-overlap-testing"
4) Select trace type "Automatic", and select "Preserve 
Folder Structure"
5) press Finish The specified traces are imported with trace type 

set. Make sure that the traces can be opened. SWTBot Pass
Preparation Delete all traces in project

3.39

Import from tar.gz archive, preserve 
folder structure

1) Open Import wizard (see 3.1-3.2)
2) Select archive file: traces.tar.gz
3) select directory the root directory
4) Select trace type "Automatic", unselect "Overwrite 
existing without warning" and select "Preserve Folder 
Structure"
5) press Finish

All the files get imported under their respective 
folders. The CTF traces can be opened (kernel-
overlap-testing, simple_server...) SWTBot Pass

Preparation Delete all traces in project

3.40

Import from tar.gz archive, no 
preserve folder structure

1) Open Import wizard (see 3.1-3.2)
2) Select archive file: traces.tar.gz
3) select directory the root directory
4) Select trace type "Automatic", unselect "Overwrite 
existing without warning" and unselect "Preserve 
Folder Structure"
5) press Finish
6) Select Rename All when dialog comes up.

All traces are imported with trace type set. The 
traces from folder "clashes" are renamed with 
suffix (2). Make sure that the traces can be 
opened SWTBot Pass

Preparation Delete all traces in project

3.41
Import from tar.gz archive specific 
traces

1) Open Import wizard (see 3.1-3.2)
2) Select archive file: traces.tar.gz
3) select file "z-clashes/ExampleCustomTxt.txt" and 
folder "kernel-overlap-testing"
4) Select trace type "Automatic", and select "Preserve 
Folder Structure"
5) press Finish The specified traces are imported with trace type 

set. Make sure that the traces can be opened. SWTBot Pass

4 Trace
4.1 Trace menu Select an LTTng trace and open its context menu Correct menu opens (Open , Copy, Rename, …) SWTBot Pass
4.2 Open trace Select the Open menu Trace is opened and views are populated SWTBot Pass

4.3 Copy trace
Select the Copy menu and provide a new name. 
Open. Trace is replicated under the new name SWTBot Pass

4.4 Rename trace
Select the Rename menu and provide a new name. 
Reopen. Trace is renamed. The trace editor is closed. SWTBot Pass

4.5 Delete trace Select the Delete menu and confirm deletion Trace is deleted. The trace editor is closed. SWTBot Pass
4.6 Open Trace (Accelerator) Select trace and press Enter Trace is opened SWTBot Pass Numpad-enter doesn't work

4.7 Delete Trace (Accelerator) Select trace and press Delete and confirm deletion Trace is deleted. The trace editor is closed. SWTBot Pass

4.8 Open Trace (double click) Double-click a trace Trace is opened SWTBot Pass
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4.9 Open Trace (already open) Open two traces. Open the first trace again. The first trace editor is simply brought to front. SWTBot Pass

5 Experiments Folder

5.1 Experiments menu
Select the Experiments folder and open it context 
menu

Correct menu opens (New, Import XML 
Analysis, Refresh) RCPTT Pass Loic Import XML Analysis renamed "Manage XML Analysis"

5.2 Create experiment Select the New menu and provide experiment name Experiment appears under folder, no traces yet RCPTT Pass

6 Experiment

6.1 Experiment menu Select an experiment and open its context menu
Correct menu opens (Select, Open , Copy, 
Rename, …) RCPTT Pass

6.2 Select Traces dialog Select the Select Traces menu
Select Traces dialog is open and populated w/ 
traces RCPTT Pass

6.3 Select traces Select a few LTTng traces and finish Selected traces are imported in the experiment RCPTT Pass
6.4 Open experiment Select the Open menu Experiment is opened and views are populated Manual Pass Verified in Aug. 22-2018 at 09:53AM.

6.5 Copy experiment
Select the Copy menu and provide a new name. 
Open. Experiment is replicated under the new name RCPTT Pass

6.6 Rename experiment
Select the Rename menu and provide a new name. 
Open. Experiment is renamed RCPTT Pass

6.7 Delete experiment Select the Delete menu and confirm deletion Experiment is deleted RCPTT Pass
6.8 Open Experiment (Accelerator) Select an Experiment and press Enter Experiment is opened RCPTT Pass Numpad-enter doesn't work

6.9 Delete Experiment (Accelerator)
Select an Experiment and press Delete and confirm 
deletion Experiment is deleted RCPTT Pass

6.10 Delete Experiment (open experiment)
Open an experiment, select expereiment and press 
Delete and confirm deletion Experiment is closed and deleted Manual Pass Verified in Aug. 22-2018 at 09:54AM.

6.11
Select Traces while Experiment is 
open

Open an experiment and select an additional trace 
(see 6.3)

Experiment is closed and selected traces is 
imported to the experiment Manual Pass Verified in Aug. 22-2018 at 09:55AM.

7 Experiment Traces
7.1 Trace menu Select an LTTng trace and open its context menu Correct menu opens w/ Copy disabled + Remove RCPTT Pass
7.2 Open trace Select the Open menu Trace is opened and views are populated Manual Pass Verified in Aug. 22-2018 at 09:56AM.

7.3 Remove trace
Open Experiment, select the Remove menu and 
confirm removal

Experiment is closed, trace is removed from 
experiment RCPTT Pass

7.4 Drag and Drop from Traces D&D a few LTTng traces from the Traces directory
Selected traces are added to the experiment with 
proper icon. Experiment can be opened. Manual Pass Verified in Aug. 22-2018 at 09:56AM.

7.5 Drag and Drop from other Tracing
D&D a few LTTng traces from another Tracing 
project's Traces folder

Selected traces are added to the experiment + 
Traces with proper icon. Experiment can be 
opened. Manual Pass Verified in Aug. 22-2018 at 09:56AM.

7.6 Drag and Drop from non-Tracing D&D a few traces from a non-Tracing project

Selected traces are added to the experiment + 
Traces with proper icon. Experiment can be 
opened. Manual Pass Verified in Aug. 22-2018 at 09:56AM.

7.7 Drag and Drop from external D&D a few traces from an external file manager

Selected traces are added to the experiment + 
Traces with proper icon. Experiment can be 
opened. Manual Pass Verified in Aug. 22-2018 at 09:56AM.

7.8
Drag and Drop from external (non-
traces)

D&D a few files (non-traces) from an external file 
manager

Selected traces are added to the experiment + 
Traces with proper icon (system icon). 
Experiment cannot be opened. Manual Pass Verified in Aug. 22-2018 at 09:59AM.

7.9
Drag and Drop of trace with existing 
name

1) D&D a trace with name of an existing trace into 
experiment folder
2) Confirm the renaming of traces

Verify that trace is added into the traces folder 
and experiment folder with the trace name of the 
orignal trace plus a suffix 2 Manual Pass Verified in Aug. 22-2018 at 10:01AM.

7.10
Drag and Drop of trace with existing 
name (2nd time)

Redo test 7.8 with the same trace and same 
destination folder

Verify that trace is added into the traces folder 
and experiemnt folder with the trace name of the 
orignal trace plus a suffix 3 Manual Pass Verified in Aug. 22-2018 at 10:01AM.

7.11
Drag and Drop of trace  while 
Experiment is open

Open an experiment and D&D a trace from the 
Traces directory (see 7.4)

Experiment is closed and selected traces is 
imported to the experiment Manual Pass Verified in Aug. 22-2018 at 10:02AM.

8 Propagation
8.1 Preparation Copy experiment Selected experiment is replicated Manual Pass Verified in Aug. 22-2018 at 10:03AM.

8.2 Rename propagation
In Traces folder, rename a trace showing in both 
experiments New name is propagated to both experiments Manual Pass Verified in Aug. 22-2018 at 10:03AM.

8.3 Delete propagation
In Traces folder, delete a trace showing in both 
experiments Selected trace is removed from both experiments Manual Pass Verified in Aug. 22-2018 at 10:06AM.
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8.4 Propagate trace type 1
Add a trace to 2 experiments. Change its type from 
Traces All occurences of that trace are updated Manual Pass Verified in Aug. 22-2018 at 10:07AM.

8.5 Propagate trace type 2
Add a trace to 2 experiments. Change its type from 
one of the experiments All occurences of that trace are updated Manual Pass Verified in Aug. 22-2018 at 10:08AM.

9 Properties View Synchronization

9.1 Trace synchronization

Select a trace under a Traces folder in Project 
Explorer view. Repeat with trace under an 
Experiment.

The Properties view is updated with the selected 
trace's "Resource properties" Property and 
Value. The "Info > type" property shows the 
selected trace category and trace type name. Manual Pass Verified in Aug. 22-2018 at 10:08AM.

9.2 Other trace nodes synchronization
Select a Traces folder, Experiments folder, or an 
experiment in Project Explorer view.

The Properties view is updated with the selected 
item's Property and Value. For Experiment verify 
the "type" property is set. Manual Pass Verified in Aug. 22-2018 at 10:08AM.

9.3 Check trace properties
Open an LTTng kernel trace, click on the trace, check 
the new properties view. The "Trace properties" should be populated Manual Pass Verified in Aug. 22-2018 at 10:08AM.

9.4 Check trace properties - experiment

Open an experiment which contains LTTng kernel 
traces, click on the experiment, check the new 
properties view. 

The "Trace properties" should be populated for 
every subtrace Manual Pass Verified in Aug. 22-2018 at 10:10AM. Old:New feature … not implemented yet, now it is implemented.

10 Trace Type Selection

10.1 Preparation
Import an file with unrecognized trace type (${local}
/traces/import/unrecognized.log)

Imported trace appear in Traces with default 
icon. File is can be opened by default Editor 
(either Eclipse text or system editor depending 
on plug-ins installed) SWTBot Pass

10.2 Trace properties Select the trace and open the Properties View Selected trace type is blank Manual Pass Verified in Aug. 22-2018 at 10:11AM.

10.3 Trace filtering Select an experiment and open Select Traces dialog Untyped trace does not appear in list SWTBot Pass SWTBot tries invalid type for a given valid trace, same thing.

11 Supplementary Files

11.1 Preparation

1) In Project Explorer remove filter for hidden 
resources (Coolbar menu > Customize View... > 
unselect '.* resources)
2) Create Experiment with 2 LTTng CTF traces in it

Verify that .tracing directory is shown under the 
project RCPTT Pass

11.2
Create Supplementary File (State 
History File) from trace

Open a LTTng CTF trace and wait for indexing to 
finish

Verify that org.eclipse.tracecompass.analysis.os.
linux.kernel.ht is created under .tracing/<trace 
name>/. RCPTT Pass

11.3 Trace Context sensitive menu

a) Select trace under Folder Traces and click right 
mouse button 
b) Redo test: Select trace under Experiment Folder
c) Redo test: Select Experiment

Verify that menu item 'Delete Supplementary 
Files...' is shown in the context-sensitve menu RCPTT Pass

11.4 Delete Supplementary Files Action
1) Select trace and click right mouse button 
2) Select 'Delete Supplementary Files...' 

Verify that confirmation dialog box is opend and 
<trace name>/StateHistory.ht is listed RCPTT Pass

11.5 Select and delete State History File
Select <trace name>/StateHistory.ht file and click on 
'Ok'

Make sure that file .tracing/<trace 
name>/StateHistory.ht is deleted from the project 
explorer view RCPTT Pass

11.6
Create Supplementary File (State 
History File) from experiment Open Experiment with 2 LTTng CTF traces

Verify that two StateHistory.ht files are created 
under .tracing/<trace1 name>/ and .
/tracing/<trace2 name>/ respectively. Also 
verify, that supplementatry folder for the 
experiment ./tracing/<exp name>_exp is created. RCPTT Pass

11.7 Delete Supplementary Files Action
1) Select Experiment and click right mouse button 
2) Select 'Delete Supplementary Files...' 

Verify that confirmation dialog box is opend and 
shows 3 root entries: 
<exp name>, <trace1 name> and <trace2 name>, 
with their respective supplementary files below RCPTT Pass

11.8 Select and delete State History File
Select one history file (<trace name>/StateHistory.ht) 
and click on 'Ok'

Make sure that the selected file .tracing/<trace 
name>/StateHistory.ht is deleted from the project 
explorer view RCPTT Pass

11.9
Select and delete multiple State 
History files

1) Redo 11.2 and 11.6
2) Select both history files and click on 'Ok'

Make sure that both history files are deleted 
under .tracing/<trace1 name>/ and .
tracing/<trace2 name>/ respectively RCPTT Pass

11.10 Delete Trace
a) Redo 11.2 to create Supplementary File
b) Delete trace

Verify that supplementary directory .
tracing/<trace name>/ is deleted. RCPTT Pass
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11.11 Delete Experiment

a) redo 11.6 to create experiment and Supplementary 
File
b) delete Experiment

Verify that supplementary File StateHistory.ht .
tracing/<trace1 name>/ and ./tracing/<trace2 
name>/  are NOT deleted.  Also verify that the 
supplementary folder for the experiment .
/tracing/exp_name_exp is deleted. RCPTT Pass

11.12 Delete Experiment Trace

a) redo 11.6 to create experiment and Supplementary 
File
b) remove traces under Experiment

Verify that supplementary File StateHistory.ht .
tracing/<trace1 name>/ and ./tracing/<trace2 
name>/  are NOT deleted RCPTT Pass

11.13
Delete Supplementary Files Action 
while trace is open Open trace and then redo 11.4

Verify that trace is closed and supplementary 
files are deleted RCPTT Pass

12 Link With Editor

12.1 Preparation

1) In Project Explorer make sure that "Link with 
Editor" button is selected
2) Open multiple traces and experiments RCPTT Pass

12.2 Select trace/experiment in Editors area
Select several traces and experiments one after each 
other in Editors area

Verify that after each selection the corresponding 
trace or experiment element is selected in the 
Project Explorer RCPTT Pass small problem, might be GTK3

12.3
Select opened traces/experiments in 
Project Explorer

Select several open traces and experiments one after 
each other in Project Explorer

Verify that after each selection the corresponding 
trace or experiment is brought to the top in the 
Editors area Manual Pass Verified in Aug. 22-2018 at 10:11AM.

12.4 Preparation

1) In Project Explorer make sure that "Link with 
Editor" button is not selected
2) Open multiple traces and experiments (if not open) RCPTT Pass

12.5 Select trace/experiment in Editors area
Select several traces and experiments one after each 
other in Editors area

Verify that selection in Project Explorer doesn't 
change RCPTT Pass

12.6
Select opened traces/experiments in 
Project Explorer

Select several open traces and experiments one after 
each other in Project Explorer Verify that Editor in focus is not changed RCPTT Pass

13 Trace Package Export Wizard

13.1 Preparation

1) Import 2 traces that generate supplementay files 
(trace2, kernel_vm)
2) Open both traces, wait for the indexing to finish
2) Add bookmarks in the two traces

13.2 Open the trace package export wizard

Click on “File”, “Export...”, “Tracing”, “Trace 
Package Export” and click Next
Alternatively, Right-click in Project Explorer on 
Project and select "Export", “Tracing”, “Trace 
Package Export” and click Next
Alternatively, select multiple traces, right-click and 
select "Trace Package Export"

A  wizard should appear with a list of projects 
and traces to select. Next button should be 
disabled. SWTBot Pass

13.3 Select Traces

On the left side, select the project in which the traces 
were imported. Then on the right side, selected both 
traces.

Next should be become enabled when the first 
trace is selected. If all traces are unselected, the 
Next button is disabled. SWTBot Pass

13.4 Deselect/Select All
With traces selected, press the Deselect All button. 
Then press on the Select All button. Click Next.

Next should become disabled after Deselect All, 
enabled after Select All. SWTBot Pass

13.5 Trace element selection Unselect the trace2 element

All elements in the trace tree are unselected, the 
Approximate uncompressed size field changes to 
a lower number. SWTBot Pass

13.6 Trace sub-element selection Unselect the kernel_vm > Trace element

All elements in the trace tree are unselected, the 
Approximate uncompressed size field changes to 
0. The Next button is disabled. Manual Pass Verified in Aug. 22-2018 at 10:24AM.

13.7 Select/Deselect All
With nothing selected, click Select All. Then click 
Deselect All. Then click Select All again.

When Select All is clicked, all the tree elements 
are selected, the approximate size increases. 
When Deselect All is clicked, all the tree 
elements are deselected and the approximate size 
decreases. Manual Pass Verified in Aug. 22-2018 at 10:24AM.

13.8 Archive file selection

1) Click on the Browse button.
2) Select a location on the filesystem
3) Enter the file name export.tar

A file chooser dialog comes up. When the 
destination file is entered, the “To archive file” is 
filed with export.tar.gz. The Finish button should 
be enabled. Manual Pass Verified in Aug. 22-2018 at 10:25AM.

13.9
Change export options, change 
compression Unselect the “Compress” checkbox.

The name of the archive file changes to export.
tar SWTBot Pass

13.10 Change export options, change format Change to Zip format
The name of the archive file changes to export.
zip SWTBot Pass
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13.11
Change export options, change format 
and compression

Change to Tar format then select the Compress 
checkbox.

The name of the archive file changes to export.
tar.gz Manual Pass Verified in Aug. 22-2018 at 10:26AM.

13.12 Finish the wizard Click Finish

A progress bar should appear at the bottom the 
the dialog and it should disappear upon 
completion. The export.tar.gz file should be 
created on the file system. SWTBot Pass

13.13 Overwrite
Open the wizard again and select the traces (step 
13.2, 13.3). Click Finish.

The Archive file name should be remembered 
and already filled. A dialog should prompt the 
user to overwrite. Answering No should keep the 
wizard opened. Answering Yes should re-export 
the archive and close the wizard. Manual Pass Verified in Aug. 22-2018 at 10:26AM.

13.14 Verify formats

Open the wizard again and select the traces (step 
13.2, 13.3). This time, choose Zip format. Click 
Finish.

The export.zip file should be created on the file 
system Manual Pass Verified in Aug. 22-2018 at 10:27AM.

13.15 Verify content
Open the tar.gz and the zip files in an archive 
manager.

In both archives, verify that it contains:
1) A trace folder for each trace containing all the 
trace files (excluding supplementary files)
2) A .tracing folder containing all the 
supplementary files
3) An export-manifest.xml file listing the trace 
files, supplementary files and bookmarks Manual Pass Verified in Aug. 22-2018 at 10:27AM.

13.16 Partial selection

Open the wizard again and select the traces (step 
13.2, 13.3). This time, unselect both Supplementary 
files subtrees. Click Finish.

Verify that the exported archive contains:
In both archives, verify that it contains:
1) A Traces folder containing all the trace files 
(excluding supplementary files)
2) No .tracing folder
3) An export-manifest.xml file listing the trace 
files and bookmarks Manual Pass Verified in Aug. 22-2018 at 10:27AM.

14 Trace Package Import Wizard

14.1 Preparation

Create an empty tracing project. Make sure you have 
export.tar.gz available from the Trace Package Export 
Wizard (13) test case, which should include 
everything including trace files, supplementary files 
and export-manifest.xml.

14.2 Open the trace package import wizard
Click on “File”, “Import...”, “Tracing”, “Trace 
Package Import” and click Next

The first page of the wizard should appear 
(Choose content to import) SWTBot Pass

14.3 Project Selection
Click the Select button. Choose the previously created 
project.

The Into project field gets filled with the selected 
project name. SWTBot Pass

14.4 Archive file selection
1) Click on the Browse button.
2) Browse for export.tar.gz on the file system

Finish should be become enabled when the first 
trace is selected. If all traces are unselected, the 
Next button is disabled. SWTBot Pass

14.5 Deselect/Select All
With traces selected, press the Deselect All button. 
Then press on the Select All button.

Finish should become disabled after Deselect 
All, enabled after Select All. SWTBot Pass

14.6 Trace element selection Unselect the trace2 element All elements in the trace tree are unselected. SWTBot Pass
14.7 Trace sub-element selection Unselect the kernel_vm > Trace element All elements in the trace tree are unselected. Manual Pass Verified in Aug. 22-2018 at 10:27AM.

14.8 Select/Deselect All
With nothing selected, click Select All. Then click 
Deselect All. Then click Select All again.

When Select All is clicked, all the tree elements 
are selected. When Deselect All is clicked, all 
the tree elements are deselected.. SWTBot Pass

14.9 Finish the wizard Click Finish

A progress bar should appear at the bottom the 
the dialog and it should disappear upon 
completion. The two traces should appear under 
the project in Project Explorer SWTBot Pass Very fast

14.10 Supplementary Files Right-click on trace2 in Project Explorer
Delete Supplementary files appears in the 
content menu Manual Pass Verified in Aug. 22-2018 at 10:28AM.

14.11 Bookmarks Open the Bookmarks view
Bookmarks appear in the list for the imported 
traces Manual Pass Verified in Aug. 22-2018 at 10:28AM.

14.12 Open from bookmark Double click on one of the bookmarks

The corresponding trace opens at the 
bookmarked event. Bookmarks are displayed in 
the event table. Manual Pass Verified in Aug. 22-2018 at 10:29AM.

14.13 Overwrite
Open the wizard again (step 13.2) and select the 
archive file (step 13.4). Click Finish.

A dialog should prompt the user to overwrite for 
each trace. Answering Yes to All should 
overwrite without prompting again. Manual Pass Verified in Aug. 22-2018 at 10:29AM.

15 Time Offsetting
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15.1 Preparation

Open Project Explorer view and Properties view. 
Create an empty tracing project. Import two different 
traces to the project. Open the traces and note their 
start time. Close the traces.

15.2
Apply time offset dialog - trace 
selection

Select both trace elements in the Project Explorer 
view. Right-click and select Apply Time Offset...

The Apply time offset dialog opens in Basic 
mode. The Trace name show both traces and the 
Offset in seconds is blank. SWTBot Pass

15.3
Apply time offset dialog - folder 
selection

Select the Traces folder element in the Project 
Explorer view. Right-click and select Apply Time 
Offset...

The Apply time offset dialog opens in Basic 
mode. The Trace name show both traces and the 
Offset in seconds is blank. SWTBot Pass

15.4
Apply time offset dialog - experiment 
selection

Create an experiment with both traces. Select the 
experiment element in the Project Explorer view. 
Right-click and select Apply Time Offset...

The Apply time offset dialog opens in Basic 
mode. The Trace name show both traces and the 
Offset in seconds is blank. SWTBot Pass

15.5 Apply time offset dialog - Basic mode

Select a trace element in the Project Explorer view. 
Right-click and select Apply Time Offset... In the 
Offset in seconds column, enter a time with seconds 
and decimals. Click OK. Open the trace.

The timestamps in the trace are all offset by the 
entered value. The Properties view shows the 
'time offset' with the entered value. SWTBot Pass

15.6
Apply time offset dialog - cumulative 
offset

Select the same trace element in the Project Explorer 
view. Right-click and select Apply Time Offset... In 
the Offset in seconds column, enter a time with 
seconds and decimals. Click OK. Open the trace.

The timestamps in the trace are all offset by the 
cumulative sum of the previous and current 
entered value. The Properties view shows the 
'time offset' with the cumulative value. SWTBot Pass

15.7 Clear time offset

Select the trace element in the Project Explorer view. 
Right-click and select Clear time offset. Click OK to 
confirm. Open the trace.

The timestamps in the trace are back to their 
original values. The Properties view shows the 
'time offset' as blank. SWTBot Pass

15.8
Apply time offset dialog - Advanced 
mode

Open one trace and close the other trace. Select both 
trace elements in the Project Explorer view. Right-
click and select Apply Time Offset... Choose the 
Advanced radio button.

The Apply time offset dialog opens and is 
switched to Advanced mode. The Trace name 
show both traces and the Offset in seconds is 
blank. The Reference time for the opened trace is 
set to its start time. Manual Pass Verified in Aug. 22-2018 at 10:29AM.

15.9
Apply time offset dialog - Advanced 
mode - compute from selection

Double-click the second trace to open it. Select an 
event in its trace editor. Select the first trace editor. 
Select an event in its trace editor. Click the button in 
the dialog row of the second trace. Click OK. Open 
both traces.

Both traces are open. Selecting an event updates 
the Reference time for the selected trace, and 
updates the Target time for all traces. Pressing 
the button computes the Offset in seconds as the 
difference between Target time and Reference 
time for that row. The trace which has a 
computed offset is closed when the OK button is 
pressed. After reopening, the two previously 
selected events now have the same timestamp. 
The Properties view shows the 'time offset' with 
the computed value. Manual Pass Verified in Aug. 22-2018 at 10:29AM.

15.10
Apply time offset dialog - Advanced 
mode - compute from entered values

Select the first trace element in the Project Explorer 
view. Right-click and select Apply Time Offset... 
Choose the Advanced radio button. Double-click the 
trace name to open it. Select the Reference time cell 
and copy the start time. Select the Target time and 
paste the value. Edit both values to different times. 
Click the button in the trace row. Click OK. Open the 
trace.

The trace is opened. The Reference time is set to 
the trace start time. The Reference time and 
Target time can be copied, pasted, and edited. 
Pressing the button computes the Offset based on 
the current time values. The trace is closed with 
the OK button is pressed. After reopening, the 
timestamps in the trace are offset according to 
the computed value. The Properties view shows 
the 'time offset' with the computed value. Manual Pass Verified in Aug. 22-2018 at 10:29AM.

15.11 Clear time offset with opened traces

Open both traces. Select both trace elements in the 
Project Explorer view. Right-click and select Clear 
time offset. Click OK to confirm. Open the traces.

The opened traces are closed when the OK 
button is pressed. After reopening, the 
timestamps in the traces are back to their original 
values. The Properties view shows the 'time 
offset' as blank. Manual Pass Verified in Aug. 22-2018 at 10:29AM.
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Section Pass Fail Type To Do Comment

TMF - Histogram View 49 0 5 0 48
Target: Ubuntu 14.04 64 bit

Step Test Case Action Verification Comment

1 Preparation

1.1 Step 1 Open and reset LTTng Kernel perspective
LTTng Kernel perspective opens with 
correct views SWTBot Pass

1.2 Step 2 Open an LTTng trace Views are populated SWTBot Pass

2 Manage View

2.1 Close view Close the Histogram View
Histogram View is removed from 
perspective SWTBot Pass 84710

2.2 Open view Window > Show View > Tracing > Histogram
Histogram View is displayed and re-
populated SWTBot Pass 84710

2.3 Resize Resize the Histogram View width-wise
Histograms are compressed/decompressed 
without loss SWTBot Pass Tested with HistogramDataModelTest

3 Full Trace Histogram
3.1 Single selection Select timestamp with left-click Selection Start/End + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 15:42PM.

3.2 Range selection Select time range with shift-left-click, shift-left-drag or left-drag Selection Start/End + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 15:42PM.

3.3 Drag zoom window Drag the zoom window left/right with ctrl-left-drag or middle-drag
Zoom window is dragged, won't go beyond 
full range Manual Pass Verified in Aug. 21-2018 at 15:44PM.

3.4 Move zoom window Move the zoom window with ctrl-left-click or middle-click
Zoom window is centered on click, won't go 
beyond full range Manual Pass Verified in Aug. 21-2018 at 15:44PM.

3.5 Set zoom window Set a new zoom window with right-drag
Zoom window is set, Window Span is 
updated, won't go beyond histogram range Manual Pass Verified in Aug. 21-2018 at 15:45PM.

3.6 Zoom in/out Zoom in/out with mouse wheel up/down

Zoom window is updated, Window Span is 
updated, won't go below 2 ns, won't exceed 
full trace range Manual Pass Verified in Aug. 21-2018 at 15:45PM.

3.7 Arrow keys Move the current event using left/right arrow keys
Selection (blue bar) moves to the 
previous/next non-empty bucket Manual Pass Verified in Aug. 21-2018 at 15:46PM.

3.8 Home/End keys Press Home/End key

Selection Start/End moves to beginning/end 
of trace (i.e. start time of last bucket is 
selected) Manual Pass Verified in Aug. 21-2018 at 15:47PM.

3.9 Lost events
With a trace containing lost events, click the "Hide lost events" toolbar 
icon. Click it again.

The lost events (red bars) are toggled on and 
off. Manual Pass Verified in Aug. 21-2018 at 15:52PM.

3.10 Zoom in/out (key) Zoom in/out with +/- key

Zoom window is updated, Window Span is 
updated, won't go below 2 ns, won't exceed 
full trace range Manual Pass Verified in Aug. 21-2018 at 15:51PM.

4 Time Range Histogram
4.1 Single selection Select timestamp with left-click Selection Start/End + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 15:54PM.

4.2 Range selection Select time range with shift-left-click, shift-left-drag or left-drag Selection Start/End + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 15:56PM.

4.3 Drag zoom window Drag the zoom window left/right with ctrl-left-drag or middle-drag
Zoom window is dragged, won't go beyond 
full range Manual Pass Verified in Aug. 21-2018 at 15:56PM.

4.4 Zoom in/out Zoom in/out with mouse wheel up/down

Zoom window is updated, Window Span is 
updated, won't go below 2 ns, won't exceed 
full trace range Manual Pass Verified in Aug. 21-2018 at 15:58PM.

4.5 Arrow keys Move the current event using left/right arrow keys
Selection (blue bar) moves to the 
previous/next non-empty bucket Manual Pass Verified in Aug. 21-2018 at 15:58PM.

4.6 Home/End keys Press Home/End key

Selection Start/End moves to beginning/end 
of time range (i.e. start time of last bucket is 
selected) Manual Pass Verified in Aug. 21-2018 at 15:59PM.

4.7 Lost events
With a trace containing lost events, click the "Hide lost events" toolbar 
icon. Click it again.

The lost events (red bars) are toggled on and 
off. Manual Pass Verified in Aug. 21-2018 at 15:59PM.

3.10 Zoom in/out (key) Zoom in/out with +/- key

Zoom window is updated, Window Span is 
updated, won't go below 2 ns, won't exceed 
full trace range Manual Pass Verified in Aug. 21-2018 at 15:59PM.

5 Selection Start/End
5.1 Set selection start Enter a TS within the full range in Selection Start widget Selection Start + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 16:15PM.

5.2 Set selection end Enter a TS within the full range in Selection End widget Selection End + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 16:15PM.

5.3 Set selection (linked)
Select the link icon. Enter a TS within the full range in Selection Start 
widget Selection Start/End + blue bars are updated Manual Pass Verified in Aug. 21-2018 at 16:16PM.

5.4 Set invalid selection start Enter a TS before the full range start in Selection Start widget Selection Start + blue bar set to first event Manual Pass Verified in Aug. 21-2018 at 16:18PM.

5.5 Set invalid selection end Enter a TS after the full range end in Selection End widget Selection End + blue bar set to last event Manual Pass Verified in Aug. 21-2018 at 16:18PM.

6 Window Span
6.1 Set window span Enter a span in Window Span widget Both Histograms are updated accordingly Manual Pass Verified in Aug. 22-2018 at 08:54AM.

6.2 Set large window span Enter an invalid span (too large) in Window Span widget Span set to full range Manual Pass Verified in Aug. 22-2018 at 08:55AM.
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6.3 Set invalid window span
Enter an invalid span (too small, negative, not a number) in Window 
Span widget Span set to previous value Manual N/A Verified in Aug. 22-2018 at 08:58AM. What is too small? 1ns seems to work (smaller than 1ns). Hung: i think the 1ns is a minimum value and the result of this test case needs to be changed

7
Selected Timestamp 
Synchronization

7.1
Time Range mouse 
synchronization

Click on the time range histogram. The time of the bucket at the 
mouse position is selected.

Other views are synchronized to the selected 
time Manual Pass Verified in Aug. 22-2018 at 09:04AM.

7.2
Full Trace mouse 
synchronization

Click on the full trace histogram. The time of the bucket at the mouse 
position is selected.

Other views are synchronized to the selected 
time Manual Pass

Verified in Aug. 22-2018 at 09:06AM. Zoom Window is moved if 
selection is outside the current zoom window and a time graph 
window is open (e.g. CFV). Otherwise zoom window stays.

7.3
Selection synchronization 
(linked)

Select the link icon. Enter a time within the full range in Selection 
Start widget

Other views are synchronized to the selected 
time Manual Pass Verified in Aug. 22-2018 at 09:07AM.

7.4 External synchronization In any other view that supports time synchronization, select a time.
Selection Start/End + blue bars in both 
histograms are updated to the selected time Manual Pass Verified in Aug. 22-2018 at 09:09AM.

8
Selected Time Range 
Synchronization

8.1
Time Range mouse 
synchronization

Select a time range in the small histogram (shift-left click, left-drag or 
shift-left drag).

Verify that the selected time range shows in 
both histograms, and in other views. Manual Pass Verified in Aug. 21-2018 at 16:37PM.

8.2
Full Trace mouse 
synchronization

Select a time range in the full histogram (shift-left click, left-drag, 
shift-left drag).

Verify that the selected time range shows in 
both histograms, and in other views. Manual Pass Verified in Aug. 21-2018 at 16:37PM.

8.3
Selection Start/End 
synchronization Enter a time within the full range in Selection Start/End widget

Other views are synchronized to the selected 
time range Manual Pass

Verified in Aug. 21-2018 at 16:47PM. Zoom Window is moved if 
selection is outside the current zoom window and a time graph 
window is open (e.g. CFV). Otherwise zoom window stays.

8.4 External synchronization
In any other view that supports time range synchronization, select a 
time range.

Selection Start/End + blue bars in both 
histograms are updated to the selected time 
range Manual Pass Verified in Aug. 21-2018 at 16:37PM.

9
Zoom Window 
synchronization

9.1
Time Range mouse 
synchronization

Select a zoom window in the small histogram (ctrl-left drag, middle-
drag, right-drag, mouse wheel up/down).

Other views are synchronized to the new 
range Manual Pass Verified in Aug. 22-2018 at 09:18AM.

9.2
Full Trace mouse 
synchronization

Select a zoom window in the full histogram (ctrl-left drag, middle-
click, middle-drag, right-drag, mouse wheel up/down).

Other views are synchronized to the new 
range Manual Pass Verified in Aug. 22-2018 at 09:18AM.

9.3
Window Span 
synchronization Enter a new span in Window Span widget

Other views are synchronized to the new 
range Manual Pass Verified in Aug. 22-2018 at 09:15AM.

9.4 External synchronization
In any other view that supports range synchronization, select a new 
zoom window.

Window Span and both histograms are 
updated to the new range Manual Pass Verified in Aug. 22-2018 at 09:20AM.

10
Multiple Trace 
Synchronization

Preparation

1) Download traces.zip (if necessary) and unzip into a local 
directory ${local}
2) Import kernel trace ${local}/traces/import/kernel-
overlap-testing 
3) Import UST ${local}/traces/import/trace ust-overlap-
testing
4) Create experiment with trace of 2) in it

10.1
Open multiple traces (no 
overlap) Open multiple traces that don't overlap in time View shows the last opened trace Manual Pass Verified in Aug. 22-2018 at 09:27AM.

10.2
Change selected time and 
range (no overlap) Select a time and new range

Selection Start/End, Window Span and both 
histograms are updated to selected time and 
new range. Manual Pass Verified in Aug. 21-2018 at 16:45PM.

10.3
Open multiple traces 
(overlap)

- Open multiple traces that overlap in time
- For both traces, in Events table right mouse-click -> Follow time 
updates from other traces View shows the last opened trace Manual Pass Verified in Aug. 21-2018 at 16:47PM.

10.4
Change selected time and 
range (overlap) Select a time and new range

Selection Start/End, Window Span and both 
histograms are updated to selected time and 
new range. Manual Pass Verified in Aug. 21-2018 at 16:47PM.

10.5 Select other trace (overlap) Select different trace by clicking its editor tab 

View is updated to show selected trace. 
Selection Start/End, Window Span and both 
histograms are set to the newly selected time 
and range. Manual Pass Verified in Aug. 21-2018 at 16:45PM.

10.6 Trace coloring
With an experiment containing multiple traces opened, click the 
"Activate trace coloring" toolbar icon. Click it again.

The colors in both Histograms and toggled 
on and off. When it is toggled off, the 
legend disappears at the bottom and only 
one color is used for non-lost events. Manual Pass Verified in Aug. 22-2018 at 09:36AM.

10.7 Close all traces Close all trace editor tabs View is cleared. Manual Pass Verified in Aug. 21-2018 at 16:44PM.
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Section Pass Fail To Do Comment

TMF - Colors View 6 0 6 0 0
Target: Ubuntu 14.10 64 bit

Step Test Case Action Verification Comment

1 Open a test trace a trace is visible in the events editor SWTBot SWTBot Pass

2 Open the colors view the view is visible SWTBot SWTBot Pass

3 Select a color and a filter
Select a color and a filter, the matching events should update their 
colors (background and foreground) to the new ones SWTBot SWTBot Pass

4 Add multiple colors Click on add 4 times, four colors should be displayed SWTBot SWTBot Pass

5 Change the color priorities
By clicking on up and down, the order of the displayed colors should 
change SWTBot SWTBot Pass

6 Delete all the colors The color filters should disappear. SWTBot SWTBot Pass
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Section Pass Fail Type To Do Comment
TMF - BookmarksView 17 0 2 0 15

Target: Ubuntu 14.10 64 bit

Step Test Case Action Verification Comment

1 Preparation

1.1 Preparation step 1 Open and reset LTTng Kernel perspective
LTTng Kernel perspective opens with 
correct views. SWTBot Pass

2 Trace bookmarks
2.1 Show Bookmarks View Select Bookmarks view (bottom folder) Bookmaks view is shown Manual Pass Verified in Aug. 21-2018 at 15:09PM.

2.2 Open trace Open an LTTng CTF Kernel trace

Views are populated. Verify that a 
Kernel events editor is opened showing 
LTTng Kernel specific columns SWTBot Pass

2.3 Add Trace Bookmark

Add a bookmark,  by
a) double-clicking on the left margin next to an event 
b) right-clicking the margin and select Add bookmark.... 
c) using the Edit > Add bookmark... menu.
Enter the bookmark description in dialog box

Make sure that bookmark icon is shown 
on left site of the event row and is added 
to the Bookmarks view with relevant 
information (i.e. Description entered and 
correct trace resource) Manual Pass Verified in Aug. 21-2018 at 15:15PM.

2.4 Open Trace Bookmark (1)
Scroll within event table so that bookmark is not visible anymore and 
then double-click on bookmark in Bookmarks View

Make sure that event with bookmark is 
selected and visible in event table Manual Pass Verified in Aug. 21-2018 at 15:24PM.

2.5 Open Trace Bookmark (2)
Open another trace #2 and then double-click on bookmark in 
Bookmarks view

Make sure that correct trace #1 is 
brought to top and correct event with 
bookmark is selected in events table Manual Pass Verified in Aug. 21-2018 at 15:29PM.

2.6 Open Trace Bookmark (3)
Close the trace #1 and then double-click on bookmark in Bookmarks 
view

Make sure that correct trace #1 is opened 
and correct event with bookmark is 
selected in events table Manual Pass Verified in Aug. 21-2018 at 15:30PM.

2.7
Delete Bookmark (from 
table)

Select bookmarks icon in event table right-click on icon and select 
"Remove Bookmark"

Make sure that bookmark icon is 
removed from event table and 
corresponding bookmark is removed 
from the Bookmarks view Manual Pass Verified in Aug. 21-2018 at 15:31PM.

2.8
Delete Bookmark (from 
table) Double-clicking bookmarks icon in event table.

Make sure that bookmark icon is 
removed from event table and 
corresponding bookmark is removed 
from the Bookmarks view Manual Pass Verified in Aug. 21-2018 at 15:31PM.

2.9
Delete Bookmark (from 
Bookmarks view)

Add a bookmark (see 2.4), then select bookmark in Bookmarks view, 
right mouse click and select "Delete". Confirm the deletion.

Make sure that bookmark icon is 
removed from event table and 
corresponding Bookmark is removed 
from the Bookmarks view Manual Pass Verified in Aug. 21-2018 at 15:32PM.

3 Experiment bookmarks

3.1 Create and open experiment
Create Experiment with 2 LTTng CTF Kernel traces in it and open 
experiment

Verify that an Events editor is opened 
showing LTTng Kernel specific columns Manual Pass Verified in Aug. 21-2018 at 15:35PM.
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3.2 Add Experiment Bookmark

Add a bookmark,  by
a) double-clicking on the left margin next to an event 
b) right-clicking the margin and select Add bookmark.... 
c) using the Edit > Add bookmark... menu.
Enter the bookmark description in dialog box

Make sure that bookmark icon is shown 
on left site of the event row and is added 
to the Bookmarks view with relevant 
information (i.e. Description entered and 
correct experiment resource) Manual Pass Verified in Aug. 21-2018 at 15:35PM.

3.3
Open Experiment Bookmark 
(1)

Scroll within event table so that bookmark is not visible anymore and 
then double-click on bookmark in Bookmarks View

Make sure that event with bookmark is 
selected and visible in event table Manual Pass Verified in Aug. 21-2018 at 15:36PM.

3.4
Open Experiment Bookmark 
(2)

Open another trace #2 and then double-click on bookmark in 
Bookmarks view

Make sure that correct experiment #1 is 
brought to top and correct event with 
bookmark is selected in events table Manual Pass Verified in Aug. 21-2018 at 15:37PM.

3.5
Open Experiment Bookmark 
(3)

Close the experiment #1 and then double-click on bookmark in 
Bookmarks view

Make sure that correct experiment #1 is 
opened and correct event with bookmark 
is selected in events table Manual Pass Verified in Aug. 21-2018 at 15:37PM.

3.6
Delete Bookmark (from 
table)

Select bookmarks icon in Events view, right-click on icon and select 
"Remove Bookmark"

Make sure that bookmark icon is 
removed from event table and 
corresponding bookmark is removed 
from the Bookmarks view Manual Pass Verified in Aug. 21-2018 at 15:38PM.

3.7
Delete Bookmark (from 
Bookmarks view)

Add a bookmark (see 6.4), then select bookmark in Bookmarks view, 
right mouse click and select "Delete". Confirm the deletion.

Make sure that bookmark icon is 
removed from event table and 
corresponding Bookmark is removed 
from the Bookmarks view Manual Pass Verified in Aug. 21-2018 at 15:38PM.
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Section Pass Fail To Do Comment

TMF - Filters View 12 0 12 0 1
Target: Ubuntu 14.10 64 bit

Step Test Case Action Verification Comment

1 Open a trace to be filtered Trace is opened SWTBot SWTBot Pass

2 Open filter view Filter view is opened SWTBot SWTBot Pass

3
Create a filter on event type 
and timestamp The filterview contains a filter on the event type and the timestamp SWTBot SWTBot Pass

3.1 Apply that filter A subset of the events pass SWTBot SWTBot Pass

4
Create a filter on the 
timestamp oring field values Create the filter SWTBot SWTBot Pass

4.1 Apply that filter A subset of the events pass SWTBot SWTBot Pass

5
Create a filter with equals 
node Create the filter SWTBot SWTBot Pass

5.1 Apply that filter A subset of the events pass SWTBot SWTBot Pass

6
Create a filter with matches 
node Create the filter SWTBot SWTBot Pass

6.1 Apply that filter A subset of the events pass SWTBot SWTBot Pass

7
Create a filter with contains 
node Create the filter SWTBot SWTBot Pass

7.1 Apply that filter A subset of the events pass SWTBot SWTBot Pass
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Section Pass Fail To Do Comment

TMF - Sequence Diagram 35 2 2 0 35
Target: Ubuntu 16.04 64 bit

Step Test Case Action Verification Type Comment

1 Preparation
1) Download traces.zip (if necessary) and unzip 
into a local directory ${local}
2 )Use traces simple-server-thread1 and simple-
server-thread2 under traces/import/ for test cases 
below

Note: UI tests are not SWTBot, but JUnit  tests. Tests are 
triggered programmatically right below the dialogs level

1.1 Open perspective Open and reset LTTng Kernel perspective

LTTng Kernel perspective opens with 
correct views:
Project Explorer, Control, Control Flow, 
Resources, Statistics, Histogram, 
Properties, Bookmarks SWTBot Pass

1.2
Open TMF Sequence 
Diagram View

Use menu Window → Show View → Other … → Tracing 
→ Sequence Diagram

Verify that 'Sequence Diagram' view is 
shown SWTBot Pass

1.3
Create and open experiment 
with sequence diagram data

1) Create Tracing Project
2) Create Experiment (SeqExp) 
3) Import 2 traces simple-server-thread1 and simple-server-
thread2
4) Add these 2 traces to experiment
6) Open (double-click on) the experiment

Verify that sequence diagram was loaded. 
The interaction show the signal numbers 
(Note that trace doesn't contain strings for 
the interactions. A special parser would be 
necessary to map signal number to trace) Manual Pass Verified in Aug. 21-2018 at 13:38PM.

2 Manage View
2.1 Close view Close Sequence Diagram view Sequence Diagram View is removed from perspectiveManual Pass Verified in Aug. 21-2018 at 13:39PM.

2.2

Open view when 
experiment/traces is already 
loaded

1) Close 'Sequence Diagram' View 
2) load sequence diagram experiment 
3) Open Sequence Diagram view

Verify that sequence diagram was loaded. 
Verify that all 17 pages are loaded. Manual Pass

Verified in Aug. 21-2018 at 13:42PM.. Difficult to get the 
numb of pages

3 Tooltip

3.1 Hover over interaction
1) Goto to first page (no selection of any interaction or 
lifeline) 2) Hover over first interaction (arrow or number)

Verify that tooltip appears with content 
with interaction name and time stamp 
(10000 14:58:00.740995147) Manual Pass

Verified in Aug. 21-2018 at 13:43PM.. Tooltip backgound 
is very dark and text is hard to read on Ubuntu 14.10, 
16.10 with default theme
https://bugs.eclipse.org/bugs/show_bug.cgi?id=455523.

3.2
Hover over interaction after 
selection

1) Goto to first page 
2) select first interaction 
3) Hover over 3rd interaction

Verify that tooltip appears with content 
with interaction names and time stamp 
delta between selected interaction and 
interaction that was hovered over (10001 
→ 10000 delta: 000.000 157 023) Manual Pass Verified in Aug. 21-2018 at 13:46PM.

3.3
Hover over time compression 
bar

Hover over first element in time compression bar on the left 
of the view

Verify that tooltip appears with delta and 
graph to show where delta is in relation to 
current configured min max values. (delta: 
000.000 3 480) Manual Pass Verified in Aug. 21-2018 at 13:47PM.

4 View Synchronization

4.1 Selection of interaction Select an interaction in the 'Sequence Diagram'

Verify that interaction is highlighted in 
'Sequence Diagram' view. Verify that in 
the events table the corresponding event is 
selected. Verify that time stamps matches Manual Pass Verified in Aug. 21-2018 at 13:47PM.

4.2
Selection of event in events 
table

Select an sequence diagram event in the events table (type 
SEND or RECEIVE)

Verify that corresponding interaction is 
selected in the 'Sequence Diagram' view Manual Pass Verified in Aug. 21-2018 at 13:48PM.

4.3 Selection of new time range Change time range in 'Histogram View'. 

Verify that the content of the 'Sequence 
diagram' changes and the interactions are 
part of the new window range Manual Pass Verified in Aug. 21-2018 at 13:51PM.
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5 View Actions

5.1 Test page navigation

Use buttons and menu items 'Go to next page', 'Go to 
previous page', 'Go to last page' and 'Go to first page' to 
navigate through trace. Use also menu item 'Pages...' to jump 
to specific page

Verify that different time ranges are 
selected when changing page by looking 
at Histogram View. Histogram View 
window will show the start of the page. 
Note that there are 10000 interactions per 
page. In this traces there are in total 
160032 interactions. Verify that last page 
has 32 interactions between 2 lifelines. Manual Pass Verified in Aug. 21-2018 at 13:52PM.

5.2 Test menu item 'Pages...'

1) Select menu item 'Pages...' 
2) In text box type “9” 
3) Click on 'OK'

Verify that a dialog box will show. Verify 
that for this trace it shows 'Total: 17 pages 
is shown” and the current page is 
displayed in the text box. After step 3) 
verify that page where changed to page 9. 
For this trace page 9 is the page with 3 
lifelines. Manual Pass Verified in Aug. 21-2018 at 13:55PM.

5.3 Find of interaction

Goto to page 1 → 
1) Use button and menu item “Find” 
2) select Interactions and deselect lifeline 
3) type regular expression 10.*00 
4) press find 
5) press find 
6) press find 
7) press find 
8) press find

After 4) verify that interaction 10000 
(player1 → master) is selected. After 5) 
verify that interaction 10100 (master → 
player1) is selected. After 6) verify that 
10000 (player2 → master) is selected. 
After 7) verify that interaction 10100 
(master → player2). After 8 nothing else 
will be found Manual Pass Verified in Aug. 21-2018 at 14:01PM.

5.4 Find of lifeline

Goto to page 1 → 
1) Use button and menu item “Find” 
2) select lifeline and deselect interaction 
3) type  player2 
4) press find 
5) press find

After 4) verify that lifeline with name 
player2 is selected (page 9 with 3 
lifelines). After 5) player2 is selected on 
page 10 Manual Pass

Verified in Aug. 21-2018 at 14:14PM. I agree with JC, It 
reaches the right pages but the selection does not 
highlight anything when the find box is still opened. It 
only highlight the lifeline when we close the find dialog. 
Bernd: It supposed to highlight the lifeline on the correct 
page. So, test is successful. JC: The selection highlight 
the lifeline but it is difficult to see.

5.5 Find criteria persistence
1) Restart eclipse 
2) open find dialog 

Verify that previous used find criteria are 
still in the list Manual Pass Verified in Aug. 21-2018 at 14:27PM.

5.6 Find short-cut
1) Select 'Sequence Diagram' view 
2) pres CTRL+F Verify that find dialog opens Manual Pass Verified in Aug. 21-2018 at 14:29PM.

5.7 Filter of interactions

Goto to page 1 → 
1) Use menu item 'Hide Patterns...' 
2) Press Add 
3.1) select Interactions and deselect Lifeline 
3.2) type regular expression 10.*03 
4) Press 'Create' 
5) Press 'Ok'

After 5) verify that Interactions with name 
10003 and 10103 are not shown Manual Pass Verified in Aug. 21-2018 at 14:32PM.

5.8 Filter of lifelines

Goto to page 9 → 
1) Use menu item 'Hide Patterns...' 
2) Press Add 
3.1) select Lifelines and deselect Interactions 
3.2) type regular player2 
4) Press 'Create' 
5) Press 'Ok' After 5) verify that player2 is not shown Manual Pass Verified in Aug. 21-2018 at 14:33PM.

5.9 Deselect filter

1) Apply one filter 
2) Use menu item 'Hide Patterns...' 
3) deselect filter 
4) click 'Ok'

Verify that all lifelines and interactions are 
shown Manual Pass Verified in Aug. 21-2018 at 14:35PM.

5.10 Filter criteria persistence
1) Restart eclipse 
2) open hide dialog 

Verify that previous used hide criteria are 
still in the list Manual Pass Verified in Aug. 21-2018 at 14:36PM.

5.11 Zoom-in

1) Use button and menu item for zoom-in to activate 
zooming  in 
2) click into sequence diagram view

Verify that 'Sequence Diagram' view 
zooms in. Note that no selection is 
possible. Manual Pass Verified in Aug. 21-2018 at 14:36PM.

5.12 Selection after zooming

1) Click on button and menu item 'Select' to go back to 
selection mode 
2) select an interaction Verify that selection is possible. Manual Pass Verified in Aug. 21-2018 at 14:36PM.
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5.13 Zoom-out

1) Use button and menu item for zoom-out to activate 
zooming out 
2) click into sequence diagram view

Verify that 'Sequence Diagram' view 
zoom out. Note that no selection is 
possible. Manual Pass Verified in Aug. 21-2018 at 14:37PM.

5.14 Reset zoom
1) Use button and menu item for 'Reset zoom factor' to reset 
the zoom level

Verify that 'Sequence Diagram' view goes 
back to default zoom Manual Pass Verified in Aug. 21-2018 at 14:38PM.

5.15 Configure min/max

1) Select menu item 'Configure Min Max' 
2) Change min to 100 and max to 2000 (keep scale and 
precision) 
3) press 'Ok'

After 1) verify that a dialog box shows 
with default values. After 3) verify that 
time compression bar changes some 
colors. It will show more deeper red 
because the max value is lower. Manual Pass Verified in Aug. 21-2018 at 14:40PM.

5.16 Configure min/max (default)

After changing min and max 
1) select menu 'Configure Min Max' 
2) press 'Default' 3) press 'Ok'

After step 2) the default values are shown. 
After step 3) the time compression bar 
will change colors. Note that the default 
values are computed based on all deltas of 
2 consecutive interactions. Manual Pass Verified in Aug. 21-2018 at 14:40PM.

5.17 Show node end

Goto to page 1 → 
1) Resize view so that the arrow of the interaction is not 
shown 
2) select on interaction 
3) Use menu item Navigation → Show node end

Verify that end lifeline of the interaction 
(the arrow) is shown Manual Pass Verified in Aug. 21-2018 at 14:40PM.

5.18 Show node start

Goto to page 1 → 
1) Resize view so that the beginning of the interactions are 
not shown 
2) select on interaction 
3) Use menu item Navigation → Show node start

Verify that start lifeline of the interaction 
is shown Manual Pass Verified in Aug. 21-2018 at 14:55PM.

5.19 Show node end short-cut

Goto to page 1 → 
1) Resize view so that the arrow of the interaction is not 
shown 
2) select on interaction 
3) Press SHIFT+ALT+END

Verify that end lifeline of the interaction 
(the arrow) is shown Manual Fail

Verified in Aug. 21-2018 at 14:56PM. The shortcut is not 
working when the mouse is hovering the interaction as 
seen in the previous version 4.0.0

5.20 Show node start short-cut

Goto to page 1 → 
1) Resize view so that the arrow of the interaction is not 
shown 
2) select on interaction 
3) Press SHIFT+ALT+HOME

Verify that start lifeline of the interaction 
is shown Manual Fail

Verified in Aug. 21-2018 at 14:56PM. The shortcut is not 
working when the mouse is hovering the interaction as 
seen in the previous version 4.0.0

5.21 Scroll down short cut Press SHIFT+ALT+ARROW_DOWN
Verify that within a page the display 
scrolls down per view size Manual Pass Verified in Aug. 21-2018 at 15:00PM.

5.22 Scroll up short cut Press SHIFT+ALT+ARROW_UP
Verify that within a page the display 
scrolls up per view size Manual Pass

Verified in Aug. 21-2018 at 15:00PM. Key 
combination on Ubuntu 12.04 is used for something 
else. This can be disabled using the combiz-
settings-manager (http://askubuntu.
com/questions/171489/how-to-unbind-shift-alt-up-
shortkey-in-12-04) 
After disabling this combination this test case 
passes

On Ubuntu 14.04, 14.10, this is not an issue, by 
default the keys are not mapped.

5.23 Overview feature
Goto page 9 → Keep pressing + icon at the lowest right 
corner of the view and drag down, up, left or right

Verify that it's possible to navigate 
through a  page of the sequence diagram 
view Manual Pass

Verified in Aug. 21-2018 at 15:01PM. On Ubuntu, the 
movement is hectic and the overview box is very narrow.

On Mac OS X 10.8, the button is not visible but there is a 
visible empty space that is clickable in its place. Clicking 
on it brings up the overview box which has a reasonable 
size but movement is still hectic.

Bug 436442

5.24 Print

Select 'Sequence Diagram' view and press printer icon in the 
Eclipse's tool bar (or use CTRL+P). Select one pager page to 
print Verify that it is possible to print Manual Pass

Verified in Aug. 21-2018 at 15:05PM. The dialog is 
confusing on Ubuntu. The "from pages" option do not 
update directly the values you enter

Works on windows (including CTRL+P) Pass on 16.04 and 16.10... could it be cups giving you a hard time?
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5.25 Remove filter (Bug 391714)

1) Create 1filter if necessary (see 5.8)
2) Open Error Log view if necessary
3) Open filter dialog box and remove all filters
4) Press 'Ok'
5) Open filter dialog box again

Verify that no exceptions occurred and 
after 5) no filter are listed Manual Pass Verified in Aug. 21-2018 at 15:07PM.

5.27
Time Sync. without 
interactions (Bug 391716)

1) Open trace without any sequence diagram information
2) Open SD view if necessary
3) Open Error Log view if necessary
4) change time range in Histogram view
5) Change time current selected time in Histogram View Make sure that no exceptions occurred Manual Pass Verified in Aug. 21-2018 at 15:07PM.
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Section Pass Fail Type To Do Comment

TMF - EventsEditor 22 0 11 0 16
Target: 

Step Test Case Action Verification Comment

1 Preparation

1.1 Preparation step 1 Open and reset LTTng Kernel perspective LTTng Kernel perspective opens with correct views. SWTBot Pass

2 Trace bookmarks Moved to sheet "BookmarksVIew"

3 Experiment bookmarks Moved to sheet "BookmarksVIew"

4 Filter

4.1 Filter In the header row, enter some regex and press Ctrl+Enter

Only events matching regex are displayed. Top and 
bottom filter status rows update while filtering is 
ongoing. When filtering is done, status rows show 
number of matching events. SWTBot Pass

4.2 Cancel filter
In the header row, enter some regex and press Ctrl+Enter, then quickly 
press ESC before filtering is done

Only some events matching regex are displayed. Status 
rows show partial number of matching events, with 
different 'stop' icon. Manual Pass Verified in Aug. 20-2018 at 16:09PM.

4.3 Un-filter In the header bar, click the icon to delete a filter
All events are displayed. Selected event remains 
selected and visible. Status rows are removed. SWTBot Pass

4.4 Filter & Search In the filter bar, enter some regex; likewise in the search bar Events are filtered and highlighted accordingly SWTBot Pass
4.5 Search & Filter In the search bar, enter some regex; likewise in the filter bar Events are filtered and highlighted accordingly SWTBot Pass

5 Time Synchronization

5.1 Mouse synchronization Select any event in the table with the mouse button
Other views are synchronized to the selected event's 
time Manual Pass Verified in Aug. 20-2018 at 16:24PM.

5.2 Key synchronization
Select any event in the table using Up, Down, PageUp, PageDown, 
Home, End

Other views are synchronized to the selected event's 
time Manual Pass Verified in Aug. 20-2018 at 16:29PM.

5.3 Search synchronization
In the search bar, enter some regex, then search again with Enter/Shift-
Enter

Other views are synchronized to the selected event's 
time Manual Pass Verified in Aug. 20-2018 at 16:29PM.

5.4 External synchronization In any other view that supports time synchronization, select a time.
The first event at or following the selected time is 
selected and visible. Manual Pass Verified in Aug. 20-2018 at 16:29PM.

5.5 Range selection
Select an event with left button, press shift key and click select 
another event

Range of events are highlighted. Selection range is 
updated in other views that support range selection Manual Pass Verified in Aug. 20-2018 at 16:30PM.

6 Event Synchronization

6.1 Open trace Open an LTTng CTF Kernel trace

Verify that an editor is opened showing LTTng Kernel 
specific columns. Views are updated with the new 
trace. SWTBot Pass

6.2 Mouse synchronization Select any event in the table with the mouse button

The Properties view is updated with the selected 
event's Property and Value. Timestamp and Content 
are expandable. Manual Pass Verified in Aug. 20-2018 at 16:30PM.

6.3 Key synchronization
Select any event in the table using Up, Down, PageUp, PageDown, 
Home, End

The Properties view is updated with the selected 
event's Property and Value. Timestamp and Content 
are expandable. Manual Pass Verified in Aug. 20-2018 at 16:30PM.
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6.4 Search synchronization
In the search bar, enter some regex, then search again with Enter/Shift-
Enter

The Properties view is updated with the selected 
event's Property and Value. Timestamp and Content 
are expandable. Manual Pass Verified in Aug. 20-2018 at 16:31PM.

6.5 External synchronization

In any other view that supports time synchronization, select a time. 
The selected event in the editor is updated. Then give focus back to the 
editor.

The Properties view is updated with the selected 
event's Property and Value. Timestamp and Content 
are expandable. Manual Pass Verified in Aug. 20-2018 at 16:33PM.

7
Source Code / Model 
Lookup

7.1 Preparation

1) Download traces.zip (if necessary) and unzip into a local 
directory ${local}
2) Unzip traces/c_project_callsite.zip and traces/callsite.zip 
to your local disk. 
3) Import demo C project to the Eclipse workspace of zip 
file c_project_callsite.zip 
4) Import the test trace of zip file callsite.zip to a tracing 
project. 

Select trace type "Generic CTF Trace" and open the trace

7.2 Open call site

1) select event in table
2) click right mouse button
3) select "Open Source Code" menu item

Verify that correct source code file and line number is 
opened Manual N/A

Verified in Aug. 21-2018 at 08:56AM. Cannot see "Open Source Code" 
menu item

7.3
Open call site (no source 
code)

1) Close source code project
2) select event in table
3) click right mouse button
4) select "Open Source Code" menu item

Since the source code is not available the no source 
code file is opened. Instead a error dialog is opened 
(with title "FileNotFoundException") Manual N/A

Verified in Aug. 21-2018 at 08:58AM. Cannot see "Open Source Code" 
menu item

7.4 Open model URI

1) select event in table (e.g. 1st event)
2) click right mouse button
3) select "Open Model Element" menu item

Since the model is not available the model element is 
not shown. Instead a error dialog is opened (with title 
"FileNotFoundException") Manual N/A

Verified in Aug. 21-2018 at 10:45AM. Cannot see "Open Source Code" 
menu item

8 Export to text

8.1 Export CTF trace

1) Open a CTF trace (e.g. LTTng Kernel)
2) Click right mouse button
3) Select "Export To Text" menu item
4) Enter a file name and location
5) Press OK

Make sure that a progress monitor dialog is opened 
during the export. After finishing make sure that the 
text file exists and it contains the events stored in the 
file. Verify that the columns are printed as shown in the 
events table and that they are separated by tab 
character. SWTBot Pass no progress monitor dialog, only a job

8.2 Export Other Trace

1) Open a trace other than CTF trace 
2) Click right mouse button
3) Select "Export To Text" menu item
4) Enter a file name and location
5) Press OK

Make sure that a progress monitor dialog is opened 
during the export. After finishing make sure that the 
text file exists and it contains the events stored in the 
file. Verify that the columns are printed as shown in the 
events table and that they are separated by tab 
character. Manual Pass

Verified in Aug. 20-2018 at 16:33PM. The format should be .csv or excel 
with , or ; as a separator

8.3 Copy to clipboard

1) Open a CTF trace (e.g. LTTng Kernel)
2) Click right mouse button
3) Select "Copy to Clipboard" menu item
4) Paste it in a text file

Verify that the columns are printed as shown in the 
events table and that they are separated by tab 
character. SWTBot Pass

9
Swap Columns and 
Change Fonts
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9.1 Swap columns in events table

1) Open a trace
2) Drag a column

Covered by SWTBot tests SWTBot Pass

8.2 Change fonts

1) Open the preferences
2) select new font for trace types
3) press apply
4) verify that the font changed

Covered by SWTBot tests SWTBot Pass

8.3 Reset fonts

1) Open the preferences
2) Reset the font settings
3) Press apply
4) verify that the font changed

Covered by SWTBot tests SWTBot Pass
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Section To Do Fail To Do Comment

TMF - Statistics View 18 0 6 0 13
Target: Ubuntu 14.04 64 bit

Step Test Case Action Verification Type Comment

1 Preparation

Preparation
Download traces simple-server-thread1 and simple-server-
thread1 from traces/import/

1.1 Open Perspective Open and reset LTTng Kernel  perspective
LTTng Kernel perspective opens 
with correct views SWTBot Pass

1.2 Open TMF Statistics View
Use menu Window → Show View → Other … → Tracing → 
Statistics

Verify that 'Statistics' view is 
shown SWTBot Pass Path is actually Window -> Show view -> Tracing -> Statistics

1.3 Open experiment

1) Create Tracing Project
2) Create Experiment (SeqExp) 
3) Import 2 traces simple-server-thread1 and simple-server-thread2
4) Select trace type "Generic CTF Trace"
5) Add these 2 traces to experiment

Verify that statistics are shown per 
trace and per event type. Each 
trace has 80021 events. Verify that 
event types 
ENTER/RETURN/SEND/RECEI
VE/INFO/after_fork_child are 
counted. RCPTT Pass

2 Manage View

2.1 Delete view Close the 'Statistics' View
Statistics' view is removed from 
perspective RCPTT Pass

2.2 Open view Use menu Window → Show View → Tracing → Statistics
Statistics' view View is displayed 
and re-populated RCPTT Pass

2.3

Open view when 
experiment/trace is already 
loaded

1) Close 'Statistics View' 2) load trace above trace 3) Open 'Statistics' 
view

Verify that statistics are shown per 
trace and per event type. Each 
trace has 80021 events. Verify that 
event types 
ENTER/RETURN/SEND/RECEI
VE/INFO/after_fork_child are 
counted RCPTT Pass

3 Other

3.1 Build of statistic index Open trace

Verify that 'Statistics' view is 
populated gradually during 
indexation Manual Pass Verified in Aug. 20-2018 at 15:54PM.

3.2 Persistence of statistics 
Open same trace multiple times after indexing of trace was finished 
the first time

Verify that when opening the trace 
the x-times (x > 1), that the 
statistics appear right away 
without parsing the trace again Manual Pass Verified in Aug. 20-2018 at 15:55PM.

4 Range Synchronization

4.1
External synchronization 
(full)

In any other view that supports range synchronization, select the full 
range of the trace.

Events in 'Events in selection' is 
updated and equals 'Events total' 
values Manual Pass Verified in Aug. 20-2018 at 15:56PM.
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4.2
External synchronization 
(range)

In any other view that supports range synchronization, select a new 
range.

Events in 'Events in selection' is 
updated according to new range Manual Pass Verified in Aug. 20-2018 at 15:56PM.

5
Multiple Trace 
Synchronization

Preparation

1) Download traces.zip (if necessary) and unzip into a local 
directory ${local}
2) Import kernel trace ${local}/traces/import/kernel-
overlap-testing 
3) Import UST ${local}/traces/import/trace ust-overlap-
testing
4) Create experiment with trace of 2) in it

Manual Pass Verified in Aug. 20-2018 at 15:57PM.

5.1
Open multiple traces (no 
overlap) Open multiple traces that don't overlap in time View shows the last opened trace Manual Pass Verified in Aug. 20-2018 at 16:07PM.

5.2
Change selected time and 
range (no overlap)

In any other view that supports range synchronization, select a new 
range

Events in 'Events in selection' is 
updated according to new range Manual Pass

Verified in Aug. 20-2018 at 16:07PM. Patrick: The pie 
chart doesn't know from which trace the event comes 
from. Maybe we could skip events in the tree that have 
zero count though? Agree with Patrick, what we should 
do?

5.3
Select other trace (no 
overlap) Select different trace by clicking its Events editor tab

View is updated to show selected 
trace. 'Events in selection' is 
updated according to the selected 
trace's previously selected range. Manual Pass Verified in Aug. 20-2018 at 16:05PM.

5.4
Open multiple traces 
(overlap) Open multiple traces that overlap in time View shows the last opened trace Manual Pass Verified in Aug. 20-2018 at 16:05PM.

5.5
Change selected time and 
range (overlap)

In any other view that supports range synchronization, select a new 
range

Events in selection' is updated 
according to new range Manual Pass Verified in Aug. 20-2018 at 16:06PM.

5.6 Select other trace (overlap) Select different trace by clicking its Events editor tab

View is updated to show selected 
trace. 'Events in selection' is 
updated according to the newly 
selected time and range. Manual Pass Verified in Aug. 20-2018 at 16:06PM.

5.7 Close all traces Close all Events editor tabs View is cleared. Manual Pass Verified in Aug. 20-2018 at 16:07PM.
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Section Pass Fail Type To Do Comment

TMF - Time Chart View 26 0 1 0 25
Target: Ubuntu 16.04 64 bit

Step Test Case Action Verification Type Comment

1 Preparation

1.1 Preparation step 1 Open and reset LTTng Kernel perspective
LTTng Kernel perspective opens with 
correct views. SWTBot Pass

1.2 Preparation step 2 Show Time Chart View Time Chart view is shown Manual Pass Verified in Aug. 20-2018 at 10:55AM.

2 Trace handling

2.1 Open trace Open an LTTng CTF Kernel trace #1

Trace #1 entry added to Time Chart 
view. Trace #1 is selected entry. Range 
of view is full trace range. Manual Pass Verified in Aug. 20-2018 at 10:55AM.

2.2 Open other trace Open an LTTng CTF Kernel trace #2

Trace #2 entry added to Time Chart 
view. Trace #2 is selected entry. Range 
of view is union of full trace ranges. Manual Pass Verified in Aug. 20-2018 at 10:55AM.

2.3 Open experiment Open an experiment

Experiment entry added to Time Chart 
view. Experiment is selected entry. 
Range of view is union of full trace 
ranges. Manual Pass Verified in Aug. 20-2018 at 10:59AM.

2.4 Select other trace Select trace #1 by clicking its trace entry in Time Chart view

Trace #1 is selected entry. View range 
does not change. Trace #1 editor tab is 
brought to top. Manual Pass Verified in Aug. 20-2018 at 11:16AM.

2.5 Select other trace (external) Select trace #2 by clicking its editor tab
Trace #2 is selected entry. View range 
does not change. Manual Pass Verified in Aug. 20-2018 at 11:17AM.

2.6 Close view Close the Time Chart view
Time Chart view is removed from 
tracing view Manual Pass Verified in Aug. 20-2018 at 11:21AM.

2.7 Open view Show Time Chart view
Time Chart view is displayed and re-
populated with opened traces data Manual Pass Verified in Aug. 20-2018 at 11:22AM.

2.8 Close trace/experiment Close trace #2 editor tab. Repeat with experiment editor tab.

Trace entry is removed from Time Chart 
view. Range is view is union of 
remaining full trace ranges. Manual Pass Verified in Aug. 20-2018 at 11:22AM.

2.9 Close last trace Close trace #1 editor tab View is cleared. Manual Pass Verified in Aug. 20-2018 at 11:23AM.

3 Time Synchronization

3.1
Mouse synchronization 
(single time) Left-click on the time chart. The selected time line is updated.

Other views are synchronized to the 
selected time. Event at or following the 
selected time is selected in the event 
table. Manual Pass Verified in Aug. 20-2018 at 11:28AM.

3.2
Mouse synchronization (time 
range)

Shift-left-click or left-drag on the time chart. The selected time range 
is updated.

Other views are synchronized to the 
selected range. Event at or following the 
selected time is selected in the event 
table. Manual Pass Verified in Aug. 20-2018 at 11:29AM.

3.3
External synchronization 
(single time) In event table, select an event.

Selected time line is updated to the 
event time. If necessary, range is 
updated to show selected time. Manual Pass Verified in Aug. 20-2018 at 11:29AM.
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3.4
External synchronization 
(time range) In event table, select an event range with shift-left-click.

Selected time line is updated to the time 
range. Manual Pass Verified in Aug. 20-2018 at 11:30AM.

4
Zoom Range 
Synchronization

4.1
Mouse wheel 
synchronization Zoom in/out with mouse wheel while holding Ctrl.

Other views are synchronized to the 
new range Manual Pass Verified in Aug. 20-2018 at 11:47AM.

4.2
Mouse drag zoom 
synchronization Drag zoom with right-button on time chart.

Other views are synchronized to the 
new range Manual Pass Verified in Aug. 20-2018 at 11:50AM.

4.3
Mouse drag move 
synchronization Drag move with ctrl-left or middle button on time chart.

Other views are synchronized to the 
new range Manual Pass Verified in Aug. 20-2018 at 12:01PM.

4.4
Mouse full range 
synchronization Double-click with left button on time chart's time scale.

Other views are synchronized to the full 
range Manual Pass Verified in Aug. 20-2018 at 12:01PM.

4.5 External synchronization
In any other view that supports range synchronization, select a new 
zoom range. View range is updated to the new range Manual Pass Verified in Aug. 20-2018 at 12:01PM.

5
Event Table 
Synchronization

5.1 Search synchronization Enter a search regex in event table
Matching events are marked in time 
chart Manual Pass Verified in Aug. 20-2018 at 13:30PM.

5.2 Search cleared Clear the search regex in event table Marks are removed in time chart Manual Pass Verified in Aug. 20-2018 at 13:30PM.

5.3 Filter synchronization Enter a filter regex in event table
Non-matching events are removed from 
time chart Manual Pass Verified in Aug. 20-2018 at 13:30PM.

5.4 Filter cleared Clear the filter regex in event table All events are shown in time chart Manual Pass Verified in Aug. 20-2018 at 13:32PM.

5.5 Bookmark synchronization Add a bookmark in event table
Bookmarked event is marked in time 
chart Manual Pass Verified in Aug. 20-2018 at 15:46PM.

5.6 Bookmark cleared Remove the bookmark in event table Mark is removed in time chart Manual Pass Verified in Aug. 20-2018 at 15:47PM.
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Section Pass Fail Type To Do Comment

TMF - Custom Parsers 28 0 12 0 18
Target: Linux 64

Step Test Case Action Verification Type Comment

0 Prerequisites

0.1 Get custom parser definition and logs

Find text and XML parser definitions in 
Traces.zip/traces/customParsers and logs 
in /import

1 View management

1.1 Open perspective
Open and reset Tracing perspective, and open 
Time Chart view Time Chart view opens. SWTBot Pass

1.2 Import custom parser definitions

Create a tracing project, open Manage 
Custom Parsers dialog and import text 
and XML custom parser definitions

Custom parsers imported (TmfGeneric, 
Custom XML Log) RCPTT Pass

1.3 Import custom traces
Create a tracing project and import a text 
and XML custom trace

Traces imported in Traces folder of project 
(ExampleCustomTxt.log, 
ExampleCustomXml.xml) and have their trace 
type auto-selected. RCPTT Pass

2 Custom parser management

2.1 Open Manage Custom Parsers dialog
Open Manage Custom Parsers dialog in 
Traces folder context menu Dialog opens. SWTBot Pass

2.2 New (text)

Select "Text" radio button, click New... 
button, enter Trace type, change stuff, 
click Next, click Finish Custom parser appears in list. SWTBot Pass

2.3 Edit (text)
Select custom parser, click Edit..., change 
stuff, click Next, click Finish

Previously entered data appears, can be 
edited. SWTBot Pass

2.4 Export (text)
Select custom parser, click Export, enter 
name, click Save Exported custom parser stored in file system. RCPTT Pass

2.5 Delete (text) Select custom parser, click Delete Custom parser is deleted. SWTBot Pass

2.6 Import (text)
Click Import, find custom parser definition, 
click Open Imported custom parser appears in list. RCPTT Pass

2.7 New (XML)

Select "XML" radio button, click New... 
button, enter Log Type, write an xml log in 
the input, 
<a><b><c>1</c><d>1</d></b><b><c>2</
c><d>1</d></b></a> then click on the 
"feeling lucky" button. Set b to log entry, 
set c to timestamp logged and d to 
message logged, set timestamp format to 
ss in both text boxes, click Next, click 
Finish Custom parser appears in list. Manual Pass Verified in Aug. 20-2018 at 10:21AM.

2.8 Edit (XML)
Select custom parser, click Edit..., change 
stuff, click Next, click Finish

Previously entered data appears, can be 
edited. Manual Pass Verified in Aug. 20-2018 at 10:28AM.
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2.9 Export (XML)
Select custom parser, click Export, enter 
name, click Save Exported custom parser stored in file system. Manual Pass Verified in Aug. 20-2018 at 10:30AM.

2.10 Delete (XML) Select custom parser, click Delete Custom parser is deleted. SWTBot Pass

2.11 Import (XML)
Click Import, find custom parser definition, 
click Open Imported custom parser appears in list. Manual Pass Verified in Aug. 20-2018 at 10:31AM.

3 Custom parser trace handling

3.1 Select trace type (text)

Select test file in Traces folder, right-click, 
select "Select Trace Type > Custom Text 
> (parser name)"

Trace type is assigned (re-open Select Trace 
Type sub-menu to verify) RCPTT Pass

Or select the trace and verify the trace type in the 
properties view

3.2 Open trace (text) Double-click on test file in Traces folder
Editor opens with events table, Time Chart 
view is populated. Manual Pass Verified in Aug. 20-2018 at 10:12AM.

3.3 Raw view (text) Right-click in editor, click Show Raw Editor is split with raw view on right pane. Manual Pass Verified in Aug. 20-2018 at 10:13AM.

3.4 Time synchronization (text)
Click in Time Chart view, select event in 
editor table, select event in raw view

All three widgets synchronize to selected 
time. Manual Pass Verified in Aug. 20-2018 at 10:14AM.

3.5 Select trace type (XML)

Select test file in Traces folder, right-click, 
select "Select Trace Type > Custom XML 
> (parser name)"

Trace type is assigned (re-open Select Trace 
Type sub-menu to verify) RCPTT Pass

3.6 Open trace (XML) Double-click on test file in Traces folder
Editor opens with events table, Time Chart 
view is populated. Manual Pass Verified in Aug. 20-2018 at 10:15AM.

3.7 Raw view (XML) Right-click in editor, click Show Raw Editor is split with raw view on right pane. Manual Pass Verified in Aug. 20-2018 at 10:15AM.

3.8 Time synchronization (XML)
Click in Time Chart view, select event in 
editor table, select event in raw view

All three widgets synchronize to selected 
time. Manual Pass Verified in Aug. 20-2018 at 10:16AM.

4 Raw viewer should this be in events editor?

4.1 Show Raw Viewer

1) Open Custom text trace
2) Right-click in table and select "Show 
Raw" Raw viewer is shown beside the events table Manual Pass Verified in Aug. 20-2018 at 09:56AM

4.2 Hide Table
Right-click in table and select "Hide 
Table"

Events table is hidden and only raw viewer is 
shown Manual Pass Verified in Aug. 20-2018 at 10:04AM.

4.3 Show Table
Right-click in raw viewer and select "Show 
Table" Events table is shown beside raw viewer Manual Pass Verified in Aug. 20-2018 at 10:10AM.

4.4 Select Event (Bug 457852) Select event in raw viewer

Correct event is select in table, timestamp is 
propagated to other TMF views and 
Properties view shows content of selected 
event Manual Pass Verified in Aug. 20-2018 at 10:11AM.

4.5
Select Event using arrow keys 
(457852)

1) select event in raw viewer with mouse
2) use arrow key down and up several 
times

Correct event is select in table, timestamp is 
propagated to other TMF views and 
Properties view shows content of selected 
event Manual Pass Verified in Aug. 20-2018 at 10:11AM.

4.6 Hide Raw viewer Right-click in table and select "Hide Raw"
Raw viewer is hidden and only events table is 
shown Manual Pass Verified in Aug. 20-2018 at 10:12AM.



4.1.0-TraceCompassTestCases State System Explorer

35

Section Pass Fail Type To Do Comment
TMF - State System Explorer 14 0 6 0

Target: Ubuntu 14.04 64 bit

Step Test Case Action Verification Type Comment Test that will make this swtbot

1 Preparation

1.1
Open TMF State System Explorer 
View

Use menu Window → Show View → Tracing 
→ State System Explorer Verify that 'State System Explorer' view is shown SWTBot Pass 84711

2 Manage View

2.1 Delete view Close the State System Explorer' View
'State System Explorer' view is removed from 
perspective SWTBot Pass 84711

2.2 Open view
Use menu Window → Show View → Tracing 
→ State System Explorer

'State System Explorer' view is displayed and re-
populated SWTBot Pass 84711

2.3 Open Trace Open an LTTng Kernel Trace

Verify that view is populated with kernel state system 
(o.e.t.analysis.os.linux.kernel) and statistics state 
systems (o.e.l.tmf.statistics.*) of opened trace SWTBot Pass Some state systems ID's should be renamed for Trace Compass 84711

2.4
Open view when trace is already 
loaded

1) Close State System Explorer View
2) Load LTTng trace
3) Open 'State System Explorer' view

Verify that view is populated with state systems from 
trace SWTBot Pass (if the state system were already built) 84711

2.5 Open Experiment Open Experiment with 2 or more LTTng traces

Verify that view is populated with all kernel state 
system and statistics state systems of opened 
experiment (separated by trace) RCPTT Pass

The values are only available for time ranges where the trace 
exists. Only after we've "visited" other timestamps, then the 
attributes show up and print "Out of range". http://eclip.se/443653 
Works now: matthew

Bruno : I find the separation weird, and sincce I never used this 
view i'd like someone else to test this item. (Only the items in the 
second trace are expendable)

2.7 Select other trace 
Select different trace by clicking its Events 
editor tab

View is updated to show selected trace. State values, 
start time and end time are updated according to the 
selected trace's previously selected range. Manual Pass Verified in Aug. 20-2018 at 09:31AM

2.6 Restart Restart Eclipse
Verify that view is populated with state systems from 
trace Manual Pass Verified in Aug. 20-2018 at 09:31AM

2.7 Close all traces
Close traces and experiment one by one from 
the editor tab

Verify that state system explorer view is cleared after 
closing the last trace Manual Pass Verified in Aug. 20-2018 at 09:32AM

3 Timestamp / Time Range Selection

3.1 Select timestamp
Select time in another view (e.g Histogram 
view) that supports time synchronization Verify that state values are updated Manual Pass Verified in Aug. 20-2018 at 09:34AM

3.2 Select time range
Select a time range in another view that 
supports time synchronization

Verify that only the start of the range is taken in 
consideration (changing the end time of the range 
should not affect the displayed values) Manual Pass Verified in Aug. 20-2018 at 09:31AM

4 Displaying of Changed Values

4.1 Highlighting of changed values
Select many different timestamps one after the 
other

Attributes whose value changed in the last timestamp 
selection should be highlighted in yellow. Manual Pass Verified in Aug. 20-2018 at 09:35AM

4.2

“Only Display Changes at Selected 
Timestamp” option with event 
selection

Enable the “Only Display Changes at Selected 
Timestamp” option with the toolbar button. 
Select different Events from the Event Table.

Verify that only the state values that changed because 
of that event are displayed. Manual Pass Verified in Aug. 20-2018 at 09:42AM

“Only Display Changes at Selected 
Timestamp” with timestamp 
selection

Enable the “Only Display Changes at Selected 
Timestamp” option. Select *timestamps* 
corresponding to state changes (for example, 
using the previous/next buttons in the Control 
Flow View).

Verify that only the state values that changed at that 
timestamp are displayed. Manual Pass Verified in Aug. 20-2018 at 09:42AM Channel CPU Event type Contents TID Prio PID

channel0_0 0 irq_handler_entry irq=0, name=timer 0 20
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Section Pass Fail To Do Comment
TMF - Flame Chart View 24 0 14 0 15

Target: Ubuntu 16.04 64 bit (ELX)

Step Test Case Action Verification Comment
0 Download the test resources Download this
1 Preparation

1.1 Open TMF Flame Chart View
Use menu Window → Show View → Other … → 
Tracing → Flame Chart Verify that 'Flame Chart' view is shown SWTBot Pass Path is actually Window -> Show view -> Tracing -> Flame Chart

1.2 Import generic trace
Import a trace that does not have any call stack 
information, like a standard kernel trace

Verify that nothing is shown in the view, except 
“Stack info not available (<tracename>)” Manual Pass Verified in Aug. 16-2018 at 12:08PM

1.3 Import cyg-profile trace
Import the trace in the "trace" directory of the 
downloaded zip

Verify that the Flame Chart View is populated with 
some callstack information. SWTBot Pass

1.4 Import cyg-profile-fast trace
Import a trace in the "trace-fast" directory of the 
downloaded zip

Verify that the Flame Chart View is populated with 
some callstack information. SWTBot Pass

2 Manage View
2.1 Delete view Close the Flame Chart View Flame Chart' view is removed from perspective Manual Pass Verified in Aug. 16-2018 at 12:08PM

2.2 Open view
Use menu Window → Show View → Other … → 
Tracing → Flame Chart Flame Chart' view is displayed and re-populated SWTBot Pass See comment 1.1. about the path

2.3 Open Trace Open "trace(-fast)" trace
Verify that view is populated with call stack 
information SWTBot Pass

2.4
Open view when trace is already 
loaded

1) Close 'Flame Chart' view
2) Open "glxgears-cyg-profile(-fast)" trace located 
in the git in ctf test
3) Open 'Flame Chart' view

Verify that view is populated with call stack 
information SWTBot Pass

2.5 Open Experiment

Open Experiment with 2 or more Flame Chart 
traces.
(You can use both traces)

Verify that view is populated with all call stack 
information (separated by trace). Manual Pass

Verified in Aug. 16-2018 at 13:33PM. Second trace is hidden in 
the first trace, needs to be expanded to show

2.7 Select other trace 
Select different trace by clicking its Events editor 
tab View is updated to show selected trace. Manual Pass Verified in Aug. 16-2018 at 13:33PM

2.6 Restart Restart Eclipse with Flame Chart trace opened
Verify that view is populated with call stack from 
trace Manual Pass Verified in Aug. 16-2018 at 13:39PM

2.7 Close all traces
Close traces and experiment one by one from the 
editor tab

Verify that Flame Chart view is cleared after closing 
the last trace Manual Pass Verified in Aug. 16-2018 at 13:39PM

3 Navigation

3.1 Select time Click on random time in the time graph pane

Selected time line is updated. Table is updated to show 
the full stack information at the selected time. Selected 
time is updated in other views. SWTBot Pass

3.2 Select Previous/Next Event Click Previous/Next Event button

Previous or next call stack change is selected and 
corresponding active function and stack depth is 
selected. Table is updated to show the full stack 
information at the selected time. Selected time is 
updated in other views. SWTBot Pass

https://drive.google.com/file/d/0BxUCnNTRLr5pWUdXd0JJV3hyeEk/edit?usp=sharing
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3.3 Zoom to function (table) Double-click on a function in the table pane
Time range is updated to the full duration of the 
selected function SWTBot Pass

3.4 Zoom to function (time graph)
Double-click on a function (interval) in the time 
graph pane

Time range is updated to the full duration of the 
selected function SWTBot Pass

3.5 Go to first event in trace Go to events editor, press home the Flame Chart view is updated Manual Pass
Fixed in https://git.eclipse.org/r/#/c/80177/1 Hung:Verified in 
Aug. 16-2018 at 13:39PM

N/A
4 Synchronization

4.1 Time synchronization Select a random time in another view

Selected time line is updated. Table is updated to show 
the full stack information at the selected time. If 
selected time is outside current range, time range is 
updated to include it. SWTBot Pass

The vertical scroll bar is not updated(Sonia: only when you select 
a rendom time in the histogram view).If you select  an event (in 
another view)before the start of the calls, the vertical scroll bar 
goes down.

4.2 Event synchronization
Select a call stack-impacting event (function 
entry/exit) in events table

In addition to updating the selected time, the active 
function at the event time is selected. Vertical scroll 
bar is updated if necessary. SWTBot Pass

4.3 Time range synchronization Select a new time range in Histogram view. Time range is updated. SWTBot Pass

5 Function name import - Text file

5.1 Invalid text file import

Open 'trace' from Fibonacci.zip. Click the "Select a 
mapping file" button in the view and click 
"Browse" to select a random .txt file that does not 
contain any debugging info. The function addresses do not change. Manual Pass Verified in Aug. 16-2018 at 14:46PM

5.2 Valid text file import Import a file "fibonacci.symbols"

The view now displays function names instead of 
function addresses (both in the timegraph and the call 
stack areas). SWTBot Pass

The symbol mapping is applied on view level. If multiple traces 
are opened, or if an experiment with multiple traces is opened, 
they cannot each have their own mapping. Bug 459909.
France : I am not sure what to do here Sonia : The bug is resolved 
, you can specify a mapping file for each trace if you have a 
multiple traces in one experiment.

6 Function name import - CDT

6.1 Binary import

Click the "Select a binary file" button in the view 
and click "Browse" to select the fibonacci 
executable (fibonacci).

The view now displays the function names for both 
traces Manual Pass

Sonia :you have to specify the binary file for each trace.The view 
won't display the function names for the both traces if we select 
the fibonacci executable for a trace in an experiment with multiple 
traces. Hung:Verified in Aug. 16-2018 at 14:47PM

6.2 Binary import lttng 2.8+
Open an lttng 2.8+ trace with the executable 
present

The view now displays the function names for the 
trace Manual Pass Verified in Aug. 16-2018 at 14:468PM
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Section Pass Fail Type To Do Comment

GDB Tracing 25 0 5 0 20
Target: Ubuntu 14.04 64 bit

GDB 7.11.1 Eclipse CPP EPP RC2

Step Test Case Action Verification Type Comment

1 Preparation
1.1 Step 1 Open and reset the GDB Trace perspective GDB Trace perspective opens with correct views Manual Pass Verified in Aug. 16-2018 at 11:45AM

1.2 Step 2 Open Navigator View (used for independent verification) Navigator View opens Manual Pass Verified in Aug. 16-2018 at 11:47AM

2 Project Creation
2.1 New Project Wizard Open New Tracing Project Wizard Tracing Project Wizard opens SWTBot Pass
2.2 Create project Specify a project name and finish Tracing project appears in Project Explorer SWTBot Pass
2.3 Project structure Close and open the new Tracing project Project contains the Traces folder SWTBot Pass

3 Traces Folder

3.1 Traces Folder menu Select the Traces folder and open its context menu
Correct menu opens (Open Trace, Import, New 
Folder, …) SWTBot Pass

3.2 Trace Import Wizard Select Import Trace Trace Import Wizard appears SWTBot Pass
3.3 Import traces Select a GDB Trace from samples directory and finish Imported traces appear in Folders with proper icon Manual Pass Verified in Aug. 16-2018 at 11:48AM

4 Trace Configuration

4.1 Project/executable selection Double-click on an un-configured trace
Verify that an Error Dialog opens that notfiies the 
user to select the trace executable Manual Pass Verified in Aug. 16-2018 at 11:48AM

4.2 Select Trace Executable

1) Right mouse click on trace 
2) Select menu item "Select Trace Executable"
3) Fill in the proper values in dialog and finish

Trace is configured (4.3 is successful, when 4.2 was 
successful) Manual Pass Verified in Aug. 16-2018 at 11:50AM

4.3 Open configured trace Double-click on a configured trace Trace is opened, events table and views are populated Manual Pass Verified in Aug. 16-2018 at 11:52AM

5 Source Code Lookup

5.1 Select event With mouse select an event in events table
The corresponding source code location is selected in 
the source code file. Manual Pass Verified in Aug. 16-2018 at 11:55AM

5.2 Select another event redo 5.1
The corresponding source code location is selected in 
the source code file. Manual Pass Verified in Aug. 16-2018 at 11:59AM

6 Events Table Navigation

6.1 Arrow keys Update the current event using up/down keys within window

Each keystroke modifies the selected event and the 
corresponding source code location is selected in the 
source code file. Manual Pass Verified in Aug. 16-2018 at 12:01PM

6.2 Scrolling Update the current event using up/down keys outside window

Table is refreshed to display new current event and 
the corresponding source code location is selected in 
the source code file Manual Pass Verified in Aug. 16-2018 at 12:02PM

6.3 PgUp/PgDn Update the current event using PgUp/PgDn keys Table is scrolled accordingly Manual Pass Verified in Aug. 16-2018 at 12:03PM

6.4 Home/End Update the current event using Home/End keys

Table jumps from first to last event and the 
corresponding source code location is selected in the 
source code file Manual Pass Verified in Aug. 16-2018 at 12:04PM

7 Events Searching & Filtering
7.1 Search In the search bar, enter some RE Events corresponding to the RE are highlighted Manual Pass Verified in Aug. 16-2018 at 12:04PM
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7.2 Navigation Navigate through highlighted events using Enter/Shift-Enter Next/previous highlighted event selected accordingly Manual Pass Verified in Aug. 16-2018 at 12:05PM

7.3 Un-search In the search bar, clear the RE Events are displayed normally Manual Pass Verified in Aug. 16-2018 at 12:05PM

7.4 Filter In the search bar, enter some RE and press Ctrl+Enter Only events matching RE are displayed Manual Pass Verified in Aug. 16-2018 at 12:06PM

7.5 Filter & Search In the filter bar, enter some RE; likewise in the search bar Events are filtered and highlighted accordingly Manual Pass Verified in Aug. 16-2018 at 12:06PM

7.6 Un-filter In the filter header, remove the filter Events are displayed normally Manual Pass Verified in Aug. 16-2018 at 12:07PM

8 Events Synchronization

8.1 Synch from Events View Click on an event in the Events View
Trace Control View is updated; Debug View is 
updated Manual Pass Verified in Aug. 16-2018 at 12:08PM

8.2 Synch from Trace Control Go up/down from the Trace Control View Events View is updated accordingly Manual Pass Verified in Aug. 16-2018 at 12:08PM
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Section Pass Fail Type To Do Comment

LTTng 2.0 - CPU Analysis 27 0 5 0 20
Target: Ubuntu 16.04 64 bit (ELX)

Step Test Case Action Verification Type Comment

0 Prerequisites

0.1 Import traces
Import LTTng Kernel traces in 
Tracing project

1 Project View

1.1
Check analysis can 
execute

In the project explorer and expand a 
LTTng Kernel trace

"CPU usage" analysis is present 
and it's not crossed out Manual Pass Verified in Aug. 16-2018 at 14:57PM 84702

1.2
Verify help message when 
applicable

In the project explorer, open and 
expand the LTTng kernel trace, right-
click the CPU usage analysis and 
select Help

A generic help message appears 
with the name of the analysis Manual Pass

Sonia: The help message doesn't explain the 
role of the view or how to use it. There should 
be more details available. Hung: Verified in 
Aug. 16-2018 at 14:59PM same as Sonia idea.

1.5
Check analysis for another 
trace type

In the project explorer, expand a non-
LTTng Kernel trace

"CPU usage" analysis is not 
present Manual Pass Verified in Aug. 16-2018 at 14:57PM 84702

2 View Management

2.1 Populate analysis's view

Open an LTTng kernel trace and 
expand the "CPU usage" analysis in 
the project explorer

"CPU Usage" View appears under 
the analysis Manual Pass Verified in Aug. 16-2018 at 14:57PM

2.2 Open view
Double-click the CPU usage View 
under the CPU usage analysis

The CPU usage Usage view opens 
and triggers the cpu analysis. After 
the analysis, both tree viewer and 
xy charts are populated. SWTBot Pass

2.3 Close trace Close the trace The CPU Usage view is emptied. Manual Pass Verified in Aug. 16-2018 at 15:02PM

2.4 Open trace
With the view already opened, open 
the trace The CPU Usage view is populated. SWTBot Pass

2.5 Close view Close the CPU Usage view The view is closed. Manual Pass Verified in Aug. 16-2018 at 15:02PM

2.6 Re-open view

Double-click the CPU Usage view 
under the CPU usage analysis in 
project explorer.

The view opens and is 
automatically populated. SWTBot Pass

3 View selection

3.1 Select an entry
Select an entry in the tree viewer 
section

A new series is added to the xy 
chart, corresponding to the 
selected TID SWTBot Pass
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3.2 Select another entry
Select another entry from the tree 
viewer

A new series is added to the xy 
chart, and the previous TID's 
series is not displayed anymore Manual Pass Verified in Aug. 22-2018 at 11:34AM

Christophe: not 
sure I understand. 
Multiple series can 
be selected; when 
selecting a 2nd 
series, the first one 
is still displayed.
Simon: I think this 
is old and refers to 
an older view. With 
the new tree view 
the behavior is as 
you described

4 Mouse handling

4.1 Drag move time range
Drag move xy chart left and right with 
middle button and shift mouse wheel

Time range is dragged. When 
mouse button is released, series 
are updated and new time range is 
propagated to other views. Manual Pass Verified in Aug. 22-2018 at 11:34AM

4.2
Zoom time range (mouse 
wheel)

Zoom with ctrl mouse wheel up and 
down, cursor inside xy chart

Time range is zoomed in and out, 
relative to mouse cursor. When 
mouse wheel is stopped for a short 
time, series are updated and new 
time range is propagated to other 
views, including the tree viewer 
beside the chart. The selected 
process remains the same. SWTBot Pass

4.3 Mouse vertical scroll
Scroll with mouse wheel up and 
down, cursor outside xy chart

Table scroll up and down. Selected 
process does not change. Vertical 
scroll bar updated. Manual Pass Verified in Aug. 22-2018 at 11:34AM

4.4 Vertical scroll bar Click and drag vertical scroll bar
Tree viewer scrolls up and down. 
Selected process does not change. Manual Pass Verified in Aug. 22-2018 at 11:35AM

4.5 Drag select time range
Drag select time graph with right 
button in xy chart

Selection highlighted. When 
mouse button is released, time 
range is zoomed to selection, 
series are updated and new time 
range is propagated to other views. 
Selected process remains the 
same. Manual Pass Verified in Aug. 22-2018 at 11:36AM

Christophe: 
selected process is 
lost if the new time 
range does not 
contain data from 
the process, even 
when zooming 
back out. Not sure 
if it should be 
marked as a fail.

4.6 Mouse hover
Hover mouse in xy chart region 
anywhere

Tool tip shows the total and 
selected process (if any) cpu 
usage at the time Manual Pass Verified in Aug. 22-2018 at 11:39AM

4.7 Drag mouse selection Drag select xy chart with left button
Selection highlighted and selection 
range is propagated to other views Manual Pass Verified in Aug. 22-2018 at 11:39AM
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4.8 Shift key selection

Click select with left button (begin 
time), press shift key and click select 
another time (end time)

Selection highlighted and selection 
rang is propagated to other views Manual Pass Verified in Aug. 22-2018 at 11:40AM

4.9 Sort columns
Click on column headers once then 
twice

Entries are sorted in ascending 
then descending order on the 
column value. Selected process 
does not change. Manual Pass Verified in Aug. 22-2018 at 11:42AM

Simon: Sometime 
with GTK3 sorting 
by column cause 
the process column 
to add extra 
padding between 
the checkbox and 
the label. On GTK2 
everything seems 
fine

4.10
Drag mouse selection 
(Status bar) Drag select xy chart with left button

Selection highlighted. Status bar of 
Eclipse is updated with time 
information: T, T1, T2 and delta, 
where T is the time of the mouse 
position, T1 the first selected time, 
T2 the second (draggged) selected 
time and delta the time difference 
between T2-T1 (can be negative) Manual Pass Verified in Aug. 22-2018 at 11:42AM

4.11
Shift key selection (Status 
bar)

Click select with left button (begin 
time), press shift key and click select 
another time (end time)

Selection highlighted. Status bar of 
Eclipse is updated with time 
information: T, T1, T2 and delta, 
where T is the time of the mouse 
position, T1 the first selected time, 
T2 the second (draggged) selected 
time and delta the time difference 
between T2-T1 (can be negative) Manual Pass Verified in Aug. 22-2018 at 11:42AM

Verified in Aug. 22-
2018 at 11:39AM

5 Keyboard handling

5.1
Keyboard navigation in tree 
viewer

With focus on table, use UP, DOWN, 
HOME, END keys

Selected process is changed. xy 
chart selection is updated. Vertical 
scroll bar updated. Manual Pass Verified in Aug. 22-2018 at 11:25AM

6 Synchronization

6.1 Time synchronization Select a random time in another view

Selected time line is updated. If 
selected time is outside current 
range, time range is updated to 
include it. Manual Pass Verified in Aug. 22-2018 at 11:24AM

6.2 Time range synchronization
Select a new time range in CPU 
usage view or in Histogram view. Time range is updated. Manual Pass Verified in Aug. 22-2018 at 11:24AM

6.3
Time range selection 
synchronisation

In any other view that supports range 
synchronization, select a new range.

Selection is highlighted. If the most 
left time (T1) of selected time range is 
outside the current range, then time 
range is updated to include it Manual Pass Verified in Aug. 22-2018 at 11:24AM
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CPU usage works with 
experiments Manual Pass Verified in Aug. 16-2018 at 15:04PM

works with 1 kernel 
trace experiments
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Section Pass Fail To Do Comment

TMF - Remote Fetching 53 0 51 0 18
Target: Ubuntu 14.04 64 bit

Step Test Case Action Verification Type Comment

1 Preparation
1.1 Step 1 Open Trace Compass and reset Lttng perspective Lttng perspective opens with correct views

2 Opening

2.1 Open Profile Editor 1
Right-click on Traces Folder -> Fetch Remote Traces 
… -> Manage Profiles The Profile Editor of preference page opens SWTBot Pass

Bruno : Not this test, but the Fetch Remotes 
Traces dialog, has a help button that does 
nothing. Patrick: See Bug 440238.

2.2 Open Profile Editor 2 Window -> Preferences-> Tracing -> Remote Profiles The Profile Editor of preference page opens SWTBot Pass

3 Edit Profile - Add/Delete

3.1 Create Profile
Open Profile Editor > Click on 'Add' > Enter profile 
name, remote information, root path and trace pattern New Profile is created and template is provided SWTBot Pass

3.2 Add Node
Select Profile node > right mouse click > select 'New 
Connection Node'

New Connection Node is create under the profile 
and template is provided SWTBot Pass

3.3 Add trace group
Select node node > righ mouse click > select 'New 
Trace Group'

New Trace Group is created under the node and 
template is provided SWTBot Pass

3.4 Add trace
Select trace group > right mouse click > select 'New 
Trace'

New Trace is created under Trace Group and 
template is provided SWTBot Pass

3.5 Delete Trace Select trace > right mouse click > select Delete Trace is deleted SWTBot Pass

3.6 Delete Trace Group
Select Trace Group> right mouse click > select 
Delete Trace Group is deleted RCPTT Pass

3.7 Delete Connection Node
Select Connection Node > right mouse click > select 
Delete Connection Node is deleted RCPTT Pass

3.8 Remove Profile Select Profile > click on 'Remove' button Profile is deleted SWTBot Pass

4 Edit Profile - Reorder

4.1 Move profile up/down
Create at 2-3 profiles > select 2nd profile and press 
buttons 'Move Up'/'Move Down' Profiles are moved up and down RCPTT Pass

4.2 Move connection node up/down

Make sure that there are 2 or 3 connection nodes > 
select 1 connection node > click buttons 'Move 
Up'/'Move Down'

Connection Nodes are moved up and down within 
a profile RCPTT Pass

4.3 Move Trace Group up/down
Make sure that there are 2 or 3 trace gropus > select 1 
trace group > click buttons 'Move Up'/'Move Down'

Trace Groups are moved up and down within a 
connection node RCPTT Pass

4.4 Move Trace up/down
Make sure that there are 2 or 3 trace groups > select 1 
traces > click buttons 'Move Up'/'Move Down'

Traces are moved up and down within a Trace 
Group SWTBot Pass

5 Edit Profile - Copy, Cut, Paste

5.1 Copy/Paste Profile

Select Profile > click right mouse button on a profile 
> Select Copy -> click right mouse button on other 
profile > Select Paste Profile is pasted under the selected profile RCPTT Pass

5.2 Copy/Paste Profile (Keys) Redo 5.1 with CTRL+C and CTRL+V keys Profile is pasted under the selected profile RCPTT Pass
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5.3 Copy/Paste Connection Node

Select Profile > click right mouse button on a 
Connection Node > Select Copy -> click right mouse 
button on other Connection Node > Select Paste

Profile is pasted under the selected Connection 
Node RCPTT Pass

5.4
Copy/Paste Connection Node 
(Keys) Redo 5.3 with CTRL+C and CTRL+V keys

Profile is pasted under the selected Connection 
Node RCPTT Pass

5.5 Copy/Paste Trace Group

Select Profile > click right mouse button on a Trace 
Group > Select Copy -> click right mouse button on 
other Trace Group > Select Paste Profile is pasted under the selected Trace Group RCPTT Pass

5.6 Copy/Paste Trace Group (Keys) Redo 5.5 with CTRL+C and CTRL+V keys Profile is pasted under the selected Trace Group RCPTT Pass

5.7 Copy/Paste Trace

Select Profile > click right mouse button on a Trace > 
Select Copy -> click right mouse button on other 
Trace > Select Paste Profile is pasted under the selected Trace SWTBot Pass

5.8 Copy/Paste Trace (Key) Redo 5.5 with CTRL+C and CTRL+V keys Profile is pasted under the selected Trace RCPTT Pass
5.9 Cut/Paste Redo 5.1 - 5.8 with cut and paste Successful cut and paste RCPTT Pass Trace (5.7) is done with SWTBot

6 Edit Profile - Adverserial
6.1 Error empty  profile name Clear profile name Error message "Profile must not be empty" RCPTT Pass
6.2 Duplicate profile name Add profile with name of existing profile Error message "<name>: Duplicate profile name" RCPTT Pass

6.3
Error empty Connection node 
name Clear Connection node name Error message "Node name must not be empty" RCPTT Pass

6.4 Duplicate Connection node name
Within a profile, add Connection node with name of 
existing node Error message "Duplicate node names" RCPTT Pass

6.5 Missing username in URI remove user name of a Connection Node
Error message "URI must include user 
information" RCPTT Pass

6.6 Invalid URI add invalid URI
Error message "URI must include valid host and 
port number" or "Unsupported URI scheme" RCPTT Pass

6.7 Error empty Trace Group Delete Trace Group root path Error message "Root path must not be empty" RCPTT Pass
6.8 Error empty Trace Delete File Pattern Error message "File pattern must not be empty" RCPTT Pass
6.9 Invalid File pattern Add trace with invalid regular expression Error message "Invalid file pattern" RCPTT Pass

5 Export/Import Profile

7.1 Export Profile
Select multipe profiles > Click Export Button > 
Select Folder and enter file name > OK Only selected profiles are exported SWTBot Pass

7.2 Import Profile
Click on Import Button > select profile XML file > 
OK Profiles are imported SWTBot Pass

7.3 Import Profile Redo 7.2
after second import an error message appears 
"Duplicate profile names" SWTBot Pass

8 Remote Fetch Wizard

8.1 Preparation

1) Generate CTF trace in 
<plugin>/generated/synthetic-trace
2) Import profiles from <plugin>/profiles/test-
profiles.xml SWTBot Pass
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8.2

Create and run Profile "new 
Profile" (syslog + synthetic CTF 
trace in sub-directory)

1) Create Profile with Local connection, 1 trace group 
(root  /tmp/traces/) and 2 traces (.*syslog.* and .
*synthetic.*) in this group
2) Select profile in Fetch Remote Traces wizard 
(Remote Profile page)
3) Click on 'Next' button
4) Click on 'Finish'

Verify that all test traces are imported with correct 
trace types assigned.  Verify that folder structure is 
preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.3

Create and run Profile "new 
Profile" (syslog + synthetic CTF 
trace in sub-directory), only 1 trace 
selected

1) Create Profile with Local connection, 1 trace group 
(root  /tmp/traces/) and 2 traces (.*syslog.* and .
*synthetic.*) in this group
2) Select profile in Fetch Remote Traces wizard 
(Remote Profile page)
3) Click on 'Next' button
4) deslect the synthetic CTF trace
5) Click on 'Finish'

Verify that only the selected traces are imported 
with correct trace types assigned.  Verify that 
folder structure is preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.4 Run Profile "TestAllRecursive"

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'

Verify that all test traces are imported with correct 
trace types assigned (LTTng kernel, LTTng UST, 
custom text, custom XML). The file unrecognized.
log is importeds with unrecognized trace type. 
Make sure that directory structure is preserved. SWTBot Pass Local connection is used in SWTBot

8.5
Re-run Profile "TestAllRecursive"  
(Rename)

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'
4) In dialog box select 'Rename' for the first trace and 
'Rename ALL' for the second traces

Verify that all  test traces are imported with new 
name and correct trace types assigned  (LTTng 
kernel, LTTng UST, custom text, custom XML). 
The file unrecognized.log is importeds with 
unrecognized trace type.  Make sure that directory 
structure is preserved. SWTBot Pass Local connection is used in SWTBot

8.6
Re-run Profile "TestAllRecursive"  
(Overwrite)

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'
4) In dialog box select 'Overwrite' for the first trace 
and 'Overwrite ALL' for the second traces

Verify that all test traces are imported with correct 
trace types assigned where old traces are 
overwritten.  (LTTng kernel, LTTng UST, custom 
text, custom XML). The file unrecognized.log is 
importeds with unrecognized trace type.  Make 
sure that directory structure is preserved. SWTBot Pass Local connection is used in SWTBot

8.7
Re-run Profile "TestAllRecursive"  
(Skip)

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'
4) In dialog box select 'Skip' for the first trace and 
`Skip ALL' for the second traces

Verify that all test traces are skipped and no trace 
is imported SWTBot Pass Local connection is used in SWTBot

8.8
Re-run Profile "TestAllRecursive"  
(Overwrite 2)

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Select checkbox 'Overwrite traces without 
warning'
3) Click on 'Next' button (enter password if needed)
4) Click on 'Finish'

Verify that all test traces are imported with correct 
trace types  assigned where old traces are 
overwritten (no dialog box opens).  (LTTng kernel, 
LTTng UST, custom text, custom XML). The file 
unrecognized.log is importeds with unrecognized 
trace type.  Make sure that directory structure is 
preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted
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8.9
Re-run Profile "TestAllRecursive"  
(2)

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Finish' (enter password if needed)

Verify that all test traces are imported with correct 
trace types assigned. The second page is omitted.  
(LTTng kernel, LTTng UST, custom text, custom 
XML). The file unrecognized.log is importeds with 
unrecognized trace type.  Make sure that directory 
structure is preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.10
Run Profile 
"TestAllNonRecursive"

1) Select profile "TestAllNonRecursive" in Fetch 
Remote Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'

Verify that only traces from root path are imported  
(LTTng kernel, LTTng UST, custom text, custom 
XML). The file unrecognized.log is importeds with 
unrecognized trace type.  Make sure that directory 
structure is preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.11
Run Profile 
"TestSpecificRecursive"

1) Select profile "TestSpecificRecursive" in Fetch 
Remote Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'

Verify that only kernel and custom text/XML logs 
are imported from root and subdirectory.  Make 
sure that directory structure is preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.12
Run Profile 
"TestSpecificNonRecursive"

1) Select profile "TestSpecificNonRecursive" in 
Fetch Remote Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'

Verify that only kernel and custom text/XML logs 
are imported from root directory only.  Make sure 
that directory structure is preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.13

Run Profile 
"TestSpecificMutliGroupRecursiv
e"

1) Select profile "TestSpecificMultiGroupRecursive" 
in Fetch Remote Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'

Verify that only traces from root path are imported  
(LTTng kernel, LTTng UST, custom text, custom 
XML). Make sure that directory structure is 
preserved. SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.14 Cancel Import

1) Select profile "TestAllRecursive" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'
4) Cancel import (red square or Cancel button) Verify that import operation is cancelled SWTBot Pass Local connection is used in SWTBot

Clear traces Delete all traces from Traces directory All traces deleted

8.15 Run Profile "TestMultiNodes"

1) Select profile "TestMultiNodes" in Fetch Remote 
Traces wizard (Remote Profile page)
2) Click on 'Next' button (enter password if needed)
3) Click on 'Finish'

Verify that only traces from root path are imported  
(LTTng kernel, LTTng UST, custom text, custom 
XML). The file unrecognized.log is importeds with 
unrecognized trace type.  Make sure that directory 
structure is preserved. 2 nodes directories are 
created with the above traces stored SWTBot Pass Local connection is used in SWTBot

9 Connection Handling

9.1
Error cannot connect to remote 
host (node doesn't exist)

Create profile with IP address that cannot be 
connected to and run profile

Operation to connect to remote node fails and error 
dialog is shown with detailed information (after 
time-out) SWTBot Pass
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9.2
Error cannot connect to remote 
host (wrong password)

Create profile with valid IP address. When asked for 
password enter invalid password

Operation to connect to remote node fails with 
time-out and error dialog is shown with detailed 
information. Note time-out is as per remote 
development preferences Manual Pass

Verified in Aug. 22-2018 at 11:46AM. SWTBot test 
can be run locally by removing the @Ignore tag

10 Other Remote Backends
Clear traces Delete all traces from Traces directory All traces deleted

10.2 Remote Fetch using SSH
Update profile with local username and run test 9.2 
entering the correct password

Verify that all test traces are imported with correct 
trace types assigned (LTTng kernel, LTTng UST, 
custom text, custom XML). The file unrecognized.
log is importeds with unrecognized trace type. 
Make sure that directory structure is preserved. Manual Pass Verified in Aug. 16-2018 at 15:20PM
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Section Pass Fail Type To Do Comment

LTTng 2.0 - Control Flow View 52 0 15 0 39
Target: Windows

Step Test Case Action Verification Comment

0 Prerequisites

0.1 Import traces Import LTTng Kernel traces in Tracing project

0.2 Create experiment
Create an experiment with LTTng Kernel 
traces

1 View management
1.1 Open perspective Open and reset LTTng Kernel Perspective Control Flow view opens. SWTBot Pass

1.2 Open trace Open LTTng Kernel trace in Project Explorer

Control Flow view is populated with 
processes, sorted by Trace then TID. Child 
processes appear under their parent, sorted 
by birth time. Range is set to initial offset. 
Arrows are drawn between states of a CPU. SWTBot Pass

1.2 Open experiment
Open experiment with LTTng Kernel traces in 
Project Explorer

Control Flow view is populated with 
processes, sorted by Trace then TID. Child 
processes appear under their parent, sorted 
by birth time. Range is set to initial offset. 
Arrows are drawn between states of a CPU. Manual Pass Verified in Aug. 16-2018 at 15:21PM

1.3 Close view Close the Control Flow view View is closed. SWTBot Pass

1.4 Open view Open the Control Flow view
Control Flow view is opened and populated 
with processes. SWTBot Pass

2 View selection
2.1 Select process in table Select a process in the table Same process is highlighted in time graph. Manual Pass Verified in Aug. 16-2018 at 15:29PM

2.2 Select process in time graph
Select a process in the time graph (empty 
region)

Same process is highlighted in table. Selected 
time line is updated. Other views are 
synchronized to selected time. Manual Pass Verified in Aug. 16-2018 at 15:29PM

2.3 Select state in time graph Select a state in the time graph

Same process is highlighted in table. State is 
highlighted in time graph. Selected time line is 
updated. Other views are synchronized to 
selected time. Manual Pass Verified in Aug. 16-2018 at 15:29PM

3 Mouse handling

3.1 Drag move chart area
Ctrl-Drag move time graph left and right with 
middle button

Visible range is dragged. When mouse button 
is released, states are updated and new time 
range is propagated to other views. Manual Pass Verified in Aug. 16-2018 at 15:38PM

3.2 Zoom time range (mouse wheel)
Zoom with mouse wheel up and down, cursor 
inside time graph while holding the Ctl button

Time range is zoomed in and out, relative to 
mouse cursor. When mouse wheel is stopped 
for a short time, states are updated and new 
time range is propagated to other views. Manual Pass Verified in Aug. 16-2018 at 15:38PM

3.3 Zoom time range (mouse drag)
Drag in time graph scale left and right with 
left button

Time range is zoomed in and out. When 
mouse button is released, states are updated 
and new time range is propagated to other 
views. Manual Pass Verified in Aug. 16-2018 at 15:38PM

3.4 Mouse vertical scroll Scroll with mouse wheel up and down

Table and time graph scroll up and down and 
remain aligned. Selected process does not 
change. Vertical scroll bar updated. Manual Pass Verified in Aug. 16-2018 at 15:38PM

3.5 Vertical scroll bar Click and drag vertical scroll bar

Table and time graph scroll up and down and 
remain aligned. Selected process does not 
change. Manual Pass Verified in Aug. 16-2018 at 15:38PM

3.6 Drag zoom time range Drag select time graph with right button

Selection highlighted. When mouse button is 
released, time range is zoomed to selection, 
states are updated and new time range is 
propagated to other views. Manual Pass Verified in Aug. 16-2018 at 15:38PM
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3.7 Double-click reset time range Double-click left button on time scale

Time range is reset to full range, states are 
updated and new time range is propagated to 
other views. Manual Pass Verified in Aug. 16-2018 at 15:39PM

3.8 Mouse hover (empty region)
Hover mouse in time graph over empty 
region Tool tip shows process name only. Manual Pass Verified in Aug. 16-2018 at 15:40PM

3.9 Mouse hover (state) Hover mouse in time graph over state

Tool tip shows process name, state name, 
date, start time, stop time, duration. For 
USERMODE state, CPU is shown. For 
SYSCALL state, CPU and System Call is 
shown. For INTERRUPTED state, CPU is 
shown. Manual Pass Verified in Aug. 16-2018 at 15:41PM

3.10 Drag mouse selection Drag select time graph with left button

Selection highlighted. Status bar of Eclipse is 
updated with time information: T, T1, T2 and 
delta, where T is the time of the mouse 
position, T1 the first selected time, T2 the 
second (dragged) selected time and delta the 
time difference between T2-T1 (can be 
negative) Manual Pass Verified in Aug. 16-2018 at 15:42PM

3.11 Shift key selection

Click select with left button (begin time), 
press shift key and click select another time 
(end time)

Selection highlighted. Status bar of Eclipse is 
updated with time information: T, T1, T2 and 
delta, where T is the time of the mouse 
position, T1 the first selected time, T2 the 
second (dragged) selected time and delta the 
time difference between T2-T1 (can be 
negative) Manual Pass Verified in Aug. 16-2018 at 15:42PM

4 Keyboard handling

4.1
Keyboard navigation in time graph 
(process selection)

With focus on time graph, use UP, DOWN, 
HOME, END keys

Selected process is changed. Table selection 
is updated. Vertical scroll bar updated. Manual Pass Verified in Aug. 16-2018 at 15:42PM

4.2
Keyboard navigation in time graph 
(state selection)

With focus on time graph, use LEFT, RIGHT 
keys

Previous or next state is selected. Selected 
time is updated in other views. SWTBot Pass

5 Tool bar handling

5.1 Show Legend Click Show Legend button
The legend dialog is opened and can be 
closed. SWTBot Pass

5.2 Reset Time Scale Click Reset Time Scale button

Time range is reset to full range, states are 
updated and new time range is propagated to 
other views. SWTBot Pass Documentation fix : what does "states are updated" imply?

5.3 Select Previous/Next Event Click Previous/Next Event button
Previous or next state is selected. Selected 
time is updated in other views. SWTBot Pass

5.4 Select Previous/Next Process Click Previous/Next Process button
Selected process is changed in table and time 
graph. Vertical scroll bar updated. Manual Pass Verified in Aug. 16-2018 at 15:54PM

5.5 Zoom In/Out Click Zoom In/Out button

Time range is zoomed in and out, relative to 
center of selection or window. States are 
updated and new time range is propagated to 
other views. Manual Pass Verified in Aug. 17-2018 at 16:48PM

5.6 Filter Dialog  Open Filter Dialog Verify that all buttons are working correctly SWTBot Pass Pro tip: "Uncheck selected" and "Uncheck subtree" do the same thing

5.7 Filter Processes

1) Open Filter Dialog
2) Deselect several processes
3) Press Ok

Verify that only selected processes are 
displayed in the view SWTBot Pass

5.8 Hide Arrows Click Hide Arrows button
Verify that arrows are not drawn in the time 
graph Manual Pass Verified in Aug. 16-2018 at 15:54PM

5.9 Follow CPU Forward
With focus on time graph, click Follow CPU 
Forward button

Time graph is updated to show the next state 
for this cpu following the arrow, the event is 
selected in the Events editor. SWTBot Pass

5.10 Follow CPU Backward
With focus on time graph, click Follow CPU 
Backward button

Time graph is updated to show the previous 
state for this cpu following the arrow, the 
event is selected in the Events editor. SWTBot Pass

5.11 Optimize Click on the optimize button verify that the processes are closer together. SWTBot Pass

5.12 Re-Optimize Click on the optimize button a few more times
verify that the processes did not move, the 
optimization is stable SWTBot Pass
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5.13 Go to next event of selected thread
Select a thread and click on go to next event 
of selected thread

Verify in the events table that the selected 
thread is the same as the previous event Manual Pass Verified in Aug. 16-2018 at 15:54PM

5.14
Go to previous event of selected 
thread

Select a thread and click on go to previous 
event of selected thread

Verify in the events table that the selected 
thread is the same as the previous event Manual Pass Verified in Aug. 16-2018 at 16:04PM

6 Synchronization

6.1 Time synchronization Select a random time in another view

Selected time line is updated. If selected time 
is outside current range, time range is 
updated to include it. Manual Pass Verified in Aug. 16-2018 at 16:07PM

6.2 Event synchronization

Select a state-impacting event 
(sched_switch, syscall, ...) in events table or 
in Resources view using Select 
Previous/Next event.

In addition to updating the selected time, the 
process containing the state change is 
selected and revealed. Vertical scroll bar is 
updated if necessary. Manual Pass Verified in Aug. 16-2018 at 16:07PM

6.3 Window range synchronization
Select a new window range in Resources 
view or in Histogram view. Window range is updated. Manual Pass Verified in Aug. 16-2018 at 16:08PM

6.4 Selection range synchronization
In any other view that supports selection 
range synchronization, select a new range.

Selection is highlighted. If the left time (T1) of 
selected time range is outside the current 
range, then window range is updated to 
include it Manual Pass Verified in Aug. 16-2018 at 16:08PM. Tested with Ressources view, Control Flow view and Histogram view.

7 Multiple Trace Synchronization

Preparation

1) Download traces.zip (if necessary) and 
unzip into a local directory ${local}
2) Import kernel trace ${local}
/traces/import/kernel-overlap-testing 
3) Import UST ${local}
/traces/import/trace ust-overlap-testing
4) Create experiment with trace of 2) in it

7.1 Open multiple traces (no overlap) Open multiple traces that don't overlap in time View shows the last opened trace Manual Pass Verified in Aug. 16-2018 at 16:09PM

7.2
Change selected time and range (no 
overlap) Select a time and new range

Selected time line and time range is updated to 
selected time and new range. Manual Pass Verified in Aug. 16-2018 at 16:09PM

7.3 Select other trace (no overlap)
Select different trace by clicking its Events editor 
tab

View is updated to show selected trace. Selected 
time line and time range are restored to the 
selected trace's previously selected time and range. Manual Pass Verified in Aug. 16-2018 at 16:10PM

7.4 Open multiple traces (overlap)

- Open multiple traces that overlap in time
- For both traces, in Events table right mouse-
click -> "Follow time updates from other traces" View shows the last opened trace Manual Pass Verified in Aug. 16-2018 at 16:10PM

7.5
Change selected time and range 
(overlap) Select a time and new range

Selected time line and time range is updated to 
selected time and new range. Manual Pass Verified in Aug. 16-2018 at 16:11PM

7.6 Select other trace (overlap)
Select different trace by clicking its Events editor 
tab

View is updated to show selected trace. Selected 
time line and time range are set to the newly 
selected time and range. Manual Pass Verified in Aug. 16-2018 at 16:12PM

7.7 Close all traces Close all Events editor tabs View is cleared. Manual Pass Verified in Aug. 16-2018 at 16:12PM

8.1 Filtering
Preparation Open 2 LTTng Kernel Traces

8.1 Apply filter (1st trace)

1) Open filter dialog
2) Create filter
3) Click on OK

Make sure that only selected processes of 
filter dialog are shown SWTBot Pass

8.2 Apply filter (2nd trace)

1) Switch to 2nd trace (keep 1st open)
2) Open filter dialog
3) Create filter
4) Click on OK

Make sure that only selected processes of 
filter dialog are shown Manual Pass Verified in Aug. 16-2018 at 15:45PM

8.3 Persitent filter Switch between both open traces 
Make sure that previously set filter are still 
available Manual Pass Verified in Aug. 16-2018 at 15:45PM

9 Miscellaneous
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9.1 Restart (Bug 409345)

1) Open LTTng Kernel Trace
2) Select Control Flow View
3) Restart Eclipse Verify that Control Flow View is populated Manual Pass Verified in Aug. 16-2018 at 15:42PM

9.2 Select single time (Bug 477009)
1) Open LTTng UST trace while CFV is open
2) Select event in events table

Verify that Control Flow View is empty, current 
window range stays change to ensure visibility Manual Pass Verified in Aug. 16-2018 at 15:44PM

9.3
Window range synchronization 
(Bug 477012)

1) Open Control Flow view, Resources view 
and a kernel trace. Initial window range is 
'range 1'.
2) Go "right one page" on Control Flow view 
by pressing right arrow in scroll bar. 
3) Go "left one page" on Resources view by 
pressing left arrow in scroll bar.
4) Go "right one page" on Control Flow view.

Verify that after each step the initial window 
range doesn't change Manual Pass Verified in Aug. 16-2018 at 15:44PM
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Section Pass Fail To Do Comment

LTTng 2.0 - Resources View 40 0 6 0 34
Target: Windows 7

Step Test Case Action Verification Comment

0 Prerequisites

0.1 Import traces Import LTTng Kernel traces in Tracing project

0.2 Create experiment
Create an experiment with LTTng Kernel 
traces

1 View management

1.1 Open perspective
Open and reset LTTng Kernel Perspective, and 
select Resources view Resource view opens. SWTBot Pass

1.2 Open trace Open LTTng Kernel trace in Project Explorer

Resource view is populated with traces 
(sorted by name) and their resources as tree 
children (sorted by resource type then 
numerically) Range is set to initial offset. SWTBot Pass

1.2 Open experiment
Open experiment with LTTng Kernel traces in 
Project Explorer

Resource view is populated with traces 
(sorted by name) and their resources as tree 
children (sorted by resource type then 
numerically) Range is set to initial offset. Manual Pass Verified in Aug. 17-2018 at 16:23PM

1.3 Close view Close the Resources view View is closed. SWTBot Pass

1.4 Open view Open the Resources view
Resources view is opened and populated with 
processes. SWTBot Pass

2 View selection

2.2 Select resource in time graph
Select a resource in the time graph (empty 
region)

Resource is highlighted. Selected time line is 
updated. Other views are synchronized to 
selected time. Manual Pass Verified in Aug. 17-2018 at 16:24PM

2.3 Select state in time graph Select a state in the time graph

State is highlighted in time graph. Selected 
time line is updated. Other views are 
synchronized to selected time. Manual Pass Verified in Aug. 17-2018 at 16:25PM

3 Mouse handling

3.1 Drag move canvas
Drag move time graph left and right with 
middle button

Time range is dragged. When mouse button is 
released, states are updated and new window 
range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 16:25PM

3.2 Zoom time range (mouse wheel)
Zoom with mouse wheel up and down on 
header or Ctrl+mousewheel in the time graph

Time range is zoomed in and out, relative to 
mouse cursor. When mouse wheel is stopped 
for a short time, states are updated and new 
time range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 16:25PM

3.3 Zoom time range (mouse drag)
Drag in time graph scale left and right with 
left button

Time range is zoomed in and out. When 
mouse button is released, states are updated 
and new time range is propagated to other 
views. Manual Pass Verified in Aug. 17-2018 at 16:26PM

3.4 Mouse vertical scroll
Scroll with mouse wheel up and down, cursor 
outside time graph (in name space)

Time graph scrolls up and down. Selected 
process does not change. Vertical scroll bar 
updated. Manual Pass Verified in Aug. 17-2018 at 16:26PM
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3.5 Vertical scroll bar Click and drag vertical scroll bar
Time graph scroll up and down and remain 
aligned. Selected process does not change. Manual Pass Verified in Aug. 17-2018 at 16:27PM

3.6 Drag select time range Drag select time graph with right button

Selection highlighted. When mouse button is 
released, time range is zoomed to selection, 
states are updated and new time range is 
propagated to other views. Manual Pass Verified in Aug. 17-2018 at 16:27PM

3.7 Double-click reset time range Double-click left button on time scale

Time range is reset to full range, states are 
updated and new time range is propagated to 
other views. Manual Pass Verified in Aug. 17-2018 at 16:27PM

3.8 Mouse hover (empty region)
Hover mouse in time graph over empty 
region Tool tip shows resource name only. Manual Pass Verified in Aug. 17-2018 at 16:27PM

3.9 Mouse hover (state) Hover mouse in time graph over state

Tool tip shows resource name, state name, 
date, start time, end time, duration. For IRQ 
state, IRQ number is shown. For 
IRQ_ACTIVE/SOFT_IRQ_ACTIVE state, CPU 
is shown.On usermode and syscall tool tip 
shows also shows hover time, tid and process 
name. Manual Pass Verified in Aug. 17-2018 at 16:28PM

3.10 Drag mouse selection Drag select time graph with left button

Selection highlighted. Status bar of Eclipse is 
updated with time information: T, T1, T2 and 
delta, where T is the time of the mouse 
position, T1 the first selected time, T2 the 
second (dragged) selected time and delta the 
time difference between T2-T1 (can be 
negative) Manual Pass Verified in Aug. 17-2018 at 16:28PM

3.11 Shift key selection

Click select with left button (begin time), 
press shift key and click select another time 
(end time)

Selection highlighted. Status bar of Eclipse is 
updated with time information: T, T1, T2 and 
delta, where T is the time of the mouse 
position, T1 the first selected time, T2 the 
second (dragged) selected time and delta the 
time difference between T2-T1 (can be 
negative) Manual Pass Verified in Aug. 17-2018 at 16:31PM

4 Keyboard handling

4.1
Keyboard navigation in time graph 
(process selection)

With focus on time graph, use UP, DOWN, 
HOME, END keys

Selected process is changed. Vertical scroll 
bar updated. Manual Pass Verified in Aug. 17-2018 at 16:32PM

4.2
Keyboard navigation in time graph 
(state selection)

With focus on time graph, use LEFT, RIGHT 
keys

Previous or next state is selected. Selected 
time is updated in other views. Manual Pass Verified in Aug. 17-2018 at 16:32PM

5 Tool bar handling

5.1 Show Legend Click Show Legend button
The legend dialog is opened and can be 
closed. SWTBot Pass

5.2 Reset Time Scale Click Reset Time Scale button

Time range is reset to full range, states are 
updated and new time range is propagated to 
other views. Manual Pass Verified in Aug. 17-2018 at 16:32PM

5.3 Select Previous/Next Event Click Previous/Next State button
Previous or next state is selected. Selected 
time is updated in other views. Manual Pass Verified in Aug. 17-2018 at 16:32PM

5.4 Select Previous/Next Process Click Previous/Next Process button
Selected process is changed in time graph. 
Vertical scroll bar updated. Manual Pass Verified in Aug. 17-2018 at 16:32PM

5.5 Zoom In/Out Click Zoom In/Out button

Time range is zoomed in and out, relative to 
center of selection or window. States are 
updated and new time range is propagated to 
other views. Manual Pass Verified in Aug. 17-2018 at 16:32PM
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5.6 Filter Dialog  Open Filter Dialog Verify that all buttons are working correctly Manual Pass Verified in Aug. 17-2018 at 16:32PM

6 Synchronization

6.1 Time synchronization Select a random time in another view

Selected time line is updated. If selected time 
is outside current range, time range is 
updated to include it. Manual Pass Verified in Aug. 17-2018 at 16:33PM

6.2 Time range synchronization
Select a new time range in Control Flow view 
or in Histogram view. Time range is updated. Manual Pass Verified in Aug. 17-2018 at 16:33PM

6.3
Time range selection 
synchronisation

In any other view that supports range 
synchronization, select a new range.

Selection is highlighted. If begin time (T1) of 
selected time range is outside the current 
range, then time range is updated to include it Manual Pass Verified in Aug. 17-2018 at 16:33PM

7 Multiple Trace Synchronization

Preparation

1) Download traces.zip (if necessary) and 
unzip into a local directory ${local}
2) Import kernel trace ${local}
/traces/import/kernel-overlap-testing 
3) Import UST ${local}
/traces/import/trace ust-overlap-testing
4) Create experiment with trace of 2) in it

7.1 Open multiple traces (no overlap) Open multiple traces that don't overlap in time View shows the last opened trace Manual Pass Verified in Aug. 17-2018 at 16:33PM

7.2
Change selected time and range (no 
overlap) Select a time and new range

Selected time line and time range is updated to 
selected time and new range. Manual Pass Verified in Aug. 17-2018 at 16:33PM

7.3 Select other trace (no overlap)
Select different trace by clicking its Events editor 
tab

View is updated to show selected trace. Selected 
time line and time range are restored to the 
selected trace's previously selected time and range. Manual Pass Verified in Aug. 17-2018 at 16:33PM

7.4 Open multiple traces (overlap)

- Open multiple traces that overlap in time
- For both traces, in Events table right mouse-
click -> "Follow time updates from other traces" View shows the last opened trace Manual Pass Verified in Aug. 17-2018 at 16:34PM

7.5
Change selected time and range 
(overlap) Select a time and new range

Selected time line and time range is updated to 
selected time and new range. Manual Pass Verified in Aug. 17-2018 at 16:34PM

7.6 Select other trace (overlap)
Select different trace by clicking its Events editor 
tab

View is updated to show selected trace. Selected 
time line and time range are set to the newly 
selected time and range. Manual Pass Verified in Aug. 17-2018 at 16:34PM

7.7 Close all traces Close all Events editor tabs View is cleared. Manual Pass Verified in Aug. 17-2018 at 16:34PM

8.1 Filtering
Preparation Open 2 LTTng Kernel Traces

8.1 Apply filter (1st trace)

1) Open filter dialog
2) Create filter
3) Click on OK

Make sure that only selected processes of 
filter dialog are shown SWTBot Pass

8.2 Apply filter (2nd trace)

1) Switch to 2nd trace (keep 1st open)
2) Open filter dialog
3) Create filter
4) Click on OK

Make sure that only selected processes of 
filter dialog are shown Manual Pass Verified in Aug. 17-2018 at 16:34PM
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8.3 Persistent filter Switch between both open traces 
Make sure that previously set filter are still 
available Manual Pass Verified in Aug. 17-2018 at 16:34PM

9 Miscellaneous

9.1 Restart (Bug 409345)

1) Open LTTng Kernel Trace
2) Select Resource View
3) Restart Eclipse Verify that Resources View is populated Manual Pass Verified in Aug. 17-2018 at 16:35PM
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Section Pass Fail Type To Do Comment
LTTng 2.0 - Control 
View 125 0 118 6 35

Target: Ubuntu 16.04 64 bit
LTTng Tools 2.9.6, Built-in 
SSH 

Step Test Case Action Verification Type Comment

0 Prerequisites

For the tests below a Ubuntu machine with LTTng 2.0 installed 
(with lttng tools 2.5.x or later) is required. Make sure that the 
root session daemon is running (sudo lttng list -k) and have one 
UST process running (e.g. from lttng-tools git repository under 
tests/hello.cxx) LTTng Tracer Control User Guide: http://wiki.eclipse.org/Linux_Tools_Project/LTTng2/User_Guide#LTTng_Tracer_Control

0.1 Set Proxy
a) Window → Preferences → General → Network Connections
b) Set “Active Provider” to “Direct”

1 General

1.1 Open perspective Open and reset LTTng Kernel Perspective

LTTng Kernel perspective opens with 
correct Control view on the left bottom 
corner SWTBot Pass

2 Manage View

2.1 Close view Close Control View
Control view is removed from 
perspective Manual Pass Verified in Aug. 16-2018 at 15:20PM

2.2 Open Control view
Use menu Window → Show View → Other … → Lttng → 
Control Verify that Control view is shown SWTBot Pass

3 Connection Handling

3.1 Create Host Connection

1) Click Button 'New Connection...'
2) Select Tree item "Built-in SSH" and click on Create
3) Enter Connection Name (e.g. MyHost), enter Host Name (a 
DNS name  or IP address), username and password 
4) Click 'Finish'
5) In Tree select the newly create connection and click on 'Ok' 

Make sure that after 4) the new 
connection is shown in the tree. Verify 
that the new host is shown in the 
Control view (with 'Connection Name'. 
After Ssh connection has been 
established, make sure that Provider 
and Session nodes are created in the 
Control view underneath the host. 
Verify that all active Providers  (Kernel 
and UST providers) are shown under 
the 'Provider' node. RCPTT Pass

3.2 Disconnect
a) Select host to disconnect and click Button 'Disconnect'
b) Redo test with context sensitive menu item 'Disconnect'

Verify that icon for the corresponding 
node changes to the disconnect icon 
and all sub-nodes are removed. RCPTT Pass

3.3 Connect
a) Select host to connect and click Button 'Connect' 
b) Redo test with context sensitive menu item 'Connect'

Verify that icon for the corresponding 
node changes to the connected icon 
and after successful SSH connection 
all data is retrieved form the remote 
host (Providers, sessions etc). RCPTT Pass

3.4 Select Host Connection

1) Restart Eclipse 
2) Click Button 'New Connection...' 
3) Select the host previously created  
4) Select 'Ok'. (Afterwards enter user ID and Password if 
necessary)

Make sure that SSH connection is 
established and all data is retrieved 
from the remote host ( (Providers, 
sessions etc). RCPTT Pass

3.5
Node contexts sensitive 
menu (host connected)

1) Connect to remote host 
2) select connected node and click right mouse button

Verify that menu items are shown and 
enabled/disabled depending on state: 
'Connect' (disabled)
Disconnect (enabled)
Refresh (enabled)
Delete (disabled) RCPTT Pass

3.6
View button enable state 
(host connected)

1) Connect to remote host (if necessary)
2) select connected node

Verify enable state of view buttons:
'New Connection...' (enabled)
'Connect' (disabled)
'Disconnect' (enabled)
'Refresh' (enabled)
'Delete' (disabled)
'Start' (disabled)
'Stop' (disabled)
'Destroy Session...' (disabled)
'Record Snapshot' (disabled)
'Import...' (disabled) RCPTT Pass

3.7

Node contexts sensitive 
menu (host 
disconnected)

1) Disconnect from node 
2) select disconnnected node and click right mouse button

Verify that menu items are shown and 
enabled/disabled depending on state: 
'Connect' (enabled) 
'Disconnect' (disabled) 
'Refresh' (disabled)
'Delete' (enabled) RCPTT Pass

LTTng_Tracer_Control
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3.8
View button enable state 
(host connected)

1) Disconnect to remote host (if necessary)
2) select disconnected node if necessary

Verify enable state of view buttons:
'New Connection...' (enabled)
'Connect' (enabled)
'Disconnect' (disabled)
'Refresh' (disabled)
'Delete' (enabled)
'Start' (disabled)
'Stop' (disabled)
'Destroy Session...' (disabled)
'Record Snapshot' (disabled)
'Import...' (disabled) RCPTT Pass

3.9 Delete 

a) Select node to delete (state disconnected) and click on 
button 'Delete'
b) Redo test with context sensitive menu item 'Delete'

Verify that host is removed from the 
control view. RCPTT Pass

3.10
Create Host Connection 
with ssh port

re-do 3.1 but this time specify a port number other than default 
SSH port 22

The connection should fail (unless 
remote is configured for the specified 
port) RCPTT Pass

4 Session Handling
4.1 Preparation 1) Connect to remote host -

4.2
Sessions Context 
Sensitive Menu Select 'Sessions' in tree and click right mouse button

Verify that menu items are shown and 
enabled: 'Refresh', 'Create Session...', 
Load...' and 'Execute Command Script 
...' RCPTT Pass

4.3
Create Session (default 
location)

1) Click right mouse button on 'Sessions'
2) Select 'Create Session...' in the context sensitive menu 
3) Enter session name 'MySession', keep 'Session Path' empty
4) Select 'Ok'

Verify that new session is added under 
the Session tree node. Verify 
properties in Properties view (by 
selecting the session in the Control 
view):
'Session name' (=MySession)
'Session Path' 
(=/home/<user>/traces/MySession_<d
ate and time>) and 'State' 
(=INACTIVE) SWTBot Pass

4.4
Create Session (custom 
location)

1) Click right mouse button on 'Sessions' 
2) Select 'Create Session...' in the context sensitive menu 
3) Enter session name 'MyOtherSession' 
4) enter custom path (/tmp/myTraces) for 'Session Path' 
5) Select 'Ok'

Verify that new session is added under 
the Session tree node. Verify 
properties in Properties view (by 
selecting the session in the Control 
view):
'Session name' (=MyOtherSession)
 'Session Path' (=/tmp/myTraces) and 
'State' (=INACTIVE) RCPTT Pass

4.5

Create Session – 
session already exists in 
GUI

1) Click right mouse button on 'Sessions' 
2) Select 'Create Session...' in the context sensitive menu 
3) Enter session name 'MySession', keep 'Session Path' empty 

Make sure that an error message 
appears in the message area of the 
dialog box with information that 
session 'MySession' already exists in 
the tree. RCPTT Pass

4.6

Create Session – 
session already exists 
on node

1) login to the remote host using a command shell 
2) type lttng create newSession and press enter. This will create 
a session which is not know by the Control view. 
3) Click right mouse button on 'Sessions' 
4) Select 'Create Session...' in the context sensitive menu
5) Enter session name 'newSession', keep 'Session Path' empty
6) Select 'Ok'

Verify that an error dialog box will 
show with information that command 
to create a session failed. session 
already exists on the node. Select 
'Details':  Verify that the command 
error detail is shown (with return value 
(28)) RCPTT Pass

30 seconds pause in the test to create manualy a 
session on the host

4.7

Session Context 
Sensitive menu (session 
inactive) Select newly created session and click right mouse button

Verify context sensitive menu items:
'Refresh' (enabled)
'Start' (enabled)
'Stop' (disabled)
'Destroy Session...' (enabled)
'Import...' (enabled)
'Save...' (enabled)
'Enable Channel...' (enabled)
'Enable Event (default channel)...' 
(enabled)
'Record Snapshot' (disabled) RCPTT Pass

4.8
View button enable state 
(session inactive) Select newly created session (enable an event before)

Verify enable state of view buttons:
'New Connection...' (enabled)
'Connect' (disabled)
'Disconnect' (disabled)
'Refresh' (enabled)
'Delete' (disabled)
'Start' (enabled)
'Stop' (disabled)
'Destroy Session...' (enabled)
'Import...' (enabled)
'Record Snapshot' (disabled) RCPTT Pass

4.9 Start Session

a) Enable an event 
b) Select session and click on button 'Start'
c) Redo test with context sensitive menu item 'Start'

Verify that Session icon changes to 
'ACTIVE' icon. Verify that property 
view shows 'ACTIVE' for the session 
state SWTBot Pass
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4.10

Session Context 
Sensitive menu (session 
active) Select started session and click right mouse button

Verify context sensitive menu items:
'Refresh' (enabled)
'Start' (disabled)
'Stop' (enabled)
'Destroy Session...' (disabled)
'Import...' (disabled)
'Enable Channel...' (disabled)
'Enable Event (default channel)...' 
(disabled) RCPTT Pass

4.11
View button enable state 
(session active) Select started session

Verify enable state of view buttons:
'New Connection...' (enabled)
'Connect' (disabled)
'Disconnect' (disabled)
'Refresh' (enabled)
'Delete' (disabled)
'Start' (disabled)
'Stop' (enabled)
'Destroy Session...' (disabled)
'Import...' (disabled) RCPTT Pass

4.12 Destroy Session

1) In the Control view select session 'MyOtherSession' 
2) Click right mouse button 
3) select 'Destroy Session...' in the context sensitive menu 
4) Select 'Ok' in the confirmation dialog box

Verify that session is removed from 
the control view. SWTBot Pass

5
Kernel Channel 
Handling

5.1 Preparation
1) Connect to remote host
2) Create new Session 'MyOtherSession' -

5.2

Enable Channel on 
session level (default 
values)

1) Select session and right mouse click 
2) Select menu item 'Enable Channel...'
3) Enter Channel name (e.g. myChannel) and keep default 
values 
4) Select Kernel
5) Click on 'Ok'

Verify that domain 'Kernel' is created 
under session and channel is added 
under the domain. Verify that default 
values for the channel are displayed in 
the Properties view after selecting the 
channel in the tree. RCPTT Pass

5.3

Enable Channel on 
domain level (changed 
values)

1) Select domain 'Kernel' and right mouse click 
2) Select menu item 'Enable Channel...'
3) Enter Channel name (e.g. MyOtherChannel)
4) Change values 
5) Click on 'Ok'

Verify that channel is added under the 
domain. Verify that correct values for 
the channel are displayed in the 
Properties view after selecting the 
channel in the tree. RCPTT Pass

5.4
Enable Channel – 
channel already exists

1) Select domain 'Kernel' and right mouse click 
2) Select menu item 'Enable Channel'
3) Enter Channel name (e.g. MyOtherChannel) and keep 
default values
4) Click on 'Ok'

Verify that error dialog box is opened 
notifying that channel already exists. RCPTT Pass

5.5
Domain Context 
Sensitive menu Select domain 'Kernel' and click right mouse button

Verify context sensitive menu items: 
'Refresh' (enabled) 
'Enable Channel...' (enabled) 
'Enable Event (default channel)...' 
(enabled)
'Add Context...” (enabled) RCPTT Pass

5.6
Channel Context 
Sensitive menu Select channel 'MyChannel' and click right mouse button

Verify context sensitive menu items: 
'Refresh' (enabled) 
'Enable Channel' (disabled) 
'Disable Channel' (enabled)
'Enable Event (default channel)...' 
(enabled)
'Add Context...” (enabled) RCPTT Pass

5.7 Disable Channel
1) Select channel 'MyChannel' and click right mouse button
2) Select 'Disable' menu item

Verify that channel is disabled 
(disabled channel icon shown, state 
DISABLED shown in Properties view, 
menu item 'Disable' is disabled and 
menu item 'Enable' is enabled RCPTT Pass

5.8 Enable Channel
1) Select channel 'MyChannel' and click right mouse button 2) 
Select 'Enable' menu item

Verify that channel is enabled 
(enabled channel icon shown, state 
ENABLED shown in Properties view, 
menu item 'Disable' is enabled and 
menu item 'Enable' is disabled RCPTT Pass

6 UST Channel Handling

6.1

Enable Channel on 
session level (default 
values)

1) Select session and right mouse click 
2) Select menu item 'Enable Channel...'
3) Enter Channel name 'MyChannel'
4) Select UST
5) Click on Button 'Default'
5) Click on 'Ok'

Verify that domain 'UST global' is 
created under session and channel is 
added under the domain. Verify that 
default values for the channel are 
displayed in the Properties view after 
selecting the channel in the tree. SWTBot Pass

6.2 Enable/Disable Channel Redo tests 5.7 and 5.8 with UST channel See 5.7/5.8 RCPTT Pass

7 Kernel Event Handling
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7.1
Enable Event on session 
level (all tracepoints)

1) Select session and click right mouse button
2) Select menu item 'Enable Events (default channel)...'
3) Select 'Kernel'
4) Select Radio button for 'Tracepoint Events'
5) Select top level tree node 'All'
6) Click on Ok

Verify that default channel (channel0) 
is create under domain 'Kernel' and 
that all tracepoint events are added 
under the channel with state 
ENABLED. Verify properties view 
show correct values when selecting a 
event in the tree (Event 
Type=TRACEPOINT, 
State=ENABLED) SWTBot Pass

7.2
Enable Event on domain 
level (syscalls)

1) Select domain Kernel and click right mouse button
2) Select menu item 'Enable Events (default channel)...'
3) Select 'Kernel'
4) Select Radio button for 'All Syscalls'
5) Click on Ok

Verify that event with name syscalls is 
added under the default channel 
(channel0) with state ENABLED. 
Verify properties view show correct 
values when selecting a event in the 
tree (Event Type=SYSCALL, 
State=ENABLED) SWTBot Pass

7.3

Enable Event on 
Channel level (Dynamic 
Probe)

1) Select a channel (e.g. channel0) and click right mouse button
2) Select menu item 'Enable Events...'
3) Select Radio button for 'Dynamic Probe'
4) Enter Event Name 'MyEvent' and Probe (e.g. 0xc0101280, 
see file /boot/System.map<kernel version>, valid symbols have 
T or t as type, I used 'backtrace_stack' for example)
5) Click on Ok

Verify that event with name 'MyEvent' 
is added under the respective channel  
with state ENABLED. Verify properties 
view show correct values when 
selecting a event in the tree (Event 
Type=Probe, State=ENABLED, 
Address=0xc0101280, Event 
Name=MyEvent) RCPTT Pass

Command to change state of events failed
Command failed! Command:  lttng --mi xml enable-event MyEvent -k -s auto-20160607-005527 -c sdf --probe 0xffffffff820a25f5
Error Output:
Error: Event MyEvent: Enable kernel event failed (channel sdf, session auto-20160607-005527)
Return Value: 43
<?xml version="1.0" encoding="UTF-8"?>
<command xmlns="http://lttng.org/xml/ns/lttng-mi" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://lttng.org/xml/ns/lttng-mi http://lttng.org/xml/schemas/lttng-mi/3/lttng-mi-3.0.xsd" schemaVersion="3.0"><name>enable-event</name><output><events><event><name>MyEvent</name><type>PROBE</type><enabled>false</enabled><attributes><probe_attributes><address>18446744071596287477</address></probe_attributes></attributes><success>false</success></event></events></output><success>false</success></command>

7.4

Enable Event on 
Channel level (Dynamic 
Function Probe)

1) Select a channel (e.g. channel0) and click right mouse button
2) Select menu item 'Enable Events...'
3) Select Radio button for 'Dynamic Function Entry/Return 
Probe'
4) Enter Event Name 'MyOtherEvent' and Probe (e.g. 
create_dev, see file /proc/kallsyms or /boot/System.map<kernel 
version>)
5) Click on Ok

Verify that event with name 
'MyOtherEvent' is added under the 
respective channel  with state 
ENABLED. Verify properties view 
show correct values when selecting a 
event in the tree (Event 
Type=Function, State=ENABLED, 
Symbol=create_dev, Offset=0x0, 
Event Name=MyOtherEvent) RCPTT Pass

Command to change state of events failed
Command failed! Command: lttng --mi xml enable-event bob -k -s MyOtherSession --function create_dev
Error Ouptut:
Error: Event bob: Non-default channel exists within session: channel name needs to be specified with '-c name' (channel <default>, session MyOtherSession)
Return Value: 83
<?xml version="1.0" encoding="UTF-8"?>
<command><name>enable-event</name><output><events><event><name>bob</name><type>FUNCTION</type><enabled>false</enabled><filter>false</filter><attributes><probe_attributes><offset>0</offset><symbol_name>create_dev</symbol_name></probe_attributes></attributes><success>false</success></event></events></output><success>false</success></command>

7.5 Disable Event

1) Select multiple events (tracepoint events) under a channel 
(not syscalls) and click right mouse button
2) Select 'Disable' menu item

Verify that all selected events are 
disabled  (disabled event icon is 
shown, state DISABLED is shown in 
Properties view, menu item 'Disable' is 
disabled and menu item 'Enable' is 
enabled RCPTT Pass

Note: Disable and Enable menu item is only enabled for 
events of the same type, all tracepoints or all sys calls. 
For function and dynamic probe the user has to enable 
each separately.

7.6
Enable Event (tracepoint 
events)

1) Select multiple disabled events and click right mouse button 
2) Select 'Enable' menu item

Verify that selected events are 
enabled (enabled event icon is shown, 
state ENABLED is shown in Properties 
view, menu item 'Disable' is enabled 
and menu item 'Enable' is disabled RCPTT Pass

Note: Disable and Enable menu item is only enabled for 
events of the same type, all tracepoints or all sys calls. 
For function and dynamic probe the user has to enable 
each separately.

7.7
Enable Event (probe 
events)

1) Select a probe event (function or dynamic probe) disabled 
events and click right mouse button 
2) Select 'Enable' menu item

Verify that selected events are 
enabled (enabled event icon is shown, 
state ENABLED is shown in Properties 
view, menu item 'Disable' is enabled 
and menu item 'Enable' is disabled RCPTT Pass

7.8

Enable Tracepoint Event 
using filter in tree (Bug 
450526)

1) Create Session
2) Select session, right-mouse click and select 'Enable Events 
(default channel)'
3) Enter a filter (e.g. sched) for the tracepoint tree and then 
select All
4) Click on Ok

Verify that only the selected 
tracepoints (filtered) are enabled and 
not all kernel tracepoionts RCPTT Pass

8 UST Event Handling

8.1
Enable Event on session 
level (all tracepoints)

1) Select session and click right mouse button
2) Select menu item 'Enable Events (default channel)...'
3) Select 'UST'
4) Select Radio button for 'Tracepoint Events'
5) Select top level tree node 'All'
6) Click on Ok

Verify that default channel (channel0) 
is create under domain 'UST global' 
and that a wildcard event “*” is create 
under the channel with state 
ENABLED. Verify properties view 
show correct values when selecting a 
event in the tree (Event 
Type=TRACEPOINT, 
State=ENABLED) RCPTT Pass

8.2
Enable Event on domain 
level (wildcards)

1) Select domain 'UST global' and click right mouse button
2) Select menu item 'Enable Events (default channel)...'
3) Select Radio button for 'Wildcard'
4) Enter a wildcard (e.g. ust*)
5) Click on Ok

Verify that event with wildcarded name 
(e.g ust*) is added under the default 
channel (channel0) with state 
ENABLED. Verify properties view 
show correct values when selecting a 
event in the tree (Event 
Type=TRACEPOINT, 
State=ENABLED) RCPTT Pass

8.3
Enable Event on 
Channel level (log level)

1) Select a channel (create if necessary) and click right mouse 
button
2) Select menu item 'Enable Events...'
3) Select Radio button for 'Log Level'
4) Enter Event Name 'MyEvent'
5) Select log level TRACE_ERR
6) Select radio button for loglevel
7) Click on Ok

Verify that event with name 'MyEvent' 
is added under the respective channel 
with state ENABLED. Verify properties 
view show correct values when 
selecting a event in the tree (Event 
Type=TRACEPOINT, 
State=ENABLED, Log 
Level=<=TRACE_ERR, Event 
Name=MyEvent) SWTBot Pass

Note: In LTTng backend v2.4 and later provide 
information if a loglevel is for a range (e.g. <= 
TRACE_ERR) This will be displayed by the properties 
view now
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8.4

Enable Event on 
Channel level (log level 
oly)

1) Select a channel (create if necessary) and click right mouse 
button
2) Select menu item 'Enable Events...'
3) Select Radio button for 'Log Level'
4) Enter Event Name 'MyOtherEvent'
5) Select log level TRACE_INFO
6) Select radio button for loglevel-olny
7) Click on Ok

Verify that event with name 
'MyOtherEvent' is added under the 
respective channel with state 
ENABLED. Verify properties view 
show correct values when selecting a 
event in the tree (Event 
Type=TRACEPOINT, 
State=ENABLED, Log Level= 
==TRACE_INFO, Event 
Name=MyOtherEvent). 

RCPTT Pass

Note: In LTTng backend v2.4 and later provide 
information if a loglevel is for a single level (e.g. == 
TRACE_INFO) This will be displayed by the properties 
view now

8.5
Enable/Disable Event 
(tracepoint events) Redo tests 7.5 and 7.6 with UST tracepoint events See 7.5/7.6 RCPTT Pass

8.6
Enable/Disable Event 
(tracepoint events) Redo tests 7.5 and 7.6 with UST (loglevel/loglevel-only) events See 7.5/7.6 RCPTT Pass

8.7

Enable Tracepoint Event 
using filter in tree (Bug 
450526)

1) Create Session
2) Select session, right-mouse click and select 'Enable Events 
(default channel)'
3) Enter filter for the tracepoint tree and then select All
4) Click on Ok

Verify that only the selected trace 
points (filtered) are enabled and not all 
UST trace poionts RCPTT Pass

8.8 Enable Event by name

1) Create Session
2) Select session, right-mouse click and select 'Enable Events 
(default channel)'
3) Select Tracepoints 
4) Enter list of names (comma-separated) in text box 
5) Click on Ok

Verify that events entered in the comma-
separated list are added to the tree SWTBot Pass

9 Contexts Handling

9.1
Add Context (to 
channel)

1) Select kernel channel and click right mouse button
2) Select menu item 'Add Contexts...' 
3) Expand tree and select some contexts (e.g prio, procname, 
pid)
4) Click on 'Ok'

Verify that command is successful (no 
error). 
NOTE: There is no way to retrieve 
added contexts from the trace. 
Therefore GUI cannot display this 
information. RCPTT Pass

9.2
Add Context (to 
channel)

1) Select UST channel and click right mouse button
2) Select menu item 'Add Contexts...' 
3) Expand tree and select contexts procname, pthread_id, vpid 
and vtid
4) Click on 'Ok'

Verify that command is successful (no 
error). 
NOTE 1: There is no way to retrieve 
added contexts from the trace. 
Therefore GUI cannot display this 
information.
NOTE2: For UST only contexts 
procname, pthread_id, vpid and vtid 
are supported RCPTT Pass

9.3 Add Context (to event)

1) Select 1 Kernel tracepoint event and click right mouse button
2) Select menu item 'Add Contexts...' 
3) Expand tree and select some contexts (e.g prio, procname, 
pid)
4) Click on 'Ok'
Note: only when using LTTng Tools 2.0.x - 2.1.x. For v2.2 or 
later this menu item has to be disabled

Verify that command is successful (no 
error). 
NOTE: There is no way to retrieve 
added contexts from the trace. 
Therefore GUI cannot display this 
information. SWTBot Pass DEPRECATED

10
Enable Events (from 
Provider)

10.1 Enable Kernel Events

1) Create a new session
2) Select multiple Kernel Tracepoint events under Providers → 
Kernel
3) click right mouse button
4) select menu item 'Enable Event...'
5) Select newly created session
6) Select 'Ok'

Verify that domain 'Kernel' is created 
under the new session. Verify that 
default channel 'channel0' is created 
under the domain. Verify that selected 
events are added  under the channel 
and are ENABLED. RCPTT Pass

10.2 Enable UST Events

1) Make sure that UST application is running on remote host 
(see step 0)
2) Create a new session
3) Create a channel under domain 'UST global'
4) Select multiple UST Tracepoint events under Providers -> 
<UST Process>
5) click right mouse button
6) select menu item 'Enable Event...'
7) Select newly created session
8) Select newly created channel
9) Select 'Ok'

Verify that selected events are added 
under the selected channel and are 
ENABLED. RCPTT Pass

11 Importing to Project

11.1 Preparation

1) Create new session
2) Enable all Kernel Tracepoint events 
3) Enable all Kernel sycalls
4) Enable all UST events
5) Start Tracing
6) Stop Tracing after a few seconds 
7) Create new Tracing Project 
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11.2 Import to project

1) Select session from 11.1 and click right mouse button
2) Select 'Import...'
3) Select Ok

After 2 verify that all traces are 
selected by default and also that the 
tracing project with name 'Remote' is 
selected. 

Verify that during import a progress 
dialog is opened to show the progress 
of the import operation. 

Verify that traces are imported to the 
project wiith name Remote and its 
Traces folder. Verify that for the kernel 
trace the trace type "LTTng Kernel 
Trace" is set and for the UST traces 
the trace type "LTTng UST Trace" is 
set. 
 
Create Experiment, select all traces 
and open Experiment. Make sure that 
all view are populated correctly in the 
LTTng Kernel Perspective. RCPTT Pass Experiment not tested with populated views

11.3

Import to project 
(Override)

1) Repeat step 1 – 3 of test case 11.2
2) In dialog box select 'Overwrite'  (kernel trace)
3) In dialog box select 'Overwrite'  (UST trace, re-do if more 
than 1 UST trace)

Verify that traces are imported and 
existing traces are overwritten SWTBot Pass Tested with Remote Fetching 8.6

11.4
Import to project 
(Overwrite All)

1) Repeat step 1 – 3 of test case 11.2
2) In dialog box select 'Overwrite All'

Confirmation dialog only shows once. 
Verify that traces are imported and 
existing traces are overwritten RCPTT Pass Hard to be sure that the overwrite worked

11.5
Import to project 
(Rename)

1) Repeat step 1 – 3 of test case 11.2
2) In dialog box select 'Rename'  (kernel trace)
3) In dialog box select 'Rename'  (UST trace, re-do if more than 
1 UST trace)

Verify that traces are imported with a 
different name SWTBot Pass Tested with Remote Fetching 8.5

11.6
Import to project 
(Rename All)

1) Repeat step 1 – 3 of test case 11.2
2) In dialog box select 'Rename All'

Confirmation dialog only shows once. 
Verify that all traces are imported with 
a different name RCPTT Pass

11.7 Import to project (Skip)

1) Repeat step 1 – 3 of test case 11.2
2) In dialog box select 'Skip'  (kernel trace)
3) In dialog box select 'Skip'  (UST trace, re-do if more than 1 
UST trace)

Verify that each skipped trace is not 
imported SWTBot Pass Tested with Remote Fetching 8.7

11.8
Import to project (Skip 
All)

1) Repeat step 1 – 3 of test case 11.2
2) In dialog box select 'Skip All' Confirmation dialog only shows once. 

Verify that all traces are skipped RCPTT Pass Hard to be sure that the skip worked

12 Refresh

12.1 Refresh
Press refresh button and context sensitive menu item for 
different selections

Verify that the Control View is 
refreshed. Manual Pass Verified in Aug. 22-2018 at 12:01PM

14
Event Filtering (LTTng 
2.1)

14.1

For the tests below a Ubuntu machine with LTTng 2.1 installed 
(with lttng tools 2.1.x) is required. Either create a VM machine 
yourself (e.g. on Virtualbox) or install it locally on your native 
Ubuntu (if correct version). Make sure that the root session 
daemon is running (sudo lttng list -k) and have one UST 
process running (e.g. from lttng-tools git repository under 
tests/hello.cxx)

14.2 Preparation
1) Connect to remote host
2) Create new Session 'FilterSession' 

14.3
Enable UST Event on 
session level

1) Select session and click right mouse button
2) Select menu item 'Enable Events (default channel)...'
3) Select 'UST'
4) Select Radio button for 'Tracepoint Events'
5) Select one tracepoint
6) Enter filter expression on a event field
7) Click on 'Ok'

Verify that default channel (channel0) 
is create under domain 'UST global' 
and that the corresponding event is 
created under the channel with state 
ENABLED. 

Verify that Properties view shows 
correct values for this event (Event 
Type=TRACEPOINT, 
State=ENABLED, Filter=with filter, 
Filter=the actual expression in LTTng 
2.8+) RCPTT Pass
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14.4
Enable UST Event from 
provider

1) Execute 14.3
2) Select one UST Tracepoint event under Providers -> <UST 
Process>
3) click  right mouse button
4) select menu item 'Enable Event...'
5) Select newly create session and channel 
6) Enter filter expression on a event field
7) Click on 'Ok'

Verify that selected event is added 
under the selected channel. 

Verify that Properties view shows 
correct values for this event (Event 
Type=TRACEPOINT, 
State=ENABLED, Filter=with filter, 
Filter=the actual expression in LTTng 
2.8+) RCPTT Pass

14.5 Create trace

1) Start Tracing
2) Stop Tracing after a view seconds
3) Import Trace to Project 
4) Open Trace
5) Destroy Session

Make sure that only events are shown 
in the events table that met the 
condition in the filter expressions Manual Pass Verified in Aug. 22-2018 at 14:42PM

15

Create Session With 
Advanced Options 
LTTng v2.1)

15.1

For the tests below a Ubuntu machine with LTTng 2.1 installed 
(with lttng tools 2.1.x) is required. Either create a VM machine 
yourself (e.g. on Virtualbox) or install it locally on your native 
Ubuntu (if correct version). Make sure that the root session 
daemon is running (sudo lttng list -k) and have one UST 
process running (e.g. from lttng-tools git repository under 
tests/hello.cxx)

15.2
Create Session Dialog - 
Advanced Button

1) Open Create Session Dialog box
2) Select "Advanced >>>"
3) Select "<<< Basic"

After 2) verify that advanced options 
are shown (e.g. Trace Path, Protocol, 
Address and Port)

After 3) verify that advanced option are 
not shown and only basic options are 
there (Session Name and Session 
Path) RCPTT Pass

15.3

Create Session Dialog - 
Check box "Use same 
protocol and address for 
data and control"

1) Open Create Session Dialog box and select "Advanced >>>"
2) Uncheck checkbox"Use same protocol and address for data 
and control"
3) Check checkbox "Use same protocol and address for data 
and control"

After 2) verify that data Protocol and 
data Address is enabled. Note that the 
ports cannot be configured for net and 
net6 when this button is unchecked. -> 
port text fields are disabled

After 3) Verify that data Protocol and 
data Address are disabled RCPTT Pass

15.4
Create Session Dialog - 
Protocol list

1) Open Create Session Dialog box and select "Advanced >>>" Verify that the Control protocol 
dropdown menu shows net, net6 and 
file RCPTT Pass

15.5
Create Session Dialog - 
Protocol list 2

1) Open Create Session Dialog box and select "Advanced >>>"
2) Uncheck checkbox "Use same protocol and address for data 
and control"

After 2) verify that the data protocol 
dropdown menu shows net, net6, tcp 
and tcp6 RCPTT Pass

15.6
Create Session Dialog - 
Protocol propagation

1) Open Create Session Dialog box, select "Advanced >>>" 
2) Select net6 for Control Protocol
3) Select file for Control Protocol

After 2) verify that net6 is propagated 
to the data protocol and and that the 
data and control port text fields are 
enabled
After 3) verify that file is propagated to 
the data protocol and that the data and 
control port text fields are disabled. RCPTT Pass

15.7
Create Session Dialog - 
Address propagation

1) Open Create Session Dialog box, select "Advanced >>>" 
2) Enter IP address in Control address

After 2) verify that the IP address is 
propagated to the data address field RCPTT Pass

15.8
Create Session Dialog - 
Protocol propagation 2

1) Open Create Session Dialog box and select "Advanced >>>"
2) Uncheck checkbox "Use same protocol and address for data 
and control"
3) Select tcp for control protocol and tcp6 for data protocol
4) Check checkbox "Use same protocol and address for data 
and control" After 4) make sure that both data and 

control protocol show net RCPTT Pass

15.9
Create trace with file 
protocol

1) Open Create Session Dialog box and select "Advanced >>>"
2) Enter session name, select file protocol and enter directory 
/tmp/testTraces/ in address field and press ok
3) Enable events, start tracing, wait for a few seconds, stop 
tracing
4) Import traces to a existing tracing project
5) Destroy session

Verify that the traces are stored on the 
remote host under 
/tmp/testTraces/kernel and 
/tmp/testTraces/ust/<application(s)> 
repectively.

After 2) make sure that the Session 
Path in the Property View shows the 
URL with the configured parameters 

Verify that the remote import dialog 
box opens at step 4 (as described in 
test cases 11.x) and it is possible to 
transfer the traces to the tracing 
project. RCPTT Pass Need a human to fully test
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15.10
Create trace with file 
protocol and trace path

1) Open Create Session Dialog box and select "Advanced >>>"
2) Enter session name, select file protocol and enter directory 
/tmp/tmpTraces/ in address field, enter /newPath in "Trace 
Path" text field and press ok
3) Enable events, start tracing, wait for a few seconds, stop 
tracing
4) Import traces to a existing tracing project
5) Destroy session

Verify that the traces are stored on the 
remote host under 
/tmp/testTraces/newPath/kernel and 
/tmp/testTraces/newPath/ust/<applicati
on(s)> repectively.

After 3) make sure that the Session 
Path in the Property View shows the 
URL with the configured parameters 

Verify that the remote import dialog 
box opens at step 4 (as described in 
test cases 11.x) and it is possible to 
transfer the traces to the tracing 
project. RCPTT Pass Need a human to fully test

15.11
Create trace with net 
protocol

1) Start relayd on Eclipse local machine (default settings: lttng-
relayd)
2) Open Create Session Dialog box and select "Advanced >>>"
3) Enter session name, select net protocol and enter IP address 
of Eclipse local machine  in address field and press ok
4) Enable events, start tracing, wait for a few seconds, stop 
tracing
5) Import traces to a existing tracing project
6) Destroy session

Verify that the traces are stored on the 
Eclipse local machine under 
/home/<user name>/lttng-
traces/<remote machine 
name>/<session name + date>/kernel 
and /home/<user name>/lttng-
traces/<remote machine 
name>/<session name + 
date>/ust/<application(s)> repectively.

After 3) make sure that the Session 
Path in the Property View shows the 
URL with the configured parameters 

After 5) Verify that dialog box for 
selecting a tracing project is openend 
that after selecting a project and 
pressing next the default trace import 
wizard opens. Then verify that it is 
possible to transfer the traces to the 
tracing project. Manual Pass Verified in Aug. 22-2018 at 12:03PM

15.12
Create trace with tcp 
protocol and port

1) Uncheck checkbox "Use same protocol and address for data 
and control"
2 ) Start relayd on Eclipse local machine with specified ports 
(lttng-relayd -C tcp://0.0.0.0:1234 -D tcp://0.0.0.0:5678)
3) Open Create Session Dialog box and select "Advanced >>>"
4) Enter session name, select tcp protocol and enter IP address 
of Eclipse local machine  in address field, specify data and 
control ports and press ok
5) Enable events, start tracing, wait for a few seconds, stop 
tracing
6) Import traces to a existing tracing project
7) Destroy session

Verify that the traces are stored on the 
Eclipse local machine under 
/home/<user name>/lttng-
traces/<remote machine 
name>/<session name + date>/kernel 
and /home/<user name>/lttng-
traces/<remote machine 
name>/<session name + 
date>/ust/<application(s)> repectively.

After 4) make sure that the Session 
Path in the Property View shows the 
URL with the configured parameters 

After 6) Verify that dialog box for 
selecting a tracing project is openend 
that after selecting a project and 
pressing next the default trace import 
wizard opens. Then verify that it is 
possible to transfer the traces to the 
tracing project. Manual Pass Verified in Aug. 22-2018 at 12:03PM

15.13

Live Streaming Session 
(UST) - Initial 
implementation

1) Start relayd on Eclipse local machine (default settings: lttng-
relayd)
2) Select Live Mode
3) Open Create Session Dialog box and select "Advanced >>>"
4) Enter session name, select net protocol and enter IP address 
of Eclipse local machine  in address field, keep defaults for Live 
Connection and Live Delay, and press ok
5) Enable UST events (per UID channel), start tracing, wait for a 
few seconds, stop tracing
6) Import traces to a existing tracing project
7) Destroy session

Verify that session is created 
successfully. Verify that after 6)  the 
trace appears in the Traces directory 
of Remoter project. Verify that 
relevants views are updated when new 
data arrives SWTBot Pass Implementation disabled for 2.0

15.14

Live Streaming Session 
(Kernel) - Inititial 
Implementation

1) Start relayd on Eclipse local machine (default settings: lttng-
relayd)
2) Select Live Mode
3) Open Create Session Dialog box and select "Advanced >>>"
4) Enter session name, select net protocol and enter IP address 
of Eclipse local machine  in address field, keep defaults for Live 
Connection and Live Delay, and press ok
5) Enable Kernel events, start tracing, wait for a few seconds, 
stop tracing
6) Import traces to a existing tracing project
7) Destroy session

Verify that session is created 
successfully. Verify that after 6)  the 
trace appears in the Traces directory 
of Remoter project. Verify that 
relevants views are updated when new 
data arrives SWTBot Pass Implementation disabled for 2.0

16 Preferences

16.1 Open Preference Dialog
Open Preferences (Menu -> Preferences -> Tracing -> LTTng 
Tracer Control Preferences)

Verify that tracer control preferences 
exists and shows Tracing Group, 
Logging, Log File (always disabled), 
Append, Verbose Level (None, Level 
1, Level2 Level 3) RCPTT Pass

16.2 Enable Logging In Tracer Control Prferences, check checkbox Logging
Verbose Level radio buttons will be 
enabled RCPTT Pass

16.3 Disable Logging In Tracer Control Prferences, uncheck checkbox Logging
Verbose Level radio buttons will be 
disabled RCPTT Pass



4.1.0-TraceCompassTestCases LTTng 2.0 - Control

65

16.4 Test Logging level none
Execute 16.2 and execute some commands (e.g. create 
session, enable event)

Make sure that log file is created and 
contains the executed commands and 
command replies RCPTT Pass

16.5
Test Verbose Logging 
(Level 1)

1) Execute 16.2
2) select verbose level Level 1
3) Execute some commands (e.g. create session, enable event)

Make sure that log file contains the 
executed commands with -v option (e.
g. lttng -v create session) and the 
command replies come with debug 
information RCPTT Pass This makes no difference for MI starting with Lttng 2.6

16.6
Test Verbose Logging 
(Level 2)

1) Execute 16.2
2) select verbose level Level 2
3) Execute some commands (e.g. create session, enable event)

Make sure that log file contains the 
executed commands with -vv option 
(e.g. lttng -vv create session) and the 
command replies come with debug 
information RCPTT Pass This makes no difference for MI starting with Lttng 2.6

16.7
Test Verbose Logging 
(Level 3)

1) Execute 16.2
2) select verbose level Level 3
3) Execute some commands (e.g. create session, enable event)

Make sure that log file contains the 
executed commands with -vvv option 
(e.g. lttng -vvv create session) and the 
command replies come with debug 
information RCPTT Pass This makes no difference for MI starting with Lttng 2.6

16.8 Append Mode
Check checkbox Append,  restart Eclipse and open Tracer 
Control Preferences

Verify that tracer control preferences 
are persisted and the log file is opened 
in append mode (old file is not 
overwritten) RCPTT Pass

16.9 Change Tracing Group
Change Tracing group (e.g. tracing2) and execute a command 
(while logging enabled)

Verify that lttng command is executed 
with command line option -g <group>. 
Ignore any command reply errors (if 
any) RCPTT Pass

16.10
Change execution 
timeout Go to Remote Connection Preferences, Change Timeout 

After verify that values smaller than 5 
and bigger than 600 are rejected RCPTT Pass

16.11 Reset Reset to defaults

Verify: Group=tracing, Logging is 
deselected, Append is deselected, 
Verbose Level=None), and Command 
Timout is 15 RCPTT Pass

17

Create Channel with 
advance features 
(LTTng 2.2 features)

17.1

For the tests below a Ubuntu machine with LTTng 2.2 installed 
(with lttng tools 2.2.x) is required. Either create a VM machine 
yourself (e.g. on Virtualbox) or install it locally on your native 
Ubuntu (if correct version). Make sure that the root session 
daemon is running (sudo lttng list -k) and have one UST 
process running (e.g. from lttng-tools git repository under 
tests/hello.cxx).

17.2
Configure Metadata 
channel (kernel)

1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Select Checkbox 'Configure metadata channel'
4) Update all text boxes
5) Click on 'Ok'

Verify after 3) that 'Channel Name' is 
set to metadata and the correspondig 
textbox is disabled. Verify after 5) that 
metadata channel was created under 
the kernel domain. Also verify in the 
properties view that all parameters are 
set correctly when selecting the 
channel metadata. RCPTT Pass

17.3
Configure Metadata 
channel (UST) 1) Re-do 17.2 with a UST channel

Verify after 3) that 'Channel Name' is 
set to metadata and the correspondig 
textbox is disabled. Verify after 5) that 
metadata channel was created under 
the domain UST global. Also verify in 
the properties view that all parameters 
are set correctly when selecting the 
channel metadata. RCPTT Pass

Command is successful. However tracer doesn't create 
metadata channel. Bug in LTTng http://bugs.lttng.
org/issues/994

17.4
Configure File rotation 
(kernel)

1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Fill in channel name 
4) Fill in 1048576 in 'Maximum size of trace files' and also 'Sub 
Buffer Size'
5) Fill in 2 in 'Maximum number of trace files'
6) Click on 'Ok'
7) Enable all kernel events
8) Start, wait and stop tracing. 

After 8) verify on the trace node that 
trace files are not bigger than 1048576 
bytes RCPTT Pass Need a human to check the size on the host

17.5
Configure File rotation 
(ust)

1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Fill in channel name 
4) Select UST
5) Fill in 262144 in 'Maximum size of trace files' and also 'Sub 
Buffer Size'
6) Fill in 2 in 'Maximum number of trace filesfiles'
7) Click on 'Ok'
8) Enable all UST events
9) Start, wait and stop tracing. 

After 9) verify on the trace node that 
trace files are not bigger than 262144 
bytes RCPTT Pass Need a human to check the size on the host

17.6
Buffer Type - toggle 
UST/kernel

1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Select UST 
4) Select Kernel
5) Slect cancel
 

Verify after 2 and 4 that the radio 
buttons for the  buffer type is disabled 
and the buffer type "Global shared 
buffers" is selected which is the value 
for the kernel tracer.
Verify after 3) that the radio buttons 
are enabled an no buffer type is 
selected RCPTT Pass
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17.7 Default UST Buffer Type

1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Select UST 
4) Enter Channel Name
5) Select 'Ok'
 

Verify after 5) that the default buffer 
type is configured for that channel (see 
properties view). Note for LTTng Tools 
2.2 the default is per-PID and for 
LTTng Tools 2.3 and later it is per-UID RCPTT Pass

17.8
per PID UST Buffer 
Type

Prequisite: Multiple UST Applications need to run
1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Select UST
4) Select 'Per PID buffers' 
5) Enter Channel Name
6) Select 'Ok'
8) Enable all ust events
9) Start, wait and stop tracing.
10) Import trace 

Verify after 6) that the per-pid buffer 
type is configured for that channel (see 
properties view). After 10) make sure 
that for each UST application one 
trace is created RCPTT Pass 9) and 10) not tested with RCPTT

17.9
per UID UST Buffer 
Type

Prequisite: Multiple UST Applications need to run
1) Create and select session and click right mouse button
2) Select menu item 'Enable Channel...'
3) Select UST
4) Select 'Per UID buffers' 
5) Enter Channel Name
6) Select 'Ok'
8) Enable all ust events
9) Start, wait and stop tracing.
10) Import trace 

Verify after 6) that the per-pid buffer 
type is configured for that channel (see 
properties view). After 10) make sure 
that only one trace is created even 
multiple UST applications are running. RCPTT Pass

While doing this I found a few bugs but it ended up working. See 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=469425 and https:
//bugs.eclipse.org/bugs/show_bug.cgi?id=469424                            
9) and 10) not tested with RCPTT

18
Snapshot Channel 
(LTTng 2.3 features)
Preparation Connect to a node with LTTng 2.3 installed

18.1
Create Snapshot 
Session 

1) Click right mouse button on 'Sessions'
2) Select 'Create Session...' in the context sensitive menu 
3) Enter session name 'MySession', keep 'Session Path' empty
4) Select checkbox 'Snapshot Mode'
5) Select 'Ok'

Verify that new session is added under 
the Session tree node. Verify 
properties in Properties view (by 
selecting the session in the Control 
view):
'Session name' (=MySession)
'Snaphshot ID' (=1)
'Snapshot Name' (=snapshot-1)
'Session Path' 
(=/home/<user>/traces/MySession_<d
ate and time>) and 'State' 
(=INACTIVE) 

Make sure that the button and menu 
item 'Record Snapshot' is enabled RCPTT Pass

18.2 Enable Kernel Event Enable all Kernel Tracepoint and syscall events 
Verify that channel and events a 
successful enabled RCPTT Pass

18.3 Start Session
a) Select session and click on button 'Start'
b) Redo test with context sensitive menu item 'Start'

Verify that Session icon changes to 
'ACTIVE' icon. Verify that property 
view shows 'ACTIVE' for the session 
state

Make sure that the button and menu 
item 'Record Snapshot' is enabled. 
Also make sure that the Button and 
menu item 'Import' is enabled. RCPTT Pass

18.4 Record snapshot

select session and record 2 snapshots: Once with button 
'Record Snapshot' and once with context-sensitive menu item 
'Record Snapshot' Commands succeed without error RCPTT Pass

18.5
Create another snapshot 
session session name ustSession (as described in 18.1)

Make sure that snapshot session is 
created successfully RCPTT Pass

18.6 Enable UST Events Enable all UST events
Verify that channel and events a 
successful enabled RCPTT Pass

18.7 Start UST session see 18.3 see 18.3 RCPTT Pass

18.8
Record snapshot over 
multiple sessions

Select kernel and ust session (see 18.1 and 18.5) and click on 
'Record snapshot' button Command succeeds without error RCPTT Pass

18.9 Import traces Open Import dialog (see 11.2)

Verify that 4 snapshots are available 
(3 kernel and 1 UST). Verify that all 
snapshots are imported to the selected 
tracing project RCPTT Pass

18.10
Stop and destroy 
sessions Stop and destroy both sessions

Verify that sessions are destroy 
successfully RCPTT Pass

18.11
Network snapshot 
session 

1) Start relayd on Eclipse local machine (default settings: lttng-
relayd)
2) Open Create Session Dialog box, select 'Snapshot Mode'and 
select "Advanced >>>"
3) Enter session name, select net protocol and enter IP address 
of Eclipse local machine  in address field and press ok
4) Enable events (UST and Kernel), start tracing, and record a 
few snapshots, stop tracing
5) Import traces to a existing tracing project
6) Destroy session

Make sure that all steps were 
successfull. Also, import the traces 
using the standard import instead of 
the remote import Manual Pass Verified in Aug. 22-2018 at 14:45PM

18.12
Record snapshot when 
session is inactive SWTBot Pass

Note that the session has to be started at least once otherwise the 
command will fail.

.
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19 Command Script

19.1 Execute command sript
Create a command script to create a session with kernel and 
ust events enabled.

Make sure that each command of 
script is executed and script execution 
is without errors Manual Pass

Verified in Aug. 22-2018 at 14:42PM. I will provide a Perl /Python 
script in test spec.

20 Session Profiles

20.1 Save session

1) Create Tracing session
2) Select session and click right mouse button
3) Select Menu item "Save..."
4) Select 'OK'

Make sure that the session is saved 
under ~/.lttng/sessions on the remote
Make sure that session is availabe in 
the workspace by opening Window-
>Preferences -> Tracing -> LTTng 
Remote Profiles SWTBot Pass

20.2 Save session (2) 1) Re-do 20.1 (use same session name)

Make sure that the session is saved 
under ~/.lttng/sessions.
Make sure that session is availabe the 
user is prompted to skip or overwrite 
the profile in the workspace Manual To Do Verified in Aug. 22-2018 at 14:47PM

20.3 Save session (no force)
1) Re-do 20.1
 but deselect force button

The save command will be rejected by 
LTTng Tools RCPTT Pass

destroy all sessions

20.4 Load Session (local)

1) Select group "Sessions" and click right mouse button
2) Select Menu item "Load..."
3) Select a existing profile (from Local)
4) Select 'OK'

Make sure that the session is created SWTBot Pass

destroy all sessions

20.5 Load Session (remote)

1) Select group "Sessions" and click right mouse button
2) Select Menu item "Load..."
3) Select "Remote"
4) Select a existing profile (from Remote)
5) Select 'OK'

Make sure that the session is created RCPTT Pass

20.6 Open preference (1)

1) Select group "Sessions" and click right mouse button
2) Select Menu item "Load..."
3) Select "Manage..." Make sure that the LTTng Remote 

Profile preference page opens RCPTT Pass

20.7 Open preference (2)
Open Preferences (Menu -> Preferences -> Tracing -> LTTng 
Remote Profiles

Make sure that the LTTng Remote 
Profile preference page opens RCPTT Pass

20.8 Export profile

1) Open Preference page (see 20.7)
2) Select multiple profiles
3) Click on "Export..." 
3) Select destination directory and click on "OK"

Make sure profile is exported to the 
destination directory Manual To Do

20.9 Export profile (redo) Redo 20.8
Make sure that user is prompted about 
to overwrite or skip existing profile Manual To Do

20.10 Import profile

1) Open Preference page (see 20.7)
2) Click on "Import..." 
3) Select a profile on media and click on "OK"

Make sure profile is imported and 
available in workspace Manual To Do

20.11 Import profile (redo)
1) Redo 20.8 Make sure that user is prompted about 

to overwrite or skip existing profile Manual To Do

20.12 Delete profile

1) Open Preference page (see 20.7)
2) Select multiple profiles
3) Click on "Delete..." 
3) Confirm deletion

Make sure profile(s) are delete from 
the workspace and disk RCPTT Pass

21
Kernel Event Filtering 
(LTTng 2.6)

21.1

For the tests below a Ubuntu machine with LTTng 2.1 installed 
(with lttng tools 2.6.x) is required. Either create a VM machine 
yourself (e.g. on Virtualbox) or install it locally on your native 
Ubuntu (if correct version). Make sure that the root session 
daemon is running (sudo lttng list -k) and have one UST 
process running (e.g. from lttng-tools git repository under 
tests/hello.cxx)

21.2 Preparation
1) Connect to remote host
2) Create new Session 'FilterSession' 

21.3
Enable Kernel Event on 
session level

1) Select session and click right mouse button
2) Select menu item 'Enable Events (default channel)...'
3) Select 'Kernel'
4) Select Radio button for 'Tracepoint Events'
5) Select one tracepoint
6) Enter filter expression on a event field
7) Click on 'Ok'

Verify that default channel (channel0) 
is create under domain 'Kernel' and 
that the corresponding event is 
created under the channel with state 
ENABLED. 

Verify that Properties view shows 
correct values for this event (Event 
Type=TRACEPOINT, 
State=ENABLED, Filter=with filter, 
Filter=the actual expression in LTTng 
2.8+) SWTBot Pass
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21.4
Enable Kernel Event 
from provider

1) Execute 14.3
2) Select one Kernel Tracepoint event under Provider "Kernel" 
3) click  right mouse button
4) select menu item 'Enable Event...'
5) Select newly create session and channel 
6) Enter filter expression on a event field
7) Click on 'Ok'

Verify that selected event is added 
under the selected channel. 

Verify that Properties view shows 
correct values for this event (Event 
Type=TRACEPOINT, 
State=ENABLED, Filter=with filter, 
Filter=the actual expression in LTTng 
2.8+) SWTBot Pass

21.5 Create trace

1) Start Tracing
2) Stop Tracing after a view seconds
3) Import Trace to Project 
4) Open Trace
5) Destroy Session

Make sure that only events are shown 
in the events table that met the 
condition in the filter expressions Manual To Do Verified in Aug. 22-2018 at 14:54PM

22
LTTng UST  Exclude 
events (LTTng 2.5)

22.1

For the tests below a Ubuntu machine with lttng tools 2.5.x is 
required. Either create a VM machine yourself (e.g. on 
Virtualbox) or install it locally on your native Ubuntu (if correct 
version). Make sure that the root session daemon is running 
(sudo lttng list -k) and have one UST process running (e.g. from 
lttng-tools git repository under tests/hello.cxx)

22.2 Preparation
1) Connect to remote host
2) Create new Session 'FilterSession' 

22.3
Enable events with 
exclude

1) Open Enable Event Dialog, select UST
2) Use wildcards
3) Enter a event name to exclude

Verify that event is added under the 
UST Domain and relevant channel. 
Verify that the Properties view shows 
the exclusion: Exclusion=with 
Exclusion, for Exclusion the actual 
expression in LTTng 2.8+ SWTBot Pass

23
LTTng UST per syscall 
(LTTng 2.6)

23.1

For the tests below a Ubuntu machine with lttng tools 2.6.x is 
required. Either create a VM machine yourself (e.g. on 
Virtualbox) or install it locally on your native Ubuntu (if correct 
version). Make sure that the root session daemon is running 
(sudo lttng list -k) and have one UST process running (e.g. from 
lttng-tools git repository under tests/hello.cxx)

23.2 Preparation
1) Connect to remote host
2) Create new Session 'MySession' 

23.3 Enable selected syscalls

1) Open Enable Event Dialog, select Kernel
2) Select syscalls
3) In the tree, select selected syscalls
4) Select Ok

Verify that the selectetd syscalls are 
added added under the Kernel Domain 
and relevant channel. 

SWTBot Pass

destroy session

23.4 Enable all syscalls

1) Open Enable Event Dialog, select Kernel
2) Select Syscalls
3) In the tree, select all syscalls
4) Select Ok

Verify that the selectetd syscalls are 
added added under the Kernel Domain 
and relevant channel. 

SWTBot Pass

24
JUL, Log4J, Python 
Logger

24.1
Configure JUL tracing 
session (LTTng 2.6)

Configure JUL tracing session
using tree and event name

verify that session is configured 
correctly SWTBot Pass

24.2
Configure Log4J tracing 
session (LTTng 2.6)

Configure Log4J tracing session
using tree and event name

verify that session is configured 
correctly SWTBot Pass

24.3
Configure Python tracing 
session (LTTng 2.7)

Configure Python tracing session
using tree and event name

verify that session is configured 
correctly SWTBot Pass
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Section Pass Fail To Do Comment

Tracing RCP 32 0 0 0 33
Target: Ubuntu 16.04 64 bit

Step Test Case Action Verification Comment
0 Preparation

1 Start RCP

1.1 Start Tracing RCP
Open RCP from command 
line or file explorer Tracing RCP opens in default perspective Manual Pass Verified in Aug. 23-2018 at 10:39AM

Bruno : Not with this test case : If I 
open n traces, the folder "Traces 
[n]" shows the number of traces 
opened. If i go in the Properties 
view with the folder the title of the 
Properties view is Traces [n], now, 
if I delete the n traces the title of the 
Properties view is still Traces [n] 
instead of Traces [0]. Patrick: The 
Properties view updates itself when 
the selection changes.

Bruno : Not with this test case but 
the delete key doesnt work on 
Tracing project (we need to use the 
mouse right click). Bug 486505.

***(the real test case 1.1 passed)***

1.2 Start Tracing RCP with text trace

Open RCP from command line 
with --open <trace name with 
absolute path>

Trace will be opened with auto-detected 
trace type Manual Pass Verified in Aug. 23-2018 at 10:45AM

1.3
Start Tracing RCP with previously 
opened text trace

Open RCP from command line 
with --open <trace name with 
absolute path>. Use same trace 
than 1.2

Verify that the same trace that was 
previously linked into the Traces folder is 
opened and not a new trace entry is created Manual Pass Verified in Aug. 23-2018 at 10:48AM

1.4
Start Tracing RCP with Kernel 
CTF trace

Open RCP from command line 
with --open <kernel trace name 
with absolute path>

Tracing RCP is opened, the trace is linked 
to the Tracing project, the kernel analysis 
trace type is selected and trace is opened. Manual Pass Verified in Aug. 23-2018 at 10:50AM

The kernel trace opens in an editor 
but the editor of the first trace gets 
activated. Bug 443461.
Bruno : Same bug happens with 
UST traces

1.5
Start Tracing RCP with previously 
opened Kernel  CTF trace

Open RCP from command line 
with --open <kernel trace name 
with absolute path>. Use same 
trace than 1.4

Verify that the same trace that was 
previously linked into the Traces folder is 
opened and not a new trace entry is created Manual Pass Verified in Aug. 23-2018 at 10:51AM

1.6
Start Tracing RCP with new trace 
with name conflict

Open RCP from command line 
with --open <trace name with 
absolute path>, where the 
name of trace is the same than 
1.2, but the trace is located at a 
different location on disk

Verify that  a new trace is linked to the 
Tracing project and trace is opened. Verify 
that the new trace name has a integer 
number a suffix added. Manual Pass Verified in Aug. 23-2018 at 10:52AM
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1.7 Re-do 1.6

Open RCP from command line 
with --open <kernel trace with 
absolute path>, where name of 
trace is the same than 1.4, but 
the trace is located at a 
different location on disk

Verify that  a kernel trace is linked to the 
Tracing project, the kernel analysis trace 
type is selected and trace is opened. Verify 
that the new trace name has a integer 
number a suffix added. Manual Pass Verified in Aug. 23-2018 at 10:53AM

1.8
Start Tracing RCP with non-trace 
file Open file that is not a trace Trace is imported (linked) however default icon (from Eclipse) is setManual Pass Verified in Aug. 23-2018 at 10:53AM

2 File menu

2.1 Open Trace (File)

Use Menu "File -> Open Trace 
…" In the file dialog select a 
text trace and select open.

Trace will be opened with auto-detected 
trace type Manual Pass Verified in Aug. 23-2018 at 10:54AM

2.2
Open Trace (File) with previously 
opened text trace

Use Menu "File -> Open 
Trace…". In the file dialog 
select a text trace and select 
open. Use same trace than 2.1

Verify that the same trace that was 
previously linked into the Traces folder is 
opened and not a new trace entry is created Manual Pass Verified in Aug. 23-2018 at 10:55AM

2.3 Open Trace (Directory)

Use "Menu File -> Open Trace 
…" . In the file dialog select a 
file of Kernel CTF trace 
directory  and select open.

Verify that the trace is linked to the Tracing 
project, the kernel analysis trace type is 
selected and trace is opened. Manual Pass Verified in Aug. 23-2018 at 10:55AM

2.4

Open Trace (Directory) with 
previously opened Kernel CTF 
trace

Use "Menu File -> Open Trace 
…" . In the file dialog select a 
file of Kernel CTF trace 
directory  and select open. Use 
same trace than 2.3

Verify that the same trace that was 
previously linked into the Traces folder is 
opened and not a new trace entry is created Manual Pass Verified in Aug. 23-2018 at 10:55AM

2.5
Open Trace File with name 
conflict

Use Menu "File -> Open Trace 
…" In the file dialog select a 
text trace and select open, 
where the name of trace is the 
same than 2.1, but the trace is 
located at a different location 
on disk

Verify that the new trace is linked to the 
Tracing project and the trace is opened. 
Verify that the new trace name has a integer 
number a suffix added. Manual Pass Verified in Aug. 23-2018 at 10:56AM

2.6 Re-do 2.5

Use "Menu File -> Open Trace 
…" . In the file dialog select a 
file of Kernel CTF trace 
directory  and select open, 
where the name of trace is the 
same than 2.3, but the trace is 
located at a different location 
on disk

Verify that the kernel trace is linked to the 
Tracing project, the kernel analysis trace 
type is selected and trace is opened. Verify 
that the new trace name has a integer 
number a suffix added. Manual Pass Verified in Aug. 23-2018 at 10:56AM
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2.7 Open file Open file that is not a trace Trace is imported (linked) however default icon (from Eclipse) is setManual Pass Verified in Aug. 23-2018 at 10:57AM

2.8 Restart Use Menu File -> Restart
Verify that RCP is restarted with the 
previously open perspective and trace Manual Pass Verified in Aug. 23-2018 at 10:57AM

2.9 Exit Use Menu File -> Exit Tracing RCP exits Manual Pass Verified in Aug. 23-2018 at 10:57AM

3 Window Menu

3.1 Open Perspective

Use Menu Window -> Show 
Perspective -> Tracing 
Perspective Tracing perspective is opened Manual Pass Verified in Aug. 23-2018 at 10:59AM

3.2 Open View

Use Menu Window  -> Show 
View -> Select Tracing -> 
Sequence Diagram Sequence diagram view is shown Manual Pass Verified in Aug. 23-2018 at 11:00AM

3.3 Preferences
Use Menu Window -> 
Preferences Preferences dialog is shown Manual Pass Verified in Aug. 23-2018 at 11:01AM

3.4 Save Perspective As

Make changes of perspective 
by moving views and use menu  
Window -> Save Perspective 
As. Enter a perspective name 
and select Ok Perspective with new name is stored Manual Pass Verified in Aug. 23-2018 at 11:02AM

3.5 Reset Perspective

Make changes of perspective 
by moving views and use menu  
Window -> Reset Perspective. 

After confirming the reset operation the 
perspective is reset to the default layout. Manual Pass Verified in Aug. 23-2018 at 11:02AM

4 Help Menu

4.1 Help Contents
Use Menu -> Help -> Help 
Contents

Help content browser is opened. All 
Tracing related help is included Manual Pass Verified in Aug. 23-2018 at 11:03AM

4.2 Help Contents (shortcut) Use key F1
Help content browser is opened. All 
Tracing related help is included Manual Pass Verified in Aug. 23-2018 at 11:03AM

4.2 Install new Software

Use Menu -> Help -> Install 
New Software… to install new 
Eclipse feature Installation is successful Manual Pass Verified in Aug. 23-2018 at 11:04AM

4.4 About Use Menu -> Help -> About

About dialog is opened all relevent 
information (e.g. version, copyright years 
etc) is up-to-date and correct. Manual Pass Verified in Aug. 23-2018 at 11:04AM

4.5 Version + Copyright
Use Menu -> Help -> About -> 
Installation details

Go over all tracing features and plug-ins 
and verify that all have the correct version 
and copyright years Manual Pass Verified in Aug. 23-2018 at 11:05AM

5 Content
5.1 TMF presence Open Tracing perspective Tracing perspective opens Manual Pass Verified in Aug. 23-2018 at 11:05AM
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5.2 LTTng presence
Open LTTng Kernel 
perspective LTTng Kernel perspective opens Manual Pass Verified in Aug. 23-2018 at 11:06AM

5.3 PCAP Network analysis presence
Open Network Tracing 
perspective Network analysis perspectiv opens Manual Pass Verified in Aug. 23-2018 at 11:07AM

5.4
PcapNg Network analysis 
presence

Open Network Tracing 
perspective Network analysis perspectiv opens Manual Pass Verified in Aug. 23-2018 at 11:07AM

5.5 BMF presence
Open Network Tracing 
perspective Network analysis perspectiv opens Manual Pass Verified in Aug. 23-2018 at 11:11AM

6 Upgrade

6.1 Upgrade from previous release
Use Help -> Check For 
Updates RCP is upgraded Manual N/A Verified in Aug. 23-2018 at 11:07AM. Hung: Get dialog message "No updates were found in available software site"Tested with RC3
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Section Pass Fail To Do Comment

Trace Synchronization 13 0 0 0 13
Target: 

Step Test Case Action Verification Comment

0 Prerequisites

0.1 Import traces
Import the scp_dest and scp_src traces in 
the synctraces.tar.gz file

0.2 Create experiment 1
Create an experiment containing those 2 
traces

0.3 Create experiment 2 Create an experiment with any other trace
1 View Management

1.1 Open Synchronization View
Use menu Window → Show View → Tracing → 
Synchronization

Verify that 'Synchronization' view 
is shown Manual Pass Verified in Aug. 17-2018 at 15:40PM

1.2 Delete view Close the Synchronization View
Synchronization' view is removed 
from perspective Manual Pass Verified in Aug. 17-2018 at 15:57PM

1.3 Open view
Use menu Window → Show View → Tracing → 
Synchronization

Synchronization' view is displayed 
and remains empty Manual Pass Verified in Aug. 17-2018 at 15:57PM

1.4 Open Experiment
Open the experiment containing the 2 
synchronizable traces Verify that the view is still empty Manual Pass Verified in Aug. 17-2018 at 15:59PM

1.5 Synchronize experiment
Right-click on the experiment and select 
'Synchronize Traces'

After a time, the view is populated 
with synchronization result that 
say 'accurate'. And one of the 
original traces has been replace by 
a trace with the same name, but 
with an '_' at the end. Manual Pass Verified in Aug. 17-2018 at 16:00PM

1.6
Open view when trace is 
already loaded

1) Close Synchronization View
2) Load LTTng experiment
3) Open 'Synchronization' view

Verify that view is populated with 
synchronization data from 
currently opened experiment Manual Pass Verified in Aug. 17-2018 at 16:02PM

1.6.5
Synchronize experiment with 
constant offset Try to offset a trace by a second

Visually verify that a 
synchronized trace is now 
offsetted Manual Pass Verified in Aug. 17-2018 at 16:02PM

Simon: not sure what should be the result of this operation
Bernd: I think it is to add a manual time offset on top of the synchronisation

1.7 Open trace Open an Lttng Kernel trace Synchronization view is empty Manual Pass Verified in Aug. 17-2018 at 16:03PM

1.8 Re-open experiment
Open the experiment containing the 2 
synchronized traces

View shows synchronization data 
from the experiment Manual Pass Verified in Aug. 17-2018 at 16:04PM

1.9 Restart Restart Eclipse

Verify that view is populated with 
synchronization data from 
experiment Manual Pass Verified in Aug. 17-2018 at 16:04PM

2 Functionnalities

2.1 Open experiment 2
Open the experiment containing traces that 
do not synchronize

Verify that the 'Synchronization' 
view is empty Manual Pass Verified in Aug. 17-2018 at 16:04PM

2.2
Go back to previous 
experiment

Re-open the experiment with the 
synchronizable traces

Verify that the 'Synchronization' 
view contains the data from the 
experiment Manual Pass Verified in Aug. 17-2018 at 16:04PM

2.3 Synchronize experiment
Right-click on the experiment and select 
'Synchronize traces'

After the syncronization job 
finishes, the synchronized 
experiment is closed and 
experiment 2 is selected. The 
synchronization view is empty. Manual Pass Verified in Aug. 17-2018 at 16:04PM
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Section Pass Fail Type To Do Comment
LTTng 2.0 - Memory 
Analysis 22 0 6 0 17

Target: Ubuntu 16.04 64 bit

Step Test Case Action Verification Type Comment

0 Prerequisites

0.1 Download traces

Download UST trace with memory events 
from https://secretaire.dorsal.polymtl.
ca/~gbastien/traces/eclipse_mem_ust.tar.
gz. Hung: I suggest downloading eclipse 
trace

0.2
Import trace with memory 
event

Import the LTTng UST trace downloaded 
above in Tracing project

0.3
Import trace without 
memory event

Import one of the LTTng UST trace that 
does not contain the memory events, for 
example, the one used for the callstack view

0.4 Import non-UST trace Import one LTTng Kernel trace

1 Project View

1.1
Check analysis can 
execute

open the trace that contains the memory 
events. In the project explorer, expand the 
trace that contains the memory events "Ust Memory" analysis is present and "normal" SWTBot Pass 84702

1.2
Verify help message when 
applicable

In the project explorer, open and expand 
the trace that contains the memory events, 
right-click the memory analysis and select 
Help

A generic help message appears with the name of the 
analysis. Manual Pass

Verified in Aug. 17-2018 at 15:09PM, but help 
message is not helpful

1.3
Check analysis cannot 
execute

open the trace that contains the memory 
events. In the project explorer, expand the 
UST trace that does not contain memory 
events "Ust Memory" analysis is present, but striked-out Manual Pass Verified in Aug. 17-2018 at 15:10PM 84702

1.4
Verify help message when 
not applicable

In the project explorer, open and expand 
the UST trace that does not contain memory 
events, right-click the memory analysis and 
select Help

The help message mentions the analysis is impossible 
to execute and contains the requirement that is not 
fulfilled Manual Pass Verified in Aug. 17-2018 at 15:20PM

1.5
Check analysis for another 
trace type

In the project explorer, expand a LTTng 
Kernel trace "Ust Memory" analysis is not present SWTBot Pass 84702

2 View Management

2.1 Populate analysis's view

Open the UST trace with memory events 
and expand the "UST Memory" analysis in 
the project explorer "Ust Memory Usage" View appears under the analysis SWTBot Pass

2.2 Open view
Double-click the UST Memory View under 
the memory analysis

The UST Memory Usage view opens and triggers the 
memory analysis. After the analysis, the XY chart is 
populated SWTBot Pass

2.3 Close trace Close the trace The UST Memory Usage view is emptied. Manual Pass
Verified in Aug. 17-2018 at 15:25PM (see trace 
Eclipse in the project browser)

2.4 Open trace
With the view already opened, open the 
trace The UST Memory Usage view is populated. SWTBot Pass

2.5 Close view Close the UST Memory Usage view The view is closed. Manual Pass Verified in Aug. 17-2018 at 15:25PM
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2.6 Re-open view

Double-click the UST Memory Usage view 
under the memory analysis in project 
explorer. The view opens and is automatically populated. Manual Pass Verified in Aug. 17-2018 at 15:25PM

3 Mouse handling

3.1 Drag move time range
Drag move xy chart left and right with 
middle button

Time range is dragged. When mouse button is 
released, the view refreshes with the new time range Manual Pass Verified in Aug. 17-2018 at 15:28PM

3.2
Zoom time range (mouse 
wheel)

Zoom with CTL + mouse wheel up and 
down, cursor inside xy chart

Time range is zoomed in and out, relative to mouse 
cursor. When mouse wheel is stopped for a short time, 
series are updated and new time range is propagated 
to other views. Manual Pass Verified in Aug. 17-2018 at 15:28PM

3.3 Drag select time range Drag select time graph with right button

Selection highlighted. When mouse button is released, 
time range is zoomed to selection, series are updated 
and new time range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 15:28PM

3.4 Mouse hover Hover mouse in xy chart anywhere
Tool tip shows values for each thread at the given 
timestamp Manual Pass Verified in Aug. 17-2018 at 15:28PM

3.5 Drag mouse selection Drag select xy chart with left button
Selection highlighted. New selection is propagated to 
other views Manual Pass Verified in Aug. 17-2018 at 15:29PM

3.6 Shift key selection

Click select with left button (begin time), 
press shift key and click select another time 
(end time)

Selection highlighted. New selection is propagated to 
other views Manual Pass Verified in Aug. 17-2018 at 15:29PM

3.7
Drag mouse selection 
(Status bar) Drag select xy chart with left button

Selection highlighted. Status bar of Eclipse is updated 
with time information: T, T1, T2 and delta, where T is 
the time of the mouse position, T1 the first selected 
time, T2 the second (draggged) selected time and 
delta the time difference between T2-T1 (can be 
negative) Manual Pass Verified in Aug. 17-2018 at 15:29PM

3.8
Shift key selection (Status 
bar)

Click select with left button (begin time), 
press shift key and click select another time 
(end time)

Selection highlighted. Status bar of Eclipse is updated 
with time information: T, T1, T2 and delta, where T is 
the time of the mouse position, T1 the first selected 
time, T2 the second (draggged) selected time and 
delta the time difference between T2-T1 (can be 
negative) Manual Pass Verified in Aug. 17-2018 at 15:30PM

4 Synchronization

Preparation
Have the Histogram and UST Memory 
Usage views both visible SWTBot N/A

4.1 Time synchronization Select a random time in another view Selected time line is updated. Manual Pass Verified in Aug. 17-2018 at 15:31PM

4.2 Time range synchronization
Select a new time range in UST Memory 
Usage view or in Histogram view. Time range is updated. Manual Pass Verified in Aug. 17-2018 at 15:31PM

4.3
Time range selection 
synchronisation

In any other view that supports range 
synchronization, select a new range. Selection range is highlighted. Manual Pass Verified in Aug. 17-2018 at 15:31PM
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Section Pass Fail To Do Comment

Network Trace analysis 11 0 3 0 7
Target: Ubuntu 14.04 64 bit

Step Test Case Action Verification Comment

0 Prerequisites
0.1 Import traces Import the trace linked here
1 Trace Import

1.1
Open the Network Tracing 
perspective

In the project Explorer, expand any LTTng kernel 
trace

Verify that the events view, the properties and stream list 
are displayed SWTBot Pass

1.2 Open trace Double-click on the "TeamSpeak2.pcap" trace
The trace is given a "network" icon. When openned, the 
events view and histogram view is opened SWTBot Pass In SWTBot other trace is used

2 View management
2.1 Populate the views Open the "TeamSpeak2.pcap" The views are updated SWTBot Pass

2.2 Look up stream Open the Stream List view
One stream is available with endpoint A being 00:0c:29:
7c:ab:f9 Manual Pass Verified in Aug. 16-2018 at 15:42PM

2.3 Close the trace Close the trace The stream list is emptied Manual Pass Verified in Aug. 16-2018 at 15:42PM

2.4 Close view Close the Stream List view The view is closed Manual Pass Verified in Aug. 16-2018 at 15:42PM

2.5
Open view when trace is 
already loaded Re-open the trace. Open The Stream List view

The view opens with the correct title and is correctly 
populated. Manual Pass Verified in Aug. 16-2018 at 15:44PM

2.6 Open a non pcap trace Close the trace The stream list is emptied Manual Pass Verified in Aug. 16-2018 at 15:44PM

3 Stream List
3.1 Re-open trace Ensure only "TeamSpeak2.pcap" is opened The trace is opened Manual Pass Verified in Aug. 16-2018 at 15:45PM

3.1
Create a filter from the 
stream list

Right click on stream 0, and select "Extract as 
Filter"

A filter named "FILTER stream eth 00:0c:29..." is 
created Manual Pass Verified in Aug. 16-2018 at 15:45PM

3.2 Apply filter

In the events table, right click on an event and 
select "Apply preset filter-> stream eth 00:0c:
29..." 24/24 events pass the filter Manual Pass Verified in Aug. 16-2018 at 15:47PM

http://wiki.wireshark.org/SampleCaptures?action=AttachFile&do=get&target=TeamSpeak2.pcap
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Section Pass Fail Type To Do Comment
XML analysis 42 0 0 0 35

Target: Ubuntu 14.04 64 bit

Step Test Case Action Verification Type Comment

0 Prerequisites
0.1 Import traces Import LTTng kernel traces

0.2 Get a test XML file

Download the test XML file here: https://secretaire.
dorsal.polymtl.ca/~gbastien/Xml4Traces/Kernel.Linux.
xml

0.3
Make sure the XML file does 
not exists in the project

Open the Manage Xml Analyses menu and delete the 
XML file if it exists (or The XML files are located in 
<workspace directory>/.metadata/.plugins/org.eclipse.
tracecompass.tmf.analysis.xml.core/xml_files. Delete 
the linux kernel XML file if it exists.)

NOTE: XML haven't files haven't been update to latest Kernel tracepoints and 
syscall changes. So, they only work with trace LTTng 2.5 and older

1 XML file handling
1.1 Verify analysis not present In the project Explorer, expand any LTTng kernel trace Verify that there is no 'Xml kernel State System' analysis Manual Pass Verified in Aug. 17-2018 at 11:32AM

1.2 Import XML file

Right-click the Traces folder, select Manage XML 
analyses.... In the opened dialog import the Kernel.
Linux.xml file and close the dialog.

Verify that the 'Xml kernel State System' analysis is now present 
under a LTTng kernel trace Manual Pass Verified in Aug. 17-2018 at 11:33AM

1.3 Edit XML file

Right-click the Traces folder, select Manage XML 
analyses.... In the opened dialog, select Kernel.Linux 
and click Edit

Verify that the XML editor opens. The editor should have Design 
and Source sub-tabs Manual Pass Verified in Aug. 17-2018 at 11:52AM

1.4 Disable XML file

Right-click the Traces folder, select Manage XML 
analyses.... In the opened dialog, click on the checkbox 
next to Kernel.Linux to disable it and click Apply.

Verify that the 'Xml kernel State System' analysis doesn't not 
exist under a LTTng kernel trace Manual Pass Verified in Aug. 17-2018 at 13:50PM

1.5 Enable XML file

Right-click the Traces folder, select Manage XML 
analyses.... In the opened dialog, click on the checkbox 
next to Kernel.Linux to enable it and click Apply.

Verify that the 'Xml kernel State System' analysis is present 
under a LTTng kernel trace Manual Pass Verified in Aug. 17-2018 at 13:50PM

2 View management

2.1 Populate the views
Open an LTTng kernel trace (eg trace2 from the 
tracecompass-test-traces repo)

The 'Xml kernel State System' analysis should have a + next to it, 
expand it and there should be 2 views under it: 'Xml Control 
Flow View' and 'Xml Resources View' Manual Pass Verified in Aug. 17-2018 at 14:35PM

2.2
Open the 'Xml Control Flow 
View' 

Double-click the 'Xml Control Flow View' under the 
analysis

A view titled 'Xml Control Flow View' should open and it should 
look quite similar to the Control Flow View Manual Pass Verified in Aug. 17-2018 at 14:37PM

2.3 Open another XML view
Double-click the 'Xml Resources View' under the 
analysis

A view titled 'Xml Resources View' should open and it should 
look quite similar to the Resources view's CPU entries. Both 
XML views are opened. Manual Pass Verified in Aug. 17-2018 at 14:37PM

2.4 Close view Close both XML view The view are closed Manual Pass Verified in Aug. 17-2018 at 14:39PM

2.5
Open view when trace is 
already loaded Double-click one of the views under the analysis The view opens with the correct title and is correctly populated. Manual Pass Verified in Aug. 17-2018 at 14:40PM

2.6 Close traces Close all opened traces The view is emptied. Manual Pass Verified in Aug. 17-2018 at 14:02PM

2.7 Open trace Open an LTTng Kernel trace The view is populated Manual Pass Verified in Aug. 17-2018 at 14:03PM

2.8 Open another trace Open a non-LTTng Kernel trace The view is emptied. Manual Pass Verified in Aug. 17-2018 at 14:04PM

2.9 Open LTTng Kernel trace Open an LTTng Kernel trace The view is populated. Manual Pass Verified in Aug. 17-2018 at 14:04PM

3 View selection
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3.1 Select an entry in the table Select an entry in the table Same entry is highlighted in time graph. Manual Pass Verified in Aug. 17-2018 at 14:43PM

3.1 Select entry in time graph Select an entry in the time graph (empty region)
Same entry is highlighted in table. Selected time line is updated. 
Other views are synchronized to selected time. Manual Pass Verified in Aug. 17-2018 at 14:43PM

2.3 Select state in time graph Select a state in the time graph

Same entry is highlighted in table. State is highlighted in time 
graph. Selected time line is updated. Other views are 
synchronized to selected time. Manual Pass Verified in Aug. 17-2018 at 14:43PM

4 Mouse handling

4.1 Drag move time range
Drag move time graph left and right with middle 
button

Time range is dragged. When mouse button is released, states are 
updated and new time range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 14:47PM

4.2
Zoom time range (mouse 
wheel)

Zoom with CTRL + mouse wheel up and down, cursor 
inside time graph

Time range is zoomed in and out, relative to mouse cursor. When 
mouse wheel is stopped for a short time, states are updated and 
new time range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 14:48PM

4.3
Zoom time range (mouse 
drag) Drag in time graph scale left and right with left button

Time range is zoomed in and out. When mouse button is 
released, states are updated and new time range is propagated to 
other views. Manual Pass Verified in Aug. 17-2018 at 14:48PM

4.4 Mouse vertical scroll
Scroll with mouse wheel up and down, cursor outside 
time graph

Table and time graph scroll up and down and remain aligned. 
Selected entry does not change. Vertical scroll bar updated. Manual Pass Verified in Aug. 17-2018 at 14:48PM

4.5 Vertical scroll bar Click and drag vertical scroll bar
Table and time graph scroll up and down and remain aligned. 
Selected entry does not change. Manual Pass Verified in Aug. 17-2018 at 14:48PM

4.6 Drag select time range Drag select time graph with right button

Selection highlighted. When mouse button is released, time range 
is zoomed to selection, states are updated and new time range is 
propagated to other views. Manual Pass Verified in Aug. 17-2018 at 14:49PM

4.7 Double-click reset time range Double-click left button on time scale
Time range is reset to full range, states are updated and new time 
range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 14:50PM

4.8 Mouse hover (empty region) Hover mouse in time graph over empty region Tool tip shows entry name only. Manual Pass Verified in Aug. 17-2018 at 14:50PM

4.9 Mouse hover (state) Hover mouse in time graph over state
Tool tip shows entry name, state name, date, start time, end time, 
duration. Manual Pass Verified in Aug. 17-2018 at 14:51PM

4.10 Drag mouse seleection Drag select time graph with left button

Selection highlighted. Status bar of Eclipse is updated with time 
information: T, T1, T2 and delta, where T is the time of the 
mouse position, T1 the first selected time, T2 the second 
(draggged) selected time and delta the time difference between 
T2-T1 (can be negative) Manual Pass Verified in Aug. 17-2018 at 14:51PM
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4.11 Shift key selection
Click select with left button (begin time), press shift 
key and click select another time (end time)

Selection highlighted. Status bar of Eclipse is updated with time 
information: T, T1, T2 and delta, where T is the time of the 
mouse position, T1 the first selected time, T2 the second 
(draggged) selected time and delta the time difference between 
T2-T1 (can be negative) Manual Pass Verified in Aug. 17-2018 at 14:51PM

5 Keyboard handling

5.1
Keyboard navigation in table 
(entry selection)

With focus on table, use UP, DOWN, HOME, END 
keys

Selected process is changed. Time graph selection is updated. 
Vertical scroll bar updated. Manual Pass Verified in Aug. 17-2018 at 14:52PM

5.2
Keyboard navigation in table 
(tree expansion)

With focus on table, 
in Windows use LEFT, RIGHT keys while parent or 
child process is selected

in Linux use press ENTER while parent or child 
process is selected

For parent process, tree is expanded or collapsed. Time graph 
item expansion is updated. Vertical scroll bar updated. For child 
process, left changes selection to parent, time graph selection is 
updated. Vertical scroll bar updated. Manual Pass Verified in Aug. 17-2018 at 14:52PM

5.4
Keyboard navigation in time 
graph (process selection)

With focus on time graph, use UP, DOWN, HOME, 
END keys

Selected process is changed. Table selection is updated. Vertical 
scroll bar updated. Manual Pass Verified in Aug. 17-2018 at 14:52PM

5.4
Keyboard navigation in time 
graph (state selection) With focus on time graph, use LEFT, RIGHT keys

Previous or next state is selected. Selected time is updated in 
other views. Manual Pass Verified in Aug. 17-2018 at 14:53PM

6 Tool bar handling

6.1 Show Legend Click Show Legend button The legend dialog is opened and can be closed. Manual Pass Verified in Aug. 17-2018 at 14:55PM

6.2 Reset Time Scale Click Reset Time Scale button
Time range is reset to full range, states are updated and new time 
range is propagated to other views. Manual Pass Verified in Aug. 17-2018 at 14:55PM

6.3 Select Previous/Next Event Click Previous/Next Event button
Previous or next state is selected. Selected time is updated in 
other views. Manual Pass Verified in Aug. 17-2018 at 14:55PM

6.4 Select Previous/Next Process Click Previous/Next interval button
Selected interval (process/resource) is changed in table and time 
graph. Vertical scroll bar updated. Manual Pass Verified in Aug. 17-2018 at 14:56PM

6.5 Zoom In/Out Click Zoom In/Out button

Time range is zoomed in and out, relative to center of time range. 
States are updated and new time range is propagated to other 
views. Manual Pass Verified in Aug. 17-2018 at 14:56PM

6.6 Filter Dialog  Open Filter Dialog Verify that all buttons are working correctly Manual Pass Verified in Aug. 17-2018 at 14:56PM

6.7 Filter Processes

1) Open Filter Dialog
2) Deselect several processes
3) Press Ok Verify that only selected entries are displayed in the view Manual Pass Verified in Aug. 17-2018 at 14:57PM

7 Synchronization

7.1 Time synchronization Select a random time in another view
Selected time line is updated. If selected time is outside current 
range, time range is updated to include it. Manual Pass Verified in Aug. 17-2018 at 14:57PM

7.2 Time range synchronization
Select a new time range in Resources view or in 
Histogram view. Time range is updated. Manual Pass Verified in Aug. 17-2018 at 14:57PM

7.3
Time range selection 
synchronisation

In any other view that supports range synchronization, 
select a new range.

Selection is highlighted. If begin time (T1) of selected time range 
is outside the current range, then time range is updated to include 
it Manual Pass Verified in Aug. 17-2018 at 14:59PM
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Section Pass Fail To Do Comment

Critical path 45 0 2 0 39
Target: 

Step Test Case Action Verification Comment

0 Prerequisites

0.1 Import traces

Import the 3 
django traces from 
the test traces

0.2 Create experiment

Create an 
experiment with 
the 3 traces in it

0.3
Synchronize 
experiment

Synchronize the 
experiment, it 
should be 
accurate and 2 of 
the traces will be 
udpated

1
View 
management

1.1 Open trace

Open any of the 
django traces in 
Project Explorer

Expand the Views element under the trace. 
The OS Exec Graph analysis is there and 
"normal". The Critical Path analysis is there 
and the Critical Flow view is available under 
it. Manual Pass

Verified in Aug. 17-
2018 at 10:33AM

1.2 Open experiment

Open the django 
experiment in 
Project Explorer

Expand the Views element under the trace. 
The LTTng Kernel Exec Graph analysis is 
there and "normal". The Critical Path 
analysis is there and the Critical Flow view 
is available under it. Manual Pass

Verified in Aug. 17-
2018 at 10:33AM

1.3 Open view

Expand the Views 
element, then the 
Critical Path 
analysis and click 
on the Critical 
Flow View Critical Path view is opened and empty SWTBot Pass

1.4 Close view
Close the Critical 
Flow View Critical Path view is closed Manual Pass

Verified in Aug. 17-
2018 at 10:34AM

1.5 Unapplicable trace

Open a trace that 
is not a LTTng 
kernel trace

Expand the Views element under the trace. 
The LTTng Kernel Exec Graph analysis is 
not there. The Critical Path analysis is there 
and the Critical Flow view is available under 
it. Manual Pass

Verified in Aug. 17-
2018 at 10:35AM

1.6
Unapplicable 
experiment

Open an 
experiment that 
does not contain 
LTTng kernel 
traces

Expand the Views element under the trace. 
The LTTng Kernel Exec Graph analysis is 
there, but striked out. The Critical Path 
analysis is there and the Critical Flow view 
is available under it. Manual Pass

Verified in Aug. 17-
2018 at 10:37AM

2 View population
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2.1
Populate the view 
with trace

With the django-
client trace and 
the critical path 
view opened, in 
the control flow 
view, find the 
process named 
python (TID 9496). 
Right-click on the 
process and select 
"Follow 
python/9496"

The LTTng kernel exec graph is executed 
and at the end, the critical path view shows 
the interaction between 3 workers. SWTBot Pass Done in SWBot with another trace

2.2
Select worker in 
time graph

Select an empty 
region in the time 
graph section

Same process is highlighted in table. 
Selected time line is updated. Other views 
are synchronized to selected time. Manual Pass Allegedly fixed with https://bugs.eclipse.org/bugs/show_bug.cgi?id=535340. Verified in Aug. 17-2018 at 10:39AM

2.3
Select state in 
time graph

Select a state in 
the time graph

Same process is highlighted in table. State 
is highlighted in time graph. Selected time 
line is updated. Other views are 
synchronized to selected time. Manual Pass

Verified in Aug. 17-
2018 at 10:40AM

2.4
Select worker in 
tree viewer

Select a worker 
from the tree 
viewer section Same process is highlighted in time graph. Manual Pass

Verified in Aug. 17-
2018 at 10:40AM

2.5
Populate the view 
with empty path

Repeat steps of 
2.1, with django-
client trace and 
process lttng-
sessiond (TID 
9355) The Critical Path View is emptied Manual Pass

Verified in Aug. 17-
2018 at 10:40AM

2.5.5 Select again

Repeat steps of 
2.1, and select 
python/9496 again The critical path should be the same as 2.1 Manual Pass

Verified in Aug. 17-
2018 at 10:40AM

2.6 Re-opening

Close the django-
client trace, 
reopen it and 
repeat steps of 2.1

The Critical Path View should be populated 
like in step 2.1 Manual Pass

Verified in Aug. 17-
2018 at 10:47AM

2.7
Populate the view 
with experiment

Repeat steps of 
2.1, but with the 
django-experiment 
instead

The LTTng kernel exec graph is executed 
and at the end, the critical path view is 
populated with elements from the 3 traces. Manual Pass

Verified in Aug. 17-
2018 at 10:47AM

2.8

Populate with 
trace with time 
selection

Re-open django-
client trace. In the 
Control Flow View, 
select a time after 
the python 
process exited, 
then follow the 
python/9496 
process 

The Critical Path View should be populated 
like in step 2.1 Manual Pass

Verified in Aug. 17-
2018 at 10:47AM

3 Mouse handling

3.1
Drag move time 
range

Ctrl-Drag move 
time graph left and 
right with middle 
button

Time range is dragged. When mouse button 
is released, states are updated and new 
time range is propagated to other views. Manual Pass

Verified in Aug. 17-
2018 at 10:48AM
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3.2
Zoom time range 
(mouse wheel)

Zoom with mouse 
wheel up and 
down, cursor 
inside time graph 
while holding the 
Ctl button

Time range is zoomed in and out, relative to 
mouse cursor. When mouse wheel is 
stopped for a short time, states are updated 
and new time range is propagated to other 
views. Manual Pass

Verified in Aug. 17-
2018 at 10:48AM

3.3
Zoom time range 
(mouse drag)

Drag in time graph 
scale left and right 
with left button

Time range is zoomed in and out. When 
mouse button is released, states are 
updated and new time range is propagated 
to other views. Manual Pass

Verified in Aug. 17-
2018 at 10:49AM

3.4
Mouse vertical 
scroll

Scroll with mouse 
wheel up and 
down, cursor 
outside time graph

Table and time graph scroll up and down 
and remain aligned. Selected worker does 
not change. Vertical scroll bar updated. Manual Pass

Verified in Aug. 17-
2018 at 10:49AM

3.5 Vertical scroll bar
Click and drag 
vertical scroll bar

Table and time graph scroll up and down 
and remain aligned. Selected process does 
not change. Manual Pass

Verified in Aug. 17-
2018 at 10:50AM

3.6
Drag select time 
range

Drag select time 
graph with right 
button

Selection highlighted. When mouse button 
is released, time range is zoomed to 
selection, states are updated and new time 
range is propagated to other views. Manual Pass

Verified in Aug. 17-
2018 at 10:50AM

3.7
Double-click reset 
time range

Double-click left 
button on time 
scale

Time range is reset to full range, states are 
updated and new time range is propagated 
to other views. Manual Pass

Verified in Aug. 17-
2018 at 10:50AM

3.8
Mouse hover 
(empty region)

Hover mouse in 
time graph over 
empty region Tool tip shows process name and PID. Manual Pass

Verified in Aug. 17-
2018 at 10:53AM

3.9
Mouse hover 
(state)

Hover mouse in 
time graph over 
state

Tool tip shows worker name, state name, priority, date, 
start time, end time, duration. Manual Pass

Verified in Aug. 17-
2018 at 10:55AM

3.10
Drag mouse 
selection

Drag select time 
graph with left 
button

Selection highlighted. Status bar of Eclipse is updated with 
time information: T, T1, T2 and delta, where T is the time 
of the mouse position, T1 the first selected time, T2 the 
second (dragged) selected time and delta the time 
difference between T2-T1 (can be negative) Manual Pass

Verified in Aug. 17-
2018 at 10:55AM

3.11 Shift key selection

Click select with 
left button (begin 
time), press shift 
key and click 
select another 
time (end time)

Selection highlighted. Status bar of Eclipse is updated with 
time information: T, T1, T2 and delta, where T is the time 
of the mouse position, T1 the first selected time, T2 the 
second (dragged) selected time and delta the time 
difference between T2-T1 (can be negative) Manual Pass

Verified in Aug. 17-
2018 at 10:55AM

4
Keyboard 
handling

4.1

Keyboard 
navigation in table 
(process selection)

With focus on 
table, use UP, 
DOWN, HOME, 
END keys

Selected process is changed. Time graph 
selection is updated. Vertical scroll bar 
updated. Manual Pass

Verified in Aug. 17-
2018 at 10:56AM

4.2

Keyboard 
navigation in table 
(tree expansion)

With focus on table, 
in Windows use LEFT, 
RIGHT keys while trace 
or worker is selected

in Linux use SHIFT 
LEFT, RIGHT keys while 
trace or worker is 
selected

For trace, tree is expanded or collapsed. Time graph item 
expansion is updated. Vertical scroll bar updated. For 
workers, it does nothing. Manual Pass

Verified in Aug. 17-
2018 at 10:58AM

4.3

Keyboard 
navigation in time 
graph (process 
selection)

With focus on time 
graph, use UP, 
DOWN, HOME, 
END keys

Selected worker is changed. Table selection is updated. 
Vertical scroll bar updated. Manual Pass

Verified in Aug. 17-
2018 at 10:58AM
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4.4

Keyboard 
navigation in time 
graph (state 
selection)

With focus on time 
graph, use LEFT, 
RIGHT keys

Previous or next state is selected. Selected 
time is updated in other views. Manual Pass

Verified in Aug. 17-
2018 at 10:58AM

5 Tool bar handling

5.1 Align views

Click on the Align View 
Button, with another time 
graph view, eg the 
Control Flow view 
opened above or under

When it is pressed, moving the line between tree viewer 
and time graph will move the line of the other view. If not 
pressed, the line can be moved without affecting the other 
views Manual Pass

Verified in Aug. 17-
2018 at 11:00AM

5.2 Show Legend
Click Show 
Legend button

The legend dialog is opened and can be 
closed. Manual Pass

Verified in Aug. 17-
2018 at 11:15AM

5.3 Reset Time Scale
Click Reset Time 
Scale button

Time range is reset to full range, states are 
updated and new time range is propagated 
to other views. Manual Pass

Verified in Aug. 17-
2018 at 11:15AM

5.4

Select 
Previous/Next 
Event

Click 
Previous/Next 
Event button

Previous or next state is selected. Selected 
time is updated in other views. Manual Pass

Verified in Aug. 17-
2018 at 11:16AM

5.5
Select Previous/Next 
Element

Click 
Previous/Next 
Element button

Selected worker is changed in table and 
time graph. Vertical scroll bar updated. Manual Pass

Verified in Aug. 17-
2018 at 11:16AM

5.6 Zoom In/Out
Click Zoom In/Out 
button

Time range is zoomed in and out, relative to 
center of selection or window. States are 
updated and new time range is propagated 
to other views. Manual Pass

Verified in Aug. 17-
2018 at 11:16AM

5.7 Add Bookmark

Select a time, and click 
on the Add Bookmark 
button

The bookmark is added and is displayed in the other views 
as well (if enabled) Manual Pass

Verified in Aug. 17-
2018 at 11:27AM

5.8 Next/Previous marker

Add more bookmarks, 
then click on the 
next/previous marker 
buttons

The time graph view navigate between the bookmarks, 
States are updated and time selection is propagated to 
other views. When on a bookmark, the Add bookmark 
buttons changes to Delete bookmark Manual Pass

Verified in Aug. 17-
2018 at 11:28AM

5.9 Delete bookmark

With next/previous 
marker, when on a 
bookmark, click the 
delete bookmark button The bookmark is deleted from all views Manual Pass

Verified in Aug. 17-
2018 at 11:28AM

5.11 Do not show markers

Click on the down arrow 
at the extreme right of 
the view, then expand 
Show markers and 
uncheck the Bookmarks 
box

All remaining bookmarks disappear from the view, but 
remain in other views where the they are enabled Manual Pass

Verified in Aug. 17-
2018 at 11:28AM

5.12 Show markers
Same as above, recheck 
the Bookmarks box The bookmarks come back Manual Pass

Verified in Aug. 17-
2018 at 11:28AM

6 Synchronization

6.1
Time 
synchronization

Select a random 
time in another 
view

Selected time line is updated. If selected 
time is outside current range, time range is 
updated to include it. Manual Pass

Verified in Aug. 17-
2018 at 11:29AM

6.2
Window range 
synchronization

Select a new window 
range in another view Window range is updated. Manual Pass

Verified in Aug. 17-
2018 at 11:29AM

6.3
Selection range 
synchronization

In any other view 
that supports 
selection range 
synchronization, 
select a new 
range.

Selection is highlighted. If the left time (T1) 
of selected time range is outside the current 
range, then window range is updated to 
include it Manual Pass

Verified in Aug. 17-
2018 at 11:29AM

6.4 Out of region selection

With a critical path 
displayed, select a 
time in another view 
that is not in the range 
of the process being 
displayed in the critical 
path view

Selected time is updated and the critical path view is 
synced with the other Manual Pass

Verified in Aug. 17-
2018 at 11:30AM
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Section Pass Fail To Do Comment

LAMI 17 1 0 0 0
Target: Ubuntu 16.04 64 bit

Step Test Case Action Verification Comment

0 Prerequisites
0.1 Import traces any trace since we use stub for the result

0.2
Download analysis 
stubs

https://bugs.eclipse.org/bugs/attachment.cgi?id=263946
from bug: https://bugs.eclipse.org/bugs/show_bug.cgi?
id=493941

1

Custom 
external 
analysis

1.1
Add all stubs 
analysis

Create the following analysis ($name, $command):

analysisEmpty, analysisEmpty
analysisMultipleRow, analysisMultipleRow
analysisMultipleSimilarRow, analysisMultipleSimilarRow
analysisOneRow, analysisOneRow
multipleReports, multipleReports
invalidAnalysis, invalidAnalysis
errorResult, errorResult
clone, analysisOneRow

Right click on  "External Analyses" node
Click the "add" action
Insert $name
Insert "fullpath/$executable" which is the full path to the stub 
executable.
ex:"/tmp/stub/stubAnalysis" where stubAnalysis is the stub 
executable
The path do NOT support ~ or relative path

All new external analysis are present under the "External 
Analysis" node in the Project explorer view.
All new elements do NOT have the strikethrough text 
style applied 
EXCEPT for the tuple (invalidAnalysis, invalidAnalysis)

Manual Fail
Verified in Aug. 17-2018 at 10:03AM. The External Analyses node does not appear 
in Project Explorer for the trace stbAnalysis

1.2 Actions availables Right click on a non-strikethrough custom analysis. The run action can be clicked and in enabled text mode. Manual Pass Verified in Aug. 17-2018 at 10:15AM

Actions avaliables Right click on a strikethrough custom analysis. The run action CANNOT be clicked and is in disabled text mode.Manual Pass Verified in Aug. 17-2018 at 10:25AM

1.3 Delete analysis
Right click on the tuple (clone, invalidAnalysis)
Select the delete action for the node The analysis does not appear in the list anymore. Manual Pass Verified in Aug. 17-2018 at 10:15AM

1.4 Run analysis Launch remaining analysis via righ-click and run action

analysisEmpty should return a message to the user regarding the emptiness of the report.
errorResult should return an error message to the user and display the result of the command.
All other one have result and should result in a new table and new report node under the report node.Pass

2 Reports 

2.1 Reports node Expand the "Reports" node under the Project Explorer

The "Reports" node under the Project Explorer should contain 
4 report:
analysisMultipleRow Report
analysisMultipleSimilarRow Report
analysisOneRow Report
multipleReports Pass

2.2 Same name report Execute the "analysisOneRow" analysis again.

An additional node should be present under the "Reports" 
node:
analysisOneRow Report #2

Note: This behaviour is subject to change in the following 
year but still an action will be taken on same name report 
creation. Pass

2.3 Delete node
Right click on the duplicate "analysis OneRow" node and click 
on the delete action The node reports is not present anymore Pass

2.4 Open a report Right click on any report and select the "open" action
A new panel should open with the result table of the 
analysis Pass

2.5
Open the same 
report again Right click again on the same report to open it

A new panel should open with the result table of the 
analysis Pass
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2.6 Multiple report Open the "multipleReports" report.
Validate that a user is able to navigate between sub tab 
of a report Pass

3 Result Table

3.1 Prerequisites Open the "analysisMultipleRowReport" Pass
3.2 Hide table Click the "Toggle" button in the right corner of the result table The result table is hidden Pass
3.3 Show table Click the "Toggle" button in the right corner of the result table The result table is shown Pass

3.4 Sorting
Sort all column by clicking on the column name. Clicking 
multiple time on the name should change the ordering sorter. Validate that the order make sense Pass

3.5 Colum Resizing Resize the column Validate that the resize works Pass

3.6 Multiple selection
Select multiple rows by holding ctrl and clicking on multiple 
unselected rows of the table Multiple selections are highlighted in the table Pass

3.7 Unselect selection
Deselect multiple rows by holding ctrl and clicking on multiple 
selected rows of the table The clicked row should not be selected anymore Pass

4 Bar Chart

4.1 Create
Use the menu on the upper right of the result table and select 
"create bar chart"

Note: a bar chart does NOT perform agregation of 
categories values

4.2 Series dialog add Select any x and any y click add Series are added to the series list Pass

4.3
Series dialog 
remove Remove all newly created series via the delete button User should be able to delete series Pass

4.4 Creat chart Select any x and y and click add and "ok"

A bar chart should be created
Note: a bar chart does NOT perform agregation of 
categories values Pass

4.5 Selection Click on any bar inside the chart
The corresponding row should be selected in the table 
and the chart should highlight the selected bar Pass

4.6 Multi selection Ctrl+click on other unselected bar
Selections should be highlighted in the result table and 
the chart Pass

4.7 Deselection Ctrl+click on other selected bar
The clicked bar should be removed from selection and 
the result table update with the current selections Pass

4.8 Y axis
Recreate the same graph but with the y log scale option 
enabled

Y axis should be in log scale mode
Note: check for zero value and negative handling since 
log scale do not support zero and negative Pass

4.9
Keep the chart 
open Keep the chart open Pass

4.10
Hide the table 
results Hide the table results Pass

5 Scatter Chart

5.1 Create
Use the menu on the upper right of the result table and select 
"create scatter chart"

5.2 Creat chart Select any x and y and click add and "ok"
A scatter chart should be created

Pass
5.3 Selection Should be the same behaviour as the bar chart Should be the same behaviour as the bar chart Pass
5.4 Multi selection Should be the same behaviour as the bar chart Should be the same behaviour as the bar chart Pass
5.5 Deselection Should be the same behaviour as the bar chart Should be the same behaviour as the bar chart Pass

5.6 Mouse hovering Hover mouse in the graph
On mouse hovering a cross should snap to the nearest 
point Pass

5.7 Full deselection Click in the chart when no hovering cross is present All selected objects should be deselected Pass
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ps Section Pass Fail Type To Do Comment
LTTng 2.0 - I/O 
Analysis 20 1 5 0 15

Target: Ubuntu 16.04 64 bit (ELX)

Step Test Case Action Verification Type Comment

0 Prerequisites

0.1 Import traces

Import LTTng 
Kernel traces in 
Tracing project

1 Project View

1.1
Check analysis 
can execute

In the project 
explorer, 
expand a LTTng 
Kernel trace

"Input/Output" 
analysis is 
present and 
"normal" (not 
striked-out) SWTBot Pass

Bruno : In the 
'Views' tree item, 
there is  a 
Input/Output item, 
but im not sure 
what it means to be 
'normal'  
Geneviève: normal 
is not striked-out 
(added it to the 
verif step), it is a 
pass 84702

1.2

Verify help 
message when 
applicable

In the project 
explorer, open 
and expand the 
LTTng kernel 
trace, right-click 
the Input/Output 
analysis and 
select Help

A generic help 
message 
appears with 
the name of the 
analysis Manual Fail

Bruno : The help 
message doesn't 
explain much

Verified in Aug. 16-
2018 at 10:02AM - 
Hung: No generic 
help message appears 
with the name of the 
analysis
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1.5

Check analysis 
for another 
trace type

In the project 
explorer, 
expand a non-
LTTng Kernel 
trace

"Input/Output" 
analysis is not 
present SWTBot Pass 84702

2
View 
Management

2.1
Populate 
analysis's view

Open an LTTng 
kernel trace and 
expand the 
"Input/Output" 
analysis in the 
project explorer

"Disk I/O 
Activity" View 
appears under 
the analysis SWTBot Pass

2.2 Open view

Double-click the 
Disk I/O Activity 
View under the 
Input/Output 
analysis

The Disk I/O 
Activity view 
opens and 
triggers the 
input/output 
analysis. After 
the analysis, the 
xy charts is 
populated. SWTBot Pass

2.3 Close trace Close the trace

The Disk I/O 
Activity view is 
emptied. Manual Pass

Verified in Aug. 17-
2018 at 09:10AM

2.4 Open trace

With the view 
already opened, 
open the trace

The Disk I/O 
Activity view is 
populated. Manual Pass

Verified in Aug. 17-
2018 at 09:12AM

2.5 Close view
Close the Disk 
I/O Activity view

The view is 
closed. Manual Pass

Verified in Aug. 17-
2018 at 09:14AM
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2.6 Re-open view

Double-click the 
Disk I/O Activity 
view under the 
Input/Output 
analysis in 
project explorer.

The view opens 
and is 
automatically 
populated. Manual Pass

Verified in Aug. 17-
2018 at 09:15AM

3 View selection

4
Mouse 
handling

4.1
Drag move time 
range

Drag move xy 
chart left and 
right with middle 
button

Time range is 
dragged. When 
mouse button is 
released, series 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 17-
2018 at 09:16AM

4.2

Zoom time 
range (mouse 
wheel)

Zoom with 
mouse wheel up 
and down, 
cursor inside xy 
chart

Time range is 
zoomed in and 
out, relative to 
mouse cursor. 
When mouse 
wheel is 
stopped for a 
short time, 
series are 
updated and 
new time range 
is propagated to 
other views. SWTBot Pass
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4.3
Drag zoom time 
range

Drag select time 
graph with right 
button in xy 
chart

Selection 
highlighted. 
When mouse 
button is 
released, time 
range is 
zoomed to 
selection, series 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 17-
2018 at 09:17AM

4.4 Mouse hover

Hover mouse in 
xy chart region 
anywhere

Tool tip shows 
the puntual disk 
activity, with 
units in <unit>/s Manual Pass

Verified in Aug. 17-
2018 at 09:18AM

4.5
Drag mouse 
selection

Drag select xy 
chart with left 
button

Selection 
highlighted and 
selection range 
is propagated to 
other views Manual Pass

Verified in Aug. 17-
2018 at 09:19AM

4.6
Shift key 
selection

Click select with 
left button 
(begin time), 
press shift key 
and click select 
another time 
(end time)

Selection 
highlighted and 
selection rang is 
propagated to 
other views Manual Pass

Verified in Aug. 17-
2018 at 09:21AM
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4.70

Drag mouse 
selection 
(Status bar)

Drag select xy 
chart with left 
button

Selection 
highlighted. 
Status bar of 
Eclipse is 
updated with 
time 
information: T, 
T1, T2 and 
delta, where T 
is the time of 
the mouse 
position, T1 the 
first selected 
time, T2 the 
second 
(draggged) 
selected time 
and delta the 
time difference 
between T2-T1 
(can be 
negative) Manual Pass

Verified in Aug. 17-
2018 at 09:22AM
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4.8

Shift key 
selection 
(Status bar)

Click select with 
left button 
(begin time), 
press shift key 
and click select 
another time 
(end time)

Selection 
highlighted. 
Status bar of 
Eclipse is 
updated with 
time 
information: T, 
T1, T2 and 
delta, where T 
is the time of 
the mouse 
position, T1 the 
first selected 
time, T2 the 
second 
(draggged) 
selected time 
and delta the 
time difference 
between T2-T1 
(can be 
negative) Manual Pass

Christophe: when 
selecting a range 
with shift, T2 is 
always greater than 
T1. When you left 
click somewhere, it 
becomes T1, but if 
you shift+left click 
on a lower time (to 
the left), that 
second one 
becomes T1 and 
the former T1 
becomes T2. Thus, 
T2-T1 can never be 
negative. 

Fixed. Verified in 
Aug. 17-2018 at 09:
25AM

5
Keyboard 
handling

6 Synchronization

6.1
Time 
synchronization

Select a random 
time in another 
view

Selected time 
line is updated. 
If selected time 
is outside 
current range, 
time range is 
updated to 
include it. Manual Pass

Verified in Aug. 17-
2018 at 09:28AM



4.1.0-TraceCompassTestCases LTTng 2.0 - I/O analysis

92

6.2
Time range 
synchronization

Select a new 
time range in 
Disk I/O Activity 
view or in 
Histogram view.

Time range is 
updated. Manual Pass

Verified in Aug. 17-
2018 at 09:29AM

6.3

Time range 
selection 
synchronisation

In any other view 
that supports 
range 
synchronization, 
select a new 
range.

Selection is 
highlighted. If the 
most left time 
(T1) of selected 
time range is 
outside the 
current range, 
then time range is 
updated to 
include it Manual Pass

Verified in Aug. 17-
2018 at 09:30AM

6.4

Disk I/O Activity 
works with 
experiments Manual Pass

Verified in Aug. 17-
2018 at 09:32AM
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Section Pass Fail To Do Comment
LTTng 2.0 - VM 
Analysis 39 0 0 0 32

Target: 

Step Test Case Action Verification Comment

0 Prerequisites

0.1 Import traces

Download 
traces here: 
https:
//secretaire.
dorsal.polymtl.
ca/~gbastien/tra
cingSummit201
4/mpi_traces.
tgz and import 
the 3 kernel 
traces in the 
vmnet directory

0.2
Create 
experiment

Create an 
experiment with 
the 3 traces in it

0.3
Synchronize 
experiment

Synchronize the 
experiment, it 
should be 
accurate and 2 
of the traces will 
be udpated

0.4
Set experiment 
type

Right-click the 
experiment, 
click "Select 
experiment 
type..." and 
select "Virtual 
Machine 
Experiment"

1
View 
management
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1.1
Analysis 
present

Expand the 
Views element 
of the 
experiment

The Virtual 
Machine 
Analysis is 
present Manual Pass

Verified in Aug. 15-
2018 at 13:37PM

1.2
Open 
experiment

Open the vm 
experiment in 
Project Explorer

Expand the 
Views element 
under the trace, 
then the Virtual 
Machine 
Analysis 
element. The 
Virtual CPU 
view is present Manual Pass VM experiment and normal experiment need visual differenciators.

1.3 Open view

Expand the 
Views element, 
then the Virtual 
Machine 
analysis and 
click on the 
Virtual CPU 
View

Virtual CPU 
view is opened, 
the virtual 
machine 
analysis is 
triggered and 
the view gets 
filled Manual Pass launches kernel exec graph which take a very long time, slow indexing throughput

1.4 Close view

Close the 
Virtual CPU 
View

Virtual CPU 
view is closed Manual Pass

1.6
Unapplicable 
experiment

Open an 
experiment that 
is not of Virtual 
Machine 
Experiment type

Expand the 
Views element 
under the trace. 
There is no 
Virtual Machine 
Analysis. Manual Pass django exp

2
View 
population

2.1

Populate the 
view with 
experiment

With the VM 
experiment, 
open the Virtual 
CPU View

The view is 
populated with 
the VM element 
as the only 
parent and 2 
virtual guests 
having 3 
VCPUs each 
and a collapsed 
Threads entries Manual Pass

Verified in Aug. 15-
2018 at 14:37AM
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2.2
View guest's 
threads

Expand the 
Threads entry of 
a guest

A list of 
processes is 
shown, in 
numerical order 
and their time 
graph viewer 
part is filled Manual Pass

Verified in Aug. 15-
2018 at 14:38PM

2.3
VM specific 
states

Zoom in the 
VCPUs time 
graph around 
the "interesting" 
region, where 
there is more 
action (around 
the second half 
of the trace)

2 new states 
are easily 
recognizable: 
WAIT_VMM 
and 
VCPU_PREEM
PTED Manual Pass

Verified in Aug. 15-
2018 at 14:39PM

2.4
Preempted 
thread states

Select a region 
with the 
CPU_PREEMP
TED state and 
scroll down the 
threads entries 
to around 405-
406: mpi-
imbalance 
processes

We can observe 
alpha'ed states 
corresponding 
to the cpu 
preempted 
states Manual Pass

Verified in Aug. 15-
2018 at 14:41PM

2.5 Re-opening

Close the VM 
experiment, 
reopen it

The view is 
populated again Manual Pass

Verified in Aug. 15-
2018 at 13:47PM

3
Mouse 
handling

3.1
Drag move time 
range

Ctrl-Drag move 
time graph left 
and right with 
middle button

Time range is 
dragged. When 
mouse button is 
released, states 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 14:40PM
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3.2

Zoom time 
range (mouse 
wheel)

Zoom with 
mouse wheel up 
and down, 
cursor inside 
time graph while 
holding the Ctl 
button

Time range is 
zoomed in and 
out, relative to 
mouse cursor. 
When mouse 
wheel is 
stopped for a 
short time, 
states are 
updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 14:40PM

3.3

Zoom time 
range (mouse 
drag)

Drag in time 
graph scale left 
and right with 
left button

Time range is 
zoomed in and 
out. When 
mouse button is 
released, states 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 14:43PM

3.4
Mouse vertical 
scroll

Scroll with 
mouse wheel up 
and down, 
cursor outside 
time graph

Table and time 
graph scroll up 
and down and 
remain aligned. 
Selected worker 
does not 
change. Vertical 
scroll bar 
updated. Manual Pass

Verified in Aug. 15-
2018 at 14:44PM

3.5
Vertical scroll 
bar

Click and drag 
vertical scroll 
bar

Table and time 
graph scroll up 
and down and 
remain aligned. 
Selected 
process does 
not change. Manual Pass

Verified in Aug. 15-
2018 at 14:50AM
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3.6
Drag select time 
range

Drag select time 
graph with right 
button

Selection 
highlighted. 
When mouse 
button is 
released, time 
range is 
zoomed to 
selection, states 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 14:51AM

3.7
Double-click 
reset time range

Double-click left 
button on time 
scale

Time range is 
reset to full 
range, states 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 15:00PM

3.8
Mouse hover 
(empty region)

Hover mouse in 
time graph over 
empty region

Tool tip shows 
process name 
only. Manual Pass

Verified in Aug. 15-
2018 at 15:00PM

3.9
Mouse hover 
(state)

Hover mouse in 
time graph over 
state

Tool tip shows entry 
name, state name, 
date, start time, end 
time, duration. Manual Pass

Verified in Aug. 15-
2018 at 15:03PM

3.10
Drag mouse 
selection

Drag select time 
graph with left 
button

Selection highlighted. 
Status bar of Eclipse 
is updated with time 
information: T, T1, T2 
and delta, where T is 
the time of the mouse 
position, T1 the first 
selected time, T2 the 
second (dragged) 
selected time and 
delta the time 
difference between 
T2-T1 (can be 
negative) Manual Pass

Verified in Aug. 15-
2018 at 15:03PM
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3.11
Shift key 
selection

Click select with 
left button 
(begin time), 
press shift key 
and click select 
another time 
(end time)

Selection highlighted. 
Status bar of Eclipse 
is updated with time 
information: T, T1, T2 
and delta, where T is 
the time of the mouse 
position, T1 the first 
selected time, T2 the 
second (dragged) 
selected time and 
delta the time 
difference between 
T2-T1 (can be 
negative) Manual Pass

Verified in Aug. 15-
2018 at 15:07PM

4
Keyboard 
handling

4.1

Keyboard 
navigation in 
table (process 
selection)

With focus on 
table, use UP, 
DOWN, HOME, 
END keys

Selected entry 
is changed. 
Time graph 
selection is 
updated. 
Vertical scroll 
bar updated. Manual Pass

Verified in Aug. 15-
2018 at 15:10PM

4.2

Keyboard 
navigation in 
table (tree 
expansion)

With focus on table, 
in Windows use 
LEFT, RIGHT keys 
while expandable 
element is selected

in Linux use SHIFT 
LEFT, RIGHT keys 
while expandable 
element is selected

For expandable 
element, tree is 
expanded or 
collapsed. Time 
graph item expansion 
is updated. Vertical 
scroll bar updated. 
For other entries, it 
does nothing. Manual Pass

Verified in Aug. 15-
2018 at 15:16PM

4.3

Keyboard 
navigation in 
time graph 
(process 
selection)

With focus on 
time graph, use 
UP, DOWN, 
HOME, END 
keys

Selected entry is 
changed. Table 
selection is updated. 
Vertical scroll bar 
updated. Manual Pass

Verified in Aug. 15-
2018 at 15:16AM

4.4

Keyboard 
navigation in 
time graph 
(state selection)

With focus on 
time graph, use 
LEFT, RIGHT 
keys

Previous or next 
state is 
selected. 
Selected time is 
updated in other 
views. Manual Pass

Verified in Aug. 15-
2018 at 15:17PM

5
Tool bar 
handling
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5.1 Align views

Click on the Align 
View Button, with 
another time graph 
view, eg the Control 
Flow view opened 
above or under

When it is pressed, 
moving the line 
between tree viewer 
and time graph will 
move the line of the 
other view. If not 
pressed, the line can 
be moved without 
affecting the other 
views Manual Pass CFV, ResourcesView still move when the align button is deselected

5.2 Show Legend
Click Show 
Legend button

The legend 
dialog is opened 
and can be 
closed. Manual Pass

5.3
Reset Time 
Scale

Click Reset 
Time Scale 
button

Time range is 
reset to full 
range, states 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 16:27PM

5.4

Select 
Previous/Next 
Event

Click 
Previous/Next 
Event button

Previous or next 
state is 
selected. 
Selected time is 
updated in other 
views. Manual Pass State works

5.5
Select Previous/Next 
Element

Click 
Previous/Next 
Element button

Selected entry 
is changed in 
table and time 
graph. Vertical 
scroll bar 
updated. Manual Pass

Verified in Aug. 15-
2018 at 16:27PM

5.6 Zoom In/Out
Click Zoom 
In/Out button

Time range is 
zoomed in and 
out, relative to 
center of 
selection or 
window. States 
are updated and 
new time range 
is propagated to 
other views. Manual Pass

Verified in Aug. 15-
2018 at 16:27PM
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5.7 Add Bookmark

Select a time, and 
click on the Add 
Bookmark button

The bookmark is 
added and is 
displayed in the other 
views as well (if 
enabled) Manual Pass

Verified in Aug. 15-
2018 at 16:27PM

5.8 Next/Previous marker

Add more 
bookmarks, then click 
on the next/previous 
marker buttons

The time graph view 
navigate between the 
bookmarks, States 
are updated and time 
selection is 
propagated to other 
views. When on a 
bookmark, the Add 
bookmark buttons 
changes to Delete 
bookmark Manual Pass

Verified in Aug. 15-
2018 at 16:27PM

5.9 Delete bookmark

With next/previous 
marker, when on a 
bookmark, click the 
delete bookmark 
button

The bookmark is 
deleted from all views Manual Pass

Verified in Aug. 15-
2018 at 16:27PM

5.11 Do not show markers

Click on the down 
arrow at the extreme 
right of the view, then 
expand Show 
markers and uncheck 
the Bookmarks box

All remaining 
bookmarks disappear 
from the view, but 
remain in other views 
where the they are 
enabled Manual Pass

Verified in Aug. 15-
2018 at 16:00PM

5.12 Show markers

Same as above, 
recheck the 
Bookmarks box

The bookmarks come 
back Manual Pass

6 Synchronization

6.1
Time 
synchronization

Select a random 
time in another 
view

Selected time 
line is updated. 
If selected time 
is outside 
current range, 
time range is 
updated to 
include it. Manual Pass

Verified in Aug. 15-
2018 at 16:27PM

6.2
Window range 
synchronization

Select a new window 
range in another view

Window range 
is updated. Manual Pass

Verified in Aug. 15-
2018 at 16:27PM
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6.3
Selection range 
synchronization

In any other 
view that 
supports 
selection range 
synchronization, 
select a new 
range.

Selection is 
highlighted. If 
the left time (T1) 
of selected time 
range is outside 
the current 
range, then 
window range is 
updated to 
include it Manual Pass

Verified in Aug. 15-
2018 at 16:27PM
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Section Pass Fail To Do Comment
Flame Graph 19 0 11 0 18

Target: Windows 7 64 bit

Step Test Case Action Verification Comment
0 Download the test resources Download this
1 Preparation

1.1 Open TMF Flame Graph View

Use menu 
Window → Show 
View → Tracing 
→ Flame Graph

Verify that 'Flame 
Graph View' view 
is shown SWTBot Pass

Verified in Aug. 14-
2018 at 13:45PM

1.2 Import generic trace

Import a trace 
that does not have 
any call stack 
information, like 
a standard kernel 
trace

Verify that 
nothing is shown 
in the view SWTBot Pass

Verified in Aug. 15-
2018 at 09:00AM

1.3 Import cyg-profile trace

Import the trace 
in the "trace" 
directory of the 
downloaded zip

Verify that the 
Flame Graph 
View is populated 
with some 
callers/callees 
information. SWTBot Pass

Verified in Aug. 15-
2018 at 09:05AM

1.4 Import cyg-profile-fast trace

Import a trace in 
the "trace-fast" 
directory of the 
downloaded zip

Verify that the 
Flame Graph 
View is populated 
with some 
callers/callees 
information. SWTBot Pass

Verified in Aug. 15-
2018 at 09:05AM

2 Manage View

https://drive.google.com/file/d/0BxUCnNTRLr5pWUdXd0JJV3hyeEk/edit?usp=sharing
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2.1 Close view
Close the 'Flame 
Graph' View

Flame Graph' 
view is removed 
from perspective SWTBot Pass

Verified in Aug. 14-
2018 at 13:45PM

2.2 Open view

Use menu 
Window → Show 
View → Other … 
→ Tracing → 
Flame Graph

Flame Graph' 
view is displayed 
and re-populated SWTBot Pass

Verified in Aug. 14-
2018 at 13:45PM

2.3 Open Trace
Open "trace(-
fast)" trace

Verify that view 
is populated with 
callers/callees 
information SWTBot Pass

Verified in Aug. 14-
2018 at 13:45PM

2.4
Open view when trace is already 
loaded

1) Close 'Flame 
Graph' view
2) Open 
"glxgears-cyg-
profile(-fast)" 
trace located in 
the git in ctf test
3) Open 'Flame 
Graph' view

Verify that view 
is populated with 
callers/callees 
information SWTBot Pass

Verified in Aug. 15-
2018 at 09:07AM

2.5 Open Experiment

Open Experiment 
with 2 or 
moreFlame Graph 
traces.
(You can use both 
traces)

Verify that view 
is populated with 
all callers/callees 
information 
(separated by 
trace). Manual Pass

Verified in Aug. 15-
2018 at 10:07AM

2.6 Restart

Restart Eclipse 
with Flame Graph 
trace opened

Verify that view 
is populated with 
callers/callees 
from trace Manual Pass

Verified in Aug. 15-
2018 at 10:29AM
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2.7 Close all traces

Close traces and 
experiment one 
by one from the 
editor tab

Verify that Flame 
Graph view is 
cleared after 
closing the last 
trace Manual Pass

Verified in Aug. 15-
2018 at 10:32AM

3 Sorting

3.1 Thread name sorting

Open a trace 
multiple Flame 
Graph thread or 
open experiment 
with 2 or 
moreFlame Graph 
traces. Then 
select 'Sort 
threads by thread 
name'

The view is 
sorted by thread 
name. Manual Pass

Verified in Aug. 15-
2018 at 10:07AM

3.2 Thead id sorting

Open a trace 
multiple Flame 
Graph thread or 
open experiment 
with 2 or 
moreFlame Graph 
traces. Then 
select 'Sort 
threads by thread 
id'

The view is 
sorted by thread 
id. Manual Pass

Verified in Aug. 15-
2018 at 10:07AM

4 Synchronization

4.1 Time synchronization

Select a random 
time in another 
view

Selected time line 
is not updating. 
Nothing happen. Manual Pass

Verified in Aug. 15-
2018 at 10:35AM
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4.2 Go to maximum

1. Open the 'Call 
Stack' View 
2. In the 'Flame 
Graph' view, 
right-click on a 
random entry in 
the graph
3. Select 'go to 
maximum'

- The 'Call Stack' 
view is populated
- The call stack 
view is 
synchronised to 
the range of the 
maximum call 
duration of the 
'Flame Graph' 
selected entry Manual Pass

Verified in Aug. 15-
2018 at 10:37AM

4.3 Go to minimum

1. Open the 'Call 
Stack' View 
2. In the 'Flame 
Graph' view, 
right-click on a 
random entry in 
the graph
3. Select 'go to 
minimum'

- The 'Call Stack' 
view is populated
- The call stack 
view is 
synchronised to 
the range of the 
minimum call 
duration of the 
'Flame Graph' 
selected entry Manual Pass

Verified in Aug. 15-
2018 at 10:44AM

5 Function name import

5.1 Function name import

1. Open the 'Call 
Stack' view with 
the 'Flame Graph' 
view and the cyg-
profile trace 
opened
2. Import 'cyg-
profile-mapping.
txt' as mapping 
text file

Both 'Call Stack' 
and 'Flame Graph' 
views display 
function name 
instead of 
function address. SWTBot Pass

5 Mouse handling
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5.1 Mouse hover (empty region)

Hover mouse in 
time graph over 
empty region

Tool tip shows 
depth only SWTBot Pass

Verified in Aug. 14-
2018 at 13:45PM

Mouse hover (state)

Hover mouse in 
time graph over 
state

Tool tip shows 
Total time and 
self times with 
standard 
statistics. SWTBot Pass

Verified in Aug. 14-
2018 at 13:45PM
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# Section Pass Fail To Do Comment

Counters View 3 0 0 0 3
Target: 

Step Test Case Action Verification Comment

1 Preparation

1.1
Import an LTTng trace (with counters)
and non LTTng traces LTTng trace (with counters): kernel VM in test-traces

In the project explorer, ensure the Counters view icon is only
strikethroughed for the non LTTng trace. Manual Pass Verified in Aug. 15-2018 at 11:07AM

2 Filtered checkbox tree
2.1 Same as 1.1 Same as above The color is changed when filtering the counters Manual Pass Verified in Aug. 15-2018 at 11:07AM

3 Displaying counters data
3.1 Same as 1.1 Same as above All counters are displayed Manual Pass Verified in Aug. 15-2018 at 11:07AM

4 Supporting experiments
4.1 Same as 1.1 Same as above All counters are displayed Manual Pass Verified in Aug. 15-2018 at 11:17AM

5 Persistence between traces
5.1 Manual N/A
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Section # Bug Reports # Open # Fixed

Bug Reports 17 16 0

Test Case Bug Title Found Bug Report Status

Sequence Diagram 5.23
[TMF] Sequence Diagram Overview feature 
not working well on recent platform versions 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=436442 Open

LTTng 2 - Memory 
Analysis 3.7, 3.8, CPU 
Analysis 4.10, 4.11

[TMF] Status bar is not updated when 
selecting time range in XY charts 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=436853 Open Enhancement

LTTng 2 - Memory 
Analysis 4.3, CPU 
Analysis 6.3, 
XmlAnalysis 7.3

[TMF] Time range selection outside current 
range should update current range in time 
graph views 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=436855 Open

LTTng 2 - Memory 
Analysis 4.1, CPU 
Analysis 6.1

[TMF] Time selection outside current range 
should update current range in xy charts 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=436861 Open

Project View 6.5
[TMF] Original experiment reappears after 
rename and copy 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=436888 Open

RCP 1.4
[lttng rcp] Opening a second trace with --open 
activates the wrong editor 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=443461 Open

Sequence Diagram 3.1
Sequence diagram interaction tooltip is hard to 
read on Ubuntu 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=455523 Open

Sequence Diagram 5.24
Button gets disabled in print dialog of 
sequence diagram after clicking on it 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=455546 Open

Memory analysis 2.4/ 
CPU Analysis

[TMF] XY chart view is cleared after being 
filled when restarting or opening a trace 0.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=467751 Open

Control view 17.9 NPE trying to destroy a session 1.0.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=469424 Open

Control view 17.9
SWTException widget is disposed trying to 
import trace from Control view 1.0.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=469425 Open

Project view Import to experiment will swallow exceptions 1.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=476475 Open
Time Chart 2.3 IOException in FlatArray.insert 1.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=476487 Open

Project Explorer 3.21
Deleting a project with the delete key does not 
work 2.0.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=486505 Open

TraceCompass 4.1.0

TraceCompass 4.0 is hang when switching 
from glxgears-cyg-profile trace to glxgears-
cyg-profile-fast 4.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=537961 Open

TraceCompass 4.1.0 Wrong export from trace to .csv file. 4.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=537965 Open
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TraceCompass 4.1.0

Missing header when clicking on up/down icon 
beside of Disk Name column of Disk I/O 
Activity bar 4.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=537970 Open

TraceCompass 4.1.0
Trace (analysis stubs) import failed, but no 
error/warning dialog box is displayed 4.1.0 https://bugs.eclipse.org/bugs/show_bug.cgi?id=538040
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