diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 96eadc60..255f2328 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -1,4 +1,4 @@
-name: Continous Integration - Testing
+name: Continous Integration
on: [push]
diff --git a/.github/workflows/documentation.yml b/.github/workflows/documentation.yml
index 826dc306..5bc4b35d 100644
--- a/.github/workflows/documentation.yml
+++ b/.github/workflows/documentation.yml
@@ -1,4 +1,4 @@
-name: documentation
+name: Documentation
on: [push, pull_request, workflow_dispatch]
diff --git a/README.md b/README.md
index 79df38d9..92641e28 100644
--- a/README.md
+++ b/README.md
@@ -7,12 +7,15 @@
An opinionated toolkit for a modern Django development experience
-[![documentation](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml)
-[![Continous Integration - Testing](https://github.com/Tobi-De/falco/actions/workflows/ci.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/ci.yml)
+[![Documentation](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml)
+[![Continous Integration](https://github.com/Tobi-De/falco/actions/workflows/ci.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/ci.yml)
[![pypi](https://badge.fury.io/py/falco-cli.svg)](https://pypi.org/project/falco-cli/)
[![Hatch project](https://img.shields.io/badge/%F0%9F%A5%9A-Hatch-4051b5.svg)](https://github.com/pypa/hatch)
[![Ruff](https://img.shields.io/endpoint?url=https://raw.githubusercontent.com/astral-sh/ruff/main/assets/badge/v2.json)](https://github.com/astral-sh/ruff)
[![MIT License](https://img.shields.io/badge/license-MIT-blue.svg)](https://github.com/Tobi-De/falco/blob/main/LICENSE)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/falco-cli)
+![PyPI - Versions from Framework Classifiers](https://img.shields.io/pypi/frameworkversions/django/falco-cli)
+
> [!WARNING]
> This is a work in progress (WIP), this is also [fuzzy-couscous](https://github.com/Tobi-De/fuzzy-couscous) new cooler brother.
diff --git a/docs/contributing.rst b/docs/contributing.rst
index 81124ab5..c25e5b1d 100644
--- a/docs/contributing.rst
+++ b/docs/contributing.rst
@@ -9,11 +9,25 @@ helps, and credit will always be given.
You can contribute in many ways:
+
+The Guides
+---------
+
+Contributions to the guides should be made via `GitHub Discussions `_. Any contribution is welcome, even for typos and grammatical errors.
+If a contribution requires a complete rewrite of a section or an entire guide, or adds new insights (similar to an article review), proper credits will be given at the bottom of the relevant guide.
+I will not accept any pull request that directly changes a guide without prior discussion on the topic, except for minor typo fixes.
+
+
+The CLI
+-------
+
+Contributions to the CLI are more open. You can fix issues, suggest new commands, or propose improvements to existing ones.
+
Types of Contributions
-----------------------
+^^^^^^^^^^^^^^^^^^^^^^
Report Bugs
-~~~~~~~~~~~
+***********
Report bugs at https://github.com/Tobi-De/falco/issues.
@@ -24,26 +38,26 @@ If you are reporting a bug, please include:
* Detailed steps to reproduce the bug.
Fix Bugs
-~~~~~~~~
+********
Look through the GitHub issues for bugs. Anything tagged with "bug" and "help
wanted" is open to whoever wants to implement it.
Implement Features
-~~~~~~~~~~~~~~~~~~
+******************
Look through the GitHub issues for features. Anything tagged with "enhancement"
and "help wanted" is open to whoever wants to implement it.
Write Documentation
-~~~~~~~~~~~~~~~~~~~
+*******************
falco could always use more documentation, whether as part of the
official falco docs, in docstrings, or even on the web in blog posts,
articles, and such.
Submit Feedback
-~~~~~~~~~~~~~~~
+***************
The best way to send feedback is to file an issue at https://github.com/Tobi-De/falco/issues.
@@ -55,7 +69,7 @@ If you are proposing a feature:
are welcome :)
Get Started!
-------------
+^^^^^^^^^^^^
Ready to contribute? Here's how to set up `falco` for local development.
@@ -64,11 +78,10 @@ Ready to contribute? Here's how to set up `falco` for local development.
$ git clone git@github.com:your_name_here/falco.git
-3. Install your local copy into a virtualenv. Assuming you have virtualenvwrapper installed, this is how you set up your fork for local development::
+3. Install your local copy into a virtualenv. Assuming you have hatch installed, this is how you set up your fork for local development::
- $ mkvirtualenv falco
$ cd falco/
- $ python setup.py develop
+ $ hatch env create
4. Create a branch for local development::
@@ -76,14 +89,13 @@ Ready to contribute? Here's how to set up `falco` for local development.
Now you can make your changes locally.
-5. When you're done making changes, check that your changes pass flake8 and the
- tests, including testing other Python versions with tox::
+4. Install pre-commit hooks for linting and code formatting before every commit::
+
+ $ pre-commit install
- $ flake8 falco tests
- $ python setup.py test or pytest
- $ tox
+5. When you're done making changes, check that your changes pass tests including testing other Python versions::
- To get flake8 and tox, just pip install them into your virtualenv.
+ $ hatch run test
6. Commit your changes and push your branch to GitHub::
@@ -94,7 +106,7 @@ Ready to contribute? Here's how to set up `falco` for local development.
7. Submit a pull request through the GitHub website.
Pull Request Guidelines
------------------------
+^^^^^^^^^^^^^^^^^^^^^^^
Before you submit a pull request, check that it meets these guidelines:
@@ -107,7 +119,7 @@ Before you submit a pull request, check that it meets these guidelines:
and make sure that the tests pass for all supported Python versions.
Tips
-----
+^^^^
To run a subset of tests::
@@ -115,14 +127,12 @@ $ pytest tests.test_falco
Deploying
----------
+^^^^^^^^^
A reminder for the maintainers on how to deploy.
Make sure all your changes are committed (including an entry in HISTORY.rst).
Then run::
-$ bump2version patch # possible: major / minor / patch
+$ hatch version patch # possible: major / minor / patch
$ git push
$ git push --tags
-
-Travis will then deploy to PyPI if tests pass.
\ No newline at end of file
diff --git a/docs/index.rst b/docs/index.rst
index 81696c45..0e75391f 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -14,6 +14,8 @@
+
+
diff --git a/pyproject.toml b/pyproject.toml
index f55d5869..35d8d745 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -24,6 +24,7 @@ classifiers = [
"Framework :: Django :: 4",
"Framework :: Django :: 4.0",
"Framework :: Django :: 4.1",
+ "Framework :: Django :: 4.2",
"Intended Audience :: Developers",
"Natural Language :: English",
]
diff --git a/src/falco/__about__.py b/src/falco/__about__.py
index 3127b10f..c42e387c 100644
--- a/src/falco/__about__.py
+++ b/src/falco/__about__.py
@@ -1,4 +1,4 @@
# SPDX-FileCopyrightText: 2023-present Tobi DEGNON
#
# SPDX-License-Identifier: MIT
-__version__ = "0.0.21"
+__version__ = "0.0.22"