-
Notifications
You must be signed in to change notification settings - Fork 234
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
757 changed files
with
22,844 additions
and
9,941 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,21 @@ | ||
#!/usr/bin/env bash | ||
set -euo pipefail | ||
|
||
$(dirname $0)/.aztec-run aztecprotocol/aztec-sandbox $@ | ||
# Call cli image if used with `aztec cli ...args` | ||
if [ -n "${1-}" ] && [ "$1" != "--help" ]; then | ||
if [ "$1" == "cli" ]; then | ||
shift | ||
$(dirname $0)/.aztec-run aztecprotocol/cli "$@" | ||
elif [ "$1" == "sandbox" ]; then | ||
$(dirname $0)/aztec-sandbox | ||
else | ||
$(dirname $0)/.aztec-run aztecprotocol/aztec "$@" | ||
fi | ||
else | ||
# TODO - display help message | ||
echo | ||
echo "Using 'aztec' CLI:" | ||
echo " aztec start <args> - Start aztec infrastructure components. See 'aztec start --help' for detailed command info." | ||
echo " aztec sandbox - Run a local sandbox network (same as aztec-sandbox)." | ||
echo " aztec cli <args> - Run the aztec client CLI. See 'aztec cli --help' for detailed command info." | ||
fi |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
#!/usr/bin/env bash | ||
set -eu | ||
|
||
TMP=tmp.dot | ||
RESULT_DOT=barretenberg_modules.dot | ||
RESULT_PNG=barretenberg_modules.png | ||
|
||
# initialize a directed graph for graphviz | ||
echo digraph BarretenbergModules { > $TMP | ||
# populate the directed graph | ||
for file in $(find ./src/barretenberg/ -iname CMakeLists.txt); do | ||
opening_chars=$(head -c 19 "$file") | ||
if [ "$opening_chars" == barretenberg_module ]; then | ||
awk -f ./scripts/barretenberg_module_digraph_edges.awk $file >> $TMP | ||
fi | ||
done | ||
echo } >> $TMP | ||
|
||
# apply transitive reduction to remove dependcies that are implied by other dependencies | ||
cat $TMP | tred > $RESULT_DOT | ||
rm $TMP | ||
|
||
# produce a PNG of the graph | ||
dot -Tpng $RESULT_DOT -o $RESULT_PNG |
35 changes: 35 additions & 0 deletions
35
barretenberg/cpp/scripts/barretenberg_module_digraph_edges.awk
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Function to extract words between parentheses | ||
function extract_edges(line) { | ||
match(line, /\(.*\)/); # Find the portion within parentheses | ||
line = substr(line, RSTART + 1, RLENGTH - 2); # Extract the words | ||
gsub(/^[ ]+/, "", line); # Remove leading spaces and tabs | ||
gsub(/[ ]+$/, "", line); # Remove trailing spaces and tabs | ||
gsub(/[ ]+/, " ", line); # Sub multiple spaces for a single space | ||
split(line, modules, " "); # Split into an array of words | ||
|
||
# If node has no dependencies, just add the node | ||
if (length(modules)==1) { | ||
print modules[1]; | ||
} | ||
else { # add edges | ||
for (i = 2; i <= length(modules); i++) { | ||
print modules[1]" -> "modules[i]; | ||
} | ||
} | ||
} | ||
|
||
# Main AWK script | ||
{ | ||
# Concatenate lines if the opening parenthesis is not closed | ||
while (!/\)/) { | ||
current_line = $0; | ||
getline; | ||
$0 = current_line $0; | ||
} | ||
|
||
# Check if the line begins with "barretenberg_module". If so, extact the digraph edges | ||
function_name = "barretenberg_module"; | ||
if ($0 ~ "^" function_name "\\(") { | ||
extract_edges($0); | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
#include "./utils.hpp" | ||
|
||
namespace bb::utils { | ||
|
||
std::vector<uint8_t> hex_to_bytes(const std::string& hex) | ||
{ | ||
std::vector<uint8_t> bytes; | ||
|
||
for (unsigned int i = 0; i < hex.length(); i += 2) { | ||
std::string byteString = hex.substr(i, 2); | ||
bytes.push_back(static_cast<uint8_t>(strtol(byteString.c_str(), nullptr, 16))); | ||
} | ||
|
||
return bytes; | ||
} | ||
|
||
} // namespace bb::utils |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
#pragma once | ||
|
||
#include <cstdint> | ||
#include <string> | ||
#include <vector> | ||
|
||
namespace bb::utils { | ||
|
||
/** | ||
* @brief Routine to transform hexstring to vector of bytes. | ||
* | ||
* @param Hexadecimal string representation. | ||
* @return Vector of uint8_t values. | ||
*/ | ||
std::vector<uint8_t> hex_to_bytes(const std::string& hex); | ||
|
||
} // namespace bb::utils |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.