Skip to content

Commit

Permalink
chore(master): Release 0.49.0 (#7933)
Browse files Browse the repository at this point in the history
🤖 I have created a release *beep* *boop*
---


<details><summary>aztec-package: 0.49.0</summary>

##
[0.49.0](aztec-package-v0.48.0...aztec-package-v0.49.0)
(2024-08-15)


### ⚠ BREAKING CHANGES

* Sequencer no longer proves
([#7860](#7860))

### Miscellaneous

* Enable execute command on aws ecs services
([#7975](#7975))
([4331bc6](4331bc6))
* Sequencer no longer proves
([#7860](#7860))
([7168290](7168290))
* Terraform template for prover-node
([#7846](#7846))
([546f946](546f946))
</details>

<details><summary>barretenberg.js: 0.49.0</summary>

##
[0.49.0](barretenberg.js-v0.48.0...barretenberg.js-v0.49.0)
(2024-08-15)


### Miscellaneous

* Pin yarn versions in noir-projects and bb/ts
([#7988](#7988))
([83f33a1](83f33a1))
</details>

<details><summary>aztec-packages: 0.49.0</summary>

##
[0.49.0](aztec-packages-v0.48.0...aztec-packages-v0.49.0)
(2024-08-15)


### ⚠ BREAKING CHANGES

* alternative key registry contract
([#7523](#7523))
* Sequencer no longer proves
([#7860](#7860))

### Features

* Add `FunctionDefinition::parameters`,
`FunctionDefinition::return_type` and `impl Eq for Quoted`
(noir-lang/noir#5681)
([b1c7374](b1c7374))
* Add `Quoted::as_expr` and `Expr::as_function_call`
(noir-lang/noir#5708)
([91042c7](91042c7))
* Add `Type::as_struct` (noir-lang/noir#5680)
([b1c7374](b1c7374))
* Add `Type::get_trait_impl`
(noir-lang/noir#5716)
([ccbef55](ccbef55))
* Add `Type::implements` (noir-lang/noir#5701)
([91042c7](91042c7))
* Add `Type::is_field` and `Type::as_integer`
(noir-lang/noir#5670)
([b1c7374](b1c7374))
* Add `Type` methods: `as_tuple`, `as_slice`, `as_array`, `as_constant`,
`is_bool` (noir-lang/noir#5678)
([b1c7374](b1c7374))
* Add a limited form of arithmetic on generics
(noir-lang/noir#5625)
([b1c7374](b1c7374))
* Add array_to_str_lossy (noir-lang/noir#5613)
([b1c7374](b1c7374))
* Add generate-secret-and-hash to cli
([#7977](#7977))
([cdf62a0](cdf62a0))
* Add mutating FunctionDefinition functions
(noir-lang/noir#5685)
([b1c7374](b1c7374))
* Add proven flag to sent tx wait opts
([#7950](#7950))
([e80e7d2](e80e7d2))
* Add some `Module` comptime functions
(noir-lang/noir#5684)
([b1c7374](b1c7374))
* Alternative key registry contract
([#7523](#7523))
([3e6a20f](3e6a20f))
* **avm:** More no fake rows + virtual dyn gas (part 1)
([#7942](#7942))
([9e8ba96](9e8ba96))
* Derive `Ord` and `Hash` in the stdlib; add `std::meta::make_impl`
helper (noir-lang/noir#5683)
([b1c7374](b1c7374))
* Destroy_note_unsafe
([#7891](#7891))
([5cda7ba](5cda7ba))
* **docs:** Nits
([#7838](#7838))
([a76c999](a76c999))
* Enable UltraHonk verifier
([#7923](#7923))
([5e8b4a8](5e8b4a8)),
closes
[#7373](#7373)
* Implement closures in the comptime interpreter
(noir-lang/noir#5682)
([b1c7374](b1c7374))
* IVC integration tests using new accumulate model
([#7946](#7946))
([c527ae9](c527ae9))
* LSP autocompletion for use statement
(noir-lang/noir#5704)
([91042c7](91042c7))
* LSP closing brace hints (noir-lang/noir#5686)
([b1c7374](b1c7374))
* LSP fields, functions and methods completion after "." and "::"
(noir-lang/noir#5714)
([ccbef55](ccbef55))
* LSP hover now includes "Go to" links
(noir-lang/noir#5677)
([b1c7374](b1c7374))
* LSP path completion (noir-lang/noir#5712)
([91042c7](91042c7))
* **noir_js:** Expose UltraHonk and integration tests
(noir-lang/noir#5656)
([b1c7374](b1c7374))
* Optimizing PrivateFPC
([#7980](#7980))
([d018335](d018335))
* Private refunds optimizations
([#7968](#7968))
([cea8295](cea8295))
* Resolve arguments to attributes
(noir-lang/noir#5649)
([b1c7374](b1c7374))
* **ssa:** Simple serialization of unoptimized SSA to file
(noir-lang/noir#5679)
([b1c7374](b1c7374))
* Sync from aztec-packages (noir-lang/noir#5718)
([ccbef55](ccbef55))
* Update honk ultra_recursive_verifier to do aggregation
([#7582](#7582))
([a96a5ad](a96a5ad))


### Bug Fixes

* Add locations to most SSA instructions
(noir-lang/noir#5697)
([b1c7374](b1c7374))
* Allow txs on block zero
([#7928](#7928))
([5e25cd6](5e25cd6))
* Build error in e2e_block_building
([0d0646d](0d0646d))
* **debugger:** Update the debugger to handle the new Brillig debug
metadata format (noir-lang/noir#5706)
([91042c7](91042c7))
* Delete forks after proving job has finished
([#7972](#7972))
([2b4a842](2b4a842))
* Deploy verifier cmd
([#7983](#7983))
([f4fa797](f4fa797))
* Derive generic types (noir-lang/noir#5674)
([b1c7374](b1c7374))
* Do not duplicate redundant Brillig debug metadata
(noir-lang/noir#5696)
([b1c7374](b1c7374))
* Do not mount ssh agent on OSX
([#7991](#7991))
([950db8e](950db8e))
* **docs:** Add redirects for website links
([#7979](#7979))
([e890814](e890814))
* Elaborate struct & trait annotations in the correct module
(noir-lang/noir#5643)
([b1c7374](b1c7374))
* Fix where clause issue in items generated from attributes
(noir-lang/noir#5673)
([b1c7374](b1c7374))
* Lay plumbing for having simulations throw an error if they cannot be
added in a block
([#7839](#7839))
([eedbc11](eedbc11))
* Let a trait impl that relies on another trait work
(noir-lang/noir#5646)
([b1c7374](b1c7374))
* Only record bytecode if &gt;0
([#7932](#7932))
([3f145b3](3f145b3))
* Remove missing file
([#7941](#7941))
([4d9290f](4d9290f))
* Replace unused ArrayGet/Set with constrain if possibly out of bounds
(noir-lang/noir#5691)
([ccbef55](ccbef55))
* Switch verify proof to arrays
(noir-lang/noir#5664)
([b1c7374](b1c7374))
* Track L1 block for last L2 block body retrieved
([#7927](#7927))
([cd36be4](cd36be4)),
closes
[#7918](#7918)
* Unexpose get note nonces on pxe
([#7889](#7889))
([163c3a6](163c3a6))
* Use data dir for lmdb forks
([#7973](#7973))
([5b53d43](5b53d43))
* Workaround from_slice with nested slices
(noir-lang/noir#5648)
([b1c7374](b1c7374))


### Miscellaneous

* Add docs tip about filenames between commands
(noir-lang/noir#5695)
([b1c7374](b1c7374))
* Add env var to disable bb cleanup
([#7936](#7936))
([806a370](806a370))
* Add parser support for `&lt;MyType as Trait&gt;::ident`
(noir-lang/noir#5688)
([b1c7374](b1c7374))
* Add tests for noir&lt;&gt;ivc integration testing
([#7931](#7931))
([7cc47a6](7cc47a6))
* Allow passing custom executors to fuzzer
(noir-lang/noir#5710)
([91042c7](91042c7))
* **avm:** Fewer errors unless testing
([#7943](#7943))
([33b65a9](33b65a9))
* **bb:** Constexpr simplifications
([#7906](#7906))
([65d3b7f](65d3b7f))
* **bb:** Prereq work for polynomial mem optimization
([#7949](#7949))
([5ca5138](5ca5138))
* **ci:** Print detailed target timings
([#7934](#7934))
([fb574aa](fb574aa))
* Do not clean up bb files on err
([#7985](#7985))
([75c6768](75c6768))
* Enable execute command on aws ecs services
([#7975](#7975))
([4331bc6](4331bc6))
* Ensure bootstrapped networks have no pending blocks when proving
starts
([#7986](#7986))
([fb471b3](fb471b3))
* Fork logs and prover job catch
([#7982](#7982))
([69bde53](69bde53))
* Move siloing to reset
([#7871](#7871))
([014b5f0](014b5f0))
* Pin yarn versions in noir-projects and bb/ts
([#7988](#7988))
([83f33a1](83f33a1))
* Release Noir(0.33.0) (noir-lang/noir#5550)
([b1c7374](b1c7374))
* Replace relative paths to noir-protocol-circuits
([cd5f138](cd5f138))
* Replace relative paths to noir-protocol-circuits
([6f3cef9](6f3cef9))
* Replace relative paths to noir-protocol-circuits
([54c4441](54c4441))
* Replace VERSION with IMAGE on provernet template
([d5e48aa](d5e48aa))
* Sequencer no longer proves
([#7860](#7860))
([7168290](7168290))
* Simplify registry
([#7939](#7939))
([8e0418f](8e0418f))
* Terraform template for prover-node
([#7846](#7846))
([546f946](546f946))
* Update provernet docker compose template
([#7929](#7929))
([33d47d2](33d47d2))
* Updating token with refunds
([#7969](#7969))
([504deba](504deba))
</details>

<details><summary>barretenberg: 0.49.0</summary>

##
[0.49.0](barretenberg-v0.48.0...barretenberg-v0.49.0)
(2024-08-15)


### Features

* **avm:** More no fake rows + virtual dyn gas (part 1)
([#7942](#7942))
([9e8ba96](9e8ba96))
* IVC integration tests using new accumulate model
([#7946](#7946))
([c527ae9](c527ae9))
* Update honk ultra_recursive_verifier to do aggregation
([#7582](#7582))
([a96a5ad](a96a5ad))


### Miscellaneous

* **avm:** Fewer errors unless testing
([#7943](#7943))
([33b65a9](33b65a9))
* **bb:** Constexpr simplifications
([#7906](#7906))
([65d3b7f](65d3b7f))
* **bb:** Prereq work for polynomial mem optimization
([#7949](#7949))
([5ca5138](5ca5138))
</details>

---
This PR was generated with [Release
Please](https://github.com/googleapis/release-please). See
[documentation](https://github.com/googleapis/release-please#release-please).
  • Loading branch information
AztecBot authored Aug 15, 2024
1 parent d018335 commit 3d61bdf
Show file tree
Hide file tree
Showing 8 changed files with 142 additions and 7 deletions.
8 changes: 4 additions & 4 deletions .release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
".": "0.48.0",
".": "0.49.0",
"yarn-project/cli": "0.35.1",
"yarn-project/aztec": "0.48.0",
"barretenberg": "0.48.0",
"barretenberg/ts": "0.48.0"
"yarn-project/aztec": "0.49.0",
"barretenberg": "0.49.0",
"barretenberg/ts": "0.49.0"
}
99 changes: 99 additions & 0 deletions CHANGELOG.md

Large diffs are not rendered by default.

16 changes: 16 additions & 0 deletions barretenberg/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,21 @@
# Changelog

## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.48.0...barretenberg-v0.49.0) (2024-08-15)


### Features

* **avm:** More no fake rows + virtual dyn gas (part 1) ([#7942](https://github.com/AztecProtocol/aztec-packages/issues/7942)) ([9e8ba96](https://github.com/AztecProtocol/aztec-packages/commit/9e8ba96cc1a5eed9a4d4cf764a7c3d3a2d975617))
* IVC integration tests using new accumulate model ([#7946](https://github.com/AztecProtocol/aztec-packages/issues/7946)) ([c527ae9](https://github.com/AztecProtocol/aztec-packages/commit/c527ae94521c4d76153224b7e10cf176038df76b))
* Update honk ultra_recursive_verifier to do aggregation ([#7582](https://github.com/AztecProtocol/aztec-packages/issues/7582)) ([a96a5ad](https://github.com/AztecProtocol/aztec-packages/commit/a96a5ad2b153cbe995de753cb7db1da0d0072e0c))


### Miscellaneous

* **avm:** Fewer errors unless testing ([#7943](https://github.com/AztecProtocol/aztec-packages/issues/7943)) ([33b65a9](https://github.com/AztecProtocol/aztec-packages/commit/33b65a9e6a5072df8ba45991545b6e5386c99622))
* **bb:** Constexpr simplifications ([#7906](https://github.com/AztecProtocol/aztec-packages/issues/7906)) ([65d3b7f](https://github.com/AztecProtocol/aztec-packages/commit/65d3b7f68fe921d7cf7495a92863c555783636d9))
* **bb:** Prereq work for polynomial mem optimization ([#7949](https://github.com/AztecProtocol/aztec-packages/issues/7949)) ([5ca5138](https://github.com/AztecProtocol/aztec-packages/commit/5ca513881409880e8581a3fc6c9f3b3452087957))

## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.47.1...barretenberg-v0.48.0) (2024-08-12)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/cpp/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
project(
Barretenberg
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
VERSION 0.48.0 # x-release-please-version
VERSION 0.49.0 # x-release-please-version
LANGUAGES CXX C
)
# Insert version into `bb` config file
Expand Down
7 changes: 7 additions & 0 deletions barretenberg/ts/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,12 @@
# Changelog

## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.48.0...barretenberg.js-v0.49.0) (2024-08-15)


### Miscellaneous

* Pin yarn versions in noir-projects and bb/ts ([#7988](https://github.com/AztecProtocol/aztec-packages/issues/7988)) ([83f33a1](https://github.com/AztecProtocol/aztec-packages/commit/83f33a1c131c89c2113bea0527cfa5586529714c))

## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.47.1...barretenberg.js-v0.48.0) (2024-08-12)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/ts/package.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
"name": "@aztec/bb.js",
"packageManager": "yarn@1.22.22",
"version": "0.48.0",
"version": "0.49.0",
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
"license": "MIT",
"type": "module",
Expand Down
13 changes: 13 additions & 0 deletions yarn-project/aztec/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,18 @@
# Changelog

## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.48.0...aztec-package-v0.49.0) (2024-08-15)


### ⚠ BREAKING CHANGES

* Sequencer no longer proves ([#7860](https://github.com/AztecProtocol/aztec-packages/issues/7860))

### Miscellaneous

* Enable execute command on aws ecs services ([#7975](https://github.com/AztecProtocol/aztec-packages/issues/7975)) ([4331bc6](https://github.com/AztecProtocol/aztec-packages/commit/4331bc615427970fe99b1c9a29038a55cd7d9071))
* Sequencer no longer proves ([#7860](https://github.com/AztecProtocol/aztec-packages/issues/7860)) ([7168290](https://github.com/AztecProtocol/aztec-packages/commit/71682901b04215d78c613f627a0a46a642001019))
* Terraform template for prover-node ([#7846](https://github.com/AztecProtocol/aztec-packages/issues/7846)) ([546f946](https://github.com/AztecProtocol/aztec-packages/commit/546f9463f2fbc37ba43dbcd8d11cedfae52d480b))

## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.47.1...aztec-package-v0.48.0) (2024-08-12)


Expand Down
2 changes: 1 addition & 1 deletion yarn-project/aztec/package.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
{
"name": "@aztec/aztec",
"version": "0.48.0",
"version": "0.49.0",
"type": "module",
"exports": {
".": "./dest/index.js"
Expand Down

0 comments on commit 3d61bdf

Please sign in to comment.