Skip to content

Commit

Permalink
wrangle python
Browse files Browse the repository at this point in the history
  • Loading branch information
IlyasRidhuan committed Mar 7, 2024
1 parent 7411e6d commit aacb843
Show file tree
Hide file tree
Showing 2 changed files with 11 additions and 5 deletions.
1 change: 0 additions & 1 deletion barretenberg/acir_tests/Dockerfile.bb.sol
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,6 @@ RUN apt update && apt install git bash curl jq -y
COPY --from=0 /usr/src/barretenberg/cpp/build /usr/src/barretenberg/cpp/build
COPY --from=1 /usr/src/barretenberg/sol/src/ultra/BaseUltraVerifier.sol /usr/src/barretenberg/sol/src/ultra/BaseUltraVerifier.sol
COPY --from=noir-acir-tests /usr/src/noir/noir-repo/test_programs /usr/src/noir/noir-repo/test_programs
# COPY --from=ghcr.io/foundry-rs/foundry:latest /usr/local/bin/anvil /usr/local/bin/anvil

RUN curl -L https://foundry.paradigm.xyz | bash
ENV PATH="${PATH}:/root/.foundry/bin"
Expand Down
15 changes: 11 additions & 4 deletions l1-contracts/Dockerfile
Original file line number Diff line number Diff line change
@@ -1,18 +1,25 @@
# Building requires foundry.
# FROM ghcr.io/foundry-rs/foundry:nightly-4a643801d0b3855934cdec778e33e79c79971783
FROM ubuntu:lunar
RUN apt update && apt install git jq bash nodejs npm yarn python3 python3-pip -y && pip3 install slither-analyzer==0.10.0 slitherin==0.5.0

RUN apt update && apt install curl git jq bash nodejs npm python3.11-full python3-pip -y

# Use virtualenv, do not try to use pipx, it's not working.
RUN python3 -m venv /root/.venv
RUN /root/.venv/bin/pip3 install slither-analyzer==0.10.0 slitherin==0.5.0
RUN curl -L https://foundry.paradigm.xyz | bash
RUN source ~/.bashrc
ENV PATH="~/.foundry/bin:${PATH}"

# Set env variables for foundry and venv
ENV PATH="${PATH}:/root/.foundry/bin:/root/.venv/bin"
RUN foundryup

WORKDIR /usr/src/l1-contracts
COPY . .
RUN git init
RUN forge clean && forge fmt --check && forge build && forge test

RUN npm install --global yarn
RUN yarn && yarn lint

RUN git add . && yarn slither && yarn slither-has-diff
RUN forge build

Expand Down

0 comments on commit aacb843

Please sign in to comment.