Skip to content

Commit

Permalink
Merge remote-tracking branch 'origin/master' into is/goblin_translato…
Browse files Browse the repository at this point in the history
…r_composer_prover_verifier
  • Loading branch information
codygunton committed Nov 7, 2023
2 parents fc44c7b + 8abd39f commit b1885ac
Show file tree
Hide file tree
Showing 116 changed files with 1,758 additions and 11,542 deletions.
238 changes: 120 additions & 118 deletions .circleci/config.yml
Original file line number Diff line number Diff line change
Expand Up @@ -992,14 +992,14 @@ jobs:
name: "Noop"
command: echo Noop

canary-end:
docker:
- image: cimg/base:2023.09
resource_class: small
steps:
- run:
name: "Noop"
command: echo Noop
# canary-end:
# docker:
# - image: cimg/base:2023.09
# resource_class: small
# steps:
# - run:
# name: "Noop"
# command: echo Noop

bench-summary:
machine:
Expand All @@ -1011,18 +1011,18 @@ jobs:
name: "Assemble benchmark summary from uploaded logs"
command: ./scripts/ci/assemble_e2e_benchmark.sh

deploy-npm-canary:
# Deploys next version under 'canary' dist tag.
machine:
image: ubuntu-2204:2023.07.2
resource_class: medium
steps:
- *checkout
- *setup_env
# Aztec.js and dependencies
- run:
name: "yarn-project"
command: yarn-project/deploy_npm.sh canary
# deploy-npm-canary:
# # Deploys next version under 'canary' dist tag.
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: medium
# steps:
# - *checkout
# - *setup_env
# # Aztec.js and dependencies
# - run:
# name: "yarn-project"
# command: yarn-project/deploy_npm.sh canary

deploy-npm:
machine:
Expand All @@ -1036,27 +1036,27 @@ jobs:
name: "yarn-project"
command: yarn-project/deploy_npm.sh latest

deploy-dockerhub-canary:
machine:
image: ubuntu-2204:2023.07.2
resource_class: medium
steps:
- *checkout
- *setup_env
- run:
name: "Deploy to dockerhub"
command: yarn-project/deploy_dockerhub.sh canary
# deploy-dockerhub-canary:
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: medium
# steps:
# - *checkout
# - *setup_env
# - run:
# name: "Deploy to dockerhub"
# command: yarn-project/deploy_dockerhub.sh canary

deploy-ecr:
machine:
image: ubuntu-2204:2023.07.2
resource_class: medium
steps:
- *checkout
- *setup_env
- run:
name: "yarn-project"
command: yarn-project/deploy_ecr.sh
# deploy-ecr:
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: medium
# steps:
# - *checkout
# - *setup_env
# - run:
# name: "yarn-project"
# command: yarn-project/deploy_ecr.sh

deploy-dockerhub:
machine:
Expand All @@ -1069,49 +1069,49 @@ jobs:
name: "Deploy to dockerhub"
command: yarn-project/deploy_dockerhub.sh

build-deployment-canary:
machine:
image: ubuntu-2204:2023.07.2
resource_class: large
steps:
- *checkout
- *setup_env
- run:
name: "Build"
command: build canary true
# build-deployment-canary:
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: large
# steps:
# - *checkout
# - *setup_env
# - run:
# name: "Build"
# command: build canary true

canary-uniswap-test:
machine:
image: ubuntu-2204:2023.07.2
resource_class: large
steps:
- *checkout
- *setup_env
- run:
name: "Test"
command: run_script canary ./scripts/run_tests ./src/uniswap_trade_on_l1_from_l2.test.ts canary ./scripts/docker-compose.yml
# canary-uniswap-test:
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: large
# steps:
# - *checkout
# - *setup_env
# - run:
# name: "Test"
# command: run_script canary ./scripts/run_tests ./src/uniswap_trade_on_l1_from_l2.test.ts canary ./scripts/docker-compose.yml

canary-browser-test:
machine:
image: ubuntu-2204:2023.07.2
resource_class: large
steps:
- *checkout
- *setup_env
- run:
name: "Test"
command: run_script canary ./scripts/run_tests ./src/aztec_js_browser.test.ts canary ./scripts/docker-compose-browser.yml
# canary-browser-test:
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: large
# steps:
# - *checkout
# - *setup_env
# - run:
# name: "Test"
# command: run_script canary ./scripts/run_tests ./src/aztec_js_browser.test.ts canary ./scripts/docker-compose-browser.yml

canary-cli-test:
machine:
image: ubuntu-2204:2023.07.2
resource_class: large
steps:
- *checkout
- *setup_env
- run:
name: "Test"
command: run_script canary ./scripts/run_tests ./src/cli.test.ts canary ./scripts/docker-compose.yml
# canary-cli-test:
# machine:
# image: ubuntu-2204:2023.07.2
# resource_class: large
# steps:
# - *checkout
# - *setup_env
# - run:
# name: "Test"
# command: run_script canary ./scripts/run_tests ./src/cli.test.ts canary ./scripts/docker-compose.yml

# Repeatable config for defining the workflow below.
tag_regex: &tag_regex /^aztec-packages-v.*/
Expand Down Expand Up @@ -1412,54 +1412,56 @@ workflows:
<<: *defaults

# Deploy under canary tag
- deploy-npm-canary:
requires:
- e2e-end
<<: *deploy_defaults
- deploy-dockerhub-canary:
requires:
- e2e-end
<<: *deploy_defaults
- deploy-ecr:
requires:
- e2e-end
<<: *deploy_defaults
# - deploy-npm-canary:
# requires:
# - e2e-end
# <<: *deploy_defaults
# - deploy-dockerhub-canary:
# requires:
# - e2e-end
# <<: *deploy_defaults
# - deploy-ecr:
# requires:
# - e2e-end
# <<: *deploy_defaults

- build-deployment-canary:
requires:
- deploy-npm-canary
- deploy-dockerhub-canary
<<: *deploy_defaults
# - build-deployment-canary:
# requires:
# - deploy-npm-canary
# - deploy-dockerhub-canary
# <<: *deploy_defaults

# Run canary tests
- canary-uniswap-test:
requires:
- build-deployment-canary
<<: *deploy_defaults
# - canary-uniswap-test:
# requires:
# - build-deployment-canary
# <<: *deploy_defaults

- canary-browser-test:
requires:
- build-deployment-canary
<<: *deploy_defaults
# - canary-browser-test:
# requires:
# - build-deployment-canary
# <<: *deploy_defaults

- canary-cli-test:
requires:
- build-deployment-canary
<<: *deploy_defaults
# - canary-cli-test:
# requires:
# - build-deployment-canary
# <<: *deploy_defaults

- canary-end:
requires:
- canary-uniswap-test
- canary-browser-test
- canary-cli-test
<<: *deploy_defaults
# - canary-end:
# requires:
# - canary-uniswap-test
# - canary-browser-test
# - canary-cli-test
# <<: *deploy_defaults

# Production deployment
# Production deployment
- deploy-dockerhub:
requires:
- canary-end
# - canary-end
- e2e-end
<<: *deploy_defaults
- deploy-npm:
requires:
- canary-end
# - canary-end
- e2e-end
<<: *deploy_defaults
2 changes: 2 additions & 0 deletions .vscode/settings.json
Original file line number Diff line number Diff line change
Expand Up @@ -126,6 +126,8 @@
"[javascript]": {
"editor.defaultFormatter": "esbenp.prettier-vscode"
},
// Now when a new file is pasted in /yellow-paper/docs/readme.md, the image file is created at /yellow-paper/docs/images/readme/image.png.
"markdown.copyFiles.destination": {"/yellow-paper/**/*": "images/${documentBaseName}/"},
///////////////////////////////////////
// C++/Circuits settings
///////////////////////////////////////
Expand Down
2 changes: 1 addition & 1 deletion README.md
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ All the packages that make up [Aztec](https://docs.aztec.network).
- [Aztec.js](./yarn-project/aztec.js/): A tool for interacting with the Aztec network. It communicates via the [Private Execution Environment (PXE)](./yarn-project/pxe/).
- [Aztec Boxes](./yarn-project/boxes/): A minimal framework for building full stack applications for Aztec (using React).
- [Example contracts](./yarn-project/noir-contracts/): Example contracts for the Aztec network, written in Noir.
- [End to end tests](./yarn-project/end-to-end/): Integration tests writted in Typescript--a good reference for how to use the packages for specific tasks.
- [End to end tests](./yarn-project/end-to-end/): Integration tests written in Typescript--a good reference for how to use the packages for specific tasks.

## Issues Board

Expand Down
4 changes: 2 additions & 2 deletions barretenberg/.gitrepo
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
[subrepo]
remote = https://github.com/AztecProtocol/barretenberg
branch = master
commit = 340a25673099eee4ae38d4b4a24e2df1cce0c5d0
parent = 3e071046d7b0f280cc3b5c426399902425aa1039
commit = 70f7b2915aaaa99446a0376c51c919d2fece5bd1
parent = 0ed8c79677c3679e19e7d90317b7bd3e12c4248f
method = merge
cmdver = 0.4.6
2 changes: 1 addition & 1 deletion barretenberg/acir_tests/Dockerfile.bb
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,6 @@ COPY --from=0 /usr/src/barretenberg/cpp/build /usr/src/barretenberg/cpp/build
WORKDIR /usr/src/barretenberg/acir_tests
COPY . .
# Run every acir test through native bb build "prove_and_verify".
RUN ./run_acir_tests.sh
RUN FLOW=all_cmds ./run_acir_tests.sh
# Run 1_mul through native bb build, all_cmds flow, to test all cli args.
RUN VERBOSE=1 FLOW=all_cmds ./run_acir_tests.sh 1_mul
19 changes: 19 additions & 0 deletions barretenberg/acir_tests/clone_test_vectors.sh
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
#!/bin/bash
set -eu

# Pull down the test vectors from the noir repo, if we don't have the folder already.
if [ ! -d acir_tests ]; then
if [ -n "${TEST_SRC:-}" ]; then
cp -R $TEST_SRC acir_tests
else
rm -rf noir
git clone -b $BRANCH --filter=blob:none --no-checkout https://github.com/noir-lang/noir.git
cd noir
git sparse-checkout init --cone
git sparse-checkout set tooling/nargo_cli/tests/acir_artifacts
git checkout
cd ..
mv noir/tooling/nargo_cli/tests/acir_artifacts acir_tests
rm -rf noir
fi
fi
8 changes: 0 additions & 8 deletions barretenberg/acir_tests/flows/proof_as_fields.sh

This file was deleted.

21 changes: 0 additions & 21 deletions barretenberg/acir_tests/flows/prove.sh

This file was deleted.

8 changes: 0 additions & 8 deletions barretenberg/acir_tests/flows/vk_as_fields.sh

This file was deleted.

8 changes: 0 additions & 8 deletions barretenberg/acir_tests/flows/write_vk.sh

This file was deleted.

Loading

0 comments on commit b1885ac

Please sign in to comment.