Skip to content

Commit

Permalink
[1 changes] fix(ssa): RC correctness issue (noir-lang/noir#6134)
Browse files Browse the repository at this point in the history
fix: let token pretty printer handle `+=` and similar token sequences (noir-lang/noir#6135)
fix: allow providing default implementations of unconstrained trait methods (noir-lang/noir#6138)
feat: remove unnecessary branching in keccak impl (noir-lang/noir#6133)
feat: do not double error on import with error (noir-lang/noir#6131)
chore: remove unnecessary `Prover.toml`s (noir-lang/noir#6140)
chore: split `noirc_frontend/src/tests.rs` into submodules (noir-lang/noir#6139)
feat: remove aztec macros (noir-lang/noir#6087)
  • Loading branch information
AztecBot committed Sep 24, 2024
1 parent bcec12d commit dd9f394
Show file tree
Hide file tree
Showing 1,860 changed files with 12,610 additions and 125,407 deletions.
2 changes: 1 addition & 1 deletion .noir-sync-commit
Original file line number Diff line number Diff line change
@@ -1 +1 @@
9bf2dcbf166f9ffd97c369c0de3d95329c850d47
5b1c896c605ed1047fc17a437e0b58792a778e2d
4 changes: 2 additions & 2 deletions noir/noir-repo/.release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
{
".": "0.33.0",
"acvm-repo": "0.49.0"
".": "0.34.0",
"acvm-repo": "0.50.0"
}
3 changes: 0 additions & 3 deletions noir/noir-repo/.tokeignore
Original file line number Diff line number Diff line change
@@ -1,9 +1,6 @@
docs
scripts

# aztec_macros is explicitly considered OOS for Noir audit
aztec_macros

# config files
*.toml
*.md
Expand Down
207 changes: 207 additions & 0 deletions noir/noir-repo/CHANGELOG.md

Large diffs are not rendered by default.

86 changes: 28 additions & 58 deletions noir/noir-repo/Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

18 changes: 8 additions & 10 deletions noir/noir-repo/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,8 +1,6 @@
[workspace]

members = [
# Aztec Macro crate for metaprogramming
"aztec_macros",
# Compiler crates
"compiler/noirc_arena",
"compiler/noirc_evaluator",
Expand Down Expand Up @@ -42,7 +40,7 @@ resolver = "2"

[workspace.package]
# x-release-please-start-version
version = "0.33.0"
version = "0.34.0"
# x-release-please-end
authors = ["The Noir Team <team@noir-lang.org>"]
edition = "2021"
Expand All @@ -59,13 +57,13 @@ unused_qualifications = "warn"
[workspace.dependencies]

# ACVM workspace dependencies
acir_field = { version = "0.49.0", path = "acvm-repo/acir_field", default-features = false }
acir = { version = "0.49.0", path = "acvm-repo/acir", default-features = false }
acvm = { version = "0.49.0", path = "acvm-repo/acvm" }
brillig = { version = "0.49.0", path = "acvm-repo/brillig", default-features = false }
brillig_vm = { version = "0.49.0", path = "acvm-repo/brillig_vm", default-features = false }
acvm_blackbox_solver = { version = "0.49.0", path = "acvm-repo/blackbox_solver", default-features = false }
bn254_blackbox_solver = { version = "0.49.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }
acir_field = { version = "0.50.0", path = "acvm-repo/acir_field", default-features = false }
acir = { version = "0.50.0", path = "acvm-repo/acir", default-features = false }
acvm = { version = "0.50.0", path = "acvm-repo/acvm" }
brillig = { version = "0.50.0", path = "acvm-repo/brillig", default-features = false }
brillig_vm = { version = "0.50.0", path = "acvm-repo/brillig_vm", default-features = false }
acvm_blackbox_solver = { version = "0.50.0", path = "acvm-repo/blackbox_solver", default-features = false }
bn254_blackbox_solver = { version = "0.50.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }

# Noir compiler workspace dependencies
fm = { path = "compiler/fm" }
Expand Down
Loading

0 comments on commit dd9f394

Please sign in to comment.