Skip to content

Commit

Permalink
[1 changes] fix(frontend): Disallow signed numeric generics (noir-lan…
Browse files Browse the repository at this point in the history
…g/noir#5572)

chore: disable aztec-packages CI checks (noir-lang/noir#5566)
feat: LSP inlay parameter hints (noir-lang/noir#5553)
feat: Add `TraitDefinition::as_trait_constraint()` (noir-lang/noir#5541)
fix: Fix `uhashmap` test name (noir-lang/noir#5563)
fix: let unary traits work at comptime (noir-lang/noir#5507)
feat: Add a compile-time hash map type (noir-lang/noir#5543)
chore(docs): Docs for turbofish operator (noir-lang/noir#5555)
fix(frontend): Error for when impl is stricter than trait (noir-lang/noir#5343)
chore: filter warnings from elaborator in Aztec Macros (noir-lang/noir#5556)
fix: Don't panic when a macro fails to resolve (noir-lang/noir#5537)
fix(ssa): More robust array deduplication check (noir-lang/noir#5547)
fix: Fix occurs check (noir-lang/noir#5535)
fix: type_of for pointer types (noir-lang/noir#5536)
chore: Release Noir(0.32.0) (noir-lang/noir#5268)
fix: revert PR #5449 (noir-lang/noir#5548)
fix: never panic in LSP inlay hints (noir-lang/noir#5534)
feat: LSP document symbol (noir-lang/noir#5532)
feat: add comptime support for `modulus_*` compiler builtins (noir-lang/noir#5530)
chore: Remove unknown annotation warning (noir-lang/noir#5531)
feat: Add TraitConstraint type (noir-lang/noir#5499)
fix: Error on empty function bodies (noir-lang/noir#5519)
feat: LSP inlay hints for let and global (noir-lang/noir#5510)
chore: Remove dbg on find_func_with_name (noir-lang/noir#5526)
chore: Remove the remainder of legacy code (noir-lang/noir#5525)
chore: Remove `--use-legacy` and resolution code (noir-lang/noir#5248)
chore: switch to Noir Keccak implementation with variable size support (noir-lang/noir#5508)
chore: standardize experimental feature disclaimer across documentation (noir-lang/noir#5367)
  • Loading branch information
AztecBot committed Jul 22, 2024
1 parent e44ef70 commit ed49eab
Show file tree
Hide file tree
Showing 355 changed files with 20,420 additions and 8,715 deletions.
2 changes: 1 addition & 1 deletion .noir-sync-commit
Original file line number Diff line number Diff line change
@@ -1 +1 @@
bb6913ac53620fabd73e24ca1a2b1369225903ec
2b4853e71859f225acc123160e87c522212b16b5
53 changes: 53 additions & 0 deletions noir/noir-repo/.github/workflows/test-js-packages.yml
Original file line number Diff line number Diff line change
Expand Up @@ -509,6 +509,59 @@ jobs:
working-directory: ./examples/codegen_verifier
run: ./test.sh

external-repo-checks:
needs: [build-nargo]
runs-on: ubuntu-22.04
timeout-minutes: 30
strategy:
fail-fast: false
matrix:
project:
# - { repo: AztecProtocol/aztec-nr, path: ./ }
# - { repo: AztecProtocol/aztec-packages, path: ./noir-projects/noir-contracts }
# Disabled as aztec-packages requires a setup-step in order to generate a `Nargo.toml`
#- { repo: AztecProtocol/aztec-packages, path: ./noir-projects/noir-protocol-circuits }
- { repo: zac-williamson/noir-edwards, path: ./, ref: 0016ce82cd58b6ebb0c43c271725590bcff4e755 }
# TODO: Enable these once they're passing against master again.
# - { repo: zac-williamson/noir-bignum, path: ./, ref: 030c2acce1e6b97c44a3bbbf3429ed96f20d72d3 }
# - { repo: vlayer-xyz/monorepo, path: ./, ref: ee46af88c025863872234eb05d890e1e447907cb }
# - { repo: hashcloak/noir-bigint, path: ./, ref: 940ddba3a5201b508e7b37a2ef643551afcf5ed8 }

name: Check external repo - ${{ matrix.project.repo }}

steps:
- name: Checkout
uses: actions/checkout@v4
with:
repository: ${{ matrix.project.repo }}
path: test-repo
ref: ${{ matrix.project.ref }}

- name: Download nargo binary
uses: actions/download-artifact@v4
with:
name: nargo
path: ./nargo

- name: Set nargo on PATH
run: |
nargo_binary="${{ github.workspace }}/nargo/nargo"
chmod +x $nargo_binary
echo "$(dirname $nargo_binary)" >> $GITHUB_PATH
export PATH="$PATH:$(dirname $nargo_binary)"
nargo -V
- name: Remove requirements on compiler version
working-directory: ./test-repo
run: |
# Github actions seems to not expand "**" in globs by default.
shopt -s globstar
sed -i '/^compiler_version/d' ./**/Nargo.toml
- name: Run nargo check
working-directory: ./test-repo/${{ matrix.project.path }}
run: nargo check

# This is a job which depends on all test jobs and reports the overall status.
# This allows us to add/remove test jobs without having to update the required workflows.
tests-end:
Expand Down
4 changes: 2 additions & 2 deletions noir/noir-repo/.release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
{
".": "0.31.0",
"acvm-repo": "0.47.0"
".": "0.32.0",
"acvm-repo": "0.48.0"
}
132 changes: 132 additions & 0 deletions noir/noir-repo/CHANGELOG.md

Large diffs are not rendered by default.

59 changes: 30 additions & 29 deletions noir/noir-repo/Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

16 changes: 8 additions & 8 deletions noir/noir-repo/Cargo.toml
Original file line number Diff line number Diff line change
Expand Up @@ -42,7 +42,7 @@ resolver = "2"

[workspace.package]
# x-release-please-start-version
version = "0.31.0"
version = "0.32.0"
# x-release-please-end
authors = ["The Noir Team <team@noir-lang.org>"]
edition = "2021"
Expand All @@ -53,13 +53,13 @@ repository = "https://github.com/noir-lang/noir/"
[workspace.dependencies]

# ACVM workspace dependencies
acir_field = { version = "0.47.0", path = "acvm-repo/acir_field", default-features = false }
acir = { version = "0.47.0", path = "acvm-repo/acir", default-features = false }
acvm = { version = "0.47.0", path = "acvm-repo/acvm" }
brillig = { version = "0.47.0", path = "acvm-repo/brillig", default-features = false }
brillig_vm = { version = "0.47.0", path = "acvm-repo/brillig_vm", default-features = false }
acvm_blackbox_solver = { version = "0.47.0", path = "acvm-repo/blackbox_solver", default-features = false }
bn254_blackbox_solver = { version = "0.47.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }
acir_field = { version = "0.48.0", path = "acvm-repo/acir_field", default-features = false }
acir = { version = "0.48.0", path = "acvm-repo/acir", default-features = false }
acvm = { version = "0.48.0", path = "acvm-repo/acvm" }
brillig = { version = "0.48.0", path = "acvm-repo/brillig", default-features = false }
brillig_vm = { version = "0.48.0", path = "acvm-repo/brillig_vm", default-features = false }
acvm_blackbox_solver = { version = "0.48.0", path = "acvm-repo/blackbox_solver", default-features = false }
bn254_blackbox_solver = { version = "0.48.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }

# Noir compiler workspace dependencies
fm = { path = "compiler/fm" }
Expand Down
Loading

0 comments on commit ed49eab

Please sign in to comment.