Skip to content

Commit

Permalink
py-jsbeautifier: Update wip/py-jsbeautifier to 1.6.12
Browse files Browse the repository at this point in the history
pkgsrc changes:
 - Use ALTERNATIVES in order to permit multi-pkgs to coexists and adjust
   PLIST and introduce Makefile post-install target accordingly

Changes:
* CSS: Preserve Newlines ([#537](beautifier/js-beautify#537))

Reverted #1117 - Preserve newlines broken

* On beautify, new line before next CSS selector ([#1142](beautifier/js-beautify#1142))

Added `preserver_newlines` to css beautifier

* Fixed html formatting issue with attribute wrap (Thanks, @HookyQR!)
* Fixed python package publishing

* Wrong HTML beautification starting with v1.6.5 ([#1115](beautifier/js-beautify#1115))
* Ignore linebreak when meet handlebar ([#1104](beautifier/js-beautify#1104))
* Lines are not un-indented correctly when attributes are wrapped ([#1103](beautifier/js-beautify#1103))
* force-aligned is not aligned when indenting with tabs ([#1102](beautifier/js-beautify#1102))
* Python package fails to publish  ([#1101](beautifier/js-beautify#1101))
* Explaination of 'operator_position' is absent from README.md ([#1047](beautifier/js-beautify#1047))

* Fixed a batch of comment and semicolon-less code bugs

* Incorrect indentation after loop with comment ([#1090](beautifier/js-beautify#1090))
* Extra newline is inserted after beautifying code with anonymous function ([#1085](beautifier/js-beautify#1085))
* end brace with next comment line make bad indent ([#1043](beautifier/js-beautify#1043))
* Javascript comment in last line doesn't beautify well ([#964](beautifier/js-beautify#964))
* indent doesn't work with comment (jsdoc) ([#913](beautifier/js-beautify#913))
* Wrong indentation, when new line between chained methods ([#892](beautifier/js-beautify#892))
* Comments in a non-semicolon style have extra indent ([#815](beautifier/js-beautify#815))
* [bug] Incorrect indentation due to commented line(s) following a function call with a function argument. ([#713](beautifier/js-beautify#713))
* Wrong indent formatting ([#569](beautifier/js-beautify#569))

Added `content_unformatted` option (Thanks @arai-a)

* HTML pre code indentation ([#928](beautifier/js-beautify#928))
* Beautify script/style tags but ignore their inner JS/CSS content ([#906](beautifier/js-beautify#906))

* Added support for editorconfig from stdin
* Added js-beautify to cdnjs
* Fixed CRLF to LF for HTML and CSS on windows
* Added inheritance/overriding to config format (Thanks @DaniGuardiola and @HookyQR)
* Added `force-align` to `wrap-attributes` (Thanks @LukinoS)
* Added `force-expand-multiline` to `wrap-attributes` (Thanks @tobias-zucali)
* Added `preserve-inline` as independent brace setting (Thanks @Coburn37)
* Fixed handlebars with angle-braces (Thanks @mmsqe)

* Wrong indentation for comment after nested unbraced control constructs ([#1079](beautifier/js-beautify#1079))
* Should prefer breaking the line after operator ? instead of before operator < ([#1073](beautifier/js-beautify#1073))
* New option "force-expand-multiline" for "wrap_attributes" ([#1070](beautifier/js-beautify#1070))
* Breaks if html file starts with comment ([#1068](beautifier/js-beautify#1068))
* collapse-preserve-inline restricts users to collapse brace_style ([#1057](beautifier/js-beautify#1057))
* Parsing failure on numbers with "e" ([#1054](beautifier/js-beautify#1054))
* Issue with Browser Instructions ([#1053](beautifier/js-beautify#1053))
* Add preserve inline function for expand style braces ([#1052](beautifier/js-beautify#1052))
* Update years in LICENSE ([#1038](beautifier/js-beautify#1038))
* JS. Switch with template literals. Unexpected indentation. ([#1030](beautifier/js-beautify#1030))
* The object with spread object formatted not correctly ([#1023](beautifier/js-beautify#1023))
* Bad output generator function in class ([#1013](beautifier/js-beautify#1013))
* Support editorconfig for stdin ([#1012](beautifier/js-beautify#1012))
* Publish to cdnjs ([#992](beautifier/js-beautify#992))
* breaks if handlebars comments contain handlebars tags ([#930](beautifier/js-beautify#930))
* Using jsbeautifyrc is broken ([#929](beautifier/js-beautify#929))
* Option to put HTML attributes on their own lines, aligned ([#916](beautifier/js-beautify#916))
* Erroneously changes CRLF to LF on Windows in HTML and CSS ([#899](beautifier/js-beautify#899))
* Weird space in {get } vs { normal } ([#888](beautifier/js-beautify#888))
* Bad for-of formatting with constant Array ([#875](beautifier/js-beautify#875))
* Problems with filter property in css and scss ([#755](beautifier/js-beautify#755))
* Add "collapse-one-line" option for non-collapse brace styles  ([#487](beautifier/js-beautify#487))
  • Loading branch information
iamleot committed Apr 14, 2017
1 parent 3a33f18 commit 99e2edb
Show file tree
Hide file tree
Showing 4 changed files with 10 additions and 6 deletions.
1 change: 1 addition & 0 deletions py-jsbeautifier/ALTERNATIVES
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
bin/js-beautify @PREFIX@/bin/js-beautify-@PYVERSSUFFIX@
5 changes: 4 additions & 1 deletion py-jsbeautifier/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD$

DISTNAME= jsbeautifier-1.6.4
DISTNAME= jsbeautifier-1.6.12
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_PYPI:=j/jsbeautifier/}
Expand All @@ -15,5 +15,8 @@ DEPENDS+= ${PYPKGPREFIX}-six>=1.6.1:../../lang/py-six

USE_LANGUAGES= # none

post-install:
${MV} ${DESTDIR}${PREFIX}/bin/js-beautify ${DESTDIR}${PREFIX}/bin/js-beautify-${PYVERSSUFFIX} || ${TRUE}

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"
2 changes: 1 addition & 1 deletion py-jsbeautifier/PLIST
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
@comment $NetBSD$
bin/js-beautify
bin/js-beautify-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand Down
8 changes: 4 additions & 4 deletions py-jsbeautifier/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD$

SHA1 (jsbeautifier-1.6.4.tar.gz) = c16805d2cc6d7710b128b1b6f451d9df32b42b61
RMD160 (jsbeautifier-1.6.4.tar.gz) = 1728ebfc50ff56ecd371dde0cb44a8d0c3d6eb2e
SHA512 (jsbeautifier-1.6.4.tar.gz) = d58f4f0fb7f7a114891a8218c423b2fadaf2b6e1259f9ddf9e417564dcdb082f66ed24a924ba785784fdf02a7d8e3c851666f4c25e2fd6a0861ce34872a3196f
Size (jsbeautifier-1.6.4.tar.gz) = 51139 bytes
SHA1 (jsbeautifier-1.6.12.tar.gz) = 61307c7de64f9cb5e2eed79585e5aeb606c85289
RMD160 (jsbeautifier-1.6.12.tar.gz) = 46f2f79018fdc30e0b8bcea6728c1719bbad6e36
SHA512 (jsbeautifier-1.6.12.tar.gz) = b9281dd807f11f4bc419e7bfb55652471393be39daa61f0b72ae607864952a8ae576832d757ac31847eb8364c7cc08ed0899c8911c3416775359de4522c28824
Size (jsbeautifier-1.6.12.tar.gz) = 55636 bytes

0 comments on commit 99e2edb

Please sign in to comment.