Skip to content

Commit

Permalink
consul: Update to 1.5.0
Browse files Browse the repository at this point in the history
SECURITY:

* connect: Envoy versions lower than 1.9.1 are vulnerable to CVE-2019-9900
  and CVE-2019-9901. Both are related to HTTP request parsing and so only
  affect Consul Connect users if they have configured HTTP routing rules
  via the "escape hatch". We recommend Envoy 1.9.1 be used. Note that while
  we officially deprecate support for older version of Envoy in 1.5.0, we
  recommend using Envoy 1.9.1 with all previous versions of Consul Connect
  too (back to 1.3.0 where Envoy support was introduced).

BREAKING CHANGES:

* /watch: (note this only affects downstream programs importing /watch
  package as a library not the watch feature in Consul) The watch package
  was moved from github.com/hashicorp/consul/watch to
  github.com/hashicorp/consul/api/watch to live in the API module. This was
  necessary after updating the repo to use Go modules or else various other
  bugs cropped up. The watch package API has not changed so projects
  depending on it should need to only update the import statement to get
  their code functioning again. [GH-5664]
* ui: Legacy UI has been removed. Setting the CONSUL_UI_LEGACY environment
  variable to 1 or true will no longer revert to serving the old
  UI. [GH-5643]

FEATURES:

* Connect Envoy Supports L7 Observability: We introduce features that allow
  configuring Envoy sidecars to emit metrics and tracing at L7 (http,
  http2, grpc supported). For more information see the Envoy Integration
  docs.
* Centralized Configuration: Enables central configuration of some service
  and proxy defaults. For more information see the Configuration Entries
  docs
* api: Implement data filtering for some endpoints using a new filtering
  language. [GH-5579]
* snapshot agent (Consul Enterprise): Added support for saving snapshots to
  Azure Blob Storage.
* acl: tokens can be created with an optional expiration time [GH-5353]
* acl: tokens can now be assigned an optional set of service identities
  [GH-5390]
* acl: tokens can now be assigned to roles [GH-5514]
* acl: adding support for kubernetes auth provider login [GH-5600]
* ui: Template-able Dashboard links for Service detail pages [GH-5704]
  [GH-5777]
* ui: support for ACL Roles [GH-5635]

IMPROVEMENTS:

* cli: allow to add ip addresses as Subject Alternative Names when creating
  certificates with consul tls cert create [GH-5602]
* dns: Allow for hot-reload of many DNS configurations. [GH-4875]
* agent: config is now read if json or hcl is set as the config-format or
  the extension is either json or hcl [GH-5723]
* acl: Allow setting token accessor ids and secret ids during token
  creation. [[GH-4977] (hashicorp/consul#4977)]
* ui: Service Instances page redesign and further visibility of Connect
  Proxies [GH-5326]
* ui: Blocking Query support / live updates for Services and Nodes,
  requires enabling per user via the UI Settings area [GH-5070] [GH-5267]
* ui: Finer grained searching for the Service listing page [GH-5507]
* ui: Add proxy icons to proxy services and instances where appropriate
  [GH-5463]

BUG FIXES:

* api: fix panic in 'consul acl set-agent-token' [GH-5533]
* api: fix issue in the transaction API where the health check definition
  struct wasn't being deserialized properly [GH-5553]
* acl: memdb filter of tokens-by-policy was inverted [GH-5575]
* acl: Fix legacy rules translation for JSON based rules. [GH-5493]
* agent: Fixed a bug causing RPC errors when the discovery_max_stale time
  was exceeded. [GH-4673]
* agent: Fix an issue with registering health checks for an agent service
  where the service name would be missing. [GH-5705]
* connect: fix an issue where Envoy would fail to bootstrap if some
  upstreams were unavailable [GH-5499]
* connect: fix an issue where health checks on proxies might be missed by
  watchers of /health/service/:service API [GH-5506]
* connect: fix a race condition that could leave proxies with no
  configuration for long periods on startup [GH-5793]
* logger: fix an issue where the log-file option was not respecting the
  log-level [GH-4778]
* catalog: fix an issue where renaming nodes could cause registration
  instability [GH-5518]
* network areas (Consul Enterprise): Fixed an issue that could cause a lock
  to be held unnecessarily causing other operations to hang.
  • Loading branch information
iquiw committed May 11, 2019
1 parent a6f3037 commit cc50bef
Show file tree
Hide file tree
Showing 2 changed files with 5 additions and 6 deletions.
3 changes: 1 addition & 2 deletions consul/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD$

DISTNAME= consul-1.4.4
PKGREVISION= 1
DISTNAME= consul-1.5.0
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GITHUB:=hashicorp/}

Expand Down
8 changes: 4 additions & 4 deletions consul/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD$

SHA1 (consul-1.4.4.tar.gz) = fa1aa8a14bb2104dece84e1d059c829166c605b0
RMD160 (consul-1.4.4.tar.gz) = 0fd2879b5c5cc4b29d8cd84a2e5b54957460890f
SHA512 (consul-1.4.4.tar.gz) = d3e5dd536726976b705fe4c78c67eaf345b8f47225919c0ca1609d75e74343d9a16d893ef4cd5140998f23b3149cfa60f5b432ed9a7251bb3b232be9b65e7241
Size (consul-1.4.4.tar.gz) = 22736827 bytes
SHA1 (consul-1.5.0.tar.gz) = 97faed32e3985cc0b23b7044ff2bae8a8092ca91
RMD160 (consul-1.5.0.tar.gz) = d8b4e5299b4663f50198df852ce43cf72ca78c31
SHA512 (consul-1.5.0.tar.gz) = 8cefb77b56b27995bba38517144bf42585bd1d9ad9a10fc0c9b6bc1a87bfbd042e336ed5e945cfce1fb8eb4b8162dbc8246e2b4109dea5767b8745a7b2159ef8
Size (consul-1.5.0.tar.gz) = 20830405 bytes

0 comments on commit cc50bef

Please sign in to comment.