Skip to content

Commit

Permalink
Update chat/matrix-synapse to 1.77.0
Browse files Browse the repository at this point in the history
Synapse 1.77.0 (2023-02-14)
===========================

No significant changes since 1.77.0rc2.


Synapse 1.77.0rc2 (2023-02-10)
==============================

Bugfixes
--------

- Fix bug where retried replication requests would return a failure. Introduced in v1.76.0. ([\#15024](matrix-org/synapse#15024))


Internal Changes
----------------

- Prepare for future database schema changes. ([\#15036](matrix-org/synapse#15036))


Synapse 1.77.0rc1 (2023-02-07)
==============================

Features
--------

- Experimental support for [MSC3952](matrix-org/matrix-spec-proposals#3952): intentional mentions. ([\#14823](matrix-org/synapse#14823), [\#14943](matrix-org/synapse#14943), [\#14957](matrix-org/synapse#14957), [\#14958](matrix-org/synapse#14958))
- Experimental support to suppress notifications from message edits ([MSC3958](matrix-org/matrix-spec-proposals#3958)). ([\#14960](matrix-org/synapse#14960), [\#15016](matrix-org/synapse#15016))
- Add profile information, devices and connections to the command line [user data export tool](https://matrix-org.github.io/synapse/v1.77/usage/administration/admin_faq.html#how-can-i-export-user-data). ([\#14894](matrix-org/synapse#14894))
- Improve performance when joining or sending an event in large rooms. ([\#14962](matrix-org/synapse#14962))
- Improve performance of joining and leaving large rooms with many local users. ([\#14971](matrix-org/synapse#14971))


Bugfixes
--------

- Fix a bug introduced in Synapse 1.53.0 where `next_batch` tokens from `/sync` could not be used with the `/relations` endpoint. ([\#14866](matrix-org/synapse#14866))
- Fix a bug introduced in Synapse 1.35.0 where the module API's `send_local_online_presence_to` would fail to send presence updates over federation. ([\#14880](matrix-org/synapse#14880))
- Fix a bug introduced in Synapse 1.70.0 where the background updates to add non-thread unique indexes on receipts could fail when upgrading from 1.67.0 or earlier. ([\#14915](matrix-org/synapse#14915))
- Fix a regression introduced in Synapse 1.69.0 which can result in database corruption when database migrations are interrupted on sqlite. ([\#14926](matrix-org/synapse#14926))
- Fix a bug introduced in Synapse 1.68.0 where we were unable to service remote joins in rooms with `@room` notification levels set to `null` in their (malformed) power levels. ([\#14942](matrix-org/synapse#14942))
- Fix a bug introduced in Synapse 1.64.0 where boolean power levels were erroneously permitted in [v10 rooms](https://spec.matrix.org/v1.5/rooms/v10/). ([\#14944](matrix-org/synapse#14944))
- Fix a long-standing bug where sending messages on servers with presence enabled would spam "Re-starting finished log context" log lines. ([\#14947](matrix-org/synapse#14947))
- Fix a bug introduced in Synapse 1.68.0 where logging from the Rust module was not properly logged. ([\#14976](matrix-org/synapse#14976))
- Fix various long-standing bugs in Synapse's config, event and request handling where booleans were unintentionally accepted where an integer was expected. ([\#14945](matrix-org/synapse#14945))


Internal Changes
----------------

- Add missing type hints. ([\#14879](matrix-org/synapse#14879), [\#14886](matrix-org/synapse#14886), [\#14887](matrix-org/synapse#14887), [\#14904](matrix-org/synapse#14904), [\#14927](matrix-org/synapse#14927), [\#14956](matrix-org/synapse#14956), [\#14983](matrix-org/synapse#14983), [\#14984](matrix-org/synapse#14984), [\#14985](matrix-org/synapse#14985), [\#14987](matrix-org/synapse#14987), [\#14988](matrix-org/synapse#14988), [\#14990](matrix-org/synapse#14990), [\#14991](matrix-org/synapse#14991), [\#14992](matrix-org/synapse#14992), [\#15007](matrix-org/synapse#15007))
- Use `StrCollection` to avoid potential bugs with `Collection[str]`. ([\#14922](matrix-org/synapse#14922))
- Allow running the complement tests suites with the asyncio reactor enabled. ([\#14858](matrix-org/synapse#14858))
- Improve performance of `/sync` in a few situations. ([\#14908](matrix-org/synapse#14908), [\#14970](matrix-org/synapse#14970))
- Document how to handle Dependabot pull requests. ([\#14916](matrix-org/synapse#14916))
- Fix typo in release script. ([\#14920](matrix-org/synapse#14920))
- Update build system requirements to allow building with poetry-core 1.5.0. ([\#14949](matrix-org/synapse#14949), [\#15019](matrix-org/synapse#15019))
- Add an [lnav](https://lnav.org) config file for Synapse logs to `/contrib/lnav`. ([\#14953](matrix-org/synapse#14953))
- Faster joins: Refactor internal handling of servers in room to never store an empty list. ([\#14954](matrix-org/synapse#14954))
- Faster joins: tag `v2/send_join/` requests to indicate if they served a partial join response. ([\#14950](matrix-org/synapse#14950))
- Allow running `cargo` without the `extension-module` option. ([\#14965](matrix-org/synapse#14965))
- Preparatory work for adding a denormalised event stream ordering column in the future. Contributed by Nick @ Beeper (@Fizzadar). ([\#14979](matrix-org/synapse#14979), [9cd7610](matrix-org/synapse@9cd7610), [f10caa7](matrix-org/synapse@f10caa7); see [\#15014](matrix-org/synapse#15014))
- Add tests for `_flatten_dict`. ([\#14981](matrix-org/synapse#14981), [\#15002](matrix-org/synapse#15002))

<details><summary>Locked dependency updates</summary>

- Bump dtolnay/rust-toolchain from e645b0cf01249a964ec099494d38d2da0f0b349f to 9cd00a88a73addc8617065438eff914dd08d0955. ([\#14968](matrix-org/synapse#14968))
- Bump docker/build-push-action from 3 to 4. ([\#14952](matrix-org/synapse#14952))
- Bump ijson from 3.1.4 to 3.2.0.post0. ([\#14935](matrix-org/synapse#14935))
- Bump types-pyyaml from 6.0.12.2 to 6.0.12.3. ([\#14936](matrix-org/synapse#14936))
- Bump types-jsonschema from 4.17.0.2 to 4.17.0.3. ([\#14937](matrix-org/synapse#14937))
- Bump types-pillow from 9.4.0.3 to 9.4.0.5. ([\#14938](matrix-org/synapse#14938))
- Bump hiredis from 2.0.0 to 2.1.1. ([\#14939](matrix-org/synapse#14939))
- Bump hiredis from 2.1.1 to 2.2.1. ([\#14993](matrix-org/synapse#14993))
- Bump types-setuptools from 65.6.0.3 to 67.1.0.0. ([\#14994](matrix-org/synapse#14994))
- Bump prometheus-client from 0.15.0 to 0.16.0. ([\#14995](matrix-org/synapse#14995))
- Bump anyhow from 1.0.68 to 1.0.69. ([\#14996](matrix-org/synapse#14996))
- Bump serde_json from 1.0.91 to 1.0.92. ([\#14997](matrix-org/synapse#14997))
- Bump isort from 5.11.4 to 5.11.5. ([\#14998](matrix-org/synapse#14998))
- Bump phonenumbers from 8.13.4 to 8.13.5. ([\#14999](matrix-org/synapse#14999))
</details>
  • Loading branch information
Midar committed Mar 1, 2023
1 parent eaf92af commit 1cf80f5
Show file tree
Hide file tree
Showing 3 changed files with 15 additions and 15 deletions.
4 changes: 2 additions & 2 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.71 2023/02/05 20:53:26 js Exp $
# $NetBSD: Makefile,v 1.72 2023/03/01 20:47:37 js Exp $

DISTNAME= matrix-synapse-1.76.0
DISTNAME= matrix-synapse-1.77.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
GITHUB_PROJECT= synapse
Expand Down
6 changes: 3 additions & 3 deletions chat/matrix-synapse/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: cargo-depends.mk,v 1.7 2023/02/05 20:53:26 js Exp $
# $NetBSD: cargo-depends.mk,v 1.8 2023/03/01 20:47:37 js Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-0.7.19
CARGO_CRATE_DEPENDS+= anyhow-1.0.68
CARGO_CRATE_DEPENDS+= anyhow-1.0.69
CARGO_CRATE_DEPENDS+= arc-swap-1.5.1
CARGO_CRATE_DEPENDS+= autocfg-1.1.0
CARGO_CRATE_DEPENDS+= bitflags-1.3.2
Expand Down Expand Up @@ -39,7 +39,7 @@ CARGO_CRATE_DEPENDS+= ryu-1.0.11
CARGO_CRATE_DEPENDS+= scopeguard-1.1.0
CARGO_CRATE_DEPENDS+= serde-1.0.152
CARGO_CRATE_DEPENDS+= serde_derive-1.0.152
CARGO_CRATE_DEPENDS+= serde_json-1.0.91
CARGO_CRATE_DEPENDS+= serde_json-1.0.92
CARGO_CRATE_DEPENDS+= smallvec-1.10.0
CARGO_CRATE_DEPENDS+= subtle-2.4.1
CARGO_CRATE_DEPENDS+= syn-1.0.104
Expand Down
20 changes: 10 additions & 10 deletions chat/matrix-synapse/distinfo
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.52 2023/02/05 20:53:26 js Exp $
$NetBSD: distinfo,v 1.53 2023/03/01 20:47:37 js Exp $

BLAKE2s (aho-corasick-0.7.19.crate) = b13c5789625903a58cfdb854bca6eb074329fde83ffb2581686f105d52d31996
SHA512 (aho-corasick-0.7.19.crate) = 0d63d29079650bde4e8a9f8529716b9d8c42db076a1d74715116240c2628173f1e86fb29c08a25ad07a0148e48789ab20de0c186a8b3dfb193cbfeb0d76ae78c
Size (aho-corasick-0.7.19.crate) = 113070 bytes
BLAKE2s (anyhow-1.0.68.crate) = 79593a6a8f5559833825e9341680bb8b1dafe01e70c99d0f014175fbe2828e71
SHA512 (anyhow-1.0.68.crate) = b8cfc132ebeac823edf18cba7e335d1939fcbb095ed4ea859f4dc4cde5b1ff35fd68f0743577c69085f74f019768a3359936bf6dc1b2aceb7e2b28ace7f74a0f
Size (anyhow-1.0.68.crate) = 43882 bytes
BLAKE2s (anyhow-1.0.69.crate) = b160fbd1ad83a1b3e26611c8e3980f3c41ddce9a7a76b3efafdbaf8c0ebbd60e
SHA512 (anyhow-1.0.69.crate) = d65e5c9404a70b1e0af90dd66af157f8c31ad0858f703765d5fc6c828f1fc8db690b17451c4108e3a52a7da2d6c2366e745d7b4bd7d19e6dba3485f7c3a43071
Size (anyhow-1.0.69.crate) = 43576 bytes
BLAKE2s (arc-swap-1.5.1.crate) = ae85262e8fa11faea978acbbbfd65351c2519cd73be05fbb2bcdf7527927e4fc
SHA512 (arc-swap-1.5.1.crate) = 8636149e92c068d5ff5352a19c9973e7bf2aba68b9363c783178903a8665f6edabbd30c25ad7992646635efe5830d67c958f8d41b44a4ed1fe5698628b41c074
Size (arc-swap-1.5.1.crate) = 66157 bytes
Expand Down Expand Up @@ -54,9 +54,9 @@ Size (lock_api-0.4.9.crate) = 25685 bytes
BLAKE2s (log-0.4.17.crate) = 6994234f481cfe97b62255329a6c6f4a07dcdb193cc54d2c7ddda0519b41d214
SHA512 (log-0.4.17.crate) = 2477d88db42b1d92c30708d88823212e236f613b3465e85eb425f83f8d16fadfaf0352f06c2999a1852102edd2f6ffb10ecb539d8a3b6c48f552a25622ccffa2
Size (log-0.4.17.crate) = 38028 bytes
BLAKE2s (matrix-synapse-1.76.0.tar.gz) = 0813dac4bb41a151a26708583e42e3f75f2878a95442e1100ac5ead5b455950a
SHA512 (matrix-synapse-1.76.0.tar.gz) = c29d4f0d91c415e5bf908e06892e631c04bcf774cd2d699cac919e86fdcfac4c0ff2a75832738b3c874b8fb6126f31dec5d038dc4d126f05c1ca0fba5583d91d
Size (matrix-synapse-1.76.0.tar.gz) = 8159151 bytes
BLAKE2s (matrix-synapse-1.77.0.tar.gz) = c7114344138733dbbc4a690dd8bc09205d66b131b70a1078afa9a5a5e2fe4e92
SHA512 (matrix-synapse-1.77.0.tar.gz) = 7e9efda255e44efb1916c903ece4d6eacc4ee069d4415bc0bd2723aef655101cfe40be9cfd1a321b1f434e6df0482c792d2dbba8b6c05c1f1ce14cac0a16926b
Size (matrix-synapse-1.77.0.tar.gz) = 8180884 bytes
BLAKE2s (memchr-2.5.0.crate) = afa77d7fdf25c72d251cda6b41f3fe065a748b101e3716aa65f0d6144f74da38
SHA512 (memchr-2.5.0.crate) = 444a163b484c233e78c0e2e4d51f01ce2da93d7d29f516a95e4b0866b20bdfd3f34137653abed53eb70387991ee3e2b5937d8d4360a85bbcb50a93005a75defa
Size (memchr-2.5.0.crate) = 65812 bytes
Expand Down Expand Up @@ -120,9 +120,9 @@ Size (serde-1.0.152.crate) = 77091 bytes
BLAKE2s (serde_derive-1.0.152.crate) = 7d9338a207fef91ddad2a810cb756832ee8fa19bcebbb0325c7378d34c10c670
SHA512 (serde_derive-1.0.152.crate) = 2f4dffb5671b4758f0b7dc0939f6b5cfe3b3ba02a53c62c75b5a0ec89d2db26bdd95f3e269d1fd4b07ec921bc0ca5f0741c26fdfcd25bd6532ac698c6c701e91
Size (serde_derive-1.0.152.crate) = 55586 bytes
BLAKE2s (serde_json-1.0.91.crate) = cecbe5087e15751e9e61b8f16667e488c3d37a92d234e54376915d39ef649c97
SHA512 (serde_json-1.0.91.crate) = b0bfa3d64fe9fb0d09ec8dcb6e41eba75ad0f0c4e34e0ffd5e2a3230057d7499a57ffda8c1615bea5195ef398afe414f3b0a143a39865123c1c5f976ea1a0337
Size (serde_json-1.0.91.crate) = 144654 bytes
BLAKE2s (serde_json-1.0.92.crate) = fe2cc421f5ef9b151e9f9367465dc0befd910e080dac19587fa5c7addd6d79d7
SHA512 (serde_json-1.0.92.crate) = 4fa760e4105484af6def828894a216059f037ca0286555e4f1ac56e9442ed781bb4ed5c286d264910602992d66cda0d0c15a077d394c21b148b39b389d2f1ee3
Size (serde_json-1.0.92.crate) = 144180 bytes
BLAKE2s (smallvec-1.10.0.crate) = 41329e6ed51a5092aa320d548b7b5f9f343f67bd54472d6fbc30a39ad5128860
SHA512 (smallvec-1.10.0.crate) = a09110184582dcc01d7a0d3fa8f74c17bf726935126d3654667b8e9c4bc43ad16ccfd8fa94feae7d9b31913aa7ee030fe5936e4b44a36302b6ce5fe37372a7ae
Size (smallvec-1.10.0.crate) = 31564 bytes
Expand Down

0 comments on commit 1cf80f5

Please sign in to comment.