Skip to content

Commit

Permalink
archivers/ruby-xz: update to 1.0.0
Browse files Browse the repository at this point in the history
== 1.0.0 (2018-05-20)

* *BreakingChange* The XZ module's methods now take any parameters
  beyond the IO object as real Ruby keyword arguments rather than
  a long argument list.
* *BreakingChange* XZ.decompress_stream now honours Ruby's
  external and internal encoding concept instead of just
  returning BINARY-tagged strings.
* *BreakingChange* Remove deprecated API on stream reader/writer
  class and instead sync the API with Ruby's zlib library
  (Ticket #12 by me).
* *BreakingChange* StreamWriter.new and StreamReader.new do not accept
  a block anymore. This is part of syncing with Ruby's zlib API.
* *BreakingChange* StreamReader.open and StreamWriter.open always
  return the new instance, even if a block is given to the method
  (previous behaviour was to return the return value of the block).
  This is part of the syncing with Ruby's zlib API.
* *BreakingChange* StreamReader.new and StreamWriter.new as well as
  the ::open variants take additional arguments as real Ruby keyword
  arguments now instead of a long parameter list plus options hash.
  This is different from Ruby's own zlib API as that one takes both
  a long parameter list and a hash of additional options. ruby-xz
  is meant to follow zlib's semantics mostly, but not as a drop-in
  replacement, so this divergence from zlib's API is okay (also
  given that it isn't possible to replicate all possible options
  1:1 anyway, since liblzma simply accepts different options as
  libz). If you've never used these methods' optional arguments,
  you should be fine.
* *BreakingChange* Stream#close now returns nil instead of the
  number of bytes written. This syncs Stream#close with Ruby's
  own IO#close, which also returns nil.
* *BreakingChange* Remove Stream#pos=, Stream#seek, Stream#stat. These
  methods irritated the minitar gem, which doesn't expect them to
  raise NotImplementedError, but directly to be missing if the object
  does not support seeking.
* *BreakingChange* StreamReader and StreamWriter now honour Ruby's
  encoding system instead of returning only BINARY-tagged strings.
* *Dependency* Remove dependency on ffi. ruby-xz now uses fiddle from
  the stdlib instead.
* *Dependency* Remove dependency on io-like. ruby-xz now implements
  all the IO mechanics itself. (Ticket #10 by me)
* *Dependency* Bump required Ruby version to 2.3.0.
* *Fix* libzlma.dylib not being found on OS X (Ticket #15 by
  s0nspark).
  • Loading branch information
taca committed Sep 23, 2018
1 parent 4750c79 commit 205343e
Show file tree
Hide file tree
Showing 4 changed files with 11 additions and 27 deletions.
8 changes: 3 additions & 5 deletions archivers/ruby-xz/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.13 2016/01/03 05:31:55 taca Exp $
# $NetBSD: Makefile,v 1.14 2018/09/23 13:44:11 taca Exp $

DISTNAME= ruby-xz-0.2.3
DISTNAME= ruby-xz-1.0.0
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:S/ruby-//}
CATEGORIES= archivers

Expand All @@ -9,9 +9,7 @@ HOMEPAGE= https://github.com/Quintus/ruby-xz
COMMENT= Ruby bindings for liblzma
LICENSE= mit

DEPENDS+= xz-[0-9]*:../../archivers/xz
DEPENDS+= ${RUBY_PKGPREFIX}-ffi-[0-9]*:../../devel/ruby-ffi
DEPENDS+= ${RUBY_PKGPREFIX}-io-like-[0-9]*:../../devel/ruby-io-like
DEPENDS+= ${RUBY_NAME}-fiddle>=${RUBY_VERSION}:../../devel/ruby-fiddle

SUBST_CLASSES+= path
SUBST_STAGE.path= pre-configure
Expand Down
5 changes: 3 additions & 2 deletions archivers/ruby-xz/PLIST
Original file line number Diff line number Diff line change
@@ -1,10 +1,11 @@
@comment $NetBSD: PLIST,v 1.4 2016/01/03 05:31:55 taca Exp $
@comment $NetBSD: PLIST,v 1.5 2018/09/23 13:44:11 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/AUTHORS
${GEM_LIBDIR}/COPYING
${GEM_LIBDIR}/HISTORY.rdoc
${GEM_LIBDIR}/LICENSE
${GEM_LIBDIR}/README.md
${GEM_LIBDIR}/lib/xz.rb
${GEM_LIBDIR}/lib/xz/fiddle_helper.rb
${GEM_LIBDIR}/lib/xz/lib_lzma.rb
${GEM_LIBDIR}/lib/xz/stream.rb
${GEM_LIBDIR}/lib/xz/stream_reader.rb
Expand Down
10 changes: 5 additions & 5 deletions archivers/ruby-xz/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.7 2016/01/03 05:31:55 taca Exp $
$NetBSD: distinfo,v 1.8 2018/09/23 13:44:11 taca Exp $

SHA1 (ruby-xz-0.2.3.gem) = ca7f717d02a3a59ca9442c55f9e2ab4125ed46b8
RMD160 (ruby-xz-0.2.3.gem) = 726aa6e89f44f171014731a4dc698bcb2d8b867f
SHA512 (ruby-xz-0.2.3.gem) = 68ddd53d2f3f42f179f529c9aeadb8040216d7de44d63692ef0b50ba5085baad417e61e5f61a38ff8817e966af59f00177fd4016514e93409e6be4c3fa988a8d
Size (ruby-xz-0.2.3.gem) = 20480 bytes
SHA1 (ruby-xz-1.0.0.gem) = cb3e7b3c9984f047772707c35b4ab877e5adb87e
RMD160 (ruby-xz-1.0.0.gem) = 5c3016a10ebd7ccee4b8f251e7f576425016bedb
SHA512 (ruby-xz-1.0.0.gem) = daa39268f0a48a0b87ee11528e7558dfa3629ee04570ff20acc4a5b632451fa13c06e1319b6e8772893137f727aa9fa76b58a9a1a39e51a9c6e536d9c49aa228
Size (ruby-xz-1.0.0.gem) = 24576 bytes
SHA1 (patch-lib_xz_lib__lzma.rb) = f0ab463ffab401a935551b560af28e26bff8d4eb
15 changes: 0 additions & 15 deletions archivers/ruby-xz/patches/patch-lib_xz_lib__lzma.rb

This file was deleted.

0 comments on commit 205343e

Please sign in to comment.