Skip to content

Commit

Permalink
Update math/sollya to version 8.0.
Browse files Browse the repository at this point in the history
Changes from version 7.0 to 8.0:
================================
Changes of syntax and output:
  * Hexadecimal constants ending on '+' or '-' (e.g., 0x123p-) now
    provoke a syntax error (as it always should have).
  * The match construct on error now matches (it used to return
    error).
  * In certain cases, procedures could not be applied to an empty set
    of arguments because a syntax error occurred before. This is now
    possible.
  * The meaning and use of infinities and signed zeros in intervals
    has been changed (see documentation for details).
  * Input and output of decimal constants is now fully exact in
    rationalmode. In all other instances, a warning message is now
    produced when an internal constant gets printed in decimal and a
    rounding occurs.

Critical bug fixes:
  * Making Sollya compile again with recent versions of fplll (at
    least on the Linux side).

Improvements in internal handling:
  * Improved performance on manipulation of polynomials.

Major bug fixes:
  * Patched a bug in interval erfc.
  * Patched a bug preventing match to work on unary minus.

Major new functionalities:
  * The interpolate command allows for polynomial interpolation with
    and without error (see documentation for details).
  * The bezout command allows for computation of a gcd along with
    matching cofactors (see documentation for details).

Minor new functionalities:
  * The externaldata command now allows generic external library
    symbols to be bound to Sollya objects (see documentation for
    details).
  * Improvements on use of the L'Hopital rule for function
    evaluations.
  * When started as an interactive tool or as a library, Sollya now
    binds the executable's 0th argument to the Sollya identifier
    __program_name.
  * In situations when the user wishes to provide the minimax with
    real coefficients to fpminimax, it is now possible to give a list
    of coefficients instead of the expression of the real minimax (see
    documentation for details).
  * The free mathematical variable can now be unbound with the rename
    command (see documentation for details).
  * The bind command now allows for procedures with an arbitrary
    number of arguments (see documentation for details).
  * The char *sollya_lib_get_help_text(char *topic) function now
    allows for access to the help text of a certain topic.

Others:
  * In certain circumstances, the printing of a list may have had
    quadratic complexity in the past. This has been corrected.
  * If the compiler supports the -flto flag; this option is disabled
    by default though. To enable LTO compilation, use
    --enable-lto-compilation. On certain systems the -flto flag is
    supported by the compiler but LTO compilation fails. In this case,
    it is recommended not to enable LTO compilation.
  * dirtyfindzeros used to include in the list of zeros any point
    where the expression given as input evaluated to NaN. Such points
    are now included only when there is a real suspicion that it could
    be a true zero of the expression.
  * externalprocedure, externalfunction and externaldata entries can
    have cross-dependencies for their symbols. The tool now makes sure
    all symbols are unloaded in the precise inverse order of their
    loading, to allow for such cross-dependencies.
  * chebyshevform command can now be used out of execute() statements.
  * remez command now tries to recognize the situation when the
    optimal error function is identically 0.
  * configure now allows for cross-compilation.

Deprecated functionalities:
  * Deprecated readxml and printxml.
  * Deprecated the proof generation feature of the infnorm command.
  * Deprecated end-elliptic lists ending with a number as a format
    list in fpminimax.

And many bugs fixed.
  • Loading branch information
alnsn committed Oct 28, 2022
1 parent 50a9fbe commit 29a64d3
Show file tree
Hide file tree
Showing 6 changed files with 11 additions and 64 deletions.
10 changes: 6 additions & 4 deletions math/sollya/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.7 2022/10/28 19:59:03 alnsn Exp $
# $NetBSD: Makefile,v 1.8 2022/10/28 23:49:43 alnsn Exp $

DISTNAME= sollya-7.0
PKGREVISION= 5
DISTNAME= sollya-8.0
CATEGORIES= math
MASTER_SITES= https://www.sollya.org/releases/sollya-7.0/
MASTER_SITES= https://www.sollya.org/releases/sollya-8.0/

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://www.sollya.org/
Expand All @@ -12,8 +11,11 @@ LICENSE= cecill-2.0 AND gnu-lgpl-v3

GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= gmake
USE_LANGUAGES= c c++

CONFIGURE_ARGS+= --with-xml2-include=${PREFIX}/include/libxml2

TEST_TARGET= check

.include "../../devel/gmp/buildlink3.mk"
Expand Down
3 changes: 1 addition & 2 deletions math/sollya/PLIST
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
@comment $NetBSD: PLIST,v 1.1 2020/05/19 14:45:21 riastradh Exp $
@comment $NetBSD: PLIST,v 1.2 2022/10/28 23:49:43 alnsn Exp $
bin/sollya
include/sollya-messages.h
include/sollya.h
lib/libsollya.la
man/man1/sollya.1
share/doc/sollya/sollya.pdf
11 changes: 4 additions & 7 deletions math/sollya/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:56:08 nia Exp $
$NetBSD: distinfo,v 1.5 2022/10/28 23:49:43 alnsn Exp $

BLAKE2s (sollya-7.0.tar.gz) = fcaf6e48a6bcb67f5858035dcc4cc93d0ecfea99c192ceb797b2b1d3e71966d9
SHA512 (sollya-7.0.tar.gz) = 14dc25ffdfae16c52b335525eb26c787e561a5b9787fe65a9858e84d49f7386dfe2f7c0b7d18268a54a2f7227f506f6dbeecf7455d1ad49bef9dafbc25c30bef
Size (sollya-7.0.tar.gz) = 3722904 bytes
SHA1 (patch-configure) = 0a63ec954969fe7f78804c430f1775fb0e9e0313
SHA1 (patch-configure.ac) = 3c6c1804d1504265bf02cb6d984d6d60d39f0c16
SHA1 (patch-general.c) = 66a0175d043c25c55e33c4e771bd11902b85f973
BLAKE2s (sollya-8.0.tar.gz) = 4e64185625bf5a1f475c7088399b417039a8643018955e5c24fa7852faf1d9a3
SHA512 (sollya-8.0.tar.gz) = 6c80a1f6dc671bf7ef0fa9095dba235167f8ce279e67095834be1b81f459d6d21aa5f25037c706dd1b628a8f6a9b5c5cfef2dca1deff4254fb8f6005e1768a64
Size (sollya-8.0.tar.gz) = 4425491 bytes
17 changes: 0 additions & 17 deletions math/sollya/patches/patch-configure

This file was deleted.

17 changes: 0 additions & 17 deletions math/sollya/patches/patch-configure.ac

This file was deleted.

17 changes: 0 additions & 17 deletions math/sollya/patches/patch-general.c

This file was deleted.

0 comments on commit 29a64d3

Please sign in to comment.