Skip to content

Commit

Permalink
go-minify: Update to 2.7.3
Browse files Browse the repository at this point in the history
Changelog picked from https://github.com/tdewolff/minify/releases

v2.7.3
    external minifiers can now use input/output files instead of only stdin/stdout using the $in and $out keywords
    SVG: don't minify inside foreignObject, fixes #291

v2.7.2
    SVG: bugfix for C, S, Q, and T commands where if the control points would not overlap with the start or end points of the curve, it would still be converted to a line.

v2.7.1
    DataURI: if the original data URI is shorter than the URL-encoded/base64-encoded URI, use the original instead, fixes #282
    Bugfix: decimal (i.e. without exponentials) incorrectly minified 139.9 to 230 instead of 140

v2.7.0
    Use custom URL encode/decode functions to fix #180 and #243
    Decimal and Number now take precision to mean the number of significant digits, and not the number of digits behind the dot (decimals); includes a few subtle bugfixes. Decimals option renamed to Precision
    Move Hash definitions and EntitiesMap from tdewolff/parse to this repository to prevent releasing new versions of tdewolff/parse everytime
    cmd: add --sync functionality
    cmd: make --watch work for newly created directories
    cmd: various fixes and improved messages
    CSS: keep quotes around IE font families, fixes #251
    CSS: major refactor to allow nested functions to be minified
    CSS: improved HSL/RGB minification
    CSS: minify more properties: color, background-color, border-color, border-*-color, caret-color, outline-color, fill, stroke, column-rule, text-shadow, text-decoration, text-emphasis, flex, flex-*, order, fixes #217
    CSS: minify background better if it has multiple layers
    CSS: improve box-shadow minification
    CSS: accept CSS functions where numbers/lengths are required, such as calc, min, max, clamp, attr, var
    SVG: print new path command after bad command, fixes #275
    SVG: print A command correctly with boolean largeArc and sweep
    SVG: avoid precision errors for alternative (absolute or relative commands) path

v2.6.3
   Add install.sh and Makefile to ./cmd/minify.
   No changes to binaries (use v2.6.2).

v2.6.2
    HTML: ignore CSS minification for amp-boilerplate
    HTML: add KeepQuotes option for attributes
    XML: bugfix for recent changes to XML parser

v2.6.1
    Upgrade to tdewolff/parse@2.3.14:

    Re-parse input immediately when encountering parse error. Previously this was only done if the error was actually read which would save us from re-parsing the file (i.e. better performance). However, an error is (a) rare and (b) happens only once per file. Re-parsing on errors does not impact the performance of well formatted files, and a reliable error message is valued more.
    Bugfix: prevent infinite loop on error on input file that contains unicode code points (i.e. any character bigger than 0xC0 usually followed by more bytes).
    Improve error messages for parsers to include parser name and print offending byte(s)

v2.6.0
    CSS: remove space after function in property value; margin:calc(10px) calc(20px) => margin:calc(10px)calc(20px)
    SVG: parse A path command correctly when the booleans largeArc and sweep are not separated by a space, such as in A10 10 0 0120 0 which is equivalent to A10 10 0 0 1 20 0
    SVG bugfix: make sure we are processing a valid path command
    SVG bugfix: prevent panic when having insufficient path arguments
    cmd: surpress error when minifying empty directory
    HTML: only minify attributes for known HTML5 tags, fixes #270
    HTML, XML, SVG: minify entities with parse@2.3.13 such as: " => ", " => ", " => ", ’ => ’, ✏ => ✏.

v2.5.2
Bugfixes:
    SVG: don't convert polyline/rect/polygon/line to path, which can break CSS, fixes #260
    SVG: relative SVG Bézier commands not properly minified
    CSS: don't remove whitespace in nested unknown at-rules, fixes #262
    CSS: fix panic for background when it contains functions other than calc for background-position, fixes #263
    CSS: fix panic for background-position with three numbers
    CSS: fix panic for url() with only whitespace or only one quote

v2.5.1
    Remove import comments
    SVG: do not convert line/rect to path if coordinates are relative percentages
    CSS: fix bug with inline CSS encountering }

v2.5.0
    CSS: fix position information in error context
    CSS: fix background-position panic with offsets that are zero
    HTML: trim and collapse whitespace in certain attribute values
    SVG: shorten cubic and quadratic Beziér path data to their shorter format or to line segments

v2.4.0
    When minifying floating points, remove trailing zeros and not other numbers
    Make M concurrent-safe
    HTML: keep double quotes around XML-flavour RDFa attributes
    CSS: revert the use of the #RRGGBBAA format as proposed in Color Module Level 4 as it is not yet an official W3C recommendation
    CSS: background-position (also within background) now works with 3 and 4 values as well
    SVG: skipping metadata or rect tags properly even if they are closed by a void tag (like <rect/>)
    SVG pathdata: when cursor doesn't move, don't emit any commands
  • Loading branch information
nikkicoon committed Apr 18, 2020
1 parent b2e9b17 commit 849d1fc
Show file tree
Hide file tree
Showing 4 changed files with 39 additions and 9 deletions.
8 changes: 5 additions & 3 deletions www/go-minify/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.15 2020/04/12 11:01:50 bsiegert Exp $
# $NetBSD: Makefile,v 1.16 2020/04/18 14:56:06 nikita Exp $

DISTNAME= minify-2.3.8
DISTNAME= minify-2.7.3
PKGNAME= go-${DISTNAME}
PKGREVISION= 14
MASTER_SITES= ${MASTER_SITE_GITHUB:=tdewolff/}
CATEGORIES= www
GITHUB_PROJECT= minify
Expand All @@ -16,6 +15,9 @@ LICENSE= mit
GO_DIST_BASE= ${DISTNAME}
GO_SRCPATH= github.com/tdewolff/minify

post-configure:
cd ${WRKSRC} && rm cmd/minify/install.sh.orig

.include "../../www/go-parse/buildlink3.mk"
.include "../../devel/go-humanize/buildlink3.mk"
.include "../../devel/go-fsnotify/buildlink3.mk"
Expand Down
10 changes: 9 additions & 1 deletion www/go-minify/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2018/11/18 08:40:17 ryoon Exp $
@comment $NetBSD: PLIST,v 1.2 2020/04/18 14:56:06 nikita Exp $
bin/minify
gopkg/pkg/${GO_PLATFORM}/github.com/tdewolff/minify.a
gopkg/pkg/${GO_PLATFORM}/github.com/tdewolff/minify/css.a
Expand All @@ -21,6 +21,7 @@ gopkg/src/github.com/tdewolff/minify/benchmarks/sample_bbc.html
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_blogpost.html
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_books.xml
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_bootstrap.css
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_car.svg
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_catalog.xml
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_dot.js
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_es6.html
Expand All @@ -35,12 +36,14 @@ gopkg/src/github.com/tdewolff/minify/benchmarks/sample_normalize.css
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_omg.xml
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_stackoverflow.html
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_testsuite.json
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_tiger.svg
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_twitter.json
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_usa.svg
gopkg/src/github.com/tdewolff/minify/benchmarks/sample_wikipedia.html
gopkg/src/github.com/tdewolff/minify/benchmarks/svg_test.go
gopkg/src/github.com/tdewolff/minify/benchmarks/xml_test.go
gopkg/src/github.com/tdewolff/minify/cmd/minify/README.md
gopkg/src/github.com/tdewolff/minify/cmd/minify/install.sh
gopkg/src/github.com/tdewolff/minify/cmd/minify/main.go
gopkg/src/github.com/tdewolff/minify/cmd/minify/minify_bash_tab_completion
gopkg/src/github.com/tdewolff/minify/cmd/minify/util.go
Expand All @@ -50,11 +53,14 @@ gopkg/src/github.com/tdewolff/minify/common.go
gopkg/src/github.com/tdewolff/minify/common_test.go
gopkg/src/github.com/tdewolff/minify/css/css.go
gopkg/src/github.com/tdewolff/minify/css/css_test.go
gopkg/src/github.com/tdewolff/minify/css/hash.go
gopkg/src/github.com/tdewolff/minify/css/table.go
gopkg/src/github.com/tdewolff/minify/css/util.go
gopkg/src/github.com/tdewolff/minify/go.mod
gopkg/src/github.com/tdewolff/minify/go.sum
gopkg/src/github.com/tdewolff/minify/html/buffer.go
gopkg/src/github.com/tdewolff/minify/html/buffer_test.go
gopkg/src/github.com/tdewolff/minify/html/hash.go
gopkg/src/github.com/tdewolff/minify/html/html.go
gopkg/src/github.com/tdewolff/minify/html/html_test.go
gopkg/src/github.com/tdewolff/minify/html/table.go
Expand All @@ -66,12 +72,14 @@ gopkg/src/github.com/tdewolff/minify/minify.go
gopkg/src/github.com/tdewolff/minify/minify_test.go
gopkg/src/github.com/tdewolff/minify/svg/buffer.go
gopkg/src/github.com/tdewolff/minify/svg/buffer_test.go
gopkg/src/github.com/tdewolff/minify/svg/hash.go
gopkg/src/github.com/tdewolff/minify/svg/pathdata.go
gopkg/src/github.com/tdewolff/minify/svg/pathdata_test.go
gopkg/src/github.com/tdewolff/minify/svg/svg.go
gopkg/src/github.com/tdewolff/minify/svg/svg_test.go
gopkg/src/github.com/tdewolff/minify/svg/table.go
gopkg/src/github.com/tdewolff/minify/xml/buffer.go
gopkg/src/github.com/tdewolff/minify/xml/buffer_test.go
gopkg/src/github.com/tdewolff/minify/xml/table.go
gopkg/src/github.com/tdewolff/minify/xml/xml.go
gopkg/src/github.com/tdewolff/minify/xml/xml_test.go
11 changes: 6 additions & 5 deletions www/go-minify/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2018/11/18 08:40:17 ryoon Exp $
$NetBSD: distinfo,v 1.2 2020/04/18 14:56:06 nikita Exp $

SHA1 (minify-2.3.8.tar.gz) = ca6c3e5820b83f32dc0d06ce32c27a4252f4d142
RMD160 (minify-2.3.8.tar.gz) = 2b84a1aa4ca19e0065bda932096bfca497b3b582
SHA512 (minify-2.3.8.tar.gz) = dced371cb18a7b69048a5c2fbb6df4bd9143e11f7d346c8378c819a8dd6dc810e2090c340a7d26ddaae0208578c92a307d534170a57fd9ff36093c19576803dd
Size (minify-2.3.8.tar.gz) = 2125614 bytes
SHA1 (minify-2.7.3.tar.gz) = 266e56c21360e7d241faf4b3e7f21ffda375d83b
RMD160 (minify-2.7.3.tar.gz) = 8134758cbfabe43ed8abcb942917edb246b8b0dc
SHA512 (minify-2.7.3.tar.gz) = 4796981cf7e9425cee618b5cdeebcdb6dcb96010772cca639f887a691acb63f36fd3c0089efa2a053d46472a96564ba7f7b59df83f463dbe9e73ebe2e4e0818f
Size (minify-2.7.3.tar.gz) = 2303638 bytes
SHA1 (patch-cmd_minify_install.sh) = bff4d4223f80acbbf820ba06e4eb3d5daba6a872
19 changes: 19 additions & 0 deletions www/go-minify/patches/patch-cmd_minify_install.sh
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
$NetBSD: patch-cmd_minify_install.sh,v 1.1 2020/04/18 14:56:06 nikita Exp $

Upstreamed at https://github.com/tdewolff/minify/pull/298
Avoid usage of bash, this is no bash script.

--- cmd/minify/install.sh~
+++ cmd/minify/install.sh
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh

if command -v git >/dev/null 2>&1 && git rev-parse --git-dir >/dev/null 2>&1; then
go install -ldflags "-s -w -X 'main.Version=$(git describe --tags)'" -trimpath
@@ -6,4 +6,4 @@ else
go install -ldflags "-s -w" -trimpath
fi

-source minify_bash_tab_completion
+. minify_bash_tab_completion

0 comments on commit 849d1fc

Please sign in to comment.