Skip to content

Commit

Permalink
xfce4-mousepad: update to 0.5.7
Browse files Browse the repository at this point in the history
Change log:

0.5.7
======
- Bug Fixes:
  - Update Appdata file and use the same description everywhere
  - Prevent warning when saving a deleted file via a symlink (#135)
  - Conform to Freedesktop.org standard for file naming
  - Properly disconnect signal handlers
  - Be sure not to disable highlighting when disabling regex search
  - Check for realpath()
  - Check for `errno.h` required by CI
  - Fix a nasty memory leak
  - Fix "Save As" procedure when it recurses
  - Allow drag and drop on selections in the textview
  - Code cleanup: Remove a useless dnd signal forwarding
  - Code cleanup: Simplify `mousepad_file_save()`
  - Fix a small memory leak
  - Improve trash can management
  - Update read-only status on file location change/validation
  - Monitor also the target of broken links
  - Fix monitoring of files opened through a symlink
  - Allow drag and drop of broken links
  - Follow symlinks if necessary when checking if a file exists
  - Replace `g_realloc()` with `g_renew()`
  - Replace `g_malloc*()` with `g_new*()` (!113)
  - Make sure that `gtk_selection_data_get_uris()` returned non-NULL (!113)
  - Initialize `contents` and use it to guard `g_file_replace_contents` (!113)
  - Fix an unlikely memory leak
  - Make CSD consistent with other Xfce windows (#145)
- Translation Updates:
  Estonian, Greek, Kazakh, Polish, Serbian, Slovenian, Swedish,
  Ukrainian

0.5.6
======
- New Features:
  - Add session backup and restore
    - Remember windows and tabs (#21, !108)
    - Handle unsaved documents (#32, !109)
    - DE session support (#3, !110)
  - Extend the use of recent history (!107)
  - Add use of `GtkSourceView:smart-backspace` (!101)
  - Add a "Move Words" action (!100)

- Appearance Changes:
  - Add a setting to control tab expansion (#100)
  - Prefs dialog: Substitute CSD for status bar visibility
  - Add a "File" tab to the prefs dialog (!108)
  - Make search input fields less flickery (!104)
  - Allow saving non-existent, empty but named file (#120, !103)
  - Enable "Save" action for read-only documents (#126, !103)
  - Make "Find as you type" an option (!102)
  - Reveal hidden setting "indent-on-tab" (!101)

- Code Refactoring:
  - A review of duplicated view-related actions (#127)

- Tests:
  - Add a test plugin to monitor application state (!105)
  - Add a test script for Mousepad (!99)

- Bug Fixes:
  - Filter notebook click events also on y-coordinate (#144)
  - Allow to open files from the trash can (#141, !112)
  - Monitor file deletion (#140, !111)
  - Printing: Create config file if it does not exist
  - Check all windows for the file to be opened
  - Fix wrong externally modified document in some situations
  - Plugin support: Properly handle plugin settings (#136)
  - Direct monitoring of symlink targets
  - Set the state of submenu actions
  - print-dialog: Fix some memory leaks
  - Fix a type inconsistency in the "encoding-changed" signal
  - Always check if the user has explicitly set a filetype
  - Fix monitoring events to listen to
  - Ensure statefull actions exist until their state is recovered
  - Fix GVariant-related memory leaks
  - Do not warn if the plugin directory does not exist
  - Add a sanity check on the window for "Externally Modified"
  - Do not set the style scheme id as translatable
  - Properly update recent menu in case of file deletion
  - CSD: Set the decoration layout for all windows
  - Add a sanity check on file location for monitoring
  - Add "preferences" action to `mousepad.desktop` (#130)

- Translation Updates:
  Albanian, Arabic, Armenian (Armenia), Basque, Belarusian, Bulgarian,
  Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish,
  Dutch, Eastern Armenian, English (Australia), English (United
  Kingdom), Estonian, Finnish, French, Galician, German, Greek, Hebrew,
  Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese,
  Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Occitan (post
  1500), Persian (Iran), Polish, Portuguese, Portuguese (Brazil),
  Romanian, Russian, Serbian, Slovak, Slovenian, Spanish, Swedish,
  Thai, Turkish, Ukrainian, Uyghur

0.5.5
======
- New Features:
  - Add a `.desktop` file to make Mousepad appear in Xfce settings (!94)
  - Add a command line option to open the prefs dialog (!94)
  - Plugin support (!92)
  - Add gspell plugin (#1, !92)
  - Disable and wipe recent history if recent-menu-items is set to 0 (#112, !89)
  - Support -ve line and column values for "Go to" location (#113, !84)

- Appearance Changes:
  - Switch to client-side decorations (!97)

- Code Refactoring:
  - Remove Xfconf dependency (#60, #122, !98)
  - A general review of sanity checks
  - A review of window lifetime management
  - A review of document lifetime management
  - Automate and sanitize memory management of sources
  - A small review of GSettings use
  - Do not use `== (TRUE|FALSE)` for boolean conditions

- Bug Fixes:
  - Fix actions to show/hide bars in fullscreen mode (#129)
  - Fix broken "Revert" action
  - Fix and extend "Move Lines" action (#87, #116, !96)
  - Support for drag and drop of tabs when search is active
  - Do a silent search when changing tabs with the search bar enabled
  - Use get/set_real_line_offset () functions for "Paste as Column" (#114, !91)
  - Restore cursor position after transpose (#115, !88)
  - Fix "Delete Line" action (#117, !86)
  - Fix recent_sort function (!90)
  - Reset line and column number if not given on command line (#121, !87)
  - menu: "Spaces to Tabs" converter converts leading spaces (#118, !85)
  - Make window require attention when opening new tabs (2) (#119)

- Translation Updates:
  Albanian, Arabic, Armenian (Armenia), Basque, Belarusian, Bulgarian,
  Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish,
  Dutch, Eastern Armenian, English (Australia), English (United
  Kingdom), Estonian, Finnish, French, Galician, German, Greek, Hebrew,
  Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese,
  Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Occitan (post
  1500), Persian (Iran), Polish, Portuguese, Portuguese (Brazil),
  Romanian, Russian, Serbian, Slovak, Slovenian, Spanish, Swedish,
  Thai, Turkish, Ukrainian, Uyghur
  • Loading branch information
dhgutteridge committed Nov 30, 2021
1 parent 22fae90 commit 8e7a766
Show file tree
Hide file tree
Showing 4 changed files with 33 additions and 10 deletions.
7 changes: 4 additions & 3 deletions editors/xfce4-mousepad/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.57 2021/05/12 00:10:58 gutteridge Exp $
# $NetBSD: Makefile,v 1.58 2021/11/30 00:45:38 gutteridge Exp $

.include "../../meta-pkgs/xfce4/Makefile.common"

VERSION= 0.5.4
VERSION= 0.5.7
DISTNAME= mousepad-${VERSION}
PKGNAME= xfce4-mousepad-${VERSION}
CATEGORIES= editors
Expand All @@ -13,8 +13,9 @@ COMMENT= Xfce text editor

CONFIGURE_ARGS+= --enable-gtksourceview4

.include "options.mk"

.include "../../devel/glib2/schemas.mk"
.include "../../devel/xfce4-conf/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/gtksourceview4/buildlink3.mk"
Expand Down
11 changes: 8 additions & 3 deletions editors/xfce4-mousepad/PLIST
Original file line number Diff line number Diff line change
@@ -1,7 +1,11 @@
@comment $NetBSD: PLIST,v 1.8 2020/12/01 05:11:53 gutteridge Exp $
@comment $NetBSD: PLIST,v 1.9 2021/11/30 00:45:38 gutteridge Exp $
bin/mousepad
share/applications/mousepad.desktop
lib/libmousepad.la
${PLIST.gspell}lib/mousepad/plugins/libmousepad-plugin-gspell.la
share/applications/org.xfce.mousepad-settings.desktop
share/applications/org.xfce.mousepad.desktop
share/glib-2.0/schemas/org.xfce.mousepad.gschema.xml
${PLIST.gspell}share/glib-2.0/schemas/org.xfce.mousepad.plugins.gspell.gschema.xml
share/icons/hicolor/128x128/apps/org.xfce.mousepad.png
share/icons/hicolor/16x16/apps/org.xfce.mousepad.png
share/icons/hicolor/48x48/apps/org.xfce.mousepad.png
Expand All @@ -20,6 +24,7 @@ share/locale/en_GB/LC_MESSAGES/mousepad.mo
share/locale/es/LC_MESSAGES/mousepad.mo
share/locale/et/LC_MESSAGES/mousepad.mo
share/locale/eu/LC_MESSAGES/mousepad.mo
share/locale/fa_IR/LC_MESSAGES/mousepad.mo
share/locale/fi/LC_MESSAGES/mousepad.mo
share/locale/fr/LC_MESSAGES/mousepad.mo
share/locale/gl/LC_MESSAGES/mousepad.mo
Expand Down Expand Up @@ -58,5 +63,5 @@ share/locale/ug/LC_MESSAGES/mousepad.mo
share/locale/uk/LC_MESSAGES/mousepad.mo
share/locale/zh_CN/LC_MESSAGES/mousepad.mo
share/locale/zh_TW/LC_MESSAGES/mousepad.mo
share/metainfo/mousepad.appdata.xml
share/metainfo/org.xfce.mousepad.appdata.xml
share/polkit-1/actions/org.xfce.mousepad.policy
8 changes: 4 additions & 4 deletions editors/xfce4-mousepad/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.14 2021/10/26 10:21:43 nia Exp $
$NetBSD: distinfo,v 1.15 2021/11/30 00:45:38 gutteridge Exp $

BLAKE2s (mousepad-0.5.4.tar.bz2) = 864a0b0cc921083c37212a04834f2cb6eca20d005aaf982cd1b00e4d15658c20
SHA512 (mousepad-0.5.4.tar.bz2) = 52d1d9b235b13a651ee7e6e1633074c7829c27e880033637eacdd7cd63f246d1f47d0cd2c981cf2a7eb96dbb7119204a685f00a60968e4478d5057bce8500370
Size (mousepad-0.5.4.tar.bz2) = 855416 bytes
BLAKE2s (mousepad-0.5.7.tar.bz2) = 74418120aeae260216861e46be46c48f3a7b67feff1bd697950ae81d49800a85
SHA512 (mousepad-0.5.7.tar.bz2) = 0302fbf0d5e7ffe20a7f712dd0dc5878552572ec77798ed329b0e5688c0d4f80c5aa527f9fadb2de7452c8983bf1efd0e117ed7c170b0ca79e09006617f357ac
Size (mousepad-0.5.7.tar.bz2) = 920371 bytes
17 changes: 17 additions & 0 deletions editors/xfce4-mousepad/options.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
# $NetBSD: options.mk,v 1.1 2021/11/30 00:45:38 gutteridge Exp $

PKG_OPTIONS_VAR= PKG_OPTIONS.mousepad
PKG_SUPPORTED_OPTIONS= gspell
PKG_SUGGESTED_OPTIONS= gspell

.include "../../mk/bsd.options.mk"

PLIST_VARS= gspell

.if !empty(PKG_OPTIONS:Mgspell)
.include "../../textproc/gspell/buildlink3.mk"
PLIST.gspell= yes
CONFIGURE_ARGS+= --enable-plugin-gspell
.else
CONFIGURE_ARGS+= --disable-plugin-gspell
.endif

0 comments on commit 8e7a766

Please sign in to comment.