Skip to content

Commit

Permalink
Update chat/matrix-synapse to 1.26.0
Browse files Browse the repository at this point in the history
Synapse 1.26.0 (2021-01-27)
===========================

This release brings a new schema version for Synapse and rolling back to a previous
version is not trivial. Please review [UPGRADE.rst](UPGRADE.rst) for more details
on these changes and for general upgrade guidance.

No significant changes since 1.26.0rc2.


Synapse 1.26.0rc2 (2021-01-25)
==============================

Bugfixes
--------

- Fix receipts and account data not being sent down sync. Introduced in v1.26.0rc1. ([\#9193](matrix-org/synapse#9193), [\#9195](matrix-org/synapse#9195))
- Fix chain cover update to handle events with duplicate auth events. Introduced in v1.26.0rc1. ([\#9210](matrix-org/synapse#9210))


Internal Changes
----------------

- Add an `oidc-` prefix to any `idp_id`s which are given in the `oidc_providers` configuration. ([\#9189](matrix-org/synapse#9189))
- Bump minimum `psycopg2` version to v2.8. ([\#9204](matrix-org/synapse#9204))


Synapse 1.26.0rc1 (2021-01-20)
==============================

This release brings a new schema version for Synapse and rolling back to a previous
version is not trivial. Please review [UPGRADE.rst](UPGRADE.rst) for more details
on these changes and for general upgrade guidance.

Features
--------

- Add support for multiple SSO Identity Providers. ([\#9015](matrix-org/synapse#9015), [\#9017](matrix-org/synapse#9017), [\#9036](matrix-org/synapse#9036), [\#9067](matrix-org/synapse#9067), [\#9081](matrix-org/synapse#9081), [\#9082](matrix-org/synapse#9082), [\#9105](matrix-org/synapse#9105), [\#9107](matrix-org/synapse#9107), [\#9109](matrix-org/synapse#9109), [\#9110](matrix-org/synapse#9110), [\#9127](matrix-org/synapse#9127), [\#9153](matrix-org/synapse#9153), [\#9154](matrix-org/synapse#9154), [\#9177](matrix-org/synapse#9177))
- During user-interactive authentication via single-sign-on, give a better error if the user uses the wrong account on the SSO IdP. ([\#9091](matrix-org/synapse#9091))
- Give the `public_baseurl` a default value, if it is not explicitly set in the configuration file. ([\#9159](matrix-org/synapse#9159))
- Improve performance when calculating ignored users in large rooms. ([\#9024](matrix-org/synapse#9024))
- Implement [MSC2176](matrix-org/matrix-spec-proposals#2176) in an experimental room version. ([\#8984](matrix-org/synapse#8984))
- Add an admin API for protecting local media from quarantine. ([\#9086](matrix-org/synapse#9086))
- Remove a user's avatar URL and display name when deactivated with the Admin API. ([\#8932](matrix-org/synapse#8932))
- Update `/_synapse/admin/v1/users/<user_id>/joined_rooms` to work for both local and remote users. ([\#8948](matrix-org/synapse#8948))
- Add experimental support for handling to-device messages on worker processes. ([\#9042](matrix-org/synapse#9042), [\#9043](matrix-org/synapse#9043), [\#9044](matrix-org/synapse#9044), [\#9130](matrix-org/synapse#9130))
- Add experimental support for handling `/keys/claim` and `/room_keys` APIs on worker processes. ([\#9068](matrix-org/synapse#9068))
- Add experimental support for handling `/devices` API on worker processes. ([\#9092](matrix-org/synapse#9092))
- Add experimental support for moving off receipts and account data persistence off master. ([\#9104](matrix-org/synapse#9104), [\#9166](matrix-org/synapse#9166))


Bugfixes
--------

- Fix a long-standing issue where an internal server error would occur when requesting a profile over federation that did not include a display name / avatar URL. ([\#9023](matrix-org/synapse#9023))
- Fix a long-standing bug where some caches could grow larger than configured. ([\#9028](matrix-org/synapse#9028))
- Fix error handling during insertion of client IPs into the database. ([\#9051](matrix-org/synapse#9051))
- Fix bug where we didn't correctly record CPU time spent in `on_new_event` block. ([\#9053](matrix-org/synapse#9053))
- Fix a minor bug which could cause confusing error messages from invalid configurations. ([\#9054](matrix-org/synapse#9054))
- Fix incorrect exit code when there is an error at startup. ([\#9059](matrix-org/synapse#9059))
- Fix `JSONDecodeError` spamming the logs when sending transactions to remote servers. ([\#9070](matrix-org/synapse#9070))
- Fix "Failed to send request" errors when a client provides an invalid room alias. ([\#9071](matrix-org/synapse#9071))
- Fix bugs in federation catchup logic that caused outbound federation to be delayed for large servers after start up. Introduced in v1.8.0 and v1.21.0. ([\#9114](matrix-org/synapse#9114), [\#9116](matrix-org/synapse#9116))
- Fix corruption of `pushers` data when a postgres bouncer is used. ([\#9117](matrix-org/synapse#9117))
- Fix minor bugs in handling the `clientRedirectUrl` parameter for SSO login. ([\#9128](matrix-org/synapse#9128))
- Fix "Unhandled error in Deferred: BodyExceededMaxSize" errors when .well-known files that are too large. ([\#9108](matrix-org/synapse#9108))
- Fix "UnboundLocalError: local variable 'length' referenced before assignment" errors when the response body exceeds the expected size. This bug was introduced in v1.25.0. ([\#9145](matrix-org/synapse#9145))
- Fix a long-standing bug "ValueError: invalid literal for int() with base 10" when `/publicRooms` is requested with an invalid `server` parameter. ([\#9161](matrix-org/synapse#9161))


Improved Documentation
----------------------

- Add some extra docs for getting Synapse running on macOS. ([\#8997](matrix-org/synapse#8997))
- Correct a typo in the `systemd-with-workers` documentation. ([\#9035](matrix-org/synapse#9035))
- Correct a typo in `INSTALL.md`. ([\#9040](matrix-org/synapse#9040))
- Add missing `user_mapping_provider` configuration to the Keycloak OIDC example. Contributed by @chris-ruecker. ([\#9057](matrix-org/synapse#9057))
- Quote `pip install` packages when extras are used to avoid shells interpreting bracket characters. ([\#9151](matrix-org/synapse#9151))


Deprecations and Removals
-------------------------

- Remove broken and unmaintained `demo/webserver.py` script. ([\#9039](matrix-org/synapse#9039))


Internal Changes
----------------

- Improve efficiency of large state resolutions. ([\#8868](matrix-org/synapse#8868), [\#9029](matrix-org/synapse#9029), [\#9115](matrix-org/synapse#9115), [\#9118](matrix-org/synapse#9118), [\#9124](matrix-org/synapse#9124))
- Various clean-ups to the structured logging and logging context code. ([\#8939](matrix-org/synapse#8939))
- Ensure rejected events get added to some metadata tables. ([\#9016](matrix-org/synapse#9016))
- Ignore date-rotated homeserver logs saved to disk. ([\#9018](matrix-org/synapse#9018))
- Remove an unused column from `access_tokens` table. ([\#9025](matrix-org/synapse#9025))
- Add a `-noextras` factor to `tox.ini`, to support running the tests with no optional dependencies. ([\#9030](matrix-org/synapse#9030))
- Fix running unit tests when optional dependencies are not installed. ([\#9031](matrix-org/synapse#9031))
- Allow bumping schema version when using split out state database. ([\#9033](matrix-org/synapse#9033))
- Configure the linters to run on a consistent set of files. ([\#9038](matrix-org/synapse#9038))
- Various cleanups to device inbox store. ([\#9041](matrix-org/synapse#9041))
- Drop unused database tables. ([\#9055](matrix-org/synapse#9055))
- Remove unused `SynapseService` class. ([\#9058](matrix-org/synapse#9058))
- Remove unnecessary declarations in the tests for the admin API. ([\#9063](matrix-org/synapse#9063))
- Remove `SynapseRequest.get_user_agent`. ([\#9069](matrix-org/synapse#9069))
- Remove redundant `Homeserver.get_ip_from_request` method. ([\#9080](matrix-org/synapse#9080))
- Add type hints to media repository. ([\#9093](matrix-org/synapse#9093))
- Fix the wrong arguments being passed to `BlacklistingAgentWrapper` from `MatrixFederationAgent`. Contributed by Timothy Leung. ([\#9098](matrix-org/synapse#9098))
- Reduce the scope of caught exceptions in `BlacklistingAgentWrapper`. ([\#9106](matrix-org/synapse#9106))
- Improve `UsernamePickerTestCase`. ([\#9112](matrix-org/synapse#9112))
- Remove dependency on `distutils`. ([\#9125](matrix-org/synapse#9125))
- Enforce that replication HTTP clients are called with keyword arguments only. ([\#9144](matrix-org/synapse#9144))
- Fix the Python 3.5 / old dependencies build in CI. ([\#9146](matrix-org/synapse#9146))
- Replace the old `perspectives` option in the Synapse docker config file template with `trusted_key_servers`. ([\#9157](matrix-org/synapse#9157))
  • Loading branch information
Midar committed Jan 31, 2021
1 parent f70054b commit b256a24
Show file tree
Hide file tree
Showing 3 changed files with 32 additions and 11 deletions.
4 changes: 2 additions & 2 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.15 2021/01/13 17:45:36 js Exp $
# $NetBSD: Makefile,v 1.16 2021/01/31 19:23:28 js Exp $

DISTNAME= matrix-synapse-1.25.0
DISTNAME= matrix-synapse-1.26.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
EGG_NAME= matrix_synapse-${PKGVERSION_NOREV}
Expand Down
29 changes: 25 additions & 4 deletions chat/matrix-synapse/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2021/01/13 17:45:36 js Exp $
@comment $NetBSD: PLIST,v 1.8 2021/01/31 19:23:28 js Exp $
bin/export_signing_key
bin/generate_config
bin/generate_log_config
Expand Down Expand Up @@ -466,9 +466,6 @@ ${PYSITELIB}/synapse/http/client.pyo
${PYSITELIB}/synapse/http/connectproxyclient.py
${PYSITELIB}/synapse/http/connectproxyclient.pyc
${PYSITELIB}/synapse/http/connectproxyclient.pyo
${PYSITELIB}/synapse/http/endpoint.py
${PYSITELIB}/synapse/http/endpoint.pyc
${PYSITELIB}/synapse/http/endpoint.pyo
${PYSITELIB}/synapse/http/federation/__init__.py
${PYSITELIB}/synapse/http/federation/__init__.pyc
${PYSITELIB}/synapse/http/federation/__init__.pyo
Expand Down Expand Up @@ -601,6 +598,9 @@ ${PYSITELIB}/synapse/replication/http/__init__.pyo
${PYSITELIB}/synapse/replication/http/_base.py
${PYSITELIB}/synapse/replication/http/_base.pyc
${PYSITELIB}/synapse/replication/http/_base.pyo
${PYSITELIB}/synapse/replication/http/account_data.py
${PYSITELIB}/synapse/replication/http/account_data.pyc
${PYSITELIB}/synapse/replication/http/account_data.pyo
${PYSITELIB}/synapse/replication/http/devices.py
${PYSITELIB}/synapse/replication/http/devices.pyc
${PYSITELIB}/synapse/replication/http/devices.pyo
Expand Down Expand Up @@ -754,9 +754,11 @@ ${PYSITELIB}/synapse/res/templates/registration_success.html
${PYSITELIB}/synapse/res/templates/room.html
${PYSITELIB}/synapse/res/templates/room.txt
${PYSITELIB}/synapse/res/templates/sso_account_deactivated.html
${PYSITELIB}/synapse/res/templates/sso_auth_bad_user.html
${PYSITELIB}/synapse/res/templates/sso_auth_confirm.html
${PYSITELIB}/synapse/res/templates/sso_auth_success.html
${PYSITELIB}/synapse/res/templates/sso_error.html
${PYSITELIB}/synapse/res/templates/sso_login_idp_picker.html
${PYSITELIB}/synapse/res/templates/sso_redirect_confirm.html
${PYSITELIB}/synapse/res/templates/terms.html
${PYSITELIB}/synapse/res/username_picker/index.html
Expand Down Expand Up @@ -1011,6 +1013,9 @@ ${PYSITELIB}/synapse/rest/synapse/client/__init__.pyo
${PYSITELIB}/synapse/rest/synapse/client/password_reset.py
${PYSITELIB}/synapse/rest/synapse/client/password_reset.pyc
${PYSITELIB}/synapse/rest/synapse/client/password_reset.pyo
${PYSITELIB}/synapse/rest/synapse/client/pick_idp.py
${PYSITELIB}/synapse/rest/synapse/client/pick_idp.pyc
${PYSITELIB}/synapse/rest/synapse/client/pick_idp.pyo
${PYSITELIB}/synapse/rest/synapse/client/pick_username.py
${PYSITELIB}/synapse/rest/synapse/client/pick_username.pyc
${PYSITELIB}/synapse/rest/synapse/client/pick_username.pyo
Expand Down Expand Up @@ -1442,6 +1447,22 @@ ${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/24drop_event_json_in
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/25user_external_ids_user_id_idx.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/26access_token_last_validated.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/27local_invites.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/28drop_last_used_column.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/28drop_last_used_column.sql.sqlite
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/28rejected_events_metadata.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/01ignored_user.py
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/01ignored_user.pyc
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/01ignored_user.pyo
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/02shard_send_to_device.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/03shard_send_to_device_sequence.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/04_event_auth_chains.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/04_event_auth_chains.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/04drop_account_data.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/05cache_invalidation.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/06chain_cover_index.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/06shard_account_data.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/06shard_account_data.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/07shard_account_data_fix.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/application_services.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_edges.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_signatures.sql
Expand Down
10 changes: 5 additions & 5 deletions chat/matrix-synapse/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.10 2021/01/13 17:45:36 js Exp $
$NetBSD: distinfo,v 1.11 2021/01/31 19:23:28 js Exp $

SHA1 (matrix-synapse-1.25.0.tar.gz) = 803761f548caf1ac39832d4167f09f079a8012a9
RMD160 (matrix-synapse-1.25.0.tar.gz) = 2aa1aee07a1d67e1e983f20fafe4f16cfba40efb
SHA512 (matrix-synapse-1.25.0.tar.gz) = 3ac85267e3d43ac0bbdb33e19e486f1cfba4384eab397cad532ab5984f80fd531a0471f1e871516bc08cf4ba6c94f4a40c9ec718a3fec156e4bfc191ebb16730
Size (matrix-synapse-1.25.0.tar.gz) = 7044061 bytes
SHA1 (matrix-synapse-1.26.0.tar.gz) = b8a1ad90ed54ecfc19ef6d1679ed8d7c099042fb
RMD160 (matrix-synapse-1.26.0.tar.gz) = 7aaf0946feead1b104549046f1a6eaf874dfacc1
SHA512 (matrix-synapse-1.26.0.tar.gz) = 82ca85aa4dc1e3220f89e7f6815786135fa9bd0b33a1055f63b309b1fa193eeb993f832db573586945191e7195e42926c5342776b249dbc8e83daf4c196f00a4
Size (matrix-synapse-1.26.0.tar.gz) = 7134261 bytes

0 comments on commit b256a24

Please sign in to comment.