Skip to content

Commit

Permalink
Update to 4.6.1
Browse files Browse the repository at this point in the history
Upstream changes:
## 4.6.1 - March 15, 2018

* [Bug Fix] Corrected an issue which could result in a dap4 failure. See [Github #888](Unidata/netcdf-c#888) for more information.
* [Bug Fix][Enhancement] Allow `nccopy` to control output filter suppresion.  See [Github #894](Unidata/netcdf-c#894) for more information.
* [Enhancement] Reverted some new behaviors that, while in line with the netCDF specification, broke existing workflows.  See [Github #843](Unidata/netcdf-c#843) for more information.
* [Bug Fix] Improved support for CRT builds with Visual Studio, improves zlib detection in hdf5 library. See [Github #853](Unidata/netcdf-c#853) for more information.
* [Enhancement][Internal] Moved HDF4 into a distinct dispatch layer. See [Github #849](Unidata/netcdf-c#849) for more information.

## 4.6.0 - January 24, 2018
* [Enhancement] Full support for using HDF5 dynamic filters, both for reading and writing. See the file docs/filters.md.
* [Enhancement] Added an option to enable strict null-byte padding for headers; this padding was specified in the spec but was not enforced.  Enabling this option will allow you to check your files, as it will return an E_NULLPAD error.  It is possible for these files to have been written by older versions of libnetcdf.  There is no effective problem caused by this lack of null padding, so enabling these options is informational only.  The options for `configure` and `cmake` are `--enable-strict-null-byte-header-padding` and `-DENABLE_STRICT_NULL_BYTE_HEADER_PADDING`, respectively.  See [Github #657](Unidata/netcdf-c#657) for more information.
* [Enhancement] Reverted behavior/handling of out-of-range attribute values to pre-4.5.0 default. See [Github #512](Unidata/netcdf-c#512) for more information.
* [Bug] Fixed error in tst_parallel2.c. See [Github #545](Unidata/netcdf-c#545) for more information.
* [Bug] Fixed handling of corrupt files + proper offset handling for hdf5 files. See [Github #552](Unidata/netcdf-c#552) for more information.
* [Bug] Corrected a memory overflow in `tst_h_dimscales`, see [Github #511](Unidata/netcdf-c#511), [Github #505](Unidata/netcdf-c#505), [Github #363](Unidata/netcdf-c#363) and [Github #244](Unidata/netcdf-c#244) for more information.

## 4.5.0 - October 20, 2017

* Corrected an issue which could potential result in a hang while using parallel file I/O. See [Github #449](Unidata/netcdf-c#449) for more information.
* Addressed an issue with `ncdump` not properly handling dates on a 366 day calendar. See [GitHub #359](Unidata/netcdf-c#359) for more information.

### 4.5.0-rc3 - September 29, 2017

* [Update] Due to ongoing issues, native CDF5 support has been disabled by **default**.  You can use the options mentioned below (`--enable-cdf5` or `-DENABLE_CDF5=TRUE` for `configure` or `cmake`, respectively).  Just be aware that for the time being, Reading/Writing CDF5 files on 32-bit platforms may result in unexpected behavior when using extremely large variables.  For 32-bit platforms it is best to continue using `NC_FORMAT_64BIT_OFFSET`.
* [Bug] Corrected an issue where older versions of curl might fail. See [GitHub #487](Unidata/netcdf-c#487) for more information.
* [Enhancement] Added options to enable/disable `CDF5` support at configure time for autotools and cmake-based builds.  The options are `--enable/disable-cdf5` and `ENABLE_CDF5`, respectively.  See [Github #484](Unidata/netcdf-c#484) for more information.
* [Bug Fix] Corrected an issue when subsetting a netcdf3 file via `nccopy -v/-V`. See [Github #425](Unidata/netcdf-c#425) and [Github #463](Unidata/netcdf-c#463) for more information.
* [Bug Fix] Corrected `--has-dap` and `--has-dap4` output for cmake-based builds. See [GitHub #473](Unidata/netcdf-c#473) for more information.
* [Bug Fix] Corrected an issue where `NC_64BIT_DATA` files were being read incorrectly by ncdump, despite the data having been written correctly.  See [GitHub #457](Unidata/netcdf-c#457) for more information.
* [Bug Fix] Corrected a potential stack buffer overflow.  See [GitHub #450](Unidata/netcdf-c#450) for more information.

### 4.5.0-rc2 - August 7, 2017

* [Bug Fix] Addressed an issue with how cmake was implementing large file support on 32-bit systems. See [GitHub #385](Unidata/netcdf-c#385) for more information.
* [Bug Fix] Addressed an issue where ncgen would not respect keyword case. See [GitHub #310](Unidata/netcdf-c#310) for more information.

### 4.5.0-rc1 - June 5, 2017

* [Enhancement] DAP4 is now included. Since dap2 is the default for urls, dap4 must be specified by
(1) using "dap4:" as the url protocol, or
(2) appending "#protocol=dap4" to the end of the url, or
(3) appending "#dap4" to the end of the url
Note that dap4 is enabled by default but remote-testing is
disbled until the testserver situation is resolved.
* [Enhancement] The remote testing server can now be specified with the `--with-testserver` option to ./configure.
* [Enhancement] Modified netCDF4 to use ASCII for NC_CHAR.  See [Github Pull request #316](Unidata/netcdf-c#316) for more information.
* [Bug Fix] Corrected an error with how dimsizes might be read. See [Github #410](Unidata/netcdf-c#410) for more information.
* [Bug Fix] Corrected an issue where 'make check' would fail if 'make' or 'make all' had not run first.  See [Github #339](Unidata/netcdf-c#339) for more information.
* [Bug Fix] Corrected an issue on Windows with Large file tests. See [Github #385](Unidata/netcdf-c#385]) for more information.
* [Bug Fix] Corrected an issue with diskless file access, see [Pull Request #400](Unidata/netcdf-c#400) and [Pull Request #403](Unidata/netcdf-c#403) for more information.
* [Upgrade] The bash based test scripts have been upgraded to use a common test_common.sh include file that isolates build specific information.
* [Upgrade] The bash based test scripts have been upgraded to use a common test_common.sh include file that isolates build specific information.
* [Refactor] the oc2 library is no longer independent of the main netcdf-c library. For example, it now uses ncuri, nclist, and ncbytes instead of its homegrown equivalents.
* [Bug Fix] `NC_EGLOBAL` is now properly returned when attempting to set a global `_FillValue` attribute. See [GitHub #388](Unidata/netcdf-c#388) and [GitHub #389](Unidata/netcdf-c#389) for more information.
* [Bug Fix] Corrected an issue where data loss would occur when `_FillValue` was mistakenly allowed to be redefined.  See [Github #390](Unidata/netcdf-c#390), [GitHub #387](Unidata/netcdf-c#387) for more information.
* [Upgrade][Bug] Corrected an issue regarding how "orphaned" DAS attributes were handled. See [GitHub #376](Unidata/netcdf-c#376) for more information.
* [Upgrade] Update utf8proc.[ch] to use the version now maintained by the Julia Language project (https://github.com/JuliaLang/utf8proc/blob/master/LICENSE.md).
* [Bug] Addressed conversion problem with Windows sscanf.  This primarily affected some OPeNDAP URLs on Windows.  See [GitHub #365](Unidata/netcdf-c#365) and [GitHub #366](Unidata/netcdf-c#366) for more information.
* [Enhancement] Added support for HDF5 collective metadata operations when available. Patch submitted by Greg Sjaardema, see [Pull request #335](Unidata/netcdf-c#335) for more information.
* [Bug] Addressed a potential type punning issue. See [GitHub #351](Unidata/netcdf-c#351) for more information.
* [Bug] Addressed an issue where netCDF wouldn't build on Windows systems using MSVC 2012. See [GitHub #304](Unidata/netcdf-c#304) for more information.
* [Bug] Fixed an issue related to potential type punning, see [GitHub #344](Unidata/netcdf-c#344) for more information.
* [Enhancement] Incorporated an enhancement provided by Greg Sjaardema, which may improve read/write times for some complex files.  Basically, linked lists were replaced in some locations where it was safe to use an array/table.  See [Pull request #328](Unidata/netcdf-c#328) for more information.
  • Loading branch information
wen committed May 16, 2018
1 parent e97f43c commit d3f8940
Show file tree
Hide file tree
Showing 4 changed files with 18 additions and 19 deletions.
5 changes: 2 additions & 3 deletions devel/netcdf/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.48 2018/04/29 21:31:20 adam Exp $
# $NetBSD: Makefile,v 1.49 2018/05/16 06:32:58 wen Exp $

DISTNAME= netcdf-4.4.1.1
PKGREVISION= 2
DISTNAME= netcdf-4.6.1
CATEGORIES= devel
MASTER_SITES= https://www.unidata.ucar.edu/downloads/netcdf/ftp/

Expand Down
7 changes: 6 additions & 1 deletion devel/netcdf/PLIST
Original file line number Diff line number Diff line change
@@ -1,12 +1,17 @@
@comment $NetBSD: PLIST,v 1.8 2017/11/28 17:52:02 minskim Exp $
@comment $NetBSD: PLIST,v 1.9 2018/05/16 06:32:58 wen Exp $
bin/nc-config
bin/nccopy
bin/ncdump
bin/ncgen
bin/ncgen3
bin/ocprint
include/netcdf.h
include/netcdf_mem.h
include/netcdf_meta.h
lib/libbzip2.la
lib/libbzip2.so
lib/libmisc.la
lib/libmisc.so
lib/libnetcdf.la
lib/libnetcdf.settings
lib/pkgconfig/netcdf.pc
Expand Down
12 changes: 6 additions & 6 deletions devel/netcdf/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.19 2017/11/28 17:52:02 minskim Exp $
$NetBSD: distinfo,v 1.20 2018/05/16 06:32:58 wen Exp $

SHA1 (netcdf-4.4.1.1.tar.gz) = 0c77ed993c614653613905a1a52802a38f578b0b
RMD160 (netcdf-4.4.1.1.tar.gz) = 027c1f71936a253cf388f7a44395f53b6ca54e70
SHA512 (netcdf-4.4.1.1.tar.gz) = 36c041e2f7ed5fc4f47fc4fa2afcdce2247f1d3794525ebdbd97d359d3ed98f150664ccf77c5366da4db2b9f0f4b17f871d861473ca9afee1462c75a302b07bb
Size (netcdf-4.4.1.1.tar.gz) = 5250973 bytes
SHA1 (netcdf-4.6.1.tar.gz) = 11912675530db61474b305b572e06f83d682aa2c
RMD160 (netcdf-4.6.1.tar.gz) = aa70f9ca6b5fbd8c914420b3570ac4f316ed47e5
SHA512 (netcdf-4.6.1.tar.gz) = a2d49b013ff1bcba748e4b1f55a14a25728bfdfce44001cbfacfd01d585ea39972950ea4db6fa6ec3531f8be8a3a3072a2338b6b211205719e81d0498fd8a502
Size (netcdf-4.6.1.tar.gz) = 5693557 bytes
SHA1 (patch-configure) = 74457173c01355cd0f99f136ae10bdc67e831489
SHA1 (patch-ncdap__test_testauth.sh) = 710879f36c1a4d54466c9065644db326db0c4ed8
SHA1 (patch-ncdap__test_testauth.sh) = 2a92af8d23238815b8d6645f2d3c2376d2c2ff91
13 changes: 4 additions & 9 deletions devel/netcdf/patches/patch-ncdap__test_testauth.sh
Original file line number Diff line number Diff line change
@@ -1,20 +1,15 @@
$NetBSD: patch-ncdap__test_testauth.sh,v 1.1 2017/11/28 17:52:02 minskim Exp $
$NetBSD: patch-ncdap__test_testauth.sh,v 1.2 2018/05/16 06:32:58 wen Exp $

Portability fix.

--- ncdap_test/testauth.sh.orig 2016-11-21 19:43:03.000000000 +0000
--- ncdap_test/testauth.sh.orig 2018-05-16 03:08:45.000000000 +0000
+++ ncdap_test/testauth.sh
@@ -273,7 +273,7 @@ if test "x$RCHOME" = x1 ; then
@@ -246,7 +246,7 @@ if test "x$RCHOME" = x1 ; then
show
fi

-if test "x$RCSPEC" == x1 ; then
+if test "x$RCSPEC" = x1 ; then
echo "*** Testing rc file in specified directory"
# Create the rc file and (optional) netrc file
xf; reset; xo
@@ -324,4 +324,3 @@ restore
xo

exit
-
reset

0 comments on commit d3f8940

Please sign in to comment.