Skip to content

Commit

Permalink
Update chat/matrix-synapse to 1.29.0
Browse files Browse the repository at this point in the history
Synapse 1.29.0 (2021-03-08)
===========================

Note that synapse now expects an `X-Forwarded-Proto` header when used with a reverse proxy. Please see [UPGRADE.rst](UPGRADE.rst#upgrading-to-v1290) for more details on this change.


No significant changes.


Synapse 1.29.0rc1 (2021-03-04)
==============================

Features
--------

- Add rate limiters to cross-user key sharing requests. ([\#8957](matrix-org/synapse#8957))
- Add `order_by` to the admin API `GET /_synapse/admin/v1/users/<user_id>/media`. Contributed by @dklimpel. ([\#8978](matrix-org/synapse#8978))
- Add some configuration settings to make users' profile data more private. ([\#9203](matrix-org/synapse#9203))
- The `no_proxy` and `NO_PROXY` environment variables are now respected in proxied HTTP clients with the lowercase form taking precedence if both are present. Additionally, the lowercase `https_proxy` environment variable is now respected in proxied HTTP clients on top of existing support for the uppercase `HTTPS_PROXY` form and takes precedence if both are present. Contributed by Timothy Leung. ([\#9372](matrix-org/synapse#9372))
- Add a configuration option, `user_directory.prefer_local_users`, which when enabled will make it more likely for users on the same server as you to appear above other users. ([\#9383](matrix-org/synapse#9383), [\#9385](matrix-org/synapse#9385))
- Add support for regenerating thumbnails if they have been deleted but the original image is still stored. ([\#9438](matrix-org/synapse#9438))
- Add support for `X-Forwarded-Proto` header when using a reverse proxy. ([\#9472](matrix-org/synapse#9472), [\#9501](matrix-org/synapse#9501), [\#9512](matrix-org/synapse#9512), [\#9539](matrix-org/synapse#9539))


Bugfixes
--------

- Fix a bug where users' pushers were not all deleted when they deactivated their account. ([\#9285](matrix-org/synapse#9285), [\#9516](matrix-org/synapse#9516))
- Fix a bug where a lot of unnecessary presence updates were sent when joining a room. ([\#9402](matrix-org/synapse#9402))
- Fix a bug that caused multiple calls to the experimental `shared_rooms` endpoint to return stale results. ([\#9416](matrix-org/synapse#9416))
- Fix a bug in single sign-on which could cause a "No session cookie found" error. ([\#9436](matrix-org/synapse#9436))
- Fix bug introduced in v1.27.0 where allowing a user to choose their own username when logging in via single sign-on did not work unless an `idp_icon` was defined. ([\#9440](matrix-org/synapse#9440))
- Fix a bug introduced in v1.26.0 where some sequences were not properly configured when running `synapse_port_db`. ([\#9449](matrix-org/synapse#9449))
- Fix deleting pushers when using sharded pushers. ([\#9465](matrix-org/synapse#9465), [\#9466](matrix-org/synapse#9466), [\#9479](matrix-org/synapse#9479), [\#9536](matrix-org/synapse#9536))
- Fix missing startup checks for the consistency of certain PostgreSQL sequences. ([\#9470](matrix-org/synapse#9470))
- Fix a long-standing bug where the media repository could leak file descriptors while previewing media. ([\#9497](matrix-org/synapse#9497))
- Properly purge the event chain cover index when purging history. ([\#9498](matrix-org/synapse#9498))
- Fix missing chain cover index due to a schema delta not being applied correctly. Only affected servers that ran development versions. ([\#9503](matrix-org/synapse#9503))
- Fix a bug introduced in v1.25.0 where `/_synapse/admin/join/` would fail when given a room alias. ([\#9506](matrix-org/synapse#9506))
- Prevent presence background jobs from running when presence is disabled. ([\#9530](matrix-org/synapse#9530))
- Fix rare edge case that caused a background update to fail if the server had rejected an event that had duplicate auth events. ([\#9537](matrix-org/synapse#9537))


Improved Documentation
----------------------

- Update the example systemd config to propagate reloads to individual units. ([\#9463](matrix-org/synapse#9463))


Internal Changes
----------------

- Add documentation and type hints to `parse_duration`. ([\#9432](matrix-org/synapse#9432))
- Remove vestiges of `uploads_path` configuration setting. ([\#9462](matrix-org/synapse#9462))
- Add a comment about systemd-python. ([\#9464](matrix-org/synapse#9464))
- Test that we require validated email for email pushers. ([\#9496](matrix-org/synapse#9496))
- Allow python to generate bytecode for synapse. ([\#9502](matrix-org/synapse#9502))
- Fix incorrect type hints. ([\#9515](matrix-org/synapse#9515), [\#9518](matrix-org/synapse#9518))
- Add type hints to device and event report admin API. ([\#9519](matrix-org/synapse#9519))
- Add type hints to user admin API. ([\#9521](matrix-org/synapse#9521))
- Bump the versions of mypy and mypy-zope used for static type checking. ([\#9529](matrix-org/synapse#9529))
  • Loading branch information
Midar committed Mar 14, 2021
1 parent 3f31dfa commit d5b1cc5
Show file tree
Hide file tree
Showing 3 changed files with 14 additions and 9 deletions.
4 changes: 2 additions & 2 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.18 2021/03/10 18:49:06 adam Exp $
# $NetBSD: Makefile,v 1.19 2021/03/14 21:21:13 js Exp $

DISTNAME= matrix-synapse-1.28.0
DISTNAME= matrix-synapse-1.29.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
EGG_NAME= matrix_synapse-${PKGVERSION_NOREV}
Expand Down
9 changes: 7 additions & 2 deletions chat/matrix-synapse/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2021/03/06 19:00:43 js Exp $
@comment $NetBSD: PLIST,v 1.10 2021/03/14 21:21:13 js Exp $
bin/export_signing_key
bin/generate_config
bin/generate_log_config
Expand Down Expand Up @@ -619,6 +619,9 @@ ${PYSITELIB}/synapse/replication/http/membership.pyo
${PYSITELIB}/synapse/replication/http/presence.py
${PYSITELIB}/synapse/replication/http/presence.pyc
${PYSITELIB}/synapse/replication/http/presence.pyo
${PYSITELIB}/synapse/replication/http/push.py
${PYSITELIB}/synapse/replication/http/push.pyc
${PYSITELIB}/synapse/replication/http/push.pyo
${PYSITELIB}/synapse/replication/http/register.py
${PYSITELIB}/synapse/replication/http/register.pyc
${PYSITELIB}/synapse/replication/http/register.pyo
Expand Down Expand Up @@ -1467,7 +1470,6 @@ ${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/26access_token_last_
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/27local_invites.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/28drop_last_used_column.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/28drop_last_used_column.sql.sqlite
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/28rejected_events_metadata.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/01ignored_user.py
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/01ignored_user.pyc
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/01ignored_user.pyo
Expand All @@ -1481,6 +1483,9 @@ ${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/06chain_cover_index.
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/06shard_account_data.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/06shard_account_data.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/07shard_account_data_fix.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/08delete_pushers_for_deactivated_accounts.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/08delete_stale_pushers.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/59/09rejected_events_metadata.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/application_services.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_edges.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_signatures.sql
Expand Down
10 changes: 5 additions & 5 deletions chat/matrix-synapse/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.12 2021/03/06 19:00:43 js Exp $
$NetBSD: distinfo,v 1.13 2021/03/14 21:21:13 js Exp $

SHA1 (matrix-synapse-1.28.0.tar.gz) = 814c5b6cb75f6fb85c1e6aa14af34108892eb1b1
RMD160 (matrix-synapse-1.28.0.tar.gz) = 5b1d1c672d513ffa32c73782f9fc84542cad0a65
SHA512 (matrix-synapse-1.28.0.tar.gz) = a248154eec9df21d82c78dd2cd166b82f6f41a2fa86096d87374417043c1c5352cc0b08265c5af4fa9927b9c6e818d3633db5a03ef2430a4cfb71d41ecc7b39c
Size (matrix-synapse-1.28.0.tar.gz) = 7184001 bytes
SHA1 (matrix-synapse-1.29.0.tar.gz) = f5ac2224a03902a2dd0808edfe4dcc8cad5f58c6
RMD160 (matrix-synapse-1.29.0.tar.gz) = 9dff6604f84ca48aa24783177538268164643aeb
SHA512 (matrix-synapse-1.29.0.tar.gz) = ee12f673854d2bce7ef5c8e288583a15056033c6c42dc07f1bc86bac66148e0da9f36c5e84d7a41b6366e41c3e8392dc8a69f5f0fd12f14ffa09dc1bff01f596
Size (matrix-synapse-1.29.0.tar.gz) = 7198706 bytes

0 comments on commit d5b1cc5

Please sign in to comment.