Skip to content

Commit

Permalink
Skip OrcJIT tests on riscv64
Browse files Browse the repository at this point in the history
OrcJIT is still in the experimental stage, and there are some issues
where the OrcJIT test fails when tested on non-x86 platforms (e.g. Issue [numba#1000](numba/llvmlite#1000)),
so skip writing this test on non-x86 platforms.
  • Loading branch information
Xunop committed Oct 19, 2023
1 parent 53a6ef9 commit 2994f4b
Showing 1 changed file with 4 additions and 4 deletions.
8 changes: 4 additions & 4 deletions python-llvmlite/riscv64.patch
Original file line number Diff line number Diff line change
@@ -1,16 +1,16 @@
diff --git PKGBUILD PKGBUILD
index 50c73a3..7fbf334 100644
--- PKGBUILD
+++ PKGBUILD
@@ -24,7 +24,10 @@ build() {
@@ -24,7 +24,12 @@ build() {

check() {
cd "${_name}-$pkgver"
- pytest -vv $_name/tests
+ # Skip MCJIT related failures, as it's known to be broken on RISC-V
+ # Skip OrcLLJIT tests on non-x86 platforms
+ pytest -vv $_name/tests --deselect llvmlite/tests/test_binding.py::TestMCJit \
+ --deselect llvmlite/tests/test_binding.py::TestGlobalConstructors \
+ --deselect llvmlite/tests/test_binding.py::TestObjectFile::test_add_object_file
+ --deselect llvmlite/tests/test_binding.py::TestObjectFile::test_add_object_file \
+ --deselect llvmlite/tests/test_binding.py::TestOrcLLJIT
}

package() {

0 comments on commit 2994f4b

Please sign in to comment.