Skip to content

Commit

Permalink
xfce4-dev-tools: upgrade 4.14.0 -> 4.16.0
Browse files Browse the repository at this point in the history
Release notes for 4.16.0
========================
- Bump glib to 2.50 based on xfce4.16 roadmap
- Do not process @linguas@ at xdt-autogen stage
- Fail xfce-build container generation if there is any error
- helpers: Prefer xfce-build over xfce-test (Fixes openembedded#38)
- helpers: Add new helper xfce-open-gitlab
- helpers: Add helper to locally run xfce-build
- helpers: Add xfce-build 'pull' argument
- xfce-build: Add Thunar to container (Fixes openembedded#40)
- Disable CFLAGS override when building CI container
- use strict CFLAGS to catch common mistakes in ci pipeline
- Add xvfb on xfce-build

Release notes for 4.15.1
========================
[Please note that this is a development release.]

Various improvements to the helpers introduced in 4.15.0,
cleanup of xdt-autogen code (thanks to Gaël Bonithon), various fixes for
our CI.

- get-translations: Fix line wrapping
- xdt-autogen: Various small improvements
- xdt-autogen: Properly handle whitespaces in filenames
- xdt-autogen: Use sed instead of tr to replace strings
- Updates README.md
- xfce-build: Add libclutter-1.0-dev for xfdashboard build
- Update .gitignore
- helpers: Use blank line for tags message
- helpers: Reuse release notes from NEWS for tag message
- helpers: Simplify xfce-update-news
- helpers: Do not strip NEWS blank line at EOF
- helpers: Install xfce-do-release
- xfce-build: Add depend for mousepad (Fixes openembedded#37)
- helpers: Add do-release helper and Readme
- xfce-build: Install python3 version of distutils-extra
- helpers: Make get-translations executable
- get-translations: Remove last comma
- get-translations: Correctly get locale from commit messages
- xfce-build: Replace build-dep with package names

Release notes for 4.15.0
========================
[Please note that this is a development release.]

- New macro XDT_VERSION_INIT(SEMVER[, TAG])

This macro takes care of setting up the version numbering.
It will define the following macros based on SEMVER and TAG:

   - xdt_version
   - xdt_version_major
   - xdt_version_minor
   - xdt_version_micro
   - xdt_version_tag
   - xdt_version_build
   - xdt_debug_default

If TAG isn't specified, the xdt_version_tag and xdt_version_git
will be empty and xdt_debug_default will be set to "minimum",
otherwise the xdt_version_build will contain a git hash and
xdt_debug_default will be set to "yes"

Example usage:

  XDT_VERSION_INIT([4.15.3],[git])
  AC_INIT([xfce4-someproject], [xdt_version()])
  ...
  XDT_FEATURE_DEBUG([xdt_debug_default])

- XDT_I18N macro will now automatically find the linguas if none are
specified during the autoconf run.

- Install m4 macros in default search dir. This makes autoconf find the
macros by default.

By setting version via XDT_VERSION_INIT and using XDT_I18N without
arguments,
this is no longer necessary to use a separate configure.ac.in and a
plain configure.ac can be used !
A big thank to Natanael Copa (ncopa) for his work on this part !

- xfce4-dev-tools now also handle the CI (docker container,
.gitlab-ci.yml templates files etc) on our new gitlab instance. A merge
request or a push to master to any of our projects automatically trigger
a build. This will help us to catch errors quicker and have better
quality. Thanks to Jason Yavorska and Simon Steinbeiss.

- New helpers are also available (xfce-get-release-notes,
xfce-get-translations, xfce-update-news) to help our maintainers to do
releases ! Thanks Simon again.

- Use datarootdir instead of datadir
- xdt-autogen: explicitly set search path for m4 macros
- Install the xfce-helpers
- Add two new helpers to help releasers
- Install m4 macros into default $datadir/aclocal
- Update README for new gitlab urls
- xdt-autogen: Improve and simplify linguas detection
- Let XDT_I18N automatically find the po/*.po as default
- Let configure generate the xdt-autogen script
- Implement XDT_VERSION_INIT
- Add manpage and tests to xdt-csource
- Add xfce4-dev-tools build in addition to container build
- Check BEFORE_SHA along with changes to .po files
- gitlabci: Ensure to run autogen in distcheck stage
- Switch to "foreign" mode for automake
- Add CI templates notes
- Update README with explanation of Dockerfile
- Fix whitespace error
- Add helper script to get all translation-updates
- Integrate xfce-build container build/creation

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
schnitzeltony authored and kraj committed Jan 6, 2021
1 parent 8a563a0 commit f21a276
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
From b2fcd5c09ee6b4ad03f93ee5e1dd32f2f062cf07 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 3 Jan 2021 15:36:07 +0100
Subject: [PATCH] Run native xdt-csource on tests
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Tests cannot be opted out so let them pass.

Upstream-Status: Inappropriate [OE specific]

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
---
tests/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/Makefile.am b/tests/Makefile.am
index fa0832c..7c46bbf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,7 +26,7 @@ DISTCLEANFILES = test-xdt-csource-data.c
BUILT_SOURCES = test-xdt-csource-data.c

test-xdt-csource-data.c: Makefile $(srcdir)/data/data.bin $(srcdir)/data/data.txt
- $(top_builddir)/xdt-csource/xdt-csource --extern --build-list data_bin $(srcdir)/data/data.bin data_txt $(srcdir)/data/data.txt > test-xdt-csource-data.c
+ xdt-csource --extern --build-list data_bin $(srcdir)/data/data.bin data_txt $(srcdir)/data/data.txt > test-xdt-csource-data.c

clean-local:
rm -f *.core core core.*
--
2.26.2

Original file line number Diff line number Diff line change
Expand Up @@ -3,15 +3,17 @@ HOMEPAGE = "http://www.xfce.org"
SECTION = "x11/libs"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"

DEPENDS = "glib-2.0"
DEPENDS_append_class-target = " ${BPN}-native"

inherit autotools pkgconfig

BBCLASSEXTEND = "native"

SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:4]}/${BPN}-${PV}.tar.bz2"
SRC_URI[md5sum] = "5f8fc8af73819c08d9e4c26a3ac457e7"
SRC_URI[sha256sum] = "2c9eb8e0fe23e47dc31411a93b683fd1b7a49140e9163f0aab9e94a3d8a0b5fd"
SRC_URI_append_class-target = " file://0001-Run-native-xdt-csource-on-tests.patch"
SRC_URI[sha256sum] = "f50b3070e66f3ebdf331744dd1ec5e1af5de333965d491e15ce05545e8eb4f04"

do_install_append() {
install -d ${D}${datadir}/aclocal
Expand Down

0 comments on commit f21a276

Please sign in to comment.