Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 74.1.2 to …
Browse files Browse the repository at this point in the history
…version 75.1.0

Anderson Bravalheri (3):
      Add warning for universal wheels
      Adapt tests for deprecation of universal
      Add news fragment

Avasam (3):
      Fix an incompatibility (and source of merge conflicts) with projects using Ruff/isort.
      Fix cross-platform compilation using `distutils._msvccompiler.MSVCCompiler`
      Fix cross-platform compilation using `distutils._msvccompiler.MSVCCompiler`.

Dimitri Papadopoulos (3):
      Ignore TRY400 globally
      Clean up ruff ignore
      Fix a couple typos found by codespell

Jason R. Coombs (32):
      Remove workaround for sphinx-contrib/sphinx-lint#83
      Clean up cruft in errors docstring.
      Rely on dependencies instead of vendoring them.
      Simply log the directory being created, rather than the whole ancestry.
      Updated mkpath to use pathlib.Path.mkdir.
      Refactored mkpath as a singledispatch function.
      Declare also the dependencies used by distutils (adds jaraco.collections).
      Replaced global variable with a custom cache wrapper.
      Extracted _copy_one function.
      "Removed support for 'compress="compress"' to archive_util.make_tarball."
      Removed deprecated 'check_warnings' from 'sdist' and 'regitser' commands.
      Enabled TestPyPIRCCommand to run its tests.
      Removed dependence of TestSdist on test_config.
      Replaced open/read/close logic with 'read_text' and added encoding to address EncodingWarning.
      Remove collect_ignore referring to msvc9compiler.
      Flagged register and upload commands and deprecated.
      Move comment back to its relevant line.
      Remove pypi-based commands upload, register, upload-docs.
      Decouple sdist tests from pypirc fixture.
      Removed PyPI commands (register, upload) and supporting logic.
      Remove reliance on distutils commands for external dependencies check.
      Remove borland compiler.
      Allow the workflow to be triggered manually.
      Add Python 3.13 and 3.14 into the matrix. (jaraco/skeleton#146)
      Move the comment to the docstring.
      Use double-backticks for rst compatibility.
      Bump version: 74.1.2 → 74.1.3
      Remove news fragments, not useful here.
      Add news fragment.
      Bump version: 74.1.3 → 75.0.0
      Removed reference to upload_docs module in entry points.
      Bump version: 75.0.0 → 75.1.0

Naveen M K (1):
      cygwinccompiler: Get the compilers from sysconfig
  • Loading branch information
fenrus75 committed Sep 17, 2024
1 parent 74546e5 commit 45add46
Show file tree
Hide file tree
Showing 7 changed files with 15 additions and 14 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/3e/2c/f0a538a2f91ce633a78daaeb34cbfb93a54bd2132a6de1f6cec028eee6ef/setuptools-74.1.2.tar.gz
URL = https://files.pythonhosted.org/packages/27/b8/f21073fde99492b33ca357876430822e4800cdf522011f18041351dfa74b/setuptools-75.1.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
1 change: 1 addition & 0 deletions buildreq_ban
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ tests-python
tests.test_markers-python
tests.test_pkg_resources-python
tests.test_resources-python
pypi(setuptools.command.upload_docs)
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/3e/2c/f0a538a2f91ce633a78daaeb34cbfb93a54bd2132a6de1f6cec028eee6ef/setuptools-74.1.2.tar.gz
url = https://files.pythonhosted.org/packages/27/b8/f21073fde99492b33ca357876430822e4800cdf522011f18041351dfa74b/setuptools-75.1.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
1 change: 0 additions & 1 deletion pumpAutospec

This file was deleted.

19 changes: 10 additions & 9 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v18
# autospec version: v19
# autospec commit: f35655a
#
Name : pypi-setuptools
Version : 74.1.2
Release : 339
URL : https://files.pythonhosted.org/packages/3e/2c/f0a538a2f91ce633a78daaeb34cbfb93a54bd2132a6de1f6cec028eee6ef/setuptools-74.1.2.tar.gz
Source0 : https://files.pythonhosted.org/packages/3e/2c/f0a538a2f91ce633a78daaeb34cbfb93a54bd2132a6de1f6cec028eee6ef/setuptools-74.1.2.tar.gz
Version : 75.1.0
Release : 340
URL : https://files.pythonhosted.org/packages/27/b8/f21073fde99492b33ca357876430822e4800cdf522011f18041351dfa74b/setuptools-75.1.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/27/b8/f21073fde99492b33ca357876430822e4800cdf522011f18041351dfa74b/setuptools-75.1.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : Apache-2.0 BSD-2-Clause BSD-3-Clause MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -63,18 +63,18 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-74.1.2
cd %{_builddir}/setuptools-74.1.2
%setup -q -n setuptools-75.1.0
cd %{_builddir}/setuptools-75.1.0
pushd ..
cp -a setuptools-74.1.2 buildavx2
cp -a setuptools-75.1.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1725545164
export SOURCE_DATE_EPOCH=1726589745
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down Expand Up @@ -124,6 +124,7 @@ cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/backports.tarfile-1.2.0
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/importlib_metadata-8.0.0.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/2b8b815229aa8a61e483fb4ba0588b8b6c491890 || :
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/importlib_resources-6.4.0.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/2b8b815229aa8a61e483fb4ba0588b8b6c491890 || :
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/inflect-7.3.1.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/jaraco.collections-5.1.0.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/jaraco.context-5.3.0.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/jaraco.functools-4.0.1.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
cp %{_builddir}/setuptools-%{version}/setuptools/_vendor/jaraco.text-3.12.1.dist-info/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
339
340
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
6a071a485074061d8d930a0afe105c95e2b3f3cb/setuptools-74.1.2.tar.gz
404d2a75368ec72728956d5d09bef4865d14adee/setuptools-75.1.0.tar.gz

0 comments on commit 45add46

Please sign in to comment.