Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 68.0.0 to …
Browse files Browse the repository at this point in the history
…version 68.1.0

Anderson Bravalheri (46):
      Remove dependency on `pip-run`.
      Avoid pytest-perf on Cygwin
      Rewrite noqa directive for the bennefit of ruff
      Add workaround for towncrier
      Revert changes in _EditableFinder
      Reuse PathFinder to deal with fs case sensitivity in editable_wheel
      Add more checks for case sensitivity in editable_wheel tests
      Adequate tests to the latest changes in wheel 0.41.1
      Allow SystemExit exceptions to pass through unless code = 0
      Remove leftover variable in test_build_meta
      Test setup.py with sys.exit(0) only for non-legacy backend
      Remove unused import
      Exclude __pycache__ and pyc files in MANIFEST.in
      Exclude newsfragments and launcher directories from find_packages
      Ignore newsfragments by default when auto-discovering flat packages
      Add newsfragment
      Fix rst syntax in newsfragment
      Use default encoding when creating .pth files in editable_wheel
      Add newsfragment
      Change UTF-8 example to something simpler to parse
      Add regression tests for sdist
      Simplify handling of relative ext.depends
      Update changelog entry
      Change classification of PR from bugfix to feature
      Improve logic operations on path handling
      Use 'resolve' instead of 'abspath'
      Add test for auto inclusion of depends in the case of symlinks
      Allow symlinked Extension.depends to be auto-included by sdist
      Add test case for when dependency files don't exit
      Capture expectation about (gui-)scripts in pyproject.toml/setup.py
      Make sure user is notified that (gui-)scripts have to be defined in dynamic
      Add news fragment
      Remove beta warning for pyproject tool.setuptools
      Update docs to remove beta status for tool.setuptools
      Remove unused import
      Mention setup.py install for zip-safe and eager-resources
      Prefer the obsolete nomenclature
      Retain warning for tool.distutils (still internal/experimental)
      Retouch pyproject config docs
      Add news fragment
      Ignore warnings about tool.distutils
      Remove confusing bit of doc
      Refactor TestRegressions to use symlink_or_skip_test
      Fix tools/finalize to use NEWS instead of CHANGES (towncrier-related)
      Improve rendering of newsfragment
      Bump version: 68.0.0 → 68.1.0

Arcadiy Ivanov (1):
      Handle `setup.py` possibly using `sys.exit`

Ashley Anderson (11):
      Fix sphinx-lint errors in docs
      Add failing test
      Update _EditableFinder (in _FINDER_TEMPLATE) to be case-sensitive on case-insensitive filesystems
      Add news fragment
      Remove redundant logic
      Ensure posix paths to enforce case-sensitivity on Windows
      Expand case-sensitivity tests
      More robust checking of path case for imports from editable installations
      Move _check_case within the template
      Fix for Python <3.10
      Small refactor to fix off-by-one, lint

Bart Broere (1):
      Fix a sentence (minor change)

Dimitri Papadopoulos (1):
      Fix a couple typos found by codespell

Hang (2):
      Update package_discovery.rst
      Update package_discovery.rst

Jason R. Coombs (29):
      Adopt towncrier for managing changelog. Fixes jaraco/skeleton#83.
      ⚫ Fade to black.
      Use a different variable name. Fixes #3961. Workaround for astral-sh/ruff#5249.
      Move towncrier config to its own file.
      Use the default 'newsfragments' for news fragments.
      Use jaraco.develop.towncrier to check changes and determine the release kind.
      Revert to towncrier default types.
      Normalized headings in changelog.
      Remove excess config
      Add newsfragment
      Exclude jaraco.develop on cygwin
      Remove code reliant on bdist_wininst. Ref #3525.
      Replace workaround for actions/setup-python#508 with 'allow-prereleases'
      Remove tox boilerplate, no longer necessary with later versions of tox.
      Require Python 3.8 or later.
      Expand 'finalize' to commit and tag the change.
      Leverage pytest-enabler 2.2 for the default config.
      Update config to honor black.
      Apply black styling to all but vendored modules.
      Manually correct line too long errors.
      Grab workaround for pytest-dev/execnet#195.
      Rely on unreleased build. Workaround for pypa/build#630.
      Move workarounds to tox.ini to avoid url references in project metadata.
      Prefer 3.x for Python version (latest stable).
      Collapse skeleton history. Workaround for jaraco/skeleton#87.
      Add links to project home page and pypi. Fixes jaraco/skeleton#77.
      Replace redundant step names with simple 'Run'.
      Increase visibility of security policy. (#4)
      Remove TOX_WORK_DIR workaround, no longer necessary with tox 4. Ref tox-dev/tox#3050.

Joyce (4):
      Feat: set ci-sage.yml top level as contents read
      feat: initial permissions to main.yml
      Create 3833.misc.rst
      Add user to changelog.d file.

Oliver Mannion (1):
      docs: remove mention of include_package_data and package_data interaction

Stefano Rivera (4):
      Exclude debian dirs from the default namespace search
      Exclude "debian" from top_level.txt.
      A news fragment
      Explain where we are ignoring Debian

Thomas Kluyver (1):
      Remove execnet workaround

ruro (14):
      add Extension.depends to build_ext.get_source_files
      add tests for Extension sdist handling
      add news fragment for PR
      improve backwards compatibility and warning messages
      remove test_auto_include_symlinked_depends
      reimplement _get_internal_depends according to the new logic
      remove no longer used functions in _path
      refactor the tests a bit
      move test project root to subdir, use source_dir fixture
      improve the touch helper function
      add test_symlinked_extension_sources
      add test_invalid_extension_depends
      inline is_relative_to (it's not available in Python 3.8)
      don't run logging verification tests under stdlib distutils

wim glenn (1):
      Typo fix pyproject_config.rst
  • Loading branch information
fenrus75 committed Aug 16, 2023
1 parent 334af13 commit 645833e
Show file tree
Hide file tree
Showing 5 changed files with 12 additions and 12 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
URL = https://files.pythonhosted.org/packages/83/b0/18310b45f6eec3757c0554dbc1e03f2f7685c8a87831aea6adc1276faacc/setuptools-68.1.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
url = https://files.pythonhosted.org/packages/83/b0/18310b45f6eec3757c0554dbc1e03f2f7685c8a87831aea6adc1276faacc/setuptools-68.1.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
16 changes: 8 additions & 8 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -4,10 +4,10 @@
# Using build pattern: distutils3
#
Name : pypi-setuptools
Version : 68.0.0
Release : 303
URL : https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
Version : 68.1.0
Release : 304
URL : https://files.pythonhosted.org/packages/83/b0/18310b45f6eec3757c0554dbc1e03f2f7685c8a87831aea6adc1276faacc/setuptools-68.1.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/83/b0/18310b45f6eec3757c0554dbc1e03f2f7685c8a87831aea6adc1276faacc/setuptools-68.1.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -61,18 +61,18 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-68.0.0
cd %{_builddir}/setuptools-68.0.0
%setup -q -n setuptools-68.1.0
cd %{_builddir}/setuptools-68.1.0
pushd ..
cp -a setuptools-68.0.0 buildavx2
cp -a setuptools-68.1.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1687274276
export SOURCE_DATE_EPOCH=1692144112
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
303
304
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
11a0ee6ae1f2dcb1bdc673dc66ee3f62db59c840/setuptools-68.0.0.tar.gz
b996986ab71c0461a5bb233f8efebb3caf522f35/setuptools-68.1.0.tar.gz

0 comments on commit 645833e

Please sign in to comment.