Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 69.1.1 to …
Browse files Browse the repository at this point in the history
…version 69.2.0

Anderson Bravalheri (30):
      Further clarify include_package_data
      Add link to `.gitignore` guidelines
      Add missing ``encoding`` to setuptools tests
      Fix formatting errors
      Adjust test_sandbox to encoding change
      Fix `pathlib.Path` error
      Rework test_pyprojecttoml.create_example
      Add more explict encodings in test_pyprojecttoml
      Refactor test_pyproject.toml to use more jaraco.path.build
      Add utf-8 encoding in test_setupcfg, test_expand
      Use jaraco.path.build in test_pyprojecttoml_dynamic_deps
      Add utf-8 encoding in test_apply_pyproject
      Add utf-8 encoding in test_packageindex
      Add utf-8 encoding in test_editable_install test_logging
      Improve utf-8 in test_config_discovery
      Avoid aliasing jaraco.path.build in tests_pyprojecttoml
      Add utf-8 encoding to test_pkg_resources
      Add newsfragment
      Add newsfragment
      Use binary mode when 'touch'-ing files in test_build_py and test_build_meta
      Minor formatting improvement
      Add `encoding` to subprocess.run inside setuptools/tests
      Add compat.py39.LOCALE_ENCODING
      Re-use compat.py39.LOCALE_ENCODING in editable_wheel
      Explicitly use 'locale' encoding for .pth files in easy_install
      Add comments to remind about utf-8 in easy-install
      Explicitly use 'locale' encoding for .pth files in setuptools.namespaces
      Add news fragment
      Update setup.cfg
      Bump version: 69.1.1 → 69.2.0

Avasam (23):
      Remoe .idea/ from .gitignore
      Drop dependency on `py`
      Replace Flake8-2020 by Ruff
      Standardize and centralize StrPath TypeAlias
      pkg_resources: Clarify some methods return `bytes`, not `str`
      Create 4243.bugfix.rst
      Return an empty list by default in `ResourceManager.cleanup_resources`
      Update newsfragments/4243.bugfix.rst
      Create 4244.bugfix.rst
      Update __init__.py
      Prevent `pkg_resources._find_adapter` from ever returning `None`
      Made `pkg_resoursces.NullProvider`'s `has_metadata` and `metadata_isdir` methods return actual booleans like all other Providers
      Fix mypy issues (#3979)
      Apply suggestions from code review
      Enable mypy on CI
      `pkg_resources`: Remove unused and shadowed variables
      Update mypy to 1.9
      update setup-python action to v5
      Update checkout action to v4
      Update cache action to v4
      Update cygwin-install-action
      Update upload-artefact action to v4
      Update .github/workflows/ci-sage.yml

Dimitri Papadopoulos (1):
      Fix a couple typos found by codespell

Jason R. Coombs (1):
      Avoid removing ruff.toml during vendoring. Closes #4252.

Tommy (1):
      small grammar fix
  • Loading branch information
fenrus75 committed Mar 15, 2024
1 parent 93f9fe2 commit d81ff57
Show file tree
Hide file tree
Showing 5 changed files with 13 additions and 13 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/c8/1f/e026746e5885a83e1af99002ae63650b7c577af5c424d4c27edcf729ab44/setuptools-69.1.1.tar.gz
URL = https://files.pythonhosted.org/packages/4d/5b/dc575711b6b8f2f866131a40d053e30e962e633b332acf7cd2c24843d83d/setuptools-69.2.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/c8/1f/e026746e5885a83e1af99002ae63650b7c577af5c424d4c27edcf729ab44/setuptools-69.1.1.tar.gz
url = https://files.pythonhosted.org/packages/4d/5b/dc575711b6b8f2f866131a40d053e30e962e633b332acf7cd2c24843d83d/setuptools-69.2.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
18 changes: 9 additions & 9 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,13 @@
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v4
# autospec commit: da8b975
# autospec commit: 3d985eb
#
Name : pypi-setuptools
Version : 69.1.1
Release : 319
URL : https://files.pythonhosted.org/packages/c8/1f/e026746e5885a83e1af99002ae63650b7c577af5c424d4c27edcf729ab44/setuptools-69.1.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/c8/1f/e026746e5885a83e1af99002ae63650b7c577af5c424d4c27edcf729ab44/setuptools-69.1.1.tar.gz
Version : 69.2.0
Release : 320
URL : https://files.pythonhosted.org/packages/4d/5b/dc575711b6b8f2f866131a40d053e30e962e633b332acf7cd2c24843d83d/setuptools-69.2.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/4d/5b/dc575711b6b8f2f866131a40d053e30e962e633b332acf7cd2c24843d83d/setuptools-69.2.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -63,18 +63,18 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-69.1.1
cd %{_builddir}/setuptools-69.1.1
%setup -q -n setuptools-69.2.0
cd %{_builddir}/setuptools-69.2.0
pushd ..
cp -a setuptools-69.1.1 buildavx2
cp -a setuptools-69.2.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1708705368
export SOURCE_DATE_EPOCH=1710542233
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
319
320
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
9a1c40450c45809f459fa9e1c936a47d2b36e585/setuptools-69.1.1.tar.gz
aebbbea52c78c80628559decae0cff7046a7f91d/setuptools-69.2.0.tar.gz

0 comments on commit d81ff57

Please sign in to comment.