Skip to content
This repository has been archived by the owner on Oct 27, 2022. It is now read-only.

Commit

Permalink
[update to 2.6.0] Fix issue found in #165 - on Windows env vars are n…
Browse files Browse the repository at this point in the history
…ot passed around if they are empty for some reason.

Daniel Hahler (1):
      tests: test_central_subprocess_no_subscript: remove omit

Hugo (1):
      Python 3.7 requires Xenial and sudo

Ionel Cristian Mărieș (44):
      Use new name.
      Drop pytest 2.7 from suite, add 3.1. Other upgrades.
      Fix issue found in #165 - on Windows env vars are not passed around if they are empty for some reason.
      Change of behavior: when report generation fails log a warning instead. This is consistent with other kinds of failures (like misconfigration) that result in no coverage data/results. Closes #161.
      Fix assertion. Also drop coverage 3.7 - it's ancient now.
      Update ci conf.
      Downgrade xdist for old pytest and remove pytest2.7 cruft.
      Fix syntax (turns out it's one dep per line in tox.ini).
      Add missing plugins specification.
      Why don't I read the comments, I dunno ...
      Pin down docutils and make requires.io stop complaining about sphinx.
      Forgot to include this in a35d40b359df2a1f044332fe1b2acbeaff20a329.
      Drop support for pytest<=2.8 and upgrade some test deps.
      Load data again before combine.
      Make sure config path is absulutized early. Fixes failures in finish (where now we reinitialize the cov object for forced combine) that are caused by sloppy cwd changes (crazy stuff ppl put in tests).
      Add a test for aliasing (the combine in finish changes).
      Seem this becomes absolute path, just let it be.
      Add tests for xdist and suprocess and fix handling in xdist mode (missing data_file attr).
      Check if it's a path first (don't absolutize None).
      Create a duplicated (ish) cov object for combining as @ryanhiebert suggests.
      Correct tests (missing arguments).
      Use aliasing for non-colocation test.
      Add missing branch option.
      Undo these changes.
      Add a coveragerc with path configuration.
      Some debugging.
      Drop support for py2.6, pytest<=2.8 and coverage<4.0.
      Drop support for old coverage internals.
      Add python version constraint like in pytest-dev/pluggy#106.
      Drop old coverage. Close #182.
      Restructure docs a bit. Add various new notes.
      Add a no_cover marker/fixture. Close #78.
      Document how to deal with plugins. Close #177
      Drop 2.9 (xdist don't support it).
      Remove unused import.
      Increase wait time (just in case sporadic failures are caused by slow interpreter startup) and wait a bit after getting the event (just in case thiiings are slooow and interpreter is sigtermed before it gets to the sleep(5) call).
      Remove progress indication (not have bogus "%" in output).
      Update test grid.
      Update changelog.
      More stuff in chnagelog.
      Update changelog.
      Update some test deps.
      Include the py37 settings in the template.
      Bump version: 2.5.1 → 2.6.0

Jean Jordaan (1):
      Fix quoting

Jeremy Bowman (2):
      Fix race condition in test
      Allow remote nodes to get source modules from .coveragerc

Julian (1):
      Fix typo in plugin docu

Michael (1):
      Added python 3.6 to classifiers

Ryan Hiebert (2):
      New coverage instance to combine
      Override cov with combining_cov

Samuel Giffard (1):
      Added in the doc a useful example to help integrate pytest-cov.

Terence D. Honles (1):
      fix DoctestItem has no attribute fixturenames (regression from #78)

hugovk (2):
      Drop support for EOL Python 2.6
      Drop support for EOL Python 3.3
  • Loading branch information
fenrus75 authored and djklimes committed Sep 5, 2018
1 parent fc60ffa commit fcc4fd5
Show file tree
Hide file tree
Showing 7 changed files with 43 additions and 15 deletions.
13 changes: 13 additions & 0 deletions .gitignore
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
.*~
*~
*.swp
.repo-index
*.log
build.log.round*
*.tar.*
*.tgz
!*.tar.*.*
*.zip
commitmsg
results/
rpms/
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pytest-cov
URL = http://pypi.debian.net/pytest-cov/pytest-cov-2.5.1.tar.gz
URL = https://files.pythonhosted.org/packages/d9/e2/58f90a316fbd94dd50bf5c826a23f3f5d079fb3cc448c1e9f0e3c33a3d2a/pytest-cov-2.6.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pytest-cov
url = http://pypi.debian.net/pytest-cov/pytest-cov-2.5.1.tar.gz
url = https://files.pythonhosted.org/packages/d9/e2/58f90a316fbd94dd50bf5c826a23f3f5d079fb3cc448c1e9f0e3c33a3d2a/pytest-cov-2.6.0.tar.gz
archives =
giturl = https://github.com/pytest-dev/pytest-cov.git

Expand All @@ -17,6 +17,8 @@ autoupdate = false
broken_c++ = false
# disable parallelization during build
broken_parallel_build = false
# this package is a library compatability package and only ships versioned library files
compat = false
# set conservative build flags
conservative_flags = false
# pass -ffast-math to compiler
Expand Down
34 changes: 23 additions & 11 deletions pytest-cov.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,29 +3,27 @@
# Generated by: autospec.py
#
Name : pytest-cov
Version : 2.5.1
Release : 40
URL : http://pypi.debian.net/pytest-cov/pytest-cov-2.5.1.tar.gz
Source0 : http://pypi.debian.net/pytest-cov/pytest-cov-2.5.1.tar.gz
Version : 2.6.0
Release : 41
URL : https://files.pythonhosted.org/packages/d9/e2/58f90a316fbd94dd50bf5c826a23f3f5d079fb3cc448c1e9f0e3c33a3d2a/pytest-cov-2.6.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/d9/e2/58f90a316fbd94dd50bf5c826a23f3f5d079fb3cc448c1e9f0e3c33a3d2a/pytest-cov-2.6.0.tar.gz
Summary : Pytest plugin for measuring coverage.
Group : Development/Tools
License : MIT
Requires: pytest-cov-python3
Requires: pytest-cov-license
Requires: pytest-cov-python
Requires: coverage
Requires: docutils
Requires: pytest
BuildRequires : Sphinx
BuildRequires : Sphinx-python
BuildRequires : buildreq-distutils3
BuildRequires : coverage
BuildRequires : coverage-python
BuildRequires : pbr
BuildRequires : pip
BuildRequires : pluggy
BuildRequires : py-python
BuildRequires : pytest

BuildRequires : python3-dev
BuildRequires : setuptools
BuildRequires : tox
BuildRequires : virtualenv

Expand All @@ -35,6 +33,14 @@ Overview

.. start-badges

%package license
Summary: license components for the pytest-cov package.
Group: Default

%description license
license components for the pytest-cov package.


%package python
Summary: python components for the pytest-cov package.
Group: Default
Expand All @@ -54,18 +60,20 @@ python3 components for the pytest-cov package.


%prep
%setup -q -n pytest-cov-2.5.1
%setup -q -n pytest-cov-2.6.0

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C
export SOURCE_DATE_EPOCH=1518380143
export SOURCE_DATE_EPOCH=1536133655
python3 setup.py build -b py3

%install
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/doc/pytest-cov
cp LICENSE %{buildroot}/usr/share/doc/pytest-cov/LICENSE
python3 -tt setup.py build -b py3 install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand All @@ -74,6 +82,10 @@ echo ----[ mark ]----
%files
%defattr(-,root,root,-)

%files license
%defattr(-,root,root,-)
/usr/share/doc/pytest-cov/LICENSE

%files python
%defattr(-,root,root,-)

Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
40
41
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
9e3cd050aae4491c65c5b0dbd5325a7c9741f23c/pytest-cov-2.5.1.tar.gz
f8fa3f9efd31709a650e0fdfe0e474aee4543f1d/pytest-cov-2.6.0.tar.gz
1 change: 1 addition & 0 deletions whatrequires
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
# This file contains recursive sources that require this package
alembic

0 comments on commit fcc4fd5

Please sign in to comment.