Skip to content

Commit

Permalink
docs: update shibuya to latest
Browse files Browse the repository at this point in the history
  • Loading branch information
Tobi-De committed Jan 3, 2024
1 parent 5675cac commit 093af77
Show file tree
Hide file tree
Showing 7 changed files with 51 additions and 20 deletions.
8 changes: 8 additions & 0 deletions docs/_static/custom.css
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
html.light {
--yue-c-code-text: var(--yue-c-text);
}

html.dark {
--yue-c-code-text: var(--yue-c-text);
}

22 changes: 16 additions & 6 deletions docs/conf.py
Original file line number Diff line number Diff line change
Expand Up @@ -26,6 +26,7 @@
"sphinx_autorun",
"cappa.ext.docutils",
"sphinx_github_changelog",
"sphinxcontrib.mermaid",
]
extlinks = {
"pull": ("https://github.com/tobi-de/falco/pull/%s", "pull request #%s"),
Expand Down Expand Up @@ -53,12 +54,21 @@
"mastodon_url": "https://fosstodon.org/@tobide",
"github_url": "https://github.com/tobi-de/falco",
"twitter_url": "https://twitter.com/tobidegnon",
"light_css_variables": {
"--sy-rc-theme": "77, 210, 255",
},
"dark_css_variables": {
"--sy-rc-theme": "0, 153, 204",
},
"accent_color": "sky",
}
html_logo = "images/logo_with_text.svg"
html_favicon = "../assets/falco-logo.svg"
html_css_files = [
"custom.css",
]

# -- Mermaid configuration -----------------------------------------------------
mermaid_version = "10.6.1"
mermaid_params = [
"--theme",
"dark",
# "--width",
# "600",
"--backgroundColor",
"transparent",
]
5 changes: 5 additions & 0 deletions docs/guides/deployment.rst
Original file line number Diff line number Diff line change
Expand Up @@ -42,6 +42,11 @@ WSGI server

**Process Managers**


**Restart without downtime**
sudo supervisorctl pid gunicorn | sudo xargs kill -s HUP
https://blog.pecar.me/gunicorn-restart

Web server
----------

Expand Down
26 changes: 16 additions & 10 deletions docs/guides/index.rst
Original file line number Diff line number Diff line change
Expand Up @@ -32,14 +32,15 @@ developer in general.
**The obvious ones**

.. grid:: 2
:class-row: surface

.. grid-item-card:: The official Django documentation
.. grid-item-card:: :octicon:`rocket` The official Django documentation
:link: https://docs.djangoproject.com/en/dev/

Django's documentation is arguably one of the best I have encountered. The **Topics guides** and **How-to guides** are particularly
noteworthy and should not be overlooked.

.. grid-item-card:: The HTMX documentation
.. grid-item-card:: :octicon:`flame` The HTMX documentation
:link: https://htmx.org/

The htmx documentation have everything you need to understand htmx but they also have great essays that are worth reading
Expand All @@ -49,23 +50,26 @@ developer in general.
**Programming principles**

.. grid:: 2
:class-row: surface
:padding: 0
:gutter: 2

.. grid-item-card:: HTML First
.. grid-item-card:: :octicon:`zap` HTML First
:link: https://html-first.com/

HTML First is a set of principles that aims to make building web software easier, faster, more inclusive, and more maintainable.

.. grid-item-card:: KISS
.. grid-item-card:: :octicon:`smiley` KISS
:link: https://en.wikipedia.org/wiki/KISS_principle

Keep it simple, stupid. This is a design principle that states that most systems work best if they are kept simple rather than made complicated.

.. grid-item-card:: WYAGNI
.. grid-item-card:: :octicon:`clock` WYAGNI
:link: https://codeanthropology.substack.com/p/yagni-and-waygni?

When Are You Gonna Need It? A look at how we reduce scope, what we lose along the way, and what we could gain if we didn't. With a short story from the startup trenches.

.. grid-item-card:: 12 Factor App
.. grid-item-card:: :octicon:`gear` 12 Factor App
:link: https://12factor.net/

The twelve-factor app is a methodology for building software-as-a-service applications. These best practices are designed to enable applications to be built with portability and resilience when deployed to the web.
Expand All @@ -74,13 +78,14 @@ developer in general.
**Blog articles and videos**

.. grid:: 2
:class-row: surface

.. grid-item-card:: Adam Johnson blog
.. grid-item-card:: :octicon:`book` Adam Johnson blog
:link: https://adamj.eu/tech/

A core Django developer, he provides comprehensive and unique content covering every aspect of the framework.

.. grid-item-card:: BugBytes
.. grid-item-card:: :octicon:`video` BugBytes
:link: https://www.youtube.com/bugbytes

This is a great YouTube channel that provides a wealth of Django and HTMX content.
Expand All @@ -89,13 +94,14 @@ developer in general.
**The special ones**

.. grid:: 2
:class-row: surface

.. grid-item-card:: The Grug Brained Developer
.. grid-item-card:: :octicon:`book` The Grug Brained Developer
:link: https://grugbrain.dev

A layman's guide to thinking like the self-aware smol brained.

.. grid-item-card:: The Cult of Done
.. grid-item-card:: :octicon:`shield-check` The Cult of Done
:link: https://medium.com/@bre/the-cult-of-done-manifesto-724ca1c2ff13

The cult of done manifesto is a set of principles that aims to help you get things done.
Expand Down
2 changes: 1 addition & 1 deletion docs/guides/task_queues_and_schedulers.rst
Original file line number Diff line number Diff line change
Expand Up @@ -60,7 +60,7 @@ For more complex tasks, I tend to choose a solution that supports redis as a tas
:class: dropdown

If you are using one of these you might want an automatic reload feature when files changes in dev, you can use the ``hupper``
python package for that purpose. It watches for file changes in the cruurent directory and restarts the worker process automatically.
python package for that purpose. It watches for file changes in the current directory and restarts the worker process automatically.

.. code-block:: bash
:caption: usage example
Expand Down
5 changes: 3 additions & 2 deletions docs/install.rst
Original file line number Diff line number Diff line change
Expand Up @@ -14,13 +14,14 @@ Next Up
-------

.. grid:: 2
:class-row: surface

.. grid-item-card:: The CLI
.. grid-item-card:: :octicon:`terminal` The CLI
:link: /the_cli/

The documentation for the ``falco`` command line interface (CLI).

.. grid-item-card:: Guides
.. grid-item-card:: :octicon:`book` Guides
:link: /guides/

A collection of guides on common web development topics and how to address them in django.
3 changes: 2 additions & 1 deletion pyproject.toml
Original file line number Diff line number Diff line change
Expand Up @@ -85,11 +85,12 @@ dependencies = [
"sphinx",
"sphinx-autobuild",
"myst-parser",
"shibuya==2023.10.26",
"shibuya",
"sphinx-design",
"sphinx-tabs",
"sphinx-copybutton",
"sphinx-togglebutton",
"sphinxcontrib-mermaid",
"sphinx-autorun",
"sphinx-github-changelog",
"rich-codex",
Expand Down

0 comments on commit 093af77

Please sign in to comment.