Skip to content

Commit

Permalink
docs: improve contribution guide
Browse files Browse the repository at this point in the history
  • Loading branch information
Tobi-De committed Dec 21, 2023
1 parent 558a729 commit f0e007e
Show file tree
Hide file tree
Showing 7 changed files with 43 additions and 27 deletions.
2 changes: 1 addition & 1 deletion .github/workflows/ci.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
name: Continous Integration - Testing
name: Continous Integration

on: [push]

Expand Down
2 changes: 1 addition & 1 deletion .github/workflows/documentation.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
name: documentation
name: Documentation

on: [push, pull_request, workflow_dispatch]

Expand Down
7 changes: 5 additions & 2 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -7,12 +7,15 @@
<p>An opinionated toolkit for a modern Django development experience</p>
</h1>

[![documentation](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml)
[![Continous Integration - Testing](https://github.com/Tobi-De/falco/actions/workflows/ci.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/ci.yml)
[![Documentation](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/documentation.yml)
[![Continous Integration](https://github.com/Tobi-De/falco/actions/workflows/ci.yml/badge.svg)](https://github.com/Tobi-De/falco/actions/workflows/ci.yml)
[![pypi](https://badge.fury.io/py/falco-cli.svg)](https://pypi.org/project/falco-cli/)
[![Hatch project](https://img.shields.io/badge/%F0%9F%A5%9A-Hatch-4051b5.svg)](https://github.com/pypa/hatch)
[![Ruff](https://img.shields.io/endpoint?url=https://raw.githubusercontent.com/astral-sh/ruff/main/assets/badge/v2.json)](https://github.com/astral-sh/ruff)
[![MIT License](https://img.shields.io/badge/license-MIT-blue.svg)](https://github.com/Tobi-De/falco/blob/main/LICENSE)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/falco-cli)
![PyPI - Versions from Framework Classifiers](https://img.shields.io/pypi/frameworkversions/django/falco-cli)


> [!WARNING]
> This is a work in progress (WIP), this is also [fuzzy-couscous](https://github.com/Tobi-De/fuzzy-couscous) new cooler brother.
Expand Down
54 changes: 32 additions & 22 deletions docs/contributing.rst
Original file line number Diff line number Diff line change
Expand Up @@ -9,11 +9,25 @@ helps, and credit will always be given.

You can contribute in many ways:


The Guides
---------

Contributions to the guides should be made via `GitHub Discussions <https://github.com/Tobi-De/falco/discussions>`_. Any contribution is welcome, even for typos and grammatical errors.
If a contribution requires a complete rewrite of a section or an entire guide, or adds new insights (similar to an article review), proper credits will be given at the bottom of the relevant guide.
I will not accept any pull request that directly changes a guide without prior discussion on the topic, except for minor typo fixes.


The CLI
-------

Contributions to the CLI are more open. You can fix issues, suggest new commands, or propose improvements to existing ones.

Types of Contributions
----------------------
^^^^^^^^^^^^^^^^^^^^^^

Report Bugs
~~~~~~~~~~~
***********

Report bugs at https://github.com/Tobi-De/falco/issues.

Expand All @@ -24,26 +38,26 @@ If you are reporting a bug, please include:
* Detailed steps to reproduce the bug.

Fix Bugs
~~~~~~~~
********

Look through the GitHub issues for bugs. Anything tagged with "bug" and "help
wanted" is open to whoever wants to implement it.

Implement Features
~~~~~~~~~~~~~~~~~~
******************

Look through the GitHub issues for features. Anything tagged with "enhancement"
and "help wanted" is open to whoever wants to implement it.

Write Documentation
~~~~~~~~~~~~~~~~~~~
*******************

falco could always use more documentation, whether as part of the
official falco docs, in docstrings, or even on the web in blog posts,
articles, and such.

Submit Feedback
~~~~~~~~~~~~~~~
***************

The best way to send feedback is to file an issue at https://github.com/Tobi-De/falco/issues.

Expand All @@ -55,7 +69,7 @@ If you are proposing a feature:
are welcome :)

Get Started!
------------
^^^^^^^^^^^^

Ready to contribute? Here's how to set up `falco` for local development.

Expand All @@ -64,26 +78,24 @@ Ready to contribute? Here's how to set up `falco` for local development.

$ git clone git@github.com:your_name_here/falco.git

3. Install your local copy into a virtualenv. Assuming you have virtualenvwrapper installed, this is how you set up your fork for local development::
3. Install your local copy into a virtualenv. Assuming you have hatch installed, this is how you set up your fork for local development::

$ mkvirtualenv falco
$ cd falco/
$ python setup.py develop
$ hatch env create

4. Create a branch for local development::

$ git checkout -b name-of-your-bugfix-or-feature

Now you can make your changes locally.

5. When you're done making changes, check that your changes pass flake8 and the
tests, including testing other Python versions with tox::
4. Install pre-commit hooks for linting and code formatting before every commit::

$ pre-commit install

$ flake8 falco tests
$ python setup.py test or pytest
$ tox
5. When you're done making changes, check that your changes pass tests including testing other Python versions::

To get flake8 and tox, just pip install them into your virtualenv.
$ hatch run test

6. Commit your changes and push your branch to GitHub::

Expand All @@ -94,7 +106,7 @@ Ready to contribute? Here's how to set up `falco` for local development.
7. Submit a pull request through the GitHub website.

Pull Request Guidelines
-----------------------
^^^^^^^^^^^^^^^^^^^^^^^

Before you submit a pull request, check that it meets these guidelines:

Expand All @@ -107,22 +119,20 @@ Before you submit a pull request, check that it meets these guidelines:
and make sure that the tests pass for all supported Python versions.

Tips
----
^^^^

To run a subset of tests::

$ pytest tests.test_falco


Deploying
---------
^^^^^^^^^

A reminder for the maintainers on how to deploy.
Make sure all your changes are committed (including an entry in HISTORY.rst).
Then run::

$ bump2version patch # possible: major / minor / patch
$ hatch version patch # possible: major / minor / patch
$ git push
$ git push --tags

Travis will then deploy to PyPI if tests pass.
2 changes: 2 additions & 0 deletions docs/index.rst
Original file line number Diff line number Diff line change
Expand Up @@ -14,6 +14,8 @@
<img src="https://img.shields.io/badge/%F0%9F%A5%9A-Hatch-4051b5.svg">
<img src="https://img.shields.io/endpoint?url=https://raw.githubusercontent.com/astral-sh/ruff/main/assets/badge/v2.json">
<img src="https://img.shields.io/badge/license-MIT-blue.svg">
<img src="https://img.shields.io/pypi/pyversions/falco-cli">
<img src="https://img.shields.io/pypi/frameworkversions/django/falco-cli">
</div>


Expand Down
1 change: 1 addition & 0 deletions pyproject.toml
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,7 @@ classifiers = [
"Framework :: Django :: 4",
"Framework :: Django :: 4.0",
"Framework :: Django :: 4.1",
"Framework :: Django :: 4.2",
"Intended Audience :: Developers",
"Natural Language :: English",
]
Expand Down
2 changes: 1 addition & 1 deletion src/falco/__about__.py
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# SPDX-FileCopyrightText: 2023-present Tobi DEGNON <tobidegnon@proton.me>
#
# SPDX-License-Identifier: MIT
__version__ = "0.0.21"
__version__ = "0.0.22"

0 comments on commit f0e007e

Please sign in to comment.