Skip to content

Commit

Permalink
dev-cpp/opentelemetry-cpp: add 1.16.1
Browse files Browse the repository at this point in the history
IUSE=jager and dev-libs/thrift dependency is removed by
open-telemetry/opentelemetry-cpp#2031

Add remote-id to metadata

Bug: https://bugs.gentoo.org/900707
Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com>
  • Loading branch information
littlewu2508 committed Aug 14, 2024
1 parent 5556ea0 commit e8c835f
Show file tree
Hide file tree
Showing 3 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/opentelemetry-cpp/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST opentelemetry-cpp-1.16.1.tar.gz 904173 BLAKE2B 7f63ddd1b4305d6c98ad4a8c52ad12bbdbd8a2b125f2143978873dff4a94675bf644bcba609bc7de65868a34b530a0930be5a836e4ff05f476d5643ae3294b90 SHA512 c93005c9b24b358a9998141f6c7fd9675778731775dacaad18f0e81117fd00aaabff371c04cf96688a9c86117727181052a141d961d4db28fc457b454351c570
DIST opentelemetry-cpp-1.3.0.tar.gz 710030 BLAKE2B 56aa3213fd9c9ac5266197c2ca417f5ff181ca28016033c9320e63122eaf9a53bdb265e1778227a9036bc42f8837755a3009cb23610268bc03b9fb24b3844c82 SHA512 38f613c208ec847c8bf7765732d8198fcc427c293a929945d72c2f739e89d2a0ad36be4d94cc3c1b77fd7b1f1d1e5d8bdb38094a493ba3da3125281cd1016836
DIST opentelemetry-cpp-1.4.0.tar.gz 722520 BLAKE2B c34867846708218e5ffcff9cdaa275e0c43201f681a68ad697d9f83ac04b7fdc6cdb69d942274cbe200b241e407ba11218c7e92da4f9adf4490e89c06388347f SHA512 a2339c0f9b2dc0d4f1964536a844241436bd68774445a0eab6e89e51965e01d3c40d2aa776d751eb497c50e9fdaa4e0023095efb14c8abbd6bbe23a2596eb3c9
DIST opentelemetry-cpp-1.6.0.tar.gz 790774 BLAKE2B 9512c092bfe49c9da82eff3950204c1f2eb654df2ed428e58ceb8877d15d80d9978fa6da37f7780352538c74de04bac69660528b255dfbce743f89b9d4020dd2 SHA512 ae0777451a3d2d676afd9f3142ab78c7afb08474f6038bd810ff0ee30fee6695e10100c901e7ffadf3faf16c7d19622acdea414cd720be8572f7720f2d528628
3 changes: 3 additions & 0 deletions dev-cpp/opentelemetry-cpp/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,6 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<upstream>
<remote-id type="github">open-telemetry/opentelemetry-cpp</remote-id>
</upstream>
<maintainer type="person">
<email>chutzpah@gentoo.org</email>
<name>Patrick McLean</name>
Expand Down
48 changes: 48 additions & 0 deletions dev-cpp/opentelemetry-cpp/opentelemetry-cpp-1.16.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="The OpenTelemetry C++ Client"
HOMEPAGE="
https://opentelemetry.io/
https://github.com/open-telemetry/opentelemetry-cpp
"
SRC_URI="https://github.com/open-telemetry/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64"
IUSE="prometheus test"

RDEPEND="
net-misc/curl:=
dev-libs/boost:=
"
DEPEND="
${RDEPEND}
test? (
dev-cpp/gtest
dev-cpp/benchmark
)
"

RESTRICT="!test? ( test )"

PATCHES=(
# remove tests the need network
"${FILESDIR}/opentelemetry-cpp-1.5.0-tests.patch"
)

src_configure() {
local mycmakeargs=(
-DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON
-DBUILD_SHARED_LIBS:BOOL=ON
-DBUILD_TESTING:BOOL=$(usex test)
-DWITH_PROMETHEUS:BOOL=$(usex prometheus)
)

cmake_src_configure
}

0 comments on commit e8c835f

Please sign in to comment.