forked from sstephenson/bats
-
Notifications
You must be signed in to change notification settings - Fork 3
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Bats 1.1.0 - 2018-07-08 This is the first release with new features relative to the original Bats 0.4.0. Added: * The `-r, --recursive` flag to scan directory arguments recursively for `*.bats` files (sstephenson#109) * The `contrib/rpm/bats.spec` file to build RPMs (sstephenson#111) Changed: * Travis exercises latest versions of Bash from 3.2 through 4.4 (sstephenson#116, sstephenson#117) * Error output highlights invalid command line options (sstephenson#45, sstephenson#46, sstephenson#118) * Replaced `echo` with `printf` (sstephenson#120) Fixed: * Fixed `BATS_ERROR_STATUS` getting lost when `bats_error_trap` fired multiple times under Bash 4.2.x (sstephenson#110) * Updated `bin/bats` symlink resolution, handling the case on CentOS where `/bin` is a symlink to `/usr/bin` (sstephenson#113, sstephenson#115) * tag 'v1.1.0': (198 commits) Bats 1.1.0 bats: Replace echo with printf Extract `abort()` function travis: Remove `bats -c` wrapper travis: Enable build with default Linux image Bash Add Bash version test to Travis job. Revert "Re-add Bash version check to Docker image build" Re-add Bash version check to Docker image build Move timing test to Docker run for Linux jobs Remove version check from Docker image build Bash version via build matrix instead of script loop Fix merge error. Add return code storage for Bash version loop Add Bash version output during 'docker build' Clean up Docker image tags Add default value for Bash version Cover more Bash versions with Docker BATS_ROOT: Elide options to reset shell options BATS_ROOT: Restore comment noting issue sstephenson#113 BATS_ROOT: Use `set -P`, remove `PWD` resolution ...
- Loading branch information
Showing
53 changed files
with
2,459 additions
and
755 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
version: 'v1.1.0.{build}' | ||
|
||
build: off | ||
|
||
# This presumes that Git bash is installed at `C:\Program Files\Git` and the | ||
# bash we're using is `C:\Program Files\Git\bin\bash.exe`. | ||
# | ||
# If instead it finds the Windows Subsystem for Linux bash at | ||
# `C:\Windows\System32\bash.exe`, it will fail with an error like: | ||
# /mnt/c/.../bats-core/test/test_helper.bash: line 1: | ||
# syntax error near unexpected token `$'{\r'' | ||
test_script: | ||
- where bash | ||
- bash --version | ||
- bash -c 'export' | ||
- bash -c 'time PATH="/usr/bin:${PATH}" bin/bats test' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,34 @@ | ||
language: c | ||
script: bin/bats --tap test | ||
language: bash | ||
|
||
os: | ||
- linux | ||
|
||
env: | ||
- BASHVER= | ||
- BASHVER=3.2 | ||
- BASHVER=4.0 | ||
- BASHVER=4.1 | ||
- BASHVER=4.2 | ||
- BASHVER=4.3 | ||
- BASHVER=4.4 | ||
|
||
matrix: | ||
include: | ||
- os: osx | ||
|
||
services: | ||
- docker | ||
|
||
script: | ||
- | | ||
if [[ "$TRAVIS_OS_NAME" == 'linux' && -n "$BASHVER" ]]; then | ||
docker build --build-arg bashver=${BASHVER} --tag bats/bats:bash-${BASHVER} . | ||
docker run -it bash:${BASHVER} --version | ||
time docker run -it bats/bats:bash-${BASHVER} --tap /opt/bats/test | ||
else | ||
time bin/bats --tap test | ||
fi | ||
notifications: | ||
email: | ||
on_success: never |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
Andrew Martin (https://control-plane.io/) | ||
Bianca Tamayo <hi@biancatamayo.me> (https://biancatamayo.me/) | ||
Jason Karns <jason.karns@gmail.com> (http://jasonkarns.com/) | ||
Mike Bland <mbland@acm.org> (https://mike-bland.com/) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,9 @@ | ||
ARG bashver=latest | ||
|
||
FROM bash:${bashver} | ||
|
||
RUN ln -s /opt/bats/bin/bats /usr/sbin/bats | ||
|
||
COPY . /opt/bats/ | ||
|
||
ENTRYPOINT ["bash", "/usr/sbin/bats"] |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
Copyright (c) 2017 bats-core contributors | ||
|
||
Permission is hereby granted, free of charge, to any person obtaining | ||
a copy of this software and associated documentation files (the | ||
"Software"), to deal in the Software without restriction, including | ||
without limitation the rights to use, copy, modify, merge, publish, | ||
distribute, sublicense, and/or sell copies of the Software, and to | ||
permit persons to whom the Software is furnished to do so, subject to | ||
the following conditions: | ||
|
||
The above copyright notice and this permission notice shall be | ||
included in all copies or substantial portions of the Software. | ||
|
||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, | ||
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF | ||
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND | ||
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE | ||
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION | ||
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION | ||
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
|
||
--- | ||
|
||
* [bats-core] is a continuation of [bats]. Copyright for portions of the | ||
bats-core project are held by Sam Stephenson, 2014 as part of the project | ||
[bats], licensed under MIT: | ||
|
||
Copyright (c) 2014 Sam Stephenson | ||
|
||
Permission is hereby granted, free of charge, to any person obtaining | ||
a copy of this software and associated documentation files (the | ||
"Software"), to deal in the Software without restriction, including | ||
without limitation the rights to use, copy, modify, merge, publish, | ||
distribute, sublicense, and/or sell copies of the Software, and to | ||
permit persons to whom the Software is furnished to do so, subject to | ||
the following conditions: | ||
|
||
The above copyright notice and this permission notice shall be | ||
included in all copies or substantial portions of the Software. | ||
|
||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, | ||
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF | ||
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND | ||
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE | ||
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION | ||
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION | ||
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
|
||
For details, please see the [version control history][commits]. | ||
|
||
[bats-core]: https://github.com/bats-core/bats-core | ||
[bats]:https://github.com/sstephenson/bats | ||
[commits]:https://github.com/bats-core/bats-core/commits/master |
Oops, something went wrong.