Skip to content

Commit

Permalink
rust: restore mis-deleted patch hunk
Browse files Browse the repository at this point in the history
It was erroneously deleted in commit dccb910 during manual rebase.

Signed-off-by: krant <aleksey.vasilenko@gmail.com>
  • Loading branch information
krant committed Mar 15, 2024
1 parent d359fa0 commit c1a90ef
Show file tree
Hide file tree
Showing 2 changed files with 13 additions and 1 deletion.
2 changes: 1 addition & 1 deletion lang/rust/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=rust
PKG_VERSION:=1.76.0
PKG_RELEASE:=1
PKG_RELEASE:=2

PKG_SOURCE:=rustc-$(PKG_VERSION)-src.tar.xz
PKG_SOURCE_URL:=https://static.rust-lang.org/dist/
Expand Down
12 changes: 12 additions & 0 deletions lang/rust/patches/0002-rustc-bootstrap-cache.patch
Original file line number Diff line number Diff line change
Expand Up @@ -41,3 +41,15 @@
let cache_dir = cache_dst.join(key);
if !cache_dir.exists() {
t!(fs::create_dir_all(&cache_dir));
@@ -704,7 +710,10 @@ download-rustc = false
let llvm_assertions = self.llvm_assertions;

let cache_prefix = format!("llvm-{llvm_sha}-{llvm_assertions}");
- let cache_dst = self.out.join("cache");
+ let cache_dst = match env::var_os("OPENWRT_RUSTC_BOOTSTRAP_CACHE") {
+ Some(v) => PathBuf::from(v),
+ None => self.out.join("cache"),
+ };
let rustc_cache = cache_dst.join(cache_prefix);
if !rustc_cache.exists() {
t!(fs::create_dir_all(&rustc_cache));

0 comments on commit c1a90ef

Please sign in to comment.