Skip to content

Commit

Permalink
reforis plugins: Force distutils-based python package builds
Browse files Browse the repository at this point in the history
In OpenWRT main / 23.05 the new build process chokes on
the OpenWRT package names differing from the python package
names. Force the use of the previous build process for now.

Alternative solutions include providing a PYPI_SOURCE_NAME that
contains the python package name, or renaming the OpenWRT packages
to have the same name as the python package.

Signed-off-by: Magnus Kessler <Magnus.Kessler@gmx.net>
  • Loading branch information
kesslerm authored and miska committed Aug 30, 2023
1 parent db4f391 commit 0a055d5
Show file tree
Hide file tree
Showing 14 changed files with 56 additions and 0 deletions.
2 changes: 2 additions & 0 deletions web/reforis/reforis-data-collection-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-diagnostics-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-haas-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-librespeed-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-netboot-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-netmetr-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-nextcloud-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-openvpn-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-remote-access-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From 3a142711c4c5ec46988af243a8cd31cf1440e1f7 Mon Sep 17 00:00:00 2001
From: Magnus Kessler <Magnus.Kessler@gmx.net>
Date: Thu, 3 Aug 2023 14:23:40 +0200
Subject: [PATCH] Fix version number in setup.py

The setup.py version number should be the same as the package version
in the js/package*.json files. This ensures that external build systems
like OpenWRT can be configured with the correct release version.

Signed-off-by: Magnus Kessler <Magnus.Kessler@gmx.net>
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index d674cfe..9475037 100644
--- a/setup.py
+++ b/setup.py
@@ -32,7 +32,7 @@ class RemoteAccessBuild(build_py):

setuptools.setup(
name=NAME,
- version='1.2.1',
+ version='1.3.0',
packages=setuptools.find_packages(exclude=['tests']),
include_package_data=True,

--
2.34.1

2 changes: 2 additions & 0 deletions web/reforis/reforis-remote-devices-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-remote-wifi-settings-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-snapshots-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down
2 changes: 2 additions & 0 deletions web/reforis/reforis-storage-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,8 @@ PKG_LICENSE_FILES:=LICENSE
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=reforis-distutils
PKG_BUILD_DEPENDS:=node/host

PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1

include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
include ../reforis/files/reforis-plugin.mk
Expand Down

0 comments on commit 0a055d5

Please sign in to comment.