Skip to content

Commit

Permalink
Update chat/element-web to 1.11.77
Browse files Browse the repository at this point in the history
Changes in [1.11.76](https://github.com/element-hq/element-web/releases/tag/v1.11.76) (2024-08-27)
==================================================================================================
## ✨ Features

* Message Pinning: rework the message pinning list in the right panel ([#12825](matrix-org/matrix-react-sdk#12825)). Contributed by @florianduros.
* Tweak UIA postMessage check to work cross-origin ([#12878](matrix-org/matrix-react-sdk#12878)). Contributed by @t3chguy.
* Delayed events (Futures) / MSC4140 for call widget ([#12714](matrix-org/matrix-react-sdk#12714)). Contributed by @AndrewFerr.
* Stop the ongoing ring if another device joins the call session. ([#12866](matrix-org/matrix-react-sdk#12866)). Contributed by @toger5.
* Rich text Editor: Auto-replace plain text emoticons with emoji ([#12828](matrix-org/matrix-react-sdk#12828)). Contributed by @langleyd.
* Clean up editor drafts for unknown rooms  ([#12850](matrix-org/matrix-react-sdk#12850)). Contributed by @langleyd.
* Rename general user settings to account ([#12841](matrix-org/matrix-react-sdk#12841)). Contributed by @dbkr.
* Update settings tab icons ([#12867](matrix-org/matrix-react-sdk#12867)). Contributed by @dbkr.
* Disable jump to read receipt button instead of hiding when nothing to jump to ([#12863](matrix-org/matrix-react-sdk#12863)). Contributed by @t3chguy.

## 🐛 Bug Fixes

* Ensure elements on Login page are disabled when in-flight ([#12895](matrix-org/matrix-react-sdk#12895)). Contributed by @t3chguy.
* Hide pinned messages when grouped in timeline when feature pinning is disabled ([#12888](matrix-org/matrix-react-sdk#12888)). Contributed by @florianduros.
* Add chat button on new room header for maximised widgets ([#12882](matrix-org/matrix-react-sdk#12882)). Contributed by @t3chguy.
* Show spinner whilst initial search request is in progress ([#12883](matrix-org/matrix-react-sdk#12883)). Contributed by @t3chguy.
* Fix user menu font ([#12879](matrix-org/matrix-react-sdk#12879)). Contributed by @florianduros.
* Allow selecting text in the right panel topic ([#12870](matrix-org/matrix-react-sdk#12870)). Contributed by @t3chguy.
* Add missing presence indicator to new room header ([#12865](matrix-org/matrix-react-sdk#12865)). Contributed by @t3chguy.
* Fix permissions in release tarballs ([#27904](element-hq/element-web#27904)). Contributed by @t3chguy.

## 🧰 Maintenance

* Update dependencies for MSC4157 ([#27906](element-hq/element-web#27906)). Contributed by @AndrewFerr.


Changes in [1.11.75](https://github.com/element-hq/element-web/releases/tag/v1.11.75) (2024-08-20)
==================================================================================================
* No changes



Changes in [1.11.74](https://github.com/element-hq/element-web/releases/tag/v1.11.74) (2024-08-13)
==================================================================================================
## ✨ Features

* Update unsupported browser react component to new designs ([#27857](element-hq/element-web#27857)). Contributed by @t3chguy.
* Invite dialog: display MXID on its own line ([#11756](matrix-org/matrix-react-sdk#11756)). Contributed by @AndrewFerr.
* Align RoomSummaryCard styles with Figma ([#12793](matrix-org/matrix-react-sdk#12793)). Contributed by @t3chguy.
* Extract Extensions into their own right panel tab ([#12844](matrix-org/matrix-react-sdk#12844)). Contributed by @t3chguy.
* Remove topic from new room header and expand right panel topic ([#12842](matrix-org/matrix-react-sdk#12842)). Contributed by @t3chguy.
* Rework how the onboarding notifications task works ([#12839](matrix-org/matrix-react-sdk#12839)). Contributed by @t3chguy.
* Update toast styles to match Figma ([#12833](matrix-org/matrix-react-sdk#12833)). Contributed by @t3chguy.
* Warn users on unsupported browsers before they lack features ([#12830](matrix-org/matrix-react-sdk#12830)). Contributed by @t3chguy.
* Add sign out button to settings profile section ([#12666](matrix-org/matrix-react-sdk#12666)). Contributed by @dbkr.
* Remove MatrixRTC realted import ES lint exceptions using a index.ts for matrixrtc ([#12780](matrix-org/matrix-react-sdk#12780)). Contributed by @toger5.
* Fix unwanted ringing of other devices even though the user is already connected to the call. ([#12742](matrix-org/matrix-react-sdk#12742)). Contributed by @toger5.
* Acknowledge `DeviceMute` widget actions ([#12790](matrix-org/matrix-react-sdk#12790)). Contributed by @toger5.

## 🐛 Bug Fixes

* Update Element icons ([#27900](element-hq/element-web#27900)). Contributed by @t3chguy.
* Fix Jitsi by updating device mute updates over postMessage API ([#27858](element-hq/element-web#27858)). Contributed by @t3chguy.
* Fix formatting of rich text emotes ([#12862](matrix-org/matrix-react-sdk#12862)). Contributed by @dbkr.
* Fixed custom emotes background color #27745 ([#12798](matrix-org/matrix-react-sdk#12798)). Contributed by @asimdelvi.
* Ignore permalink\_prefix when serializing pills ([#11726](matrix-org/matrix-react-sdk#11726)). Contributed by @herkulessi.
* Deflake the chat export test ([#12854](matrix-org/matrix-react-sdk#12854)). Contributed by @dbkr.
* Fix alignment of RTL messages ([#12837](matrix-org/matrix-react-sdk#12837)). Contributed by @dbkr.
* Handle media download errors better ([#12848](matrix-org/matrix-react-sdk#12848)). Contributed by @t3chguy.
* Make micIcon display on primary ([#11908](matrix-org/matrix-react-sdk#11908)). Contributed by @kdanielm.
* Fix compound typography font component issues ([#12826](matrix-org/matrix-react-sdk#12826)). Contributed by @t3chguy.
* Allow Chrome page translator to translate messages in rooms ([#11113](matrix-org/matrix-react-sdk#11113)). Contributed by @lukaszpolowczyk.
  • Loading branch information
Midar committed Sep 14, 2024
1 parent b17292c commit 7244f20
Show file tree
Hide file tree
Showing 3 changed files with 212 additions and 201 deletions.
4 changes: 2 additions & 2 deletions chat/element-web/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.34 2024/08/08 00:09:02 js Exp $
# $NetBSD: Makefile,v 1.35 2024/09/14 22:17:20 js Exp $

DISTNAME= element-v${PKGVERSION_NOREV}
PKGNAME= element-web-1.11.73
PKGNAME= element-web-1.11.77
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=vector-im/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}
Expand Down
Loading

0 comments on commit 7244f20

Please sign in to comment.