Skip to content

Commit

Permalink
chat/matrix-synapse: Update to 1.69.0
Browse files Browse the repository at this point in the history
Synapse 1.69.0 (2022-10-17)
===========================

Please note that legacy Prometheus metric names are now deprecated and will be removed in Synapse 1.73.0.
Server administrators should update their dashboards and alerting rules to avoid using the deprecated metric names.
See the [upgrade notes](https://matrix-org.github.io/synapse/v1.69/upgrade.html#upgrading-to-v1690) for more details.


Deprecations and Removals
-------------------------

- Remove the `complete_sso_login` method from the Module API which was
  deprecated in Synapse
  1.13.0. ([\#13843](matrix-org/synapse#13843))

- Announce that legacy metric names are deprecated, will be turned off
  by default in Synapse v1.71.0 and removed altogether in Synapse
  v1.73.0. See the upgrade notes for more
  information. ([\#14024](matrix-org/synapse#14024))

- Deprecate the `generate_short_term_login_token` method in favor of
  an async `create_login_token` method in the Module
  API. ([\#13842](matrix-org/synapse#13842))


Features
--------

- Allow application services to set the `origin_server_ts` of a state
  event by providing the query parameter `ts` in [`PUT
  /_matrix/client/r0/rooms/{roomId}/state/{eventType}/{stateKey}`](https://spec.matrix.org/v1.4/client-server-api/#put_matrixclientv3roomsroomidstateeventtypestatekey),
  per
  [MSC3316](matrix-org/matrix-spec-proposals#3316). Contributed
  by
  @lukasdenk. ([\#11866](matrix-org/synapse#11866))

- Allow server admins to require a manual approval process before new
  accounts can be used (using
  [MSC3866](matrix-org/matrix-spec-proposals#3866)). ([\#13556](matrix-org/synapse#13556))

- Exponentially backoff from backfilling the same event over and
  over. ([\#13635](matrix-org/synapse#13635),
  [\#13936](matrix-org/synapse#13936))

- Add cache invalidation across workers to module
  API. ([\#13667](matrix-org/synapse#13667),
  [\#13947](matrix-org/synapse#13947))

- Experimental implementation of
  [MSC3882](matrix-org/matrix-spec-proposals#3882)
  to allow an existing device/session to generate a login token for
  use on a new
  device/session. ([\#13722](matrix-org/synapse#13722),
  [\#13868](matrix-org/synapse#13868))

- Experimental support for thread-specific receipts
  ([MSC3771](matrix-org/matrix-spec-proposals#3771)). ([\#13782](matrix-org/synapse#13782),
  [\#13893](matrix-org/synapse#13893),
  [\#13932](matrix-org/synapse#13932),
  [\#13937](matrix-org/synapse#13937),
  [\#13939](matrix-org/synapse#13939))

- Add experimental support for [MSC3881: Remotely toggle push
  notifications for another
  client](matrix-org/matrix-spec-proposals#3881). ([\#13799](matrix-org/synapse#13799),
  [\#13831](matrix-org/synapse#13831),
  [\#13860](matrix-org/synapse#13860))

- Keep track when an event pulled over federation fails its signature
  check so we can intelligently back-off in the
  future. ([\#13815](matrix-org/synapse#13815))

- Improve validation for the unspecced, internal-only
  `_matrix/client/unstable/add_threepid/msisdn/submit_token`
  endpoint. ([\#13832](matrix-org/synapse#13832))

- Faster remote room joins: record _when_ we first partial-join to a
  room. ([\#13892](matrix-org/synapse#13892))

- Support a `dir` parameter on the `/relations` endpoint per
  [MSC3715](matrix-org/matrix-spec-proposals#3715). ([\#13920](matrix-org/synapse#13920))

- Ask mail servers receiving emails from Synapse to not send automatic
  replies (e.g. out-of-office
  responses). ([\#13957](matrix-org/synapse#13957))
  • Loading branch information
gdt committed Oct 29, 2022
1 parent 29a64d3 commit c252de7
Show file tree
Hide file tree
Showing 5 changed files with 116 additions and 40 deletions.
7 changes: 3 additions & 4 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.65 2022/10/28 19:22:49 gdt Exp $
# $NetBSD: Makefile,v 1.66 2022/10/29 00:56:40 gdt Exp $

DISTNAME= matrix-synapse-1.68.0
DISTNAME= matrix-synapse-1.69.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
GITHUB_PROJECT= synapse
Expand All @@ -13,8 +13,7 @@ LICENSE= apache-2.0

# Build tools:
TOOL_DEPENDS+= ${PYPKGPREFIX}-poetry-[0-9]*:../../devel/py-poetry
# \todo This should be TOOL_, but 1.68 is buggy (fixed in 1.69).
DEPENDS+= ${PYPKGPREFIX}-setuptools-rust-[0-9]*:../../devel/py-setuptools-rust
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-rust-[0-9]*:../../devel/py-setuptools-rust

# Dependencies as defined by synapse's build system (in theory):
# \todo Go over poetry.lock
Expand Down
25 changes: 19 additions & 6 deletions chat/matrix-synapse/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.34 2022/10/28 19:19:35 gdt Exp $
@comment $NetBSD: PLIST,v 1.35 2022/10/29 00:56:40 gdt Exp $
bin/export_signing_key
bin/generate_config
bin/generate_log_config
Expand Down Expand Up @@ -426,8 +426,6 @@ ${PYSITELIB}/synapse/notifier.py
${PYSITELIB}/synapse/notifier.pyc
${PYSITELIB}/synapse/push/__init__.py
${PYSITELIB}/synapse/push/__init__.pyc
${PYSITELIB}/synapse/push/baserules.py
${PYSITELIB}/synapse/push/baserules.pyc
${PYSITELIB}/synapse/push/bulk_push_rule_evaluator.py
${PYSITELIB}/synapse/push/bulk_push_rule_evaluator.pyc
${PYSITELIB}/synapse/push/clientformat.py
Expand All @@ -440,8 +438,6 @@ ${PYSITELIB}/synapse/push/mailer.py
${PYSITELIB}/synapse/push/mailer.pyc
${PYSITELIB}/synapse/push/presentable_names.py
${PYSITELIB}/synapse/push/presentable_names.pyc
${PYSITELIB}/synapse/push/push_rule_evaluator.py
${PYSITELIB}/synapse/push/push_rule_evaluator.pyc
${PYSITELIB}/synapse/push/push_tools.py
${PYSITELIB}/synapse/push/push_tools.pyc
${PYSITELIB}/synapse/push/push_types.py
Expand Down Expand Up @@ -477,6 +473,8 @@ ${PYSITELIB}/synapse/replication/http/register.py
${PYSITELIB}/synapse/replication/http/register.pyc
${PYSITELIB}/synapse/replication/http/send_event.py
${PYSITELIB}/synapse/replication/http/send_event.pyc
${PYSITELIB}/synapse/replication/http/send_events.py
${PYSITELIB}/synapse/replication/http/send_events.pyc
${PYSITELIB}/synapse/replication/http/state.py
${PYSITELIB}/synapse/replication/http/state.pyc
${PYSITELIB}/synapse/replication/http/streams.py
Expand Down Expand Up @@ -627,6 +625,8 @@ ${PYSITELIB}/synapse/rest/client/knock.py
${PYSITELIB}/synapse/rest/client/knock.pyc
${PYSITELIB}/synapse/rest/client/login.py
${PYSITELIB}/synapse/rest/client/login.pyc
${PYSITELIB}/synapse/rest/client/login_token_request.py
${PYSITELIB}/synapse/rest/client/login_token_request.pyc
${PYSITELIB}/synapse/rest/client/logout.py
${PYSITELIB}/synapse/rest/client/logout.pyc
${PYSITELIB}/synapse/rest/client/models.py
Expand Down Expand Up @@ -933,6 +933,8 @@ ${PYSITELIB}/synapse/storage/schema/common/delta/25/00background_updates.sql
${PYSITELIB}/synapse/storage/schema/common/delta/35/00background_updates_add_col.sql
${PYSITELIB}/synapse/storage/schema/common/delta/58/00background_update_ordering.sql
${PYSITELIB}/synapse/storage/schema/common/full_schemas/54/full.sql
${PYSITELIB}/synapse/storage/schema/common/full_schemas/72/full.sql.postgres
${PYSITELIB}/synapse/storage/schema/common/full_schemas/72/full.sql.sqlite
${PYSITELIB}/synapse/storage/schema/common/schema_version.sql
${PYSITELIB}/synapse/storage/schema/main/delta/12/v12.sql
${PYSITELIB}/synapse/storage/schema/main/delta/13/v13.sql
Expand Down Expand Up @@ -1268,7 +1270,14 @@ ${PYSITELIB}/synapse/storage/schema/main/delta/72/08begin_cache_invalidation_seq
${PYSITELIB}/synapse/storage/schema/main/delta/72/08thread_receipts.sql
${PYSITELIB}/synapse/storage/schema/main/delta/72/09partial_indices.sql.sqlite
${PYSITELIB}/synapse/storage/schema/main/delta/73/01event_failed_pull_attempts.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/02add_pusher_enabled.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/02room_id_indexes_for_purging.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/03pusher_device_id.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/03users_approved_column.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/04partial_join_details.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/04pending_device_list_updates.sql
${PYSITELIB}/synapse/storage/schema/main/delta/73/05old_push_actions.sql.postgres
${PYSITELIB}/synapse/storage/schema/main/delta/73/05old_push_actions.sql.sqlite
${PYSITELIB}/synapse/storage/schema/main/full_schemas/16/application_services.sql
${PYSITELIB}/synapse/storage/schema/main/full_schemas/16/event_edges.sql
${PYSITELIB}/synapse/storage/schema/main/full_schemas/16/event_signatures.sql
Expand All @@ -1286,6 +1295,8 @@ ${PYSITELIB}/synapse/storage/schema/main/full_schemas/16/users.sql
${PYSITELIB}/synapse/storage/schema/main/full_schemas/54/full.sql.postgres
${PYSITELIB}/synapse/storage/schema/main/full_schemas/54/full.sql.sqlite
${PYSITELIB}/synapse/storage/schema/main/full_schemas/54/stream_positions.sql
${PYSITELIB}/synapse/storage/schema/main/full_schemas/72/full.sql.postgres
${PYSITELIB}/synapse/storage/schema/main/full_schemas/72/full.sql.sqlite
${PYSITELIB}/synapse/storage/schema/state/delta/23/drop_state_index.sql
${PYSITELIB}/synapse/storage/schema/state/delta/32/remove_state_indices.sql
${PYSITELIB}/synapse/storage/schema/state/delta/35/add_state_index.sql
Expand All @@ -1298,6 +1309,8 @@ ${PYSITELIB}/synapse/storage/schema/state/delta/61/02state_groups_state_n_distin
${PYSITELIB}/synapse/storage/schema/state/delta/70/08_state_group_edges_unique.sql
${PYSITELIB}/synapse/storage/schema/state/full_schemas/54/full.sql
${PYSITELIB}/synapse/storage/schema/state/full_schemas/54/sequence.sql.postgres
${PYSITELIB}/synapse/storage/schema/state/full_schemas/72/full.sql.postgres
${PYSITELIB}/synapse/storage/schema/state/full_schemas/72/full.sql.sqlite
${PYSITELIB}/synapse/storage/state.py
${PYSITELIB}/synapse/storage/state.pyc
${PYSITELIB}/synapse/storage/types.py
Expand Down Expand Up @@ -1403,5 +1416,5 @@ ${PYSITELIB}/synapse/util/wheel_timer.py
${PYSITELIB}/synapse/util/wheel_timer.pyc
${PYSITELIB}/synapse/visibility.py
${PYSITELIB}/synapse/visibility.pyc
share/doc/matrix-synapse/README.pkgsrc.txt
share/doc/matrix-synapse/README.pkgsrc.NetBSD.txt
share/doc/matrix-synapse/README.pkgsrc.txt
28 changes: 22 additions & 6 deletions chat/matrix-synapse/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,5 +1,8 @@
# $NetBSD: cargo-depends.mk,v 1.1 2022/10/28 19:19:35 gdt Exp $
# $NetBSD: cargo-depends.mk,v 1.2 2022/10/29 00:56:40 gdt Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-0.7.19
CARGO_CRATE_DEPENDS+= anyhow-1.0.65
CARGO_CRATE_DEPENDS+= arc-swap-1.5.1
CARGO_CRATE_DEPENDS+= autocfg-1.1.0
CARGO_CRATE_DEPENDS+= bitflags-1.3.2
CARGO_CRATE_DEPENDS+= blake2-0.10.4
Expand All @@ -10,20 +13,33 @@ CARGO_CRATE_DEPENDS+= digest-0.10.5
CARGO_CRATE_DEPENDS+= generic-array-0.14.6
CARGO_CRATE_DEPENDS+= hex-0.4.3
CARGO_CRATE_DEPENDS+= indoc-1.0.7
CARGO_CRATE_DEPENDS+= itoa-1.0.3
CARGO_CRATE_DEPENDS+= lazy_static-1.4.0
CARGO_CRATE_DEPENDS+= libc-0.2.132
CARGO_CRATE_DEPENDS+= lock_api-0.4.7
CARGO_CRATE_DEPENDS+= log-0.4.17
CARGO_CRATE_DEPENDS+= memchr-2.5.0
CARGO_CRATE_DEPENDS+= memoffset-0.6.5
CARGO_CRATE_DEPENDS+= once_cell-1.13.1
CARGO_CRATE_DEPENDS+= parking_lot-0.12.1
CARGO_CRATE_DEPENDS+= parking_lot_core-0.9.3
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.43
CARGO_CRATE_DEPENDS+= pyo3-0.16.6
CARGO_CRATE_DEPENDS+= pyo3-build-config-0.16.6
CARGO_CRATE_DEPENDS+= pyo3-ffi-0.16.6
CARGO_CRATE_DEPENDS+= pyo3-macros-0.16.6
CARGO_CRATE_DEPENDS+= pyo3-macros-backend-0.16.6
CARGO_CRATE_DEPENDS+= pyo3-0.17.1
CARGO_CRATE_DEPENDS+= pyo3-build-config-0.17.1
CARGO_CRATE_DEPENDS+= pyo3-ffi-0.17.1
CARGO_CRATE_DEPENDS+= pyo3-log-0.7.0
CARGO_CRATE_DEPENDS+= pyo3-macros-0.17.1
CARGO_CRATE_DEPENDS+= pyo3-macros-backend-0.17.1
CARGO_CRATE_DEPENDS+= pythonize-0.17.0
CARGO_CRATE_DEPENDS+= quote-1.0.21
CARGO_CRATE_DEPENDS+= redox_syscall-0.2.16
CARGO_CRATE_DEPENDS+= regex-1.6.0
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.27
CARGO_CRATE_DEPENDS+= ryu-1.0.11
CARGO_CRATE_DEPENDS+= scopeguard-1.1.0
CARGO_CRATE_DEPENDS+= serde-1.0.145
CARGO_CRATE_DEPENDS+= serde_derive-1.0.145
CARGO_CRATE_DEPENDS+= serde_json-1.0.85
CARGO_CRATE_DEPENDS+= smallvec-1.9.0
CARGO_CRATE_DEPENDS+= subtle-2.4.1
CARGO_CRATE_DEPENDS+= syn-1.0.99
Expand Down
Loading

0 comments on commit c252de7

Please sign in to comment.