Skip to content

Commit

Permalink
pythongh-99086: Build: Fix -Wimplicit-int in PTHREAD_SCOPE_SYSTEM che…
Browse files Browse the repository at this point in the history
…ck (python#99085)

Clang 16 makes -Wimplicit-int fatal by default.

Avoids errors like:
```
conftest.c:142:7: error: type specifier missing, defaults to 'int'; ISO C99 and later do not support implicit int [-Wimplicit-int]
```

Signed-off-by: Sam James <sam@gentoo.org>
  • Loading branch information
thesamesam authored and mgorny committed Mar 19, 2024
1 parent 006db80 commit 3e72cda
Show file tree
Hide file tree
Showing 3 changed files with 3 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
Fix ``-Wimplicit-int`` compiler warning in :program:`configure` check for ``PTHREAD_SCOPE_SYSTEM``.
2 changes: 1 addition & 1 deletion configure
Original file line number Diff line number Diff line change
Expand Up @@ -10947,7 +10947,7 @@ else
void *foo(void *parm) {
return NULL;
}
main() {
int main() {
pthread_attr_t attr;
pthread_t id;
if (pthread_attr_init(&attr)) return (-1);
Expand Down
2 changes: 1 addition & 1 deletion configure.ac
Original file line number Diff line number Diff line change
Expand Up @@ -3232,7 +3232,7 @@ if test "$posix_threads" = "yes"; then
void *foo(void *parm) {
return NULL;
}
main() {
int main() {
pthread_attr_t attr;
pthread_t id;
if (pthread_attr_init(&attr)) return (-1);
Expand Down

0 comments on commit 3e72cda

Please sign in to comment.