Skip to content

Commit

Permalink
[3.10] pythonGH-99086: Fix -Wstrict-prototypes, -Wimplicit-function-d…
Browse files Browse the repository at this point in the history
…eclara… (python#99920)

[3.10] pythongh-99086: Fix -Wstrict-prototypes, -Wimplicit-function-declaration warnings in configure.ac (pythonGH-99406)

Follow up to 12078e7.
(cherry picked from commit e35ca41)

Co-authored-by: Sam James <sam@gentoo.org>
  • Loading branch information
thesamesam authored and mgorny committed Mar 19, 2024
1 parent 2cac20e commit a785591
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 52 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
Fix ``-Wimplicit-int``, ``-Wstrict-prototypes``, and ``-Wimplicit-function-declaration`` compiler warnings in :program:`configure` checks.
57 changes: 31 additions & 26 deletions configure
Original file line number Diff line number Diff line change
Expand Up @@ -5861,7 +5861,7 @@ if test "x$enable_profiling" = xyes; then
CC="$CC -pg"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
int main() { return 0; }
int main(void) { return 0; }
_ACEOF
if ac_fn_c_try_link "$LINENO"; then :

Expand Down Expand Up @@ -7593,7 +7593,7 @@ else
void* routine(void* p){return NULL;}
int main(){
int main(void){
pthread_t p;
if(pthread_create(&p,NULL,routine,NULL)!=0)
return 1;
Expand Down Expand Up @@ -7649,7 +7649,7 @@ else
void* routine(void* p){return NULL;}
int main(){
int main(void){
pthread_t p;
if(pthread_create(&p,NULL,routine,NULL)!=0)
return 1;
Expand Down Expand Up @@ -7699,7 +7699,7 @@ else
void* routine(void* p){return NULL;}
int main(){
int main(void){
pthread_t p;
if(pthread_create(&p,NULL,routine,NULL)!=0)
return 1;
Expand Down Expand Up @@ -7749,7 +7749,7 @@ else
void* routine(void* p){return NULL;}
int main(){
int main(void){
pthread_t p;
if(pthread_create(&p,NULL,routine,NULL)!=0)
return 1;
Expand Down Expand Up @@ -10060,7 +10060,7 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
int main()
int main(void)
{
char s[16];
int i, *p1, *p2;
Expand Down Expand Up @@ -10646,6 +10646,7 @@ $as_echo_n "checking for pthread_create in -lpthread... " >&6; }
/* end confdefs.h. */
#include <stdio.h>
#include <stdlib.h>
#include <pthread.h>
void * start_routine (void *arg) { exit (0); }
Expand Down Expand Up @@ -10947,7 +10948,7 @@ else
void *foo(void *parm) {
return NULL;
}
int main() {
int main(void) {
pthread_attr_t attr;
pthread_t id;
if (pthread_attr_init(&attr)) return (-1);
Expand Down Expand Up @@ -12256,7 +12257,7 @@ else
#include <sys/stat.h>
#include <unistd.h>
int main(int argc, char*argv[])
int main(int argc, char *argv[])
{
if(chflags(argv[0], 0) != 0)
return 1;
Expand Down Expand Up @@ -12305,7 +12306,7 @@ else
#include <sys/stat.h>
#include <unistd.h>
int main(int argc, char*argv[])
int main(int argc, char *argv[])
{
if(lchflags(argv[0], 0) != 0)
return 1;
Expand Down Expand Up @@ -13266,7 +13267,7 @@ else
#include <sys/socket.h>
#include <netinet/in.h>
int main()
int main(void)
{
int passive, gaierr, inet4 = 0, inet6 = 0;
struct addrinfo hints, *ai, *aitop;
Expand Down Expand Up @@ -14493,7 +14494,7 @@ else
#include <stdlib.h>
#include <math.h>
int main() {
int main(void) {
volatile double x, y, z;
/* 1./(1-2**-53) -> 1+2**-52 (correct), 1.0 (double rounding) */
x = 0.99999999999999989; /* 1-2**-53 */
Expand Down Expand Up @@ -15291,7 +15292,7 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
int main()
int main(void)
{
return (((-1)>>3 == -1) ? 0 : 1);
}
Expand Down Expand Up @@ -15722,7 +15723,7 @@ else
#include <stdlib.h>
#include <unistd.h>
int main()
int main(void)
{
int val1 = nice(1);
if (val1 != -1 && val1 == nice(2))
Expand Down Expand Up @@ -15765,7 +15766,7 @@ else
#include <poll.h>
#include <unistd.h>
int main()
int main(void)
{
struct pollfd poll_struct = { 42, POLLIN|POLLPRI|POLLOUT, 0 };
int poll_test;
Expand Down Expand Up @@ -15823,7 +15824,7 @@ else
extern char *tzname[];
#endif
int main()
int main(void)
{
/* Note that we need to ensure that not only does tzset(3)
do 'something' with localtime, but it works as documented
Expand Down Expand Up @@ -16584,9 +16585,10 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <stddef.h>
#include <stdio.h>
#include<stdlib.h>
int main() {
#include <stdlib.h>
int main(void) {
size_t len = -1;
const char *str = "text";
len = mbstowcs(NULL, str, 0);
Expand Down Expand Up @@ -16763,7 +16765,7 @@ else
#include <stdlib.h>
#include <string.h>
void foo(void *p, void *q) { memmove(p, q, 19); }
int main() {
int main(void) {
char a[32] = "123456789000000000";
foo(&a[9], a);
if (strcmp(a, "123456789123456789000000000") != 0)
Expand Down Expand Up @@ -16818,7 +16820,7 @@ else
);
return r;
}
int main() {
int main(void) {
int p = 8;
if ((foo(&p) ? : p) != 6)
return 1;
Expand Down Expand Up @@ -16857,7 +16859,7 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
#include <stdatomic.h>
atomic_int int_var;
atomic_uintptr_t uintptr_var;
int main() {
int main(void) {
atomic_store_explicit(&int_var, 5, memory_order_relaxed);
atomic_store_explicit(&uintptr_var, 0, memory_order_relaxed);
int loaded_value = atomic_load_explicit(&int_var, memory_order_seq_cst);
Expand Down Expand Up @@ -16890,9 +16892,10 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
volatile int val = 1;
int main() {
__atomic_load_n(&val, __ATOMIC_SEQ_CST);
int val;
int main(void) {
__atomic_store_n(&val, 1, __ATOMIC_SEQ_CST);
(void)__atomic_load_n(&val, __ATOMIC_SEQ_CST);
return 0;
}
Expand Down Expand Up @@ -16949,7 +16952,7 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
#include <dirent.h>
int main() {
int main(void) {
struct dirent entry;
return entry.d_type == DT_UNKNOWN;
}
Expand Down Expand Up @@ -16979,11 +16982,12 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <stddef.h>
#include <unistd.h>
#include <sys/syscall.h>
#include <linux/random.h>
int main() {
int main(void) {
char buffer[1];
const size_t buflen = sizeof(buffer);
const int flags = GRND_NONBLOCK;
Expand Down Expand Up @@ -17018,9 +17022,10 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <stddef.h>
#include <sys/random.h>
int main() {
int main(void) {
char buffer[1];
const size_t buflen = sizeof(buffer);
const int flags = 0;
Expand Down
Loading

0 comments on commit a785591

Please sign in to comment.