Skip to content

Commit

Permalink
chore(master): Release 0.50.0 (#8032)
Browse files Browse the repository at this point in the history
🤖 I have created a release *beep* *boop*
---


<details><summary>aztec-package: 0.50.0</summary>

##
[0.50.0](aztec-package-v0.49.2...aztec-package-v0.50.0)
(2024-08-22)


### Features

* Add a prover-node to the proving e2e tests
([#7952](#7952))
([ec5a5fb](ec5a5fb))
* Add max pending txs to bot
([#8046](#8046))
([7f5517e](7f5517e))
* Deterministic deployments for L1
([#8031](#8031))
([abc6b19](abc6b19))
* Introduce validator client
([#7854](#7854))
([e3be8e6](e3be8e6))
* JSON logging
([#8095](#8095))
([048fa12](048fa12))


### Bug Fixes

* Port option & extracting correct namespaced options
([#8097](#8097))
([e74c83e](e74c83e))
* Txe port and aztec start options
([#8071](#8071))
([23778c5](23778c5))


### Miscellaneous

* Configuration for bot on various networks
([#8063](#8063))
([453a096](453a096))
* Merge devnet fixes back to master
([#8149](#8149))
([6be2183](6be2183))
* Merge Provernet back to master
([#8070](#8070))
([82f3dc7](82f3dc7))
</details>

<details><summary>barretenberg.js: 0.50.0</summary>

##
[0.50.0](barretenberg.js-v0.49.2...barretenberg.js-v0.50.0)
(2024-08-22)


### Miscellaneous

* Merge devnet fixes back to master
([#8149](#8149))
([6be2183](6be2183))
</details>

<details><summary>aztec-packages: 0.50.0</summary>

##
[0.50.0](aztec-packages-v0.49.2...aztec-packages-v0.50.0)
(2024-08-22)


### ⚠ BREAKING CHANGES

* replace public key fetching API
([#7996](#7996))

### Features

* (LSP) suggest names that match any part of the current prefix
(noir-lang/noir#5752)
([0379462](0379462))
* Add `Expr::as_any_integer` and `Expr::as_member_access`
(noir-lang/noir#5742)
([0379462](0379462))
* Add `Expr::as_array`, `Expr::as_repeated_element_array` and same for
slice (noir-lang/noir#5750)
([0379462](0379462))
* Add `Expr::as_binary_op` (noir-lang/noir#5734)
([0379462](0379462))
* Add `Expr::as_bool` (noir-lang/noir#5729)
([0379462](0379462))
* Add `Expr::as_unary` (noir-lang/noir#5731)
([0379462](0379462))
* Add `Expr` methods: `as_tuple`, `as_parenthesized`, `as_index`,
`as_if` (noir-lang/noir#5726)
([0379462](0379462))
* Add `TraitImpl::trait_generic_args` and `TraitImpl::methods`
(noir-lang/noir#5722)
([0379462](0379462))
* Add `unsafe` blocks for calling unconstrained code from constrained
functions (noir-lang/noir#4429)
([0379462](0379462))
* Add a prover-node to the proving e2e tests
([#7952](#7952))
([ec5a5fb](ec5a5fb))
* Add max pending txs to bot
([#8046](#8046))
([7f5517e](7f5517e))
* Add reusable procedures to brillig generation
([#7981](#7981))
([99d1131](99d1131))
* Automate verify_honk_proof input generation
([#8092](#8092))
([bf38d61](bf38d61))
* **avm:** Enable zeromorph in AVM verification
([#8111](#8111))
([b1f9fb6](b1f9fb6)),
closes
[#4944](#4944)
* Build for arm
([#7994](#7994))
([0dffe1b](0dffe1b))
* Completing MockNote
([#8059](#8059))
([05efe23](05efe23)),
closes
[#7636](#7636)
* Constant addresses as addresses
([#8056](#8056))
([1da5caf](1da5caf))
* Deterministic deployments for L1
([#8031](#8031))
([abc6b19](abc6b19))
* **docs:** Cookbook integration
([#8083](#8083))
([19bd8a9](19bd8a9))
* Enabling public and private bridging w/ cli
([#8011](#8011))
([f0f9c73](f0f9c73))
* Fault-tolerant parsing of `fn` and `impl`
(noir-lang/noir#5753)
([0379462](0379462))
* Flush sequencer
([#8050](#8050))
([8821e5f](8821e5f))
* Introduce blob circuit
([#8101](#8101))
([4bb3bac](4bb3bac))
* Introduce validator client
([#7854](#7854))
([e3be8e6](e3be8e6))
* JSON logging
([#8095](#8095))
([048fa12](048fa12))
* LSP auto-import completion
(noir-lang/noir#5741)
([0379462](0379462))
* LSP autocomplete constructor fields
(noir-lang/noir#5732)
([0379462](0379462))
* LSP signature help (noir-lang/noir#5725)
([0379462](0379462))
* Max pending jobs in prover node
([#8045](#8045))
([c857604](c857604))
* Move out_hash inside tx_effect_hash
([#7489](#7489))
([ff0effe](ff0effe))
* Native Merkle Trees
([#7037](#7037))
([8a1032e](8a1032e))
* Oink recursive verifier
([#8121](#8121))
([580708a](580708a))
* **optimization:** Follow past `array_set`s when optimizing
`array_get`s (noir-lang/noir#5772)
([0379462](0379462))
* Passes copy_cycles by const reference to avoid copying
([#8051](#8051))
([495d363](495d363))
* **perf:** Mem2reg function state for value loads to optimize across
blocks (noir-lang/noir#5757)
([0379462](0379462))
* PG recursive verifier constructors based on stdlib inputs
([#8052](#8052))
([4c568b0](4c568b0))
* Poseidon2 gates for Ultra arithmetisation
([#7494](#7494))
([d86577c](d86577c))
* Prover node metrics
([#8086](#8086))
([ab018ff](ab018ff))
* Removed socat, fixed aztec-run
([#8145](#8145))
([ff94aa2](ff94aa2))
* Removing redundant key fetching
([#8043](#8043))
([2bbcc7b](2bbcc7b))
* Replace public key fetching API
([#7996](#7996))
([73d6aa9](73d6aa9))
* Small optimization in toradix
([#8040](#8040))
([0dc7a50](0dc7a50))
* Some fixes and cleanup in PG recursive verifier
([#8053](#8053))
([5f2a9bd](5f2a9bd))
* Suggest trait methods in LSP completion
(noir-lang/noir#5735)
([0379462](0379462))
* Suggest tuple fields in LSP completion
(noir-lang/noir#5730)
([0379462](0379462))
* Track world state metrics
([#8109](#8109))
([ca58d94](ca58d94))
* Typing specific pub keys
([#8099](#8099))
([638793a](638793a))
* Unify all acir recursion constraints based on RecursionConstraint and
proof_type
([#7993](#7993))
([7cb39bc](7cb39bc))
* User `super::` in LSP autocompletion if possible
(noir-lang/noir#5751)
([0379462](0379462))
* Various token note improvements
([#8062](#8062))
([8f9dfd9](8f9dfd9))
* Zk sumcheck
([#7517](#7517))
([0e9a530](0e9a530))


### Bug Fixes

* (LSP) only add cached files relevant to workspace
(noir-lang/noir#5775)
([2d70215](2d70215))
* Add DEBUG and LOG_LEVEL to valid env vars
([#8094](#8094))
([70e61f9](70e61f9))
* Add link to l1-artifacts
([#7940](#7940))
([dcfd120](dcfd120))
* Add missing trait impls for integer types to stdlib
(noir-lang/noir#5738)
([0379462](0379462))
* Allow comptime code to use break without also being `unconstrained`
(noir-lang/noir#5744)
([0379462](0379462))
* **avm:** Real bytes finalization
([#8041](#8041))
([047461a](047461a))
* **ci:** Correctly run bb tests with asserts
([#7607](#7607))
([7b73f69](7b73f69))
* Correctly constrain get header at
([#7893](#7893))
([2ebba0d](2ebba0d))
* Deploy L1 rollup contract using salt if provided
([#8074](#8074))
([1e8eddf](1e8eddf))
* Flaky e2e_prover_node test
([#8116](#8116))
([9d97bd4](9d97bd4))
* **frontend:** Continue type check if we are missing an unsafe block
(noir-lang/noir#5720)
([0379462](0379462))
* Let LSP autocompletion work in more contexts
(noir-lang/noir#5719)
([0379462](0379462))
* Port option & extracting correct namespaced options
([#8097](#8097))
([e74c83e](e74c83e))
* Set prover node max pending jobs in tests
([#8055](#8055))
([403c26f](403c26f))
* Stop WorldStrateSynchronizer in prover node
([#8126](#8126))
([f724b07](f724b07))
* Txe port and aztec start options
([#8071](#8071))
([23778c5](23778c5))
* Unconstrained fn mismatch is now a warning
(noir-lang/noir#5764)
([0379462](0379462))
* Wallet fixes for devnet, testing and misc
([#8058](#8058))
([15f3e8c](15f3e8c))


### Miscellaneous

* Add Brillig loop bytecode size regression and update noir-gates-diff
report (noir-lang/noir#5747)
([0379462](0379462))
* Apply some new lints across workspace
(noir-lang/noir#5736)
([0379462](0379462))
* **avm:** Kernel trace and finalization
([#8049](#8049))
([d7edd24](d7edd24))
* **avm:** Separate alu finalization
([#8069](#8069))
([e8a9eb4](e8a9eb4))
* **bb:** IPA parallelization cleanup
([#8088](#8088))
([9227fa9](9227fa9))
* **bb:** Simplify parallel_for_if_effective
([#8079](#8079))
([5bff26b](5bff26b))
* **bb:** Small cleanup in protogalaxy prover
([#8072](#8072))
([4cb5c83](4cb5c83))
* **ci:** Only show last 50 master cpp benches
([#8075](#8075))
([96f35bc](96f35bc))
* Clarify Field use (noir-lang/noir#5740)
([0379462](0379462))
* CLI command to set latest block as proven
([#7987](#7987))
([80eaf1d](80eaf1d))
* Configuration for bot on various networks
([#8063](#8063))
([453a096](453a096))
* Count brillig opcodes in nargo info
(noir-lang/noir#5189)
([0379462](0379462))
* Deduplication in Protogalaxy
([#8067](#8067))
([a5cc3ba](a5cc3ba))
* **docs:** Expanding solidity verifier chain list
(noir-lang/noir#5587)
([0379462](0379462))
* Dont trail whitespace in vscode
([#5661](#5661))
([7595d91](7595d91))
* Handle constant output for ec add opcode
([#8108](#8108))
([2ee79d2](2ee79d2))
* Make spans non-optional on `UnresolvedType`
(noir-lang/noir#5773)
([2d70215](2d70215))
* Merge devnet fixes back to master
([#8149](#8149))
([6be2183](6be2183))
* Merge devnet to master
([#8044](#8044))
([f84950f](f84950f))
* Merge Provernet back to master
([#8070](#8070))
([82f3dc7](82f3dc7))
* Merging `TokenWithRefunds` with `Token`
([#8042](#8042))
([8b795eb](8b795eb))
* Modified devnet config
([#8087](#8087))
([854ab45](854ab45))
* Nuking old registry contract
([#8057](#8057))
([3bd08a8](3bd08a8)),
closes
[#7955](#7955)
* Pedersen hash related cleanup in aztec.nr
([#8009](#8009))
([3c4ac65](3c4ac65))
* Portal manager cli
([#8047](#8047))
([618e251](618e251))
* Proper portal setup for fees + test
([#7944](#7944))
([9fec67e](9fec67e))
* Public kernel
([#8061](#8061))
([617a69c](617a69c))
* Refactor ACIR function IDs from raw integers to struct
(noir-lang/noir#5748)
([0379462](0379462))
* Replace relative paths to noir-protocol-circuits
([5ddf0e6](5ddf0e6))
* Replace relative paths to noir-protocol-circuits
([ca77c17](ca77c17))
* Replace relative paths to noir-protocol-circuits
([fe73c93](fe73c93))
* Replace relative paths to noir-protocol-circuits
([576bc2f](576bc2f))
* Replace relative paths to noir-protocol-circuits
([0d05d6b](0d05d6b))
* Simplify sequencer and l1 communication
([#7989](#7989))
([cee4eba](cee4eba))
* Split LSP completion.rs into several files
(noir-lang/noir#5723)
([0379462](0379462))
* Split up stdlib/recursion
([#8054](#8054))
([ec03e40](ec03e40))
* **sync-noir:** Fix modify/delete conflicts automatically
([#8090](#8090))
([a09627c](a09627c))
* Use decider verifier in ultra verifier
([#8115](#8115))
([6c5ab2b](6c5ab2b))


### Documentation

* Fix typo overview.md
([#7908](#7908))
([3749211](3749211))
* Update installation info for bb and noir
([#8119](#8119))
([a744321](a744321))
</details>

<details><summary>barretenberg: 0.50.0</summary>

##
[0.50.0](barretenberg-v0.49.2...barretenberg-v0.50.0)
(2024-08-22)


### Features

* Add a prover-node to the proving e2e tests
([#7952](#7952))
([ec5a5fb](ec5a5fb))
* Automate verify_honk_proof input generation
([#8092](#8092))
([bf38d61](bf38d61))
* **avm:** Enable zeromorph in AVM verification
([#8111](#8111))
([b1f9fb6](b1f9fb6)),
closes
[#4944](#4944)
* Native Merkle Trees
([#7037](#7037))
([8a1032e](8a1032e))
* Oink recursive verifier
([#8121](#8121))
([580708a](580708a))
* Passes copy_cycles by const reference to avoid copying
([#8051](#8051))
([495d363](495d363))
* PG recursive verifier constructors based on stdlib inputs
([#8052](#8052))
([4c568b0](4c568b0))
* Poseidon2 gates for Ultra arithmetisation
([#7494](#7494))
([d86577c](d86577c))
* Some fixes and cleanup in PG recursive verifier
([#8053](#8053))
([5f2a9bd](5f2a9bd))
* Unify all acir recursion constraints based on RecursionConstraint and
proof_type
([#7993](#7993))
([7cb39bc](7cb39bc))
* Zk sumcheck
([#7517](#7517))
([0e9a530](0e9a530))


### Bug Fixes

* **avm:** Real bytes finalization
([#8041](#8041))
([047461a](047461a))
* **ci:** Correctly run bb tests with asserts
([#7607](#7607))
([7b73f69](7b73f69))


### Miscellaneous

* **avm:** Kernel trace and finalization
([#8049](#8049))
([d7edd24](d7edd24))
* **avm:** Separate alu finalization
([#8069](#8069))
([e8a9eb4](e8a9eb4))
* **bb:** IPA parallelization cleanup
([#8088](#8088))
([9227fa9](9227fa9))
* **bb:** Simplify parallel_for_if_effective
([#8079](#8079))
([5bff26b](5bff26b))
* **bb:** Small cleanup in protogalaxy prover
([#8072](#8072))
([4cb5c83](4cb5c83))
* Deduplication in Protogalaxy
([#8067](#8067))
([a5cc3ba](a5cc3ba))
* Handle constant output for ec add opcode
([#8108](#8108))
([2ee79d2](2ee79d2))
* Merge devnet fixes back to master
([#8149](#8149))
([6be2183](6be2183))
* Split up stdlib/recursion
([#8054](#8054))
([ec03e40](ec03e40))
* Use decider verifier in ultra verifier
([#8115](#8115))
([6c5ab2b](6c5ab2b))


### Documentation

* Update installation info for bb and noir
([#8119](#8119))
([a744321](a744321))
</details>

---
This PR was generated with [Release
Please](https://github.com/googleapis/release-please). See
[documentation](https://github.com/googleapis/release-please#release-please).
  • Loading branch information
AztecBot authored Aug 22, 2024
1 parent 6be2183 commit 0b50480
Show file tree
Hide file tree
Showing 8 changed files with 211 additions and 7 deletions.
8 changes: 4 additions & 4 deletions .release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
".": "0.49.2",
".": "0.50.0",
"yarn-project/cli": "0.35.1",
"yarn-project/aztec": "0.49.2",
"barretenberg": "0.49.2",
"barretenberg/ts": "0.49.2"
"yarn-project/aztec": "0.50.0",
"barretenberg": "0.50.0",
"barretenberg/ts": "0.50.0"
}
131 changes: 131 additions & 0 deletions CHANGELOG.md

Large diffs are not rendered by default.

42 changes: 42 additions & 0 deletions barretenberg/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,47 @@
# Changelog

## [0.50.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.49.2...barretenberg-v0.50.0) (2024-08-22)


### Features

* Add a prover-node to the proving e2e tests ([#7952](https://github.com/AztecProtocol/aztec-packages/issues/7952)) ([ec5a5fb](https://github.com/AztecProtocol/aztec-packages/commit/ec5a5fb8fd9c344bcb0d33a4e9f07300d3317bf2))
* Automate verify_honk_proof input generation ([#8092](https://github.com/AztecProtocol/aztec-packages/issues/8092)) ([bf38d61](https://github.com/AztecProtocol/aztec-packages/commit/bf38d61364a0fb55ae79ef09b05df2533f3a6f17))
* **avm:** Enable zeromorph in AVM verification ([#8111](https://github.com/AztecProtocol/aztec-packages/issues/8111)) ([b1f9fb6](https://github.com/AztecProtocol/aztec-packages/commit/b1f9fb6a4986fdfa10207ec89f8b23e14d466073)), closes [#4944](https://github.com/AztecProtocol/aztec-packages/issues/4944)
* Native Merkle Trees ([#7037](https://github.com/AztecProtocol/aztec-packages/issues/7037)) ([8a1032e](https://github.com/AztecProtocol/aztec-packages/commit/8a1032ec4738e9b592b45500c1cf47c0e1820ad3))
* Oink recursive verifier ([#8121](https://github.com/AztecProtocol/aztec-packages/issues/8121)) ([580708a](https://github.com/AztecProtocol/aztec-packages/commit/580708a1f7c18338888d83e749a0740a322c86e0))
* Passes copy_cycles by const reference to avoid copying ([#8051](https://github.com/AztecProtocol/aztec-packages/issues/8051)) ([495d363](https://github.com/AztecProtocol/aztec-packages/commit/495d363fdf0b89dfeb228c200824fc5f9af7bb19))
* PG recursive verifier constructors based on stdlib inputs ([#8052](https://github.com/AztecProtocol/aztec-packages/issues/8052)) ([4c568b0](https://github.com/AztecProtocol/aztec-packages/commit/4c568b0545b022a536a6eb4199be817593e6b317))
* Poseidon2 gates for Ultra arithmetisation ([#7494](https://github.com/AztecProtocol/aztec-packages/issues/7494)) ([d86577c](https://github.com/AztecProtocol/aztec-packages/commit/d86577c2e36c5a077a859058602f455421ed93e1))
* Some fixes and cleanup in PG recursive verifier ([#8053](https://github.com/AztecProtocol/aztec-packages/issues/8053)) ([5f2a9bd](https://github.com/AztecProtocol/aztec-packages/commit/5f2a9bd3d968be491a12c63f812aa8d7e3bb585e))
* Unify all acir recursion constraints based on RecursionConstraint and proof_type ([#7993](https://github.com/AztecProtocol/aztec-packages/issues/7993)) ([7cb39bc](https://github.com/AztecProtocol/aztec-packages/commit/7cb39bceddcb9ec4142b86087a7af58d547ddfaa))
* Zk sumcheck ([#7517](https://github.com/AztecProtocol/aztec-packages/issues/7517)) ([0e9a530](https://github.com/AztecProtocol/aztec-packages/commit/0e9a530cfd83f375f6b3a1bb9fb67cf562847f9b))


### Bug Fixes

* **avm:** Real bytes finalization ([#8041](https://github.com/AztecProtocol/aztec-packages/issues/8041)) ([047461a](https://github.com/AztecProtocol/aztec-packages/commit/047461ae6bc5d6a7a4d05bba18cce0682ee75705))
* **ci:** Correctly run bb tests with asserts ([#7607](https://github.com/AztecProtocol/aztec-packages/issues/7607)) ([7b73f69](https://github.com/AztecProtocol/aztec-packages/commit/7b73f69126b8ae70aa7ade96e775cabce581358f))


### Miscellaneous

* **avm:** Kernel trace and finalization ([#8049](https://github.com/AztecProtocol/aztec-packages/issues/8049)) ([d7edd24](https://github.com/AztecProtocol/aztec-packages/commit/d7edd24e76a2ab87ac490c8c97f0c344190f646b))
* **avm:** Separate alu finalization ([#8069](https://github.com/AztecProtocol/aztec-packages/issues/8069)) ([e8a9eb4](https://github.com/AztecProtocol/aztec-packages/commit/e8a9eb4b809f582c0fa185a2193e0493fc579d98))
* **bb:** IPA parallelization cleanup ([#8088](https://github.com/AztecProtocol/aztec-packages/issues/8088)) ([9227fa9](https://github.com/AztecProtocol/aztec-packages/commit/9227fa9f25b1ef8342dbf694c5bb9d37a1b0226d))
* **bb:** Simplify parallel_for_if_effective ([#8079](https://github.com/AztecProtocol/aztec-packages/issues/8079)) ([5bff26b](https://github.com/AztecProtocol/aztec-packages/commit/5bff26b2f9aecb8298225d5abe72740fedd1f4e8))
* **bb:** Small cleanup in protogalaxy prover ([#8072](https://github.com/AztecProtocol/aztec-packages/issues/8072)) ([4cb5c83](https://github.com/AztecProtocol/aztec-packages/commit/4cb5c83174f55f046d7d37e4e6a4667556ac5907))
* Deduplication in Protogalaxy ([#8067](https://github.com/AztecProtocol/aztec-packages/issues/8067)) ([a5cc3ba](https://github.com/AztecProtocol/aztec-packages/commit/a5cc3bab86711062d180993cf4a7412d1013aa48))
* Handle constant output for ec add opcode ([#8108](https://github.com/AztecProtocol/aztec-packages/issues/8108)) ([2ee79d2](https://github.com/AztecProtocol/aztec-packages/commit/2ee79d28affa66ef3c9f73782182b6221e2e9d98))
* Merge devnet fixes back to master ([#8149](https://github.com/AztecProtocol/aztec-packages/issues/8149)) ([6be2183](https://github.com/AztecProtocol/aztec-packages/commit/6be21831764243ea42ef932aac3b79f20b483a40))
* Split up stdlib/recursion ([#8054](https://github.com/AztecProtocol/aztec-packages/issues/8054)) ([ec03e40](https://github.com/AztecProtocol/aztec-packages/commit/ec03e403cc8bfa1f40fb05fe93eadf9ed63b9b2f))
* Use decider verifier in ultra verifier ([#8115](https://github.com/AztecProtocol/aztec-packages/issues/8115)) ([6c5ab2b](https://github.com/AztecProtocol/aztec-packages/commit/6c5ab2b373086cb2842ee848329e282b463b3272))


### Documentation

* Update installation info for bb and noir ([#8119](https://github.com/AztecProtocol/aztec-packages/issues/8119)) ([a744321](https://github.com/AztecProtocol/aztec-packages/commit/a7443216dfaa7b2731911e2320b2c1c1a720e8e8))

## [0.49.2](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.49.1...barretenberg-v0.49.2) (2024-08-15)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/cpp/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
project(
Barretenberg
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
VERSION 0.49.2 # x-release-please-version
VERSION 0.50.0 # x-release-please-version
LANGUAGES CXX C
)
# Insert version into `bb` config file
Expand Down
7 changes: 7 additions & 0 deletions barretenberg/ts/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,12 @@
# Changelog

## [0.50.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.49.2...barretenberg.js-v0.50.0) (2024-08-22)


### Miscellaneous

* Merge devnet fixes back to master ([#8149](https://github.com/AztecProtocol/aztec-packages/issues/8149)) ([6be2183](https://github.com/AztecProtocol/aztec-packages/commit/6be21831764243ea42ef932aac3b79f20b483a40))

## [0.49.2](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.49.1...barretenberg.js-v0.49.2) (2024-08-15)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/ts/package.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
"name": "@aztec/bb.js",
"packageManager": "yarn@1.22.22",
"version": "0.49.2",
"version": "0.50.0",
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
"license": "MIT",
"type": "module",
Expand Down
24 changes: 24 additions & 0 deletions yarn-project/aztec/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,29 @@
# Changelog

## [0.50.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.49.2...aztec-package-v0.50.0) (2024-08-22)


### Features

* Add a prover-node to the proving e2e tests ([#7952](https://github.com/AztecProtocol/aztec-packages/issues/7952)) ([ec5a5fb](https://github.com/AztecProtocol/aztec-packages/commit/ec5a5fb8fd9c344bcb0d33a4e9f07300d3317bf2))
* Add max pending txs to bot ([#8046](https://github.com/AztecProtocol/aztec-packages/issues/8046)) ([7f5517e](https://github.com/AztecProtocol/aztec-packages/commit/7f5517ecf19e720176d4e97e07f7be557b6705d9))
* Deterministic deployments for L1 ([#8031](https://github.com/AztecProtocol/aztec-packages/issues/8031)) ([abc6b19](https://github.com/AztecProtocol/aztec-packages/commit/abc6b19b9483b02aa233ce844f01cfb876102531))
* Introduce validator client ([#7854](https://github.com/AztecProtocol/aztec-packages/issues/7854)) ([e3be8e6](https://github.com/AztecProtocol/aztec-packages/commit/e3be8e6cd23fa7b7cdf341da720decd21a5d8c44))
* JSON logging ([#8095](https://github.com/AztecProtocol/aztec-packages/issues/8095)) ([048fa12](https://github.com/AztecProtocol/aztec-packages/commit/048fa12cf21de3067908c2e03b2245ef8e674d46))


### Bug Fixes

* Port option & extracting correct namespaced options ([#8097](https://github.com/AztecProtocol/aztec-packages/issues/8097)) ([e74c83e](https://github.com/AztecProtocol/aztec-packages/commit/e74c83e581380fa344d1dc1cd783beb1b2d11e0e))
* Txe port and aztec start options ([#8071](https://github.com/AztecProtocol/aztec-packages/issues/8071)) ([23778c5](https://github.com/AztecProtocol/aztec-packages/commit/23778c5a0ac4fe512cde3a4b66df65f588cad305))


### Miscellaneous

* Configuration for bot on various networks ([#8063](https://github.com/AztecProtocol/aztec-packages/issues/8063)) ([453a096](https://github.com/AztecProtocol/aztec-packages/commit/453a096378df57b0280be9aa52697da434e1a457))
* Merge devnet fixes back to master ([#8149](https://github.com/AztecProtocol/aztec-packages/issues/8149)) ([6be2183](https://github.com/AztecProtocol/aztec-packages/commit/6be21831764243ea42ef932aac3b79f20b483a40))
* Merge Provernet back to master ([#8070](https://github.com/AztecProtocol/aztec-packages/issues/8070)) ([82f3dc7](https://github.com/AztecProtocol/aztec-packages/commit/82f3dc7320e05878cbd55136f1d88f87f14b2468))

## [0.49.2](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.49.1...aztec-package-v0.49.2) (2024-08-15)


Expand Down
2 changes: 1 addition & 1 deletion yarn-project/aztec/package.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
{
"name": "@aztec/aztec",
"version": "0.49.2",
"version": "0.50.0",
"type": "module",
"exports": {
".": "./dest/index.js"
Expand Down

0 comments on commit 0b50480

Please sign in to comment.